]> git.pld-linux.org Git - packages/bakery.git/blob - bakery.spec
- reverted false libcap BR, fix your GNOME libs
[packages/bakery.git] / bakery.spec
1 Summary:        C++ Framework for creating GNOME applications
2 Summary(pl.UTF-8):      Struktura C++ do tworzenia programów dla GNOME
3 Name:           bakery
4 Version:        2.4.3
5 Release:        1
6 License:        LGPL v2+
7 Group:          X11/Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/bakery/2.4/%{name}-%{version}.tar.bz2
9 # Source0-md5:  7d22a4610656c412e6ae3918a3e82304
10 URL:            http://bakery.sourceforge.net/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  gconfmm-devel >= 2.16.0
14 BuildRequires:  gettext-devel
15 BuildRequires:  gnome-vfsmm-devel >= 2.16.0
16 BuildRequires:  gtkmm-devel >= 2.10.5
17 BuildRequires:  intltool
18 BuildRequires:  libglademm-devel >= 2.6.3
19 BuildRequires:  libtool
20 BuildRequires:  libxml++-devel >= 2.14.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.197
23 Requires:       gconfmm >= 2.16.0
24 Requires:       gnome-vfsmm >= 2.16.0
25 Requires:       gtkmm >= 2.10.5
26 Requires:       libglademm >= 2.6.3
27 Requires:       libxml++ >= 2.14.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Bakery is a C++ Framework for creating document-based GNOME
32 applications using gtkmm and/or gnomemm.
33
34 - provides a Document/View architecture,
35 - can use XML as a Document storage format,
36 - provides default functionality, which can be easily customized,
37 - makes it easy to start developing GNOME applications,
38 - gives your application structure,
39 - contains a few utility classes.
40
41 %description -l pl.UTF-8
42 Bakery jest strukturą C++ do tworzenia opartych na dokumentach
43 programów dla GNOME przy użyciu gtkmm i/lub gnomemm.
44
45 - dostarcza architektury Dokument/Widok
46 - może używać XML jako formatu zapisu Dokumentu,
47 - dostarcza domyślnej, łatwo modyfikowalnej funkcjonalności,
48 - pozwala na łatwy start w tworzeniu aplikacji GNOME,
49 - nadaje aplikacji format,
50 - zawiera kilka klas użytkowych
51
52 %package devel
53 Summary:        Bakery header files
54 Summary(pl.UTF-8):      Pliki nagłówkowe Bakery
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       gconfmm-devel >= 2.16.0
58 Requires:       gnome-vfsmm-devel >= 2.16.0
59 Requires:       gtkmm-devel >= 2.10.5
60 Requires:       libglademm-devel >= 2.6.3
61 Requires:       libxml++-devel >= 2.14.0
62
63 %description devel
64 Header files for Bakery framework.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe dla struktury Bakery.
68
69 %package static
70 Summary:        Static Bakery library
71 Summary(pl.UTF-8):      Statyczna biblioteka Bakery
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static Bakery library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka Bakery.
80
81 %prep
82 %setup -q
83
84 %build
85 %{__intltoolize}
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %find_lang %{name}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/lib*.so
116 %{_libdir}/lib*.la
117 %{_includedir}/bakery-2.4
118 %{_pkgconfigdir}/*.pc
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/*.a
This page took 0.062122 seconds and 3 git commands to generate.