]> git.pld-linux.org Git - packages/bakery.git/blob - bakery.spec
- pass -std to enable C++ 11 for glibmm/libxml++; release 4
[packages/bakery.git] / bakery.spec
1 Summary:        C++ Framework for creating GNOME applications
2 Summary(pl.UTF-8):      Struktura C++ do tworzenia programów dla GNOME
3 Name:           bakery
4 Version:        2.6.3
5 Release:        4
6 License:        LGPL v2+
7 Group:          X11/Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/bakery/2.6/%{name}-%{version}.tar.bz2
9 # Source0-md5:  49d28fecf13252f4f2899461505e56e5
10 # http://bugzilla.gnome.org/show_bug.cgi?id=564168
11 Patch0:         %{name}-release-version.patch
12 URL:            http://bakery.sourceforge.net/
13 BuildRequires:  autoconf >= 2.59
14 BuildRequires:  automake >= 1:1.9
15 BuildRequires:  gconfmm-devel >= 2.16.0
16 BuildRequires:  gettext-tools
17 BuildRequires:  glibmm-devel >= 2.16.0
18 BuildRequires:  gtkmm-devel >= 2.10.5
19 BuildRequires:  intltool
20 BuildRequires:  libglademm-devel >= 2.6.3
21 BuildRequires:  libstdc++-devel >= 6:4.3
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  libxml++2-devel >= 2.24.0
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpmbuild(macros) >= 1.197
26 Requires:       gconfmm >= 2.16.0
27 Requires:       gtkmm >= 2.10.5
28 Requires:       libglademm >= 2.6.3
29 Requires:       libxml++2 >= 2.24.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Bakery is a C++ Framework for creating document-based GNOME
34 applications using gtkmm and/or gnomemm.
35
36 - provides a Document/View architecture,
37 - can use XML as a Document storage format,
38 - provides default functionality, which can be easily customized,
39 - makes it easy to start developing GNOME applications,
40 - gives your application structure,
41 - contains a few utility classes.
42
43 %description -l pl.UTF-8
44 Bakery jest strukturą C++ do tworzenia opartych na dokumentach
45 programów dla GNOME przy użyciu gtkmm i/lub gnomemm.
46
47 - dostarcza architektury Dokument/Widok
48 - może używać XML jako formatu zapisu Dokumentu,
49 - dostarcza domyślnej, łatwo modyfikowalnej funkcjonalności,
50 - pozwala na łatwy start w tworzeniu aplikacji GNOME,
51 - nadaje aplikacji format,
52 - zawiera kilka klas użytkowych
53
54 %package devel
55 Summary:        Bakery header files
56 Summary(pl.UTF-8):      Pliki nagłówkowe Bakery
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       gconfmm-devel >= 2.16.0
60 Requires:       glibmm-devel >= 2.16.0
61 Requires:       gtkmm-devel >= 2.10.5
62 Requires:       libglademm-devel >= 2.6.3
63 Requires:       libxml++2-devel >= 2.24.0
64
65 %description devel
66 Header files for Bakery framework.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe dla struktury Bakery.
70
71 %package static
72 Summary:        Static Bakery library
73 Summary(pl.UTF-8):      Statyczna biblioteka Bakery
74 Group:          X11/Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static Bakery library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka Bakery.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %{__intltoolize}
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 # for glibmm 2.46+/libxml++ 2.40+
95 CXXFLAGS="%{rpmcxxflags} -std=c++0x"
96 %configure
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbakery-*.la
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog NEWS README
118 %attr(755,root,root) %{_libdir}/libbakery-2.6-2.6.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libbakery-2.6-2.6.so.1
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libbakery-2.6.so
124 %dir %{_libdir}/bakery-2.6
125 %{_libdir}/bakery-2.6/include
126 %{_includedir}/bakery-2.6
127 %{_pkgconfigdir}/bakery-2.6.pc
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libbakery-2.6.a
This page took 0.079078 seconds and 4 git commands to generate.