]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
- up to 7.8 snapshot
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 22 Feb 2010 22:01:39 +0000 (22:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Mesa-tgsi_dump.patch -> 1.2
    Mesa.spec -> 1.240

Mesa-tgsi_dump.patch
Mesa.spec

index 4ddf96cb38fa66445c28e27048a204e8c4b9b76e..2271edccfa7dc48693849dc1e20213f84bd6256b 100644 (file)
@@ -1,6 +1,6 @@
---- Mesa-7.7/src/gallium/auxiliary/tgsi/tgsi_dump.c.orig       2009-12-22 03:26:02.000000000 +0100
-+++ Mesa-7.7/src/gallium/auxiliary/tgsi/tgsi_dump.c    2010-01-10 09:40:23.298610151 +0100
-@@ -47,7 +47,7 @@
+--- mesa/src/gallium/auxiliary/tgsi/tgsi_dump.c.org    2010-02-22 22:04:55.733686714 +0100
++++ mesa/src/gallium/auxiliary/tgsi/tgsi_dump.c        2010-02-22 22:05:07.487007669 +0100
+@@ -47,16 +47,16 @@
     
     uint indentation;
  
@@ -9,6 +9,17 @@
  };
  
  static void 
+-dump_ctx_printf(struct dump_ctx *ctx, const char *format, ...)
++dump_ctx_dump_printf(struct dump_ctx *ctx, const char *format, ...)
+ {
+    va_list ap;
+    (void)ctx;
+    va_start(ap, format);
+-   debug_vprintf(format, ap);
++   debug_vdump_printf(format, ap);
+    va_end(ap);
+ }
 @@ -68,19 +68,19 @@
     uint enum_count )
  {
  #define ENM(E,ENUMS)    dump_enum( ctx, E, ENUMS, sizeof( ENUMS ) / sizeof( *ENUMS ) )
  
  static const char *processor_type_names[] =
-@@ -278,7 +278,7 @@
+@@ -369,7 +369,7 @@
  {
     struct dump_ctx ctx;
  
 -   ctx.printf = dump_ctx_printf;
-+   ctx.dump_printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_dump_printf;
  
     iter_declaration( &ctx.iter, (struct tgsi_full_declaration *)decl );
  }
-@@ -323,7 +323,7 @@
+@@ -419,7 +419,7 @@
+ {
+    struct dump_ctx ctx;
+-   ctx.printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_dump_printf;
+    iter_property( &ctx.iter, (struct tgsi_full_property *)prop );
+ }
+@@ -470,7 +470,7 @@
  {
     struct dump_ctx ctx;
  
 -   ctx.printf = dump_ctx_printf;
-+   ctx.dump_printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_dump_printf;
  
     iter_immediate( &ctx.iter, (struct tgsi_full_immediate *)imm );
  }
-@@ -491,7 +491,7 @@
+@@ -605,7 +605,7 @@
  
     ctx.instno = instno;
     ctx.indent = 0;
 -   ctx.printf = dump_ctx_printf;
-+   ctx.dump_printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_dump_printf;
     ctx.indentation = 0;
  
     iter_instruction( &ctx.iter, (struct tgsi_full_instruction *)inst );
-@@ -525,7 +525,7 @@
+@@ -637,7 +637,7 @@
  
     ctx.instno = 0;
     ctx.indent = 0;
 -   ctx.printf = dump_ctx_printf;
-+   ctx.dump_printf = dump_ctx_printf;
++   ctx.dump_printf = dump_ctx_dump_printf;
     ctx.indentation = 0;
  
     tgsi_iterate_shader( tokens, &ctx.iter );
-@@ -579,7 +579,7 @@
+@@ -652,7 +652,7 @@
+ };
+ static void
+-str_dump_ctx_printf(struct dump_ctx *ctx, const char *format, ...)
++str_dump_ctx_dump_printf(struct dump_ctx *ctx, const char *format, ...)
+ {
+    struct str_dump_ctx *sctx = (struct str_dump_ctx *)ctx;
+    
+@@ -660,11 +660,11 @@
+       int written;
+       va_list ap;
+       va_start(ap, format);
+-      written = util_vsnprintf(sctx->ptr, sctx->left, format, ap);
++      written = util_vsndump_printf(sctx->ptr, sctx->left, format, ap);
+       va_end(ap);
+       /* Some complicated logic needed to handle the return value of
+-       * vsnprintf:
++       * vsndump_printf:
+        */
+       if (written > 0) {
+          written = MIN2(sctx->left, written);
+@@ -692,7 +692,7 @@
  
     ctx.base.instno = 0;
     ctx.base.indent = 0;
 -   ctx.base.printf = &str_dump_ctx_printf;
-+   ctx.base.dump_printf = &str_dump_ctx_printf;
++   ctx.base.dump_printf = &str_dump_ctx_dump_printf;
     ctx.base.indentation = 0;
  
     ctx.str = str;
index bfda65c2a569d89e1f250281d129bd72aa1270ea..1f8619a76fdd39db934f114f7b7649946940e926 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -14,6 +14,7 @@
 %bcond_without osmesa  # don't build osmesa
 %bcond_with    static
 #
+%define                snap    20100222
 # minimal supported xserver version
 %define                xserver_ver     1.5.0
 # glapi version (glapi tables in dri drivers and libglx must be in sync);
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       7.7
-Release:       2%{?with_multigl:.mgl}
+Version:       7.8
+Release:       0.%{snap}.1%{?with_multigl:.mgl}
 License:       MIT (core), SGI (GLU,libGLw) and others - see license.html file
 Group:         X11/Libraries
-Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: e3fa64a1508bc23dd9de9dd2cea7cfb1
-Source1:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
-# Source1-md5: 6fd616b27b9826d0faa23e08e05d9435
+# Source0:     ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
+## Source0-md5:        e3fa64a1508bc23dd9de9dd2cea7cfb1
+#Source1:      ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
+## Source1-md5:        6fd616b27b9826d0faa23e08e05d9435
+# git clone git://anongit.freedesktop.org/git/mesa/mesa
+# cd mesa && git archive master --prefix Mesa/ | bzip2 > ../Mesa-$(date +%Y%m%d).tar.bz2
+Source0:       %{name}-%{snap}.tar.bz2
+# Source0-md5: 7c97eb9576bf93a26fa7eca286df7926
 Patch0:                %{name}-realclean.patch
 Patch1:                %{name}-tgsi_dump.patch
 URL:           http://www.mesa3d.org/
@@ -626,7 +631,8 @@ X.org DRI driver for VMWare.
 Sterownik X.org DRI dla VMware.
 
 %prep
-%setup -q -b1
+%setup -q -n %{name}
+# -b1
 %patch0 -p0
 %patch1 -p1
 
@@ -634,8 +640,9 @@ Sterownik X.org DRI dla VMware.
 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
 
 %build
-%{__aclocal}
-%{__autoconf}
+autoreconf --install  
+#%{__aclocal}
+#%{__autoconf}
 
 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
 %if %{without gallium_intel}
@@ -656,49 +663,44 @@ common_flags="\
        --enable-selinux \
        --enable-pic \
        --enable-glx-tls \
+       --disable-glut \
+       --disable-os-mesa \
        --%{?with_egl:en}%{!?with_egl:dis}able-egl \
        --with%{!?with_demos:out}-demos"
 
-%if %{with osmesa}
-# osmesa variants
-%configure $common_flags \
+osmesa_common_flags="\
        --with-driver=osmesa \
        --disable-asm \
+       --disable-glu"
+
+%if %{with osmesa}
+# osmesa variants
+%configure $common_flags $osmesa_common_flags \
        --with-osmesa-bits=8
-%{__make} \
-       SRC_DIRS=mesa
+%{__make}
 mv %{_lib} osmesa8
 %{__make} clean
 
-%configure $common_flags \
-       --with-driver=osmesa \
-       --disable-asm \
+%configure $common_flags $osmesa_common_flags \
        --with-osmesa-bits=16
-%{__make} \
-       SRC_DIRS=mesa
+%{__make}
 mv %{_lib} osmesa16
 %{__make} clean
 
-%configure $common_flags \
-       --with-driver=osmesa \
-       --disable-asm \
+%configure $common_flags $osmesa_common_flags \
        --with-osmesa-bits=32
-%{__make} \
-       SRC_DIRS=mesa
+%{__make}
 mv %{_lib} osmesa32
 %{__make} clean
 %endif
 
 %configure $common_flags \
-       --enable-glu \
-       --enable-glw \
-       --disable-glut \
 %if %{with gallium}
        --enable-gallium \
        --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
        --enable-gallium-svga \
        --enable-gallium-nouveau \
-       --with-state-trackers=dri \
+       --with-state-trackers=dri,xorg,glx \
 %else
        --disable-gallium \
 %endif
@@ -722,6 +724,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
        DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with osmesa}
+rm -f osmesa*/libGLEW.*
 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
 %endif
 
This page took 1.229939 seconds and 4 git commands to generate.