]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
bfda65c2a569d89e1f250281d129bd72aa1270ea
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.18
25 %define         dri2proto_ver   1.99.3
26 #
27 Summary:        Free OpenGL implementation
28 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
29 Name:           Mesa
30 Version:        7.7
31 Release:        2%{?with_multigl:.mgl}
32 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
33 Group:          X11/Libraries
34 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
35 # Source0-md5:  e3fa64a1508bc23dd9de9dd2cea7cfb1
36 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
37 # Source1-md5:  6fd616b27b9826d0faa23e08e05d9435
38 Patch0:         %{name}-realclean.patch
39 Patch1:         %{name}-tgsi_dump.patch
40 URL:            http://www.mesa3d.org/
41 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  expat-devel
45 %{?with_demos:BuildRequires:    glew-devel}
46 BuildRequires:  libdrm-devel >= %{libdrm_ver}
47 BuildRequires:  libselinux-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtool >= 2:1.4d
50 %{?with_motif:BuildRequires:    motif-devel}
51 BuildRequires:  pkgconfig
52 BuildRequires:  python
53 BuildRequires:  rpmbuild(macros) >= 1.470
54 BuildRequires:  sed >= 4.0
55 BuildRequires:  xorg-lib-libXdamage-devel
56 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
57 BuildRequires:  xorg-lib-libXt-devel
58 BuildRequires:  xorg-lib-libXxf86vm-devel
59 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
60 BuildRequires:  xorg-proto-glproto-devel
61 BuildRequires:  xorg-proto-printproto-devel
62 BuildRequires:  xorg-util-makedepend
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %if %{without gallium}
66 %undefine       with_gallium_intel
67 %endif
68
69 %description
70 Mesa is a 3-D graphics library with an API which is very similar to
71 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
72 syntax or state machine, it is being used with authorization from
73 Silicon Graphics, Inc. However, the author does not possess an OpenGL
74 license from SGI, and makes no claim that Mesa is in any way a
75 compatible replacement for OpenGL or associated with SGI.
76
77 %description -l pl.UTF-8
78 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
79 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
80 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
81 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
82 OpenGL ani powiązana z SGI.
83
84 %package libGL
85 Summary:        Free Mesa3D implementation of libGL OpenGL library
86 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
87 License:        MIT
88 Group:          X11/Libraries
89 Requires:       libdrm >= %{libdrm_ver}
90 Provides:       OpenGL = 2.1
91 # reports version 1.3, but supports glXGetProcAddress() from 1.4
92 Provides:       OpenGL-GLX = 1.4
93 Obsoletes:      Mesa
94 Obsoletes:      Mesa-dri
95 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
96 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
97
98 %description libGL
99 Mesa is a 3-D graphics library with an API which is very similar to
100 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
101 syntax or state machine, it is being used with authorization from
102 Silicon Graphics, Inc. However, the author does not possess an OpenGL
103 license from SGI, and makes no claim that Mesa is in any way a
104 compatible replacement for OpenGL or associated with SGI.
105
106 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
107 specifications. It uses DRI for rendering.
108
109 %description libGL -l pl.UTF-8
110 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
111 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
112 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
113 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
114 OpenGL ani powiązana z SGI.
115
116 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
117 GLX 1.4. Używa DRI do renderowania.
118
119 %package libGL-devel
120 Summary:        Header files for Mesa3D libGL library
121 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
122 License:        MIT
123 Group:          X11/Development/Libraries
124 # loose dependency on libGL to use with other libGL binaries
125 Requires:       OpenGL >= 1.5
126 Requires:       libdrm-devel >= %{libdrm_ver}
127 Requires:       xorg-lib-libX11-devel
128 Requires:       xorg-lib-libXdamage-devel
129 Requires:       xorg-lib-libXext-devel
130 Requires:       xorg-lib-libXxf86vm-devel
131 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
132 Suggests:       OpenGL-doc-man
133 Provides:       OpenGL-GLX-devel = 1.4
134 Provides:       OpenGL-devel = 2.1
135 Obsoletes:      Mesa-devel
136 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
137 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
138 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
139 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
140
141 %description libGL-devel
142 Header files for Mesa3D libGL library.
143
144 %description libGL-devel -l pl.UTF-8
145 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
146
147 %package libGL-static
148 Summary:        Static Mesa3D libGL library
149 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
150 License:        MIT
151 Group:          X11/Development/Libraries
152 Requires:       %{name}-libGL-devel = %{version}-%{release}
153 Provides:       OpenGL-static = 2.1
154 Obsoletes:      Mesa-static
155 Obsoletes:      X11-OpenGL-static < 1:7.0.0
156 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
157
158 %description libGL-static
159 Static Mesa3D libGL library. It uses software renderer.
160
161 %description libGL-static -l pl.UTF-8
162 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
163 renderingu.
164
165 %package libGLU
166 Summary:        SGI implementation of libGLU OpenGL library
167 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
168 License:        SGI Free Software License B v2.0 (MIT-like)
169 Group:          Libraries
170 # loose dependency on libGL.so.1 to use with other libGL binaries
171 Requires:       OpenGL >= 1.2
172 Provides:       OpenGL-GLU = 1.3
173 Obsoletes:      Mesa-devel
174 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
175 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
176
177 %description libGLU
178 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
179 1.3 specifications.
180
181 %description libGLU -l pl.UTF-8
182 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
183 specyfikację OpenGL GLU 1.3.
184
185 %package libGLU-devel
186 Summary:        Header files for SGI libGLU library
187 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
188 License:        SGI Free Software License B v2.0 (MIT-like)
189 Group:          Development/Libraries
190 Requires:       %{name}-libGLU = %{version}-%{release}
191 Requires:       OpenGL-devel >= 1.2
192 Requires:       libstdc++-devel
193 Provides:       OpenGL-GLU-devel = 1.3
194
195 %description libGLU-devel
196 Header files for SGI libGLU library.
197
198 %description libGLU-devel -l pl.UTF-8
199 Pliki nagłówkowe biblioteki SGI libGLU.
200
201 %package libGLU-static
202 Summary:        Static SGI libGLU library
203 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
204 License:        SGI Free Software License B v2.0 (MIT-like)
205 Group:          Development/Libraries
206 Requires:       %{name}-libGLU-devel = %{version}-%{release}
207 Provides:       OpenGL-GLU-static = 1.3
208
209 %description libGLU-static
210 Static SGI libGLU library.
211
212 %description libGLU-static -l pl.UTF-8
213 Statyczna biblioteka SGI libGLU.
214
215 %package libGLw
216 Summary:        SGI OpenGL Xt widgets library
217 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
218 License:        SGI MIT-like
219 Group:          Libraries
220 # loose dependency on libGL.so.1 to use with other libGL binaries
221 Requires:       OpenGL >= 1.1
222 Provides:       OpenGL-GLw
223
224 %description libGLw
225 SGI OpenGL Xt widgets library.
226
227 %description libGLU -l pl.UTF-8
228 Biblioteka SGI widgetów Xt dla OpenGL-a.
229
230 %package libGLw-devel
231 Summary:        Header files for SGI libGLw library
232 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
233 License:        SGI MIT-like
234 Group:          Development/Libraries
235 Requires:       %{name}-libGLw = %{version}-%{release}
236 Requires:       OpenGL-devel >= 1.2
237 Provides:       OpenGL-GLw-devel
238
239 %description libGLw-devel
240 Header files for SGI libGLw library.
241
242 %description libGLw-devel -l pl.UTF-8
243 Pliki nagłówkowe biblioteki SGI libGLw.
244
245 %package libGLw-static
246 Summary:        Static SGI libGLw library
247 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
248 License:        SGI MIT-like
249 Group:          Development/Libraries
250 Requires:       %{name}-libGLw-devel = %{version}-%{release}
251 Provides:       OpenGL-GLw-static
252
253 %description libGLw-static
254 Static SGI libGLw library.
255
256 %description libGLw-static -l pl.UTF-8
257 Statyczna biblioteka SGI libGLw.
258
259 %package libOSMesa
260 Summary:        OSMesa (off-screen renderer) library
261 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
262 License:        MIT
263 Group:          Libraries
264 # doesn't require base
265
266 %description libOSMesa
267 OSMesa (off-screen renderer) library.
268
269 %description libOSMesa -l pl.UTF-8
270 Biblioteka OSMesa (renderująca bitmapy w pamięci).
271
272 %package libOSMesa-devel
273 Summary:        Header file for OSMesa (off-screen renderer) library
274 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
275 License:        MIT
276 Group:          Development/Libraries
277 Requires:       %{name}-libOSMesa = %{version}-%{release}
278 # for <GL/gl.h> only
279 Requires:       OpenGL-devel
280
281 %description libOSMesa-devel
282 Header file for OSMesa (off-screen renderer) library.
283
284 %description libOSMesa-devel -l pl.UTF-8
285 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
286
287 %package libOSMesa-static
288 Summary:        Static OSMesa (off-screen renderer) library
289 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
290 License:        MIT
291 Group:          Development/Libraries
292 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
293 # this static build of OSMesa needs static non-dri Mesa implementation
294 Requires:       %{name}-libGL-static = %{version}-%{release}
295
296 %description libOSMesa-static
297 Static OSMesa (off-screen renderer) library.
298
299 %description libOSMesa-static -l pl.UTF-8
300 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
301
302 %package utils
303 Summary:        OpenGL utilities from Mesa3D
304 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
305 License:        MIT
306 Group:          X11/Applications/Graphics
307 # loose deps on libGL/libGLU
308
309 %description utils
310 OpenGL utilities from Mesa3D: glxgears and glxinfo.
311
312 %description utils -l pl.UTF-8
313 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
314
315 %package demos
316 Summary:        Mesa Demos source code
317 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
318 License:        various (MIT, SGI, GPL - see copyright notes in sources)
319 Group:          Development/Libraries
320 Requires:       OpenGL-devel
321
322 %description demos
323 Demonstration programs for the Mesa libraries in source code form.
324
325 %description demos -l pl.UTF-8
326 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
327
328 %package dri-driver-ati-mach64
329 Summary:        X.org DRI driver for ATI Mach64 card family
330 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
331 License:        MIT
332 Group:          X11/Libraries
333 Requires:       xorg-driver-video-mach64
334 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
335 Requires:       xorg-xserver-server >= %{xserver_ver}
336
337 %description dri-driver-ati-mach64
338 X.org DRI driver for ATI Mach64 card family.
339
340 %description dri-driver-ati-mach64 -l pl.UTF-8
341 Sterownik X.org DRI dla rodziny kart ATI Mach64.
342
343 %package dri-driver-ati-radeon-R100
344 Summary:        X.org DRI driver for ATI R100 card family
345 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
346 License:        MIT
347 Group:          X11/Libraries
348 Requires:       xorg-driver-video-ati
349 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
350 Requires:       xorg-xserver-server >= %{xserver_ver}
351 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
352
353 %description dri-driver-ati-radeon-R100
354 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
355
356 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
357 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
358
359 %package dri-driver-ati-radeon-R200
360 Summary:        X.org DRI driver for ATI R200 card family
361 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
362 License:        MIT
363 Group:          X11/Libraries
364 Requires:       xorg-driver-video-ati
365 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
366 Requires:       xorg-xserver-server >= %{xserver_ver}
367 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
368
369 %description dri-driver-ati-radeon-R200
370 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
371
372 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
373 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
374
375 %package dri-driver-ati-radeon-R300
376 Summary:        X.org DRI driver for ATI R300 card family
377 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
378 License:        MIT
379 Group:          X11/Libraries
380 Requires:       xorg-driver-video-ati
381 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
382 Requires:       xorg-xserver-server >= %{xserver_ver}
383 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
384
385 %description dri-driver-ati-radeon-R300
386 X.org DRI driver for ATI R300 card family.
387
388 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
389 Sterownik X.org DRI dla rodziny kart ATI R300.
390
391 %package dri-driver-ati-radeon-R600
392 Summary:        X.org DRI driver for ATI R600 card family
393 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
394 License:        MIT
395 Group:          X11/Libraries
396 Requires:       radeon-ucode
397 Requires:       xorg-driver-video-ati
398 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
399 Requires:       xorg-xserver-server >= %{xserver_ver}
400
401 %description dri-driver-ati-radeon-R600
402 X.org DRI driver for ATI R600 card family.
403
404 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
405 Sterownik X.org DRI dla rodziny kart ATI R600.
406
407 %package dri-driver-ati-rage128
408 Summary:        X.org DRI driver for ATI Rage128 card family
409 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
410 License:        MIT
411 Group:          X11/Libraries
412 Requires:       xorg-driver-video-r128
413 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
414 Requires:       xorg-xserver-server >= %{xserver_ver}
415 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
416
417 %description dri-driver-ati-rage128
418 X.org DRI driver for ATI Rage128 card family.
419
420 %description dri-driver-ati-rage128 -l pl.UTF-8
421 Sterownik X.org DRI dla rodziny kart ATI Rage128.
422
423 %package dri-driver-ffb
424 Summary:        X.org DRI driver for Sun FFB card family
425 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
426 License:        MIT
427 Group:          X11/Libraries
428 Requires:       xorg-driver-video-sunffb
429 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
430 Requires:       xorg-xserver-server >= %{xserver_ver}
431
432 %description dri-driver-ffb
433 X.org DRI driver for SUN Creator3D and Elite3D card family.
434
435 %description dri-driver-ffb -l pl.UTF-8
436 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
437
438 %package dri-driver-glint
439 Summary:        X.org DRI driver for GLINT/Permedia card family
440 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
441 License:        MIT
442 Group:          X11/Libraries
443 Requires:       xorg-driver-video-glint
444 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
445 Requires:       xorg-xserver-server >= %{xserver_ver}
446 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
447
448 %description dri-driver-glint
449 X.org DRI driver for GLINT/Permedia card family.
450
451 %description dri-driver-glint -l pl.UTF-8
452 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
453
454 %package dri-driver-intel-i810
455 Summary:        X.org DRI driver for Intel i810 card family
456 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
457 License:        MIT
458 Group:          X11/Libraries
459 Requires:       xorg-driver-video-intel
460 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
461 Requires:       xorg-xserver-server >= %{xserver_ver}
462 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
463
464 %description dri-driver-intel-i810
465 X.org DRI driver for Intel i810 card family.
466
467 %description dri-driver-intel-i810 -l pl.UTF-8
468 Sterownik X.org DRI dla rodziny kart Intel i810.
469
470 %package dri-driver-intel-i915
471 Summary:        X.org DRI driver for Intel i915 card family
472 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
473 License:        MIT
474 Group:          X11/Libraries
475 Requires:       xorg-driver-video-intel
476 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
477 Requires:       xorg-xserver-server >= %{xserver_ver}
478 Obsoletes:      Mesa-dri-driver-intel-i830
479 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
480
481 %description dri-driver-intel-i915
482 X.org DRI driver for Intel i915 card family.
483
484 %description dri-driver-intel-i915 -l pl.UTF-8
485 Sterownik X.org DRI dla rodziny kart Intel i915.
486
487 %package dri-driver-intel-i965
488 Summary:        X.org DRI driver for Intel i965 card family
489 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
490 License:        MIT
491 Group:          X11/Libraries
492 Requires:       xorg-driver-video-intel
493 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
494 Requires:       xorg-xserver-server >= %{xserver_ver}
495 Obsoletes:      Mesa-dri-driver-intel-i830
496 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
497
498 %description dri-driver-intel-i965
499 X.org DRI driver for Intel i965 card family.
500
501 %description dri-driver-intel-i965 -l pl.UTF-8
502 Sterownik X.org DRI dla rodziny kart Intel i965.
503
504 %package dri-driver-matrox
505 Summary:        X.org DRI driver for Matrox G card family
506 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
507 License:        MIT
508 Group:          X11/Libraries
509 Requires:       xorg-driver-video-mga
510 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
511 Requires:       xorg-xserver-server >= %{xserver_ver}
512 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
513
514 %description dri-driver-matrox
515 X.org DRI drivers for Matrox G card family.
516
517 %description dri-driver-matrox -l pl.UTF-8
518 Sterowniki X.org DRI dla rodziny kart Matrox G.
519
520 %package dri-driver-nouveau
521 Summary:        X.org DRI driver for NVIDIA card family
522 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
523 License:        MIT
524 Group:          X11/Libraries
525 Requires:       xorg-driver-video-nouveau
526 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
527 Requires:       xorg-xserver-server >= %{xserver_ver}
528
529 %description dri-driver-nouveau
530 X.org DRI drivers for NVIDIA card family.
531
532 %description dri-driver-nouveau -l pl.UTF-8
533 Sterowniki X.org DRI dla rodziny kart NVIDIA.
534
535 %package dri-driver-savage
536 Summary:        X.org DRI driver for S3 Savage card family
537 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
538 License:        MIT
539 Group:          X11/Libraries
540 Requires:       xorg-driver-video-savage
541 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
542 Requires:       xorg-xserver-server >= %{xserver_ver}
543
544 %description dri-driver-savage
545 X.org DRI driver for S3 Savage card family.
546
547 %description dri-driver-savage -l pl.UTF-8
548 Sterownik X.org DRI dla rodziny kart S3 Savage.
549
550 %package dri-driver-sis
551 Summary:        X.org DRI driver for SiS card family
552 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
553 License:        MIT
554 Group:          X11/Libraries
555 Requires:       xorg-driver-video-sis
556 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
557 Requires:       xorg-xserver-server >= %{xserver_ver}
558 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
559
560 %description dri-driver-sis
561 X.org DRI driver for SiS card family.
562
563 %description dri-driver-sis -l pl.UTF-8
564 Sterownik X.org DRI dla rodziny kart SiS.
565
566 %package dri-driver-swrast
567 Summary:        X.org DRI software rasterizer driver
568 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
569 License:        MIT
570 Group:          X11/Libraries
571 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
572 Requires:       xorg-xserver-server >= %{xserver_ver}
573
574 %description dri-driver-swrast
575 X.org DRI software rasterizer driver.
576
577 %description dri-driver-swrast -l pl.UTF-8
578 Sterownik X.org DRI obsługujący rysowanie programowe.
579
580 %package dri-driver-tdfx
581 Summary:        X.org DRI driver for 3DFX Voodoo card family
582 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
583 License:        MIT
584 Group:          X11/Libraries
585 Requires:       Glide3-DRI
586 Requires:       xorg-driver-video-tdfx
587 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
588 Requires:       xorg-xserver-server >= %{xserver_ver}
589 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
590
591 %description dri-driver-tdfx
592 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
593 and Velocity 100/200).
594
595 %description dri-driver-tdfx -l pl.UTF-8
596 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
597 Banshee i Velocity 100/200).
598
599 %package dri-driver-via-unichrome
600 Summary:        X.org DRI driver for VIA Unichrome card family
601 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
602 License:        MIT
603 Group:          X11/Libraries
604 Requires:       xorg-driver-video-openchrome
605 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
606 Requires:       xorg-xserver-server >= %{xserver_ver}
607
608 %description dri-driver-via-unichrome
609 X.org DRI driver for VIA Unichrome card family.
610
611 %description dri-driver-via-unichrome -l pl.UTF-8
612 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
613
614 %package dri-driver-vmwgfx
615 Summary:        X.org DRI driver for VMware
616 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
617 License:        MIT
618 Group:          X11/Libraries
619 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
620 Requires:       xorg-xserver-server >= %{xserver_ver}
621
622 %description dri-driver-vmwgfx
623 X.org DRI driver for VMWare.
624
625 %description dri-driver-vmwgfx -l pl.UTF-8
626 Sterownik X.org DRI dla VMware.
627
628 %prep
629 %setup -q -b1
630 %patch0 -p0
631 %patch1 -p1
632
633 # fix demos
634 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
635
636 %build
637 %{__aclocal}
638 %{__autoconf}
639
640 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
641 %if %{without gallium_intel}
642 i915 \
643 %endif
644 %ifarch sparc sparcv9 sparc64
645 ffb \
646 %endif
647 %ifarch %{ix86} %{x8664}
648 sis \
649 %endif
650 swrast tdfx unichrome"
651
652 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
653
654 common_flags="\
655         --enable-shared \
656         --enable-selinux \
657         --enable-pic \
658         --enable-glx-tls \
659         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
660         --with%{!?with_demos:out}-demos"
661
662 %if %{with osmesa}
663 # osmesa variants
664 %configure $common_flags \
665         --with-driver=osmesa \
666         --disable-asm \
667         --with-osmesa-bits=8
668 %{__make} \
669         SRC_DIRS=mesa
670 mv %{_lib} osmesa8
671 %{__make} clean
672
673 %configure $common_flags \
674         --with-driver=osmesa \
675         --disable-asm \
676         --with-osmesa-bits=16
677 %{__make} \
678         SRC_DIRS=mesa
679 mv %{_lib} osmesa16
680 %{__make} clean
681
682 %configure $common_flags \
683         --with-driver=osmesa \
684         --disable-asm \
685         --with-osmesa-bits=32
686 %{__make} \
687         SRC_DIRS=mesa
688 mv %{_lib} osmesa32
689 %{__make} clean
690 %endif
691
692 %configure $common_flags \
693         --enable-glu \
694         --enable-glw \
695         --disable-glut \
696 %if %{with gallium}
697         --enable-gallium \
698         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
699         --enable-gallium-svga \
700         --enable-gallium-nouveau \
701         --with-state-trackers=dri \
702 %else
703         --disable-gallium \
704 %endif
705         --with-driver=dri \
706         --with-dri-drivers=${dri_drivers} \
707         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
708
709 %{__make}
710 %{__make} -C progs/xdemos glxgears glxinfo
711 %if %{with demos}
712 %{__make} -C progs/demos
713 %endif
714
715 %install
716 rm -rf $RPM_BUILD_ROOT
717
718 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
719
720 # libs without drivers
721 %{__make} install \
722         DESTDIR=$RPM_BUILD_ROOT
723
724 %if %{with osmesa}
725 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
726 %endif
727
728 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
729 # work on copy to keep -bi --short-circuit working
730 rm -rf progs-clean
731 install -d progs-clean
732 for l in demos glsl osdemos redbook samples xdemos ; do
733         cp -a progs/$l progs-clean/$l
734         %{__make} -C progs-clean/$l clean
735         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
736 done
737 rm -rf progs-clean
738 for l in util images ; do
739         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
740 done
741 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
742
743 # strip out undesirable headers
744 olddir=$(pwd)
745 cd $RPM_BUILD_ROOT%{_includedir}/GL
746 rm [a-fh-np-wyz]*.h gg*.h glf*.h
747 cd $RPM_BUILD_ROOT%{_libdir}
748 cd $olddir
749
750 %if %{with multigl}
751 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
752
753 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
754 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
755
756 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
757 %endif
758
759 %clean
760 rm -rf $RPM_BUILD_ROOT
761
762 %post   libGL -p /sbin/ldconfig
763 %postun libGL -p /sbin/ldconfig
764
765 %post   libGLU -p /sbin/ldconfig
766 %postun libGLU -p /sbin/ldconfig
767
768 %post   libGLw -p /sbin/ldconfig
769 %postun libGLw -p /sbin/ldconfig
770
771 %files libGL
772 %defattr(644,root,root,755)
773 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
774 %if %{with multigl}
775 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
776 %dir %{_libdir}/Mesa
777 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
778 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
779 %else
780 %attr(755,root,root) %{_libdir}/libGL.so.*.*
781 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
782 # symlink for binary apps which fail to conform Linux OpenGL ABI
783 # (and dlopen libGL.so instead of libGL.so.1)
784 %attr(755,root,root) %{_libdir}/libGL.so
785 %endif
786
787 %files libGL-devel
788 %defattr(644,root,root,755)
789 %doc docs/*.spec
790 %if %{with multigl}
791 %attr(755,root,root) %{_libdir}/libGL.so
792 %endif
793 %dir %{_includedir}/GL
794 %{_includedir}/GL/gl.h
795 %{_includedir}/GL/glext.h
796 %{_includedir}/GL/gl_mangle.h
797 %{_includedir}/GL/glx.h
798 %{_includedir}/GL/glxext.h
799 %{_includedir}/GL/glx_mangle.h
800 %dir %{_includedir}/GL/internal
801 %{_includedir}/GL/internal/dri_interface.h
802 %{_pkgconfigdir}/dri.pc
803 %{_pkgconfigdir}/gl.pc
804
805 %if %{with static}
806 %files libGL-static
807 %defattr(644,root,root,755)
808 %{_libdir}/libGL.a
809 %endif
810
811 %files libGLU
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
814 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
815
816 %files libGLU-devel
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_libdir}/libGLU.so
819 %{_includedir}/GL/glu.h
820 %{_includedir}/GL/glu_mangle.h
821 %{_pkgconfigdir}/glu.pc
822
823 %if %{with static}
824 %files libGLU-static
825 %defattr(644,root,root,755)
826 %{_libdir}/libGLU.a
827 %endif
828
829 %files libGLw
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
832 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
833
834 %files libGLw-devel
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/libGLw.so
837 %{_includedir}/GL/GLwDrawA.h
838 %{_includedir}/GL/GLwDrawAP.h
839 %{_includedir}/GL/GLwMDrawA.h
840 %{_includedir}/GL/GLwMDrawAP.h
841 %{_pkgconfigdir}/glw.pc
842
843 %if %{with static}
844 %files libGLw-static
845 %defattr(644,root,root,755)
846 %{_libdir}/libGLw.a
847 %endif
848
849 %if %{with osmesa}
850 %files libOSMesa
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
853 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
854
855 %files libOSMesa-devel
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_libdir}/libOSMesa*.so
858 %{_includedir}/GL/osmesa.h
859
860 %if %{with static}
861 %files libOSMesa-static
862 %defattr(644,root,root,755)
863 %{_libdir}/libOSMesa*.a
864 %endif
865 %endif
866
867 %files utils
868 %defattr(644,root,root,755)
869 %attr(755,root,root) %{_bindir}/glxgears
870 %attr(755,root,root) %{_bindir}/glxinfo
871
872 %files dri-driver-ati-mach64
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
875
876 %files dri-driver-ati-radeon-R100
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
879
880 %files dri-driver-ati-radeon-R200
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
883
884 %files dri-driver-ati-radeon-R300
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
887
888 %files dri-driver-ati-radeon-R600
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
891
892 %files dri-driver-ati-rage128
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
895
896 # sunffb (sparc only)
897 %ifarch sparc sparcv9 sparc64
898 %files dri-driver-ffb
899 %defattr(644,root,root,755)
900 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
901 %endif
902
903 # glint (requires update)
904 %if 0
905 %files dri-driver-glint
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
908 %endif
909
910 %files dri-driver-intel-i810
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
913
914 %files dri-driver-intel-i915
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
917
918 %files dri-driver-intel-i965
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
921
922 %files dri-driver-matrox
923 %defattr(644,root,root,755)
924 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
925
926 %if %{with gallium}
927 %files dri-driver-nouveau
928 %defattr(644,root,root,755)
929 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
930 %endif
931
932 %files dri-driver-savage
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
935
936 %ifarch %{ix86} %{x8664}
937 %files dri-driver-sis
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
940 %endif
941
942 %files dri-driver-swrast
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
945
946 %files dri-driver-tdfx
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
949
950 %files dri-driver-via-unichrome
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
953
954 %if %{with gallium}
955 %files dri-driver-vmwgfx
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
958 %endif
959
960 %if %{with demos}
961 %files demos
962 %defattr(644,root,root,755)
963 %{_examplesdir}/%{name}-%{version}
964 %endif
This page took 0.369938 seconds and 2 git commands to generate.