]> git.pld-linux.org Git - SPECS.git/blob - python-flask-babel.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / python-flask-babel.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # don't build doc
4 %bcond_with     tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  flask-babel
9 Summary:        Extension to Flask that adds i18n and l10n support to any Flask application with the help of babel, pytz and speaklater
10 Summary(pl.UTF-8):      Rozszerzenie Flask dodające wsparcie dla i18n i l10n przy użyciu babel, pytz i speklater.
11 # Name must match the python module/package name (as in 'import' statement)
12 Name:           python-%{module}
13 Version:        0.9
14 Release:        7
15 License:        BSD
16 Group:          Libraries/Python
17 # https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-0.9.tar.gz
18 Source0:        https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-%{version}.tar.gz
19 # Source0-md5:  4762e0392303f464d53cbebedfb87ded
20 URL:            http://github.com/mitsuhiko/flask-babel
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.710
23 %if %{with python2}
24 BuildRequires:  python-distribute
25 BuildRequires:  python-speaklater
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-distribute
29 BuildRequires:  python3-modules
30 BuildRequires:  python3-speaklater
31 %endif
32 Requires:       python-jinja2 >= 2.5
33 Requires:       python-modules
34 Requires:       python-speaklater
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Adds i18n/l10n support to Flask applications with the help of the
40 Babel library.
41
42 # %description -l pl.UTF-8
43
44 %package -n python3-%{module}
45 Summary:        -
46 Summary(pl.UTF-8):      -
47 Group:          Libraries/Python
48 Requires:       python3-jinja2 >= 2.5
49 Requires:       python3-modules
50 Requires:       python3-speaklater
51
52 %description -n python3-%{module}
53 Adds i18n/l10n support to Flask applications with the help of the
54 Babel library.
55
56 # %description -n python3-%{module} -l pl.UTF-8
57
58 %package apidocs
59 Summary:        %{module} API documentation
60 Summary(pl.UTF-8):      Dokumentacja API %{module}
61 Group:          Documentation
62
63 %description apidocs
64 API documentation for %{module}.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API %{module}.
68
69 %prep
70 %setup -q -n Flask-Babel-%{version}
71
72 %build
73 %if %{with python2}
74 %py_build %{?with_tests:test}
75 %endif
76
77 %if %{with python3}
78 %py3_build %{?with_tests:test}
79 %endif
80
81 %if %{with doc}
82 cd docs
83 %{__make} -j1 html
84 rm -rf _build/html/_sources
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 %py_install
92
93 %py_postclean
94 %endif
95
96 %if %{with python3}
97 %py3_install
98 %endif
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %if %{with python2}
104 %files
105 %defattr(644,root,root,755)
106 %doc LICENSE README
107 %{py_sitescriptdir}/flask_babel
108 %if "%{py_ver}" > "2.4"
109 %{py_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
110 %endif
111 %endif
112
113 %if %{with python3}
114 %files -n python3-%{module}
115 %defattr(644,root,root,755)
116 %doc LICENSE README
117 %{py3_sitescriptdir}/flask_babel
118 %{py3_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
119 %endif
120
121 %if %{with doc}
122 %files apidocs
123 %defattr(644,root,root,755)
124 %doc docs/_build/html/*
125 %endif
This page took 0.131396 seconds and 3 git commands to generate.