]> git.pld-linux.org Git - SPECS.git/blob - python-flask-babel.spec
SPECS updated Wed 1 May 10:14:00 CEST 2024
[SPECS.git] / python-flask-babel.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # don't build doc
4 %bcond_with     tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  flask-babel
9 Summary:        Extension to Flask that adds i18n and l10n support to any Flask application with the help of babel, pytz and speaklater
10 Summary(pl.UTF-8):      Rozszerzenie Flask dodające wsparcie dla i18n i l10n przy użyciu babel, pytz i speklater.
11 # Name must match the python module/package name (as in 'import' statement)
12 Name:           python-%{module}
13 Version:        0.9
14 Release:        8
15 License:        BSD
16 Group:          Libraries/Python
17 # https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-0.9.tar.gz
18 Source0:        https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-%{version}.tar.gz
19 # Source0-md5:  4762e0392303f464d53cbebedfb87ded
20 URL:            http://github.com/mitsuhiko/flask-babel
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.710
23 %if %{with python2}
24 BuildRequires:  python-distribute
25 BuildRequires:  python-speaklater
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules
29 BuildRequires:  python3-speaklater
30 %endif
31 Requires:       python-jinja2 >= 2.5
32 Requires:       python-modules
33 Requires:       python-speaklater
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Adds i18n/l10n support to Flask applications with the help of the
39 Babel library.
40
41 # %description -l pl.UTF-8
42
43 %package -n python3-%{module}
44 Summary:        -
45 Summary(pl.UTF-8):      -
46 Group:          Libraries/Python
47 Requires:       python3-jinja2 >= 2.5
48 Requires:       python3-modules
49 Requires:       python3-speaklater
50
51 %description -n python3-%{module}
52 Adds i18n/l10n support to Flask applications with the help of the
53 Babel library.
54
55 # %description -n python3-%{module} -l pl.UTF-8
56
57 %package apidocs
58 Summary:        %{module} API documentation
59 Summary(pl.UTF-8):      Dokumentacja API %{module}
60 Group:          Documentation
61
62 %description apidocs
63 API documentation for %{module}.
64
65 %description apidocs -l pl.UTF-8
66 Dokumentacja API %{module}.
67
68 %prep
69 %setup -q -n Flask-Babel-%{version}
70
71 %build
72 %if %{with python2}
73 %py_build %{?with_tests:test}
74 %endif
75
76 %if %{with python3}
77 %py3_build %{?with_tests:test}
78 %endif
79
80 %if %{with doc}
81 cd docs
82 %{__make} -j1 html
83 rm -rf _build/html/_sources
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %if %{with python2}
90 %py_install
91
92 %py_postclean
93 %endif
94
95 %if %{with python3}
96 %py3_install
97 %endif
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %if %{with python2}
103 %files
104 %defattr(644,root,root,755)
105 %doc LICENSE README
106 %{py_sitescriptdir}/flask_babel
107 %if "%{py_ver}" > "2.4"
108 %{py_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
109 %endif
110 %endif
111
112 %if %{with python3}
113 %files -n python3-%{module}
114 %defattr(644,root,root,755)
115 %doc LICENSE README
116 %{py3_sitescriptdir}/flask_babel
117 %{py3_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
118 %endif
119
120 %if %{with doc}
121 %files apidocs
122 %defattr(644,root,root,755)
123 %doc docs/_build/html/*
124 %endif
This page took 0.127815 seconds and 4 git commands to generate.