]> git.pld-linux.org Git - SPECS.git/blob - openjpeg2.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / openjpeg2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        An open-source JPEG 2000 codec
6 Summary(pl.UTF-8):      Biblioteka kodująca i dekodująca format JPEG 2000
7 Name:           openjpeg2
8 Version:        2.4.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/uclouvain/openjpeg/releases/
13 Source0:        https://github.com/uclouvain/openjpeg/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  4d388298335947367e91f1d100468af1
15 URL:            http://www.openjpeg.org/
16 BuildRequires:  cmake >= 2.8.2
17 BuildRequires:  doxygen
18 BuildRequires:  lcms2-devel >= 2
19 BuildRequires:  libpng-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  pkgconfig >= 1:0.22
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The OpenJPEG 2 library is an open-source JPEG 2000 codec written in C
28 language. It has been developed in order to promote the use of JPEG
29 2000, the new still-image compression standard from the Joint
30 Photographic Experts Group (JPEG).
31
32 %description -l pl.UTF-8
33 OpenJPEG 2 to mająca otwarte źródła biblioteka kodująca i dekodująca
34 format JPEG 2000, napisana w języku C. Powstała w celu promowania
35 użycia formatu JPEG 2000 - nowego standardu obrazów nieruchomych
36 stworzonego przez grupę JPEG (Joint Photographic Experts Group).
37
38 %package devel
39 Summary:        Header file for OpenJPEG 2 library
40 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OpenJPEG 2
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 This package contains the header file needed for developing programs
46 using the OpenJPEG 2 library.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera plik nagłówkowy potrzebny do tworzenia programów
50 wykorzystujących bibliotekę OpenJPEG 2.
51
52 %package static
53 Summary:        Static OpenJPEG 2 library
54 Summary(pl.UTF-8):      Statyczna biblioteka OpenJPEG 2
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static OpenJPEG 2 library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka OpenJPEG 2.
63
64 %package progs
65 Summary:        OpenJPEG 2 codec programs
66 Summary(pl.UTF-8):      Programy kodujące/dekodujące dla biblioteki OpenJPEG 2
67 Group:          Applications/Graphics
68 Requires:       %{name} = %{version}-%{release}
69
70 %description progs
71 OpenJPEG 2 codec programs.
72
73 %description progs -l pl.UTF-8
74 Programy kodujące/dekodujące dla biblioteki OpenJPEG 2.
75
76 %prep
77 %setup -q -n openjpeg-%{version}
78
79 %build
80 %cmake . \
81         -DBUILD_DOC=ON \
82         %{!?with_static_libs:-DBUILD_STATIC_LIBS=OFF} \
83         -DOPENJPEG_INSTALL_LIB_DIR=%{_lib}
84
85 # not ready for openjpeg 2:
86 #       -DBUILD_JAVA=ON
87 #       -DBUILD_JPWL=ON
88 #       -DBUILD_MJ2=ON
89 #       -DBUILD_VIEWER=ON -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk2-unicode-config
90
91 # no BUILD_JPIP here (see openjpip.spec for it)
92 # no BUILD_JP3D here (see openjp3d.spec for it)
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # packaged as doc
103 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/openjpeg-2.4
104
105 # disable completeness check incompatible with split packaging
106 %{__sed} -i -e '/_IMPORT_CHECK_FILES_FOR_\(openjp2_static\|opj_\)/d' $RPM_BUILD_ROOT%{_libdir}/openjpeg-2.4/OpenJPEGTargets-pld.cmake
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS.md CHANGELOG.md LICENSE NEWS.md README.md THANKS.md
117 %attr(755,root,root) %{_libdir}/libopenjp2.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libopenjp2.so.7
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libopenjp2.so
123 %{_includedir}/openjpeg-2.4
124 %dir %{_libdir}/openjpeg-2.4
125 %{_libdir}/openjpeg-2.4/OpenJPEG*.cmake
126 %{_pkgconfigdir}/libopenjp2.pc
127 %{_mandir}/man3/libopenjp2.3*
128
129 %if %{with static_libs}
130 %files static
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libopenjp2.a
133 %endif
134
135 %files progs
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/opj_compress
138 %attr(755,root,root) %{_bindir}/opj_decompress
139 %attr(755,root,root) %{_bindir}/opj_dump
140 %{_mandir}/man1/opj_compress.1*
141 %{_mandir}/man1/opj_decompress.1*
142 %{_mandir}/man1/opj_dump.1*
This page took 0.221246 seconds and 3 git commands to generate.