]> git.pld-linux.org Git - SPECS.git/blob - openjpeg2.spec
SPECS updated Wed 1 May 10:14:00 CEST 2024
[SPECS.git] / openjpeg2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        An open-source JPEG 2000 codec
6 Summary(pl.UTF-8):      Biblioteka kodująca i dekodująca format JPEG 2000
7 Name:           openjpeg2
8 Version:        2.5.2
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/uclouvain/openjpeg/releases/
13 Source0:        https://github.com/uclouvain/openjpeg/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  f9ee64845881a15109ed0aa73a12202f
15 URL:            http://www.openjpeg.org/
16 BuildRequires:  cmake >= 3.5
17 BuildRequires:  doxygen
18 BuildRequires:  lcms2-devel >= 2
19 BuildRequires:  libpng-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  pkgconfig >= 1:0.22
22 BuildRequires:  rpm-build >= 4.6
23 BuildRequires:  rpmbuild(macros) >= 1.605
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The OpenJPEG 2 library is an open-source JPEG 2000 codec written in C
30 language. It has been developed in order to promote the use of JPEG
31 2000, the new still-image compression standard from the Joint
32 Photographic Experts Group (JPEG).
33
34 %description -l pl.UTF-8
35 OpenJPEG 2 to mająca otwarte źródła biblioteka kodująca i dekodująca
36 format JPEG 2000, napisana w języku C. Powstała w celu promowania
37 użycia formatu JPEG 2000 - nowego standardu obrazów nieruchomych
38 stworzonego przez grupę JPEG (Joint Photographic Experts Group).
39
40 %package devel
41 Summary:        Header file for OpenJPEG 2 library
42 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OpenJPEG 2
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 This package contains the header file needed for developing programs
48 using the OpenJPEG 2 library.
49
50 %description devel -l pl.UTF-8
51 Ten pakiet zawiera plik nagłówkowy potrzebny do tworzenia programów
52 wykorzystujących bibliotekę OpenJPEG 2.
53
54 %package static
55 Summary:        Static OpenJPEG 2 library
56 Summary(pl.UTF-8):      Statyczna biblioteka OpenJPEG 2
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static OpenJPEG 2 library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka OpenJPEG 2.
65
66 %package apidocs
67 Summary:        OpenJPEG 2 API documentation
68 Summary(pl.UTF-8):      Dokumentacja API OpenJPEG 2
69 Group:          Documentation
70 BuildArch:      noarch
71
72 %description apidocs
73 OpenJPEG 2 API documentation.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API OpenJPEG 2.
77
78 %package progs
79 Summary:        OpenJPEG 2 codec programs
80 Summary(pl.UTF-8):      Programy kodujące/dekodujące dla biblioteki OpenJPEG 2
81 Group:          Applications/Graphics
82 Requires:       %{name} = %{version}-%{release}
83
84 %description progs
85 OpenJPEG 2 codec programs.
86
87 %description progs -l pl.UTF-8
88 Programy kodujące/dekodujące dla biblioteki OpenJPEG 2.
89
90 %prep
91 %setup -q -n openjpeg-%{version}
92
93 %build
94 %cmake -B build \
95         -DBUILD_DOC=ON \
96         %{!?with_static_libs:-DBUILD_STATIC_LIBS=OFF} \
97         -DOPENJPEG_INSTALL_LIB_DIR=%{_lib}
98
99 # not ready for openjpeg 2:
100 #       -DBUILD_JAVA=ON
101 #       -DBUILD_JPWL=ON
102 #       -DBUILD_MJ2=ON
103 #       -DBUILD_VIEWER=ON -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk2-unicode-config
104
105 # no BUILD_JPIP here (see openjpip.spec for it)
106 # no BUILD_JP3D here (see openjp3d.spec for it)
107
108 %{__make} -C build
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} -C build install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 # packaged as doc
117 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/html
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS.md CHANGELOG.md LICENSE NEWS.md README.md THANKS.md
128 %attr(755,root,root) %{_libdir}/libopenjp2.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libopenjp2.so.7
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libopenjp2.so
134 %{_includedir}/openjpeg-2.5
135 %{_libdir}/cmake/openjpeg-2.5
136 %{_pkgconfigdir}/libopenjp2.pc
137 %{_mandir}/man3/libopenjp2.3*
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libopenjp2.a
143 %endif
144
145 %files apidocs
146 %defattr(644,root,root,755)
147 %doc build/doc/html/*
148
149 %files progs
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/opj_compress
152 %attr(755,root,root) %{_bindir}/opj_decompress
153 %attr(755,root,root) %{_bindir}/opj_dump
154 %{_mandir}/man1/opj_compress.1*
155 %{_mandir}/man1/opj_decompress.1*
156 %{_mandir}/man1/opj_dump.1*
This page took 0.109409 seconds and 4 git commands to generate.