]> git.pld-linux.org Git - SPECS.git/blob - grantlee-qt5.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / grantlee-qt5.spec
1
2 %bcond_without  tests           # unit tests
3
4 %define         qt_ver          5.3.0
5 %define         major_ver       5.2
6
7 Summary:        Grantlee - set of frameworks for use with Qt 5
8 Summary(pl.UTF-8):      Grantlee - zbiór szkieletów do wykorzystania z Qt 5
9 Name:           grantlee-qt5
10 Version:        5.2.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://downloads.grantlee.org/grantlee-%{version}.tar.gz
15 # Source0-md5:  6239b3703674f88b2236d30d0ed67eea
16 URL:            http://www.grantlee.org/
17 BuildRequires:  Qt5Core-devel >= %{qt_ver}
18 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
19 BuildRequires:  Qt5Network-devel >= %{qt_ver}
20 BuildRequires:  Qt5Script-devel >= %{qt_ver}
21 BuildRequires:  Qt5Sql-devel >= %{qt_ver}
22 BuildRequires:  Qt5Test-devel >= %{qt_ver}
23 BuildRequires:  Qt5WebKit-devel >= %{qt_ver}
24 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
25 BuildRequires:  Qt5XmlPatterns-devel >= %{qt_ver}
26 BuildRequires:  cmake >= 3.5
27 BuildRequires:  qt5-build >= %{qt_ver}
28 BuildRequires:  qt5-qmake >= %{qt_ver}
29 BuildRequires:  qt5-linguist >= %{qt_ver}
30 BuildRequires:  rpmbuild(macros) >= 1.605
31 Requires:       Qt5Core >= %{qt_ver}
32 Requires:       Qt5Gui >= %{qt_ver}
33 Requires:       Qt5Script >= %{qt_ver}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Grantlee is a string template engine based on the Django template
38 system and written using Qt.
39
40 %description -l pl.UTF-8
41 Grantlee to silnik szablonów oparty na systemie szablonów Django i
42 napisany przy użyciu Qt.
43
44 %package devel
45 Summary:        Header files for grantlee libraries
46 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek grantlee
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       Qt5Core-devel >= %{qt_ver}
50 # only textdocument library
51 Requires:       Qt5Gui-devel >= %{qt_ver}
52 Conflicts:      grantlee-devel
53
54 %description devel
55 Header files for grantlee libraries.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe bibliotek grantlee.
59
60 %prep
61 %setup -q -n grantlee-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake ..
67
68 %{__make}
69
70 %if %{with tests}
71 QT_QPA_PLATFORM=offscreen \
72 %{__make} test ARGS=-V
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS CHANGELOG README.md
90 %attr(755,root,root) %{_libdir}/libGrantlee_Templates.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libGrantlee_Templates.so.5
92 %attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libGrantlee_TextDocument.so.5
94 %dir %{_libdir}/grantlee
95 %dir %{_libdir}/grantlee/%{major_ver}
96 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaultfilters.so
97 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaulttags.so
98 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_i18ntags.so
99 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_loadertags.so
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libGrantlee_Templates.so
104 %attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so
105 %{_includedir}/grantlee_templates.h
106 %{_includedir}/grantlee_textdocument.h
107 %{_includedir}/grantlee
108 %{_libdir}/cmake/Grantlee5
This page took 0.073463 seconds and 3 git commands to generate.