]> git.pld-linux.org Git - SPECS.git/blob - grantlee-qt5.spec
SPECS updated Wed 1 May 10:14:00 CEST 2024
[SPECS.git] / grantlee-qt5.spec
1
2 %bcond_without  tests           # unit tests
3
4 %define         qt_ver          5.3.0
5 %define         major_ver       5.3
6
7 Summary:        Grantlee - set of frameworks for use with Qt 5
8 Summary(pl.UTF-8):      Grantlee - zbiór szkieletów do wykorzystania z Qt 5
9 Name:           grantlee-qt5
10 Version:        5.3.1
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        https://github.com/steveire/grantlee/releases/download/v%{version}/grantlee-%{version}.tar.gz
15 # Source0-md5:  4ef8eae5dd61e3c7603d76208eb4d922
16 Patch0:         x87fix.patch
17 URL:            http://www.grantlee.org/
18 BuildRequires:  Qt5Core-devel >= %{qt_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
20 BuildRequires:  Qt5Network-devel >= %{qt_ver}
21 BuildRequires:  Qt5Script-devel >= %{qt_ver}
22 BuildRequires:  Qt5Sql-devel >= %{qt_ver}
23 BuildRequires:  Qt5Test-devel >= %{qt_ver}
24 BuildRequires:  Qt5WebKit-devel >= %{qt_ver}
25 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
26 BuildRequires:  Qt5XmlPatterns-devel >= %{qt_ver}
27 BuildRequires:  cmake >= 3.5
28 BuildRequires:  qt5-build >= %{qt_ver}
29 BuildRequires:  qt5-qmake >= %{qt_ver}
30 BuildRequires:  qt5-linguist >= %{qt_ver}
31 BuildRequires:  rpmbuild(macros) >= 1.605
32 Requires:       Qt5Core >= %{qt_ver}
33 Requires:       Qt5Gui >= %{qt_ver}
34 Requires:       Qt5Script >= %{qt_ver}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Grantlee is a string template engine based on the Django template
39 system and written using Qt.
40
41 %description -l pl.UTF-8
42 Grantlee to silnik szablonów oparty na systemie szablonów Django i
43 napisany przy użyciu Qt.
44
45 %package devel
46 Summary:        Header files for grantlee libraries
47 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek grantlee
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       Qt5Core-devel >= %{qt_ver}
51 # only textdocument library
52 Requires:       Qt5Gui-devel >= %{qt_ver}
53 Conflicts:      grantlee-devel
54
55 %description devel
56 Header files for grantlee libraries.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe bibliotek grantlee.
60
61 %prep
62 %setup -q -n grantlee-%{version}
63 %patch0 -p1
64
65 %build
66 install -d build
67 cd build
68 %cmake ..
69
70 %{__make}
71
72 %if %{with tests}
73 QT_QPA_PLATFORM=offscreen \
74 %{__make} test ARGS=-V
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS CHANGELOG README.md
92 %attr(755,root,root) %{_libdir}/libGrantlee_Templates.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libGrantlee_Templates.so.5
94 %attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libGrantlee_TextDocument.so.5
96 %dir %{_libdir}/grantlee
97 %dir %{_libdir}/grantlee/%{major_ver}
98 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaultfilters.so
99 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaulttags.so
100 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_i18ntags.so
101 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_loadertags.so
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libGrantlee_Templates.so
106 %attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so
107 %{_includedir}/grantlee_templates.h
108 %{_includedir}/grantlee_textdocument.h
109 %{_includedir}/grantlee
110 %{_libdir}/cmake/Grantlee5
This page took 0.611656 seconds and 4 git commands to generate.