]> git.pld-linux.org Git - packages/perl-Sereal-Decoder.git/blob - perl-Sereal-Decoder.spec
- perl req/prov fix
[packages/perl-Sereal-Decoder.git] / perl-Sereal-Decoder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Sereal
6 %define         pnam    Decoder
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Sereal::Decoder - Fast, compact, powerful binary deserialization
9 Summary(pl.UTF-8):      Sereal::Decoder - szybka, zwarta, potężna deserializacja binarna
10 Name:           perl-Sereal-Decoder
11 Version:        3.014
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Decoder-%{version}.tar.gz
17 # Source0-md5:  d52fb4fbd28acba055e9907bcbc99b47
18 URL:            http://search.cpan.org/dist/Sereal-Decoder/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-LongString
23 BuildRequires:  perl-Test-Warn
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This library implements a deserializer for an efficient,
29 compact-output, and feature-rich binary protocol called Sereal. Its
30 sister module Sereal::Encoder implements an encoder for this format.
31 The two are released separately to allow for independent and safer
32 upgrading.
33
34 The Sereal protocol versions that are compatible with this decoder
35 implementation are currently protocol versions 1, 2, and 3. As it
36 stands, it will refuse to attempt to decode future versions of the
37 protocol, but if necessary there is likely going to be an option to
38 decode the parts of the input that are compatible with version 3 of
39 the protocol. The protocol was designed to allow for this.
40
41 The protocol specification and many other bits of documentation can be
42 found in the github repository at <https://github.com/Sereal/Sereal>.
43
44 %description -l pl.UTF-8
45 Ten moduł implementuje deserializer dla wydajnego, mającego zwarte
46 wyjście i wiele możliwości, binarnego protokołu o nazwie Sereal.
47 Siostrzany moduł Sereal::Encoder implementuje koder dla tego formatu.
48 Moduły wydawane są osobno, aby umożliwić niezależne i bezpieczniejsze
49 aktualizacje.
50
51 Ten dekoder jest obecnie zgodny z protokołem Sereal w wersjach 1, 2,
52 3. Odmówi prób dekodowania późniejszych wersji, ale w razie potrzeby
53 może być opcja dekodowania części wejścia zgodnej z wersją 3
54 protokołu.
55
56 Specyfikację protokołu i inną dokumentację można znaleźć w
57 repozytorium github <https://github.com/Sereal/Sereal>.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make} \
66         CC="%{__cc}" \
67         OPTIMIZE="%{rpmcflags}"
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} pure_install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changes
82 %dir %{perl_vendorarch}/Sereal
83 %{perl_vendorarch}/Sereal/Decoder.pm
84 %{perl_vendorarch}/Sereal/Performance.pm
85 %dir %{perl_vendorarch}/Sereal/Decoder
86 %{perl_vendorarch}/Sereal/Decoder/*.pm
87 %dir %{perl_vendorarch}/auto/Sereal
88 %dir %{perl_vendorarch}/auto/Sereal/Decoder
89 %attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Decoder/Decoder.so
90 %{_mandir}/man3/Sereal::Decoder.3pm*
91 %{_mandir}/man3/Sereal::Performance.3pm*
This page took 0.103338 seconds and 4 git commands to generate.