]> git.pld-linux.org Git - packages/perl-Sereal-Decoder.git/blob - perl-Sereal-Decoder.spec
perl 5.38.0 rebuild
[packages/perl-Sereal-Decoder.git] / perl-Sereal-Decoder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         pdir    Sereal
6 %define         pnam    Decoder
7 Summary:        Sereal::Decoder - Fast, compact, powerful binary deserialization
8 Summary(pl.UTF-8):      Sereal::Decoder - szybka, zwarta, potężna deserializacja binarna
9 Name:           perl-Sereal-Decoder
10 Version:        4.025
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Decoder-%{version}.tar.gz
16 # Source0-md5:  c18bb9ddf44d44d47b1baa0aefa344a3
17 URL:            https://metacpan.org/release/Sereal-Decoder
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 7.0
19 BuildRequires:  perl-ExtUtils-ParseXS >= 2.21
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildRequires:  zstd-devel
24 %if %{with tests}
25 BuildRequires:  perl-Scalar-List-Utils
26 BuildRequires:  perl-Test-Deep
27 BuildRequires:  perl-Test-Differences
28 BuildRequires:  perl-Test-LongString
29 BuildRequires:  perl-Test-Simple >= 0.88
30 BuildRequires:  perl-Test-Warn
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This library implements a deserializer for an efficient,
36 compact-output, and feature-rich binary protocol called Sereal. Its
37 sister module Sereal::Encoder implements an encoder for this format.
38 The two are released separately to allow for independent and safer
39 upgrading.
40
41 The Sereal protocol versions that are compatible with this decoder
42 implementation are currently protocol versions 1, 2, and 3. As it
43 stands, it will refuse to attempt to decode future versions of the
44 protocol, but if necessary there is likely going to be an option to
45 decode the parts of the input that are compatible with version 3 of
46 the protocol. The protocol was designed to allow for this.
47
48 The protocol specification and many other bits of documentation can be
49 found in the github repository at <https://github.com/Sereal/Sereal>.
50
51 %description -l pl.UTF-8
52 Ten moduł implementuje deserializer dla wydajnego, mającego zwarte
53 wyjście i wiele możliwości, binarnego protokołu o nazwie Sereal.
54 Siostrzany moduł Sereal::Encoder implementuje koder dla tego formatu.
55 Moduły wydawane są osobno, aby umożliwić niezależne i bezpieczniejsze
56 aktualizacje.
57
58 Ten dekoder jest obecnie zgodny z protokołem Sereal w wersjach 1, 2,
59 3. Odmówi prób dekodowania późniejszych wersji, ale w razie potrzeby
60 może być opcja dekodowania części wejścia zgodnej z wersją 3
61 protokołu.
62
63 Specyfikację protokołu i inną dokumentację można znaleźć w
64 repozytorium github <https://github.com/Sereal/Sereal>.
65
66 %prep
67 %setup -q -n %{pdir}-%{pnam}-%{version}
68
69 %build
70 %{__perl} Makefile.PL \
71         INSTALLDIRS=vendor
72 %{__make} -j1 \
73         CC="%{__cc}" \
74         OPTIMIZE="%{rpmcflags}"
75
76 %{?with_tests:%{__make} test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} pure_install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes
89 %dir %{perl_vendorarch}/Sereal
90 %{perl_vendorarch}/Sereal/Decoder.pm
91 %{perl_vendorarch}/Sereal/Performance.pm
92 %dir %{perl_vendorarch}/Sereal/Decoder
93 %{perl_vendorarch}/Sereal/Decoder/*.pm
94 %dir %{perl_vendorarch}/auto/Sereal
95 %dir %{perl_vendorarch}/auto/Sereal/Decoder
96 %attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Decoder/Decoder.so
97 %{_mandir}/man3/Sereal::Decoder.3pm*
98 %{_mandir}/man3/Sereal::Performance.3pm*
This page took 0.119124 seconds and 4 git commands to generate.