]> git.pld-linux.org Git - packages/perl-Sereal-Decoder.git/blame - perl-Sereal-Decoder.spec
- perl req/prov fix
[packages/perl-Sereal-Decoder.git] / perl-Sereal-Decoder.spec
CommitLineData
94317d33
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
1febac3c 4
94317d33
JR
5%define pdir Sereal
6%define pnam Decoder
7%include /usr/lib/rpm/macros.perl
8Summary: Sereal::Decoder - Fast, compact, powerful binary deserialization
93113f3e 9Summary(pl.UTF-8): Sereal::Decoder - szybka, zwarta, potężna deserializacja binarna
94317d33 10Name: perl-Sereal-Decoder
93113f3e 11Version: 3.014
92fe8ce1 12Release: 4
94317d33
JR
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
1febac3c 16Source0: http://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Decoder-%{version}.tar.gz
93113f3e 17# Source0-md5: d52fb4fbd28acba055e9907bcbc99b47
94317d33
JR
18URL: http://search.cpan.org/dist/Sereal-Decoder/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
93113f3e 22BuildRequires: perl-Test-LongString
94317d33
JR
23BuildRequires: perl-Test-Warn
24%endif
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28This library implements a deserializer for an efficient,
1febac3c
ER
29compact-output, and feature-rich binary protocol called Sereal. Its
30sister module Sereal::Encoder implements an encoder for this format.
31The two are released separately to allow for independent and safer
32upgrading.
94317d33
JR
33
34The Sereal protocol versions that are compatible with this decoder
35implementation are currently protocol versions 1, 2, and 3. As it
36stands, it will refuse to attempt to decode future versions of the
37protocol, but if necessary there is likely going to be an option to
38decode the parts of the input that are compatible with version 3 of
39the protocol. The protocol was designed to allow for this.
40
1febac3c 41The protocol specification and many other bits of documentation can be
93113f3e
JB
42found in the github repository at <https://github.com/Sereal/Sereal>.
43
44%description -l pl.UTF-8
45Ten moduł implementuje deserializer dla wydajnego, mającego zwarte
46wyjście i wiele możliwości, binarnego protokołu o nazwie Sereal.
47Siostrzany moduł Sereal::Encoder implementuje koder dla tego formatu.
48Moduły wydawane są osobno, aby umożliwić niezależne i bezpieczniejsze
49aktualizacje.
50
51Ten dekoder jest obecnie zgodny z protokołem Sereal w wersjach 1, 2,
523. Odmówi prób dekodowania późniejszych wersji, ale w razie potrzeby
53może być opcja dekodowania części wejścia zgodnej z wersją 3
54protokołu.
55
56Specyfikację protokołu i inną dokumentację można znaleźć w
57repozytorium github <https://github.com/Sereal/Sereal>.
94317d33
JR
58
59%prep
60%setup -q -n %{pdir}-%{pnam}-%{version}
61
62%build
63%{__perl} Makefile.PL \
64 INSTALLDIRS=vendor
65%{__make} \
66 CC="%{__cc}" \
67 OPTIMIZE="%{rpmcflags}"
68
69%{?with_tests:%{__make} test}
70
71%install
72rm -rf $RPM_BUILD_ROOT
94317d33
JR
73%{__make} pure_install \
74 DESTDIR=$RPM_BUILD_ROOT
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
81%doc Changes
82%dir %{perl_vendorarch}/Sereal
93113f3e
JB
83%{perl_vendorarch}/Sereal/Decoder.pm
84%{perl_vendorarch}/Sereal/Performance.pm
94317d33
JR
85%dir %{perl_vendorarch}/Sereal/Decoder
86%{perl_vendorarch}/Sereal/Decoder/*.pm
87%dir %{perl_vendorarch}/auto/Sereal
88%dir %{perl_vendorarch}/auto/Sereal/Decoder
93113f3e
JB
89%attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Decoder/Decoder.so
90%{_mandir}/man3/Sereal::Decoder.3pm*
91%{_mandir}/man3/Sereal::Performance.3pm*
This page took 0.420205 seconds and 4 git commands to generate.