]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- rel 2 (kernel-2.6.16.60-1)
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
8f93639f 6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 8%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
63dabd29 10# Note that gcc4 build is very problematic and not supported by qemu team
80e91c68 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 12%bcond_without dist_kernel # without distribution kernel
b337f190 13%bcond_without kernel # build kqemu KERNEL MODULES
3a6eaa3b 14%bcond_without up # don't build up module
8bb1261c
KK
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
55023879 17%bcond_with grsec_kernel # build for kernel-grsecurity
0287446d 18
b0b2a1d9 19# no kernel kqemu module for ppc
20%ifarch ppc
21%undefine with_kqemu
22%undefine with_kernel
23%endif
0287446d 24
ae00823b
ER
25%if %{without kernel}
26%undefine with_dist_kernel
27%endif
ae00823b
ER
28%if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
29%define alt_kernel grsecurity
30%endif
0287446d
ER
31%if "%{_alt_kernel}" != "%{nil}"
32%undefine with_userspace
33%endif
ae00823b 34
420584f3
ER
35%define kqemu_version 1.3.0pre11
36%define qemu_version 0.9.1
4a24b47c 37%define pname qemu
420584f3 38
b121ac42 39%define rel 2
cd19124e 40Summary: QEMU CPU Emulator
4d74b97c 41Summary(pl): QEMU - emulator procesora
4a24b47c 42Name: %{pname}%{_alt_kernel}
420584f3
ER
43Version: %{qemu_version}
44Release: %{rel}%{?with_kqemu:k}
5a2da1d0
JB
45License: GPL
46Group: Applications/Emulators
867764ba 47#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
4a24b47c 48Source0: http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
5d541e92 49# Source0-md5: 6591df8e9270eb358c881de4ebea1262
420584f3 50Source1: http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
b337f190 51# Source1-md5: 970521874ef8b1ba4598925ace5936c3
4a24b47c
ER
52Patch0: %{pname}-nostatic.patch
53Patch1: %{pname}-cc.patch
54Patch3: %{pname}-dot.patch
55Patch4: %{pname}-gcc4_x86.patch
56Patch5: %{pname}-gcc4_ppc.patch
57Patch6: %{pname}-nosdlgui.patch
58Patch7: %{pname}-ifup.patch
81a493f2 59# Proof of concept, for reference, do not remove
4a24b47c 60Patch8: %{pname}-kde_virtual_workspaces_hack.patch
e05988b9 61# http://gwenole.beauchesne.info/en/projects/qemu
4a24b47c
ER
62Patch9: %{pname}-0.8.0-gcc4-hacks.patch
63Patch11: %{pname}-0.7.2-gcc4-opts.patch
64#Patch12: %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
65Patch13: %{pname}-dosguest.patch
033bfe61 66Patch14: %{pname}-ppc_old_binutils.patch
cd19124e 67URL: http://fabrice.bellard.free.fr/qemu/
ae00823b
ER
68%if %{with kernel}
69%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
9ea49998 70BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 71%endif
72%if %{with userspace}
867764ba 73BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 74BuildRequires: alsa-lib-devel
21c5c008 75%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 76BuildRequires: perl-tools-pod
2fb8ea02 77BuildRequires: tetex
8bb1261c 78BuildRequires: sed >= 4.0
d1ae30a6 79%endif
8bb1261c 80Requires: SDL >= 1.2.1
2ef13cb9 81# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 82ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
867764ba 85# some SPARC boot image in ELF format
ca55b10f 86%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 87
cd19124e 88%description
89QEMU is a FAST! processor emulator. By using dynamic translation it
90achieves a reasonnable speed while being easy to port on new host
91CPUs. QEMU has two operating modes:
92
93- User mode emulation. In this mode, QEMU can launch Linux processes
94 compiled for one CPU on another CPU. Linux system calls are converted
95 because of endianness and 32/64 bit mismatches. Wine (Windows
96 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
97
98- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
99 including a processor and various peripherials. It can also be used to
100 provide virtual hosting of several virtual PC on a single server.
cd19124e 101
4d74b97c 102%description -l pl
103