]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- unify kernel macros
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
8f93639f 6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 8%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
63dabd29 10# Note that gcc4 build is very problematic and not supported by qemu team
80e91c68 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 12%bcond_without dist_kernel # without distribution kernel
b337f190 13%bcond_without kernel # build kqemu KERNEL MODULES
3a6eaa3b 14%bcond_without up # don't build up module
8bb1261c
KK
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
55023879
ER
17%bcond_with grsec_kernel # build for kernel-grsecurity
18#
b0b2a1d9 19# no kernel kqemu module for ppc
20%ifarch ppc
21%undefine with_kqemu
22%undefine with_kernel
23%endif
ae00823b
ER
24#
25%if %{without kernel}
26%undefine with_dist_kernel
27%endif
28#
29%if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
30%define alt_kernel grsecurity
31%endif
32
b337f190 33%define _kqemu_version 1.3.0pre11
617c952b 34%define _rel 55
cd19124e 35Summary: QEMU CPU Emulator
4d74b97c 36Summary(pl): QEMU - emulator procesora
cd19124e 37Name: qemu
b337f190 38Version: 0.9.0
8bb1261c 39Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
40License: GPL
41Group: Applications/Emulators
867764ba 42#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 43Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b337f190 44# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
c33439fc 45Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
b337f190 46# Source1-md5: 970521874ef8b1ba4598925ace5936c3
8bd2aee2 47Patch0: %{name}-nostatic.patch
c33439fc 48Patch1: %{name}-cc.patch
d8d8cede 49Patch3: %{name}-dot.patch
8d073aaa
ER
50Patch4: %{name}-gcc4_x86.patch
51Patch5: %{name}-gcc4_ppc.patch
52Patch6: %{name}-nosdlgui.patch
53Patch7: %{name}-ifup.patch
81a493f2
MM
54# Proof of concept, for reference, do not remove
55Patch8: %{name}-kde_virtual_workspaces_hack.patch
e05988b9
AM
56# http://gwenole.beauchesne.info/en/projects/qemu
57Patch9: %{name}-0.8.0-gcc4-hacks.patch
e05988b9 58Patch11: %{name}-0.7.2-gcc4-opts.patch
b337f190 59#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
b4d7fbfb 60Patch13: %{name}-dosguest.patch
5b888e18 61# Fix crash when using qemu instances with NICs connected via socket
62# This patch will be obsolete in versions after 0.9.0
63Patch14: %{name}-0.9.0-remove-iohandlers.patch
cd19124e 64URL: http://fabrice.bellard.free.fr/qemu/
ae00823b
ER
65%if %{with kernel}
66%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
9ea49998 67BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 68%endif
69%if %{with userspace}
867764ba 70BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 71BuildRequires: alsa-lib-devel
21c5c008 72%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 73BuildRequires: perl-tools-pod
2fb8ea02 74BuildRequires: tetex
8bb1261c 75BuildRequires: sed >= 4.0
d1ae30a6 76%endif
8bb1261c 77Requires: SDL >= 1.2.1
2ef13cb9 78# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 79ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 80BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
867764ba 82# some SPARC boot image in ELF format
ca55b10f 83%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 84
cd19124e 85%description
86QEMU is a FAST! processor emulator. By using dynamic translation it
87achieves a reasonnable speed while being easy to port on new host
88CPUs. QEMU has two operating modes:
89
90- User mode emulation. In this mode, QEMU can launch Linux processes
91 compiled for one CPU on another CPU. Linux system calls are converted
92 because of endianness and 32/64 bit mismatches. Wine (Windows
93 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
94
95- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
96 including a processor and various peripherials. It can also be used to
97 provide virtual hosting of several virtual PC on a single server.
cd19124e 98
4d74b97c 99%description -l pl
100