]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- rel 2 (kernel 2.6.16.45)
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
8f93639f 6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 8%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
63dabd29 10# Note that gcc4 build is very problematic and not supported by qemu team
80e91c68 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 12%bcond_without dist_kernel # without distribution kernel
b337f190 13%bcond_without kernel # build kqemu KERNEL MODULES
3a6eaa3b 14%bcond_without up # don't build up module
8bb1261c
KK
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
39b50bf0 17#
3a6eaa3b 18
b337f190 19%define _kqemu_version 1.3.0pre11
6c36d649 20%define _rel 2
cd19124e 21Summary: QEMU CPU Emulator
4d74b97c 22Summary(pl): QEMU - emulator procesora
cd19124e 23Name: qemu
b337f190 24Version: 0.9.0
8bb1261c 25Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
26License: GPL
27Group: Applications/Emulators
867764ba 28#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 29Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b337f190 30# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
c33439fc 31Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
b337f190 32# Source1-md5: 970521874ef8b1ba4598925ace5936c3
8bd2aee2 33Patch0: %{name}-nostatic.patch
c33439fc 34Patch1: %{name}-cc.patch
d8d8cede 35Patch3: %{name}-dot.patch
8d073aaa
ER
36Patch4: %{name}-gcc4_x86.patch
37Patch5: %{name}-gcc4_ppc.patch
38Patch6: %{name}-nosdlgui.patch
39Patch7: %{name}-ifup.patch
81a493f2
MM
40# Proof of concept, for reference, do not remove
41Patch8: %{name}-kde_virtual_workspaces_hack.patch
e05988b9
AM
42# http://gwenole.beauchesne.info/en/projects/qemu
43Patch9: %{name}-0.8.0-gcc4-hacks.patch
e05988b9 44Patch11: %{name}-0.7.2-gcc4-opts.patch
b337f190 45#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
b4d7fbfb 46Patch13: %{name}-dosguest.patch
cd19124e 47URL: http://fabrice.bellard.free.fr/qemu/
d1ae30a6 48%if %{with kernel} && %{with dist_kernel}
49BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
9ea49998 50BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 51%endif
52%if %{with userspace}
867764ba 53BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 54BuildRequires: alsa-lib-devel
21c5c008 55%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 56BuildRequires: perl-tools-pod
2fb8ea02 57BuildRequires: tetex
8bb1261c 58BuildRequires: sed >= 4.0
d1ae30a6 59%endif
8bb1261c 60Requires: SDL >= 1.2.1
2ef13cb9 61# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 62ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
867764ba 65# some SPARC boot image in ELF format
ca55b10f 66%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 67
cd19124e 68%description
69QEMU is a FAST! processor emulator. By using dynamic translation it
70achieves a reasonnable speed while being easy to port on new host
71CPUs. QEMU has two operating modes:
72
73- User mode emulation. In this mode, QEMU can launch Linux processes
74 compiled for one CPU on another CPU. Linux system calls are converted
75 because of endianness and 32/64 bit mismatches. Wine (Windows
76 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
77
78- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
79 including a processor and various peripherials. It can also be used to
80 provide virtual hosting of several virtual PC on a single server.
cd19124e 81
4d74b97c 82%description -l pl
83