]> git.pld-linux.org Git - packages/perl.git/blame - perl.spec
- shorter spec, longer patch: +usemallocwrap
[packages/perl.git] / perl.spec
CommitLineData
6d45ca4e 1#
2# Conditional build:
361d5527
JB
3%bcond_without tests # do not perform "make test"
4%bcond_without threads # build without support for threads
5%bcond_without gdbm # build without the GDBM_File module
c3a42fee 6%bcond_without microperl # don't build microperl
6d45ca4e 7#
8# TODO:
469f90c5 9# - Think about unicore. If uf8*.pm, encode.pm, charnames.pm (and
6d45ca4e 10# probably others) are in the perl-base package, unicore should also
11# be there. But it's 5MB...
6d45ca4e 12# - fix "FIXME"s, review "XXX"s
13# - fix perl.prov's handling in rpm -- it should use the __perl macro
3d18c4ab 14# - add the {O,N}DBM_File modules
469f90c5 15# - review the perldiag.pod issue
16# - consider disabling ithreads by default
f10a6a7a 17# - consider introducing perl-dirs
361d5527 18# - what about "prove" (binary+manual)? (conflicts with standalone Test-Harness)
469f90c5 19#
20# TODO for perl-dependent packages:
21# - change all "R/BR: perl" to one of perl-{base,modules,devel}
22# - use the requires_eq(perl-base) for all packages strictly depending
23# on the perl version used for building (files in perl_vendorarch
24# directories; dependency on libperl.so.* often doesn't exist)
25# (should this be done on Ra-branch, too?)
6d45ca4e 26#
27
d5dcea79 28%define _abi 5.8.0
29
361d5527 30%define perlthread %{?with_threads:-thread-multi}
3eb80867 31
6d45ca4e 32%define perl_privlib %{_datadir}/perl5/%{version}
33%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 34%define perl_sitelib %{_usr}/local/share/perl5
d5dcea79 35%define perl_sitearch %{_usr}/local/lib/perl5/%{_abi}/%{_target_platform}%{perlthread}
01393b52 36%define perl_vendorlib %{_datadir}/perl5/vendor_perl
d5dcea79 37%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{_abi}/%{_target_platform}%{perlthread}
3eb80867 38
557db02e 39Summary: Practical Extraction and Report Language (Perl)
7095bd2b 40