]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- up to 0.28.0
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
ba35dfb5 10Version: 0.28.0
fe7ec2b4 11Release: 1
2feaabb3 12License: GPL v2+
fdec25bb 13Group: Libraries
35f64aba 14Source0: https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
ba35dfb5 15# Source0-md5: 934d6a5e7ae5bb339fc46aa29223a74f
35f64aba 16URL: https://lib.filezilla-project.org/
02115c6c
WF
17BuildRequires: autoconf >= 2.50
18BuildRequires: automake
15f7a1c5
JB
19%{?with_tests:BuildRequires: cppunit-devel >= 1.13.0}
20%{?with_apidocs:BuildRequires: doxygen}
02f4ce22 21BuildRequires: gettext-tools >= 0.11.0
639cd55f
JB
22%if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
23BuildRequires: glibc-localedb-all
24%endif
25BuildRequires: gnutls-devel >= 3.5.8
15f7a1c5
JB
26# -std=c++17
27BuildRequires: libstdc++-devel >= 6:7
02115c6c 28BuildRequires: libtool >= 2:2
639cd55f 29BuildRequires: nettle-devel >= 3.3
02115c6c 30BuildRequires: pkgconfig >= 1:0.7
fdec25bb 31BuildRequires: rpmbuild(macros) >= 1.583
639cd55f
JB
32Requires: gnutls-libs >= 3.5.8
33Requires: nettle >= 3.3
fdec25bb
WF
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37libfilezilla is a free, open source C++ library, offering some basic
38functionality to build high-performing, platform-independent programs.
39Some of the highlights include:
40
41- A typesafe, multi-threaded event system that's very simple to use
42 yet extremely efficient
43- Timers for periodic events
44- A datetime class that not only tracks timestamp but also their
45 accuracy, which simplifies dealing with timestamps originating from
46 different sources
47- Simple process handling for spawning child processes with redirected
48 I/O
49
98d72535
JB
50%description -l pl.UTF-8
51libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
52oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
53programów niezależnych od platformy. Uwzględnione funkcje obejmują:
54- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
55 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
56- zegary do zdarzeń regularnych
57- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
58 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
59 różnych źródeł
60- prostą obsługę procesów do tworzenia procesów potomnych z
61 przekierowanym wejściem/wyjściem
fdec25bb
WF
62
63%package devel
98d72535
JB
64Summary: Header files for libfilezilla library
65Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
02f4ce22 68Requires: libstdc++-devel >= 6:7
639cd55f
JB
69Requires: gnutls-devel >= 3.5.8
70Requires: nettle-devel >= 3.3
fdec25bb
WF
71
72%description devel
98d72535 73Header files for libfilezilla library.
fdec25bb
WF
74
75%description devel -l pl.UTF-8
98d72535 76Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
77
78%package static
98d72535
JB
79Summary: Static libfilezilla library
80Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
81Group: Development/Libraries
82Requires: %{name}-devel = %{version}-%{release}
83
84%description static
98d72535 85Static libfilezilla library.
fdec25bb
WF
86
87%description static -l pl.UTF-8
98d72535 88Statyczna biblioteka libfilezilla.
fdec25bb
WF
89
90%package apidocs
91Summary: %{name} API documentation
92Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
93Group: Documentation
94
95%description apidocs
96API documentation for %{name} library.
97
98%description apidocs -l pl.UTF-8
99Dokumentacja API biblioteki %{name}.
100
101%prep
102%setup -q
103
1676018f
AG
104cd locales
105%{__mv} bg{_BG,}.po
106%{__mv} ca{_ES,}@valencia.po
107%{__mv} cs{_CZ,}.po
108%{__mv} fa{_IR,}.po
109%{__mv} fi{_FI,}.po
110%{__mv} gl{_ES,}.po
111%{__mv} he{_IL,}.po
112%{__mv} hu{_HU,}.po
113%{__mv} id{_ID,}.po
114%{__mv} ja{_JP,}.po
115%{__mv} ko{_KR,}.po
116%{__mv} lo{_LA,}.po
117%{__mv} lt{_LT,}.po
118%{__mv} lv{_LV,}.po
119%{__mv} mk{_MK,}.po
120%{__mv} nb{_NO,}.po
121%{__mv} nn{_NO,}.po
122%{__mv} pl{_PL,}.po
123%{__mv} pt{_PT,}.po
124%{__mv} ro{_RO,}.po
125%{__mv} sk{_SK,}.po
126%{__mv} sl{_SI,}.po
127%{__mv} th{_TH,}.po
128%{__mv} uk{_UA,}.po
129%{__mv} vi{_VN,}.po
130
fdec25bb 131%build
02115c6c
WF
132%{__libtoolize}
133%{__aclocal} -I m4
134%{__autoconf}
135%{__autoheader}
136%{__automake}
fdec25bb
WF
137%configure \
138 %{!?with_static_libs:--disable-static}
139%{__make}
140
98d72535
JB
141%if %{with tests}
142# wide char conversion test fails with plain C locale
143LC_ALL=C.UTF-8 \
144%{__make} check
145%endif
146
147%if %{with apidocs}
148%{__make} -C doc html
149%endif
150
fdec25bb
WF
151%install
152rm -rf $RPM_BUILD_ROOT
153
154%{__make} install \
155 DESTDIR=$RPM_BUILD_ROOT
156
157%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
158
1676018f
AG
159# not supported by glibc (as of 2.25)
160%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
161
db09d1b5
AG
162%find_lang %{name}
163
fdec25bb
WF
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post -p /sbin/ldconfig
168%postun -p /sbin/ldconfig
169
db09d1b5 170%files -f %{name}.lang
fdec25bb 171%defattr(644,root,root,755)
98d72535
JB
172%doc AUTHORS ChangeLog NEWS README
173%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
ba35dfb5 174%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.13
fdec25bb
WF
175
176%files devel
177%defattr(644,root,root,755)
98d72535
JB
178%attr(755,root,root) %{_libdir}/libfilezilla.so
179%{_includedir}/libfilezilla
180%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
181
182%if %{with static_libs}
183%files static
184%defattr(644,root,root,755)
98d72535 185%{_libdir}/libfilezilla.a
fdec25bb
WF
186%endif
187
98d72535 188%if %{with apidocs}
fdec25bb
WF
189%files apidocs
190%defattr(644,root,root,755)
98d72535 191%doc doc/doxygen-doc/html/*
fdec25bb 192%endif
This page took 0.127947 seconds and 4 git commands to generate.