]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- -devel R: gnutls-devel nettle-devel
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
db09d1b5 10Version: 0.17.1
1676018f 11Release: 2
2feaabb3 12License: GPL v2+
fdec25bb 13Group: Libraries
35f64aba 14Source0: https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
db09d1b5 15# Source0-md5: 7cecda7c08f141223076487490374cb5
35f64aba 16URL: https://lib.filezilla-project.org/
9f68b570 17%{?with_tests:BuildRequires: cppunit-devel >= 1.13.0}
98d72535 18%{?with_apidocs:BuildRequires: doxygen}
9021009f 19%if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
98d72535
JB
20BuildRequires: glibc-localedb-all
21%endif
02115c6c
WF
22BuildRequires: autoconf >= 2.50
23BuildRequires: automake
02f4ce22 24BuildRequires: gettext-tools >= 0.11.0
db09d1b5 25BuildRequires: gnutls-devel >= 3.5.7
02115c6c 26BuildRequires: libtool >= 2:2
9f68b570 27BuildRequires: nettle-devel >= 3.1
02115c6c 28BuildRequires: pkgconfig >= 1:0.7
02f4ce22
JB
29# -std=c++17
30BuildRequires: libstdc++-devel >= 6:7
fdec25bb
WF
31BuildRequires: rpmbuild(macros) >= 1.583
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35libfilezilla is a free, open source C++ library, offering some basic
36functionality to build high-performing, platform-independent programs.
37Some of the highlights include:
38
39- A typesafe, multi-threaded event system that's very simple to use
40 yet extremely efficient
41- Timers for periodic events
42- A datetime class that not only tracks timestamp but also their
43 accuracy, which simplifies dealing with timestamps originating from
44 different sources
45- Simple process handling for spawning child processes with redirected
46 I/O
47
98d72535
JB
48%description -l pl.UTF-8
49libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
50oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
51programów niezależnych od platformy. Uwzględnione funkcje obejmują:
52- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
53 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
54- zegary do zdarzeń regularnych
55- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
56 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
57 różnych źródeł
58- prostą obsługę procesów do tworzenia procesów potomnych z
59 przekierowanym wejściem/wyjściem
fdec25bb
WF
60
61%package devel
98d72535
JB
62Summary: Header files for libfilezilla library
63Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
02f4ce22 66Requires: libstdc++-devel >= 6:7
2feaabb3
JB
67Requires: gnutls-devel >= 3.5.7
68Requires: nettle-devel >= 3.1
fdec25bb
WF
69
70%description devel
98d72535 71Header files for libfilezilla library.
fdec25bb
WF
72
73%description devel -l pl.UTF-8
98d72535 74Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
75
76%package static
98d72535
JB
77Summary: Static libfilezilla library
78Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description static
98d72535 83Static libfilezilla library.
fdec25bb
WF
84
85%description static -l pl.UTF-8
98d72535 86Statyczna biblioteka libfilezilla.
fdec25bb
WF
87
88%package apidocs
89Summary: %{name} API documentation
90Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
91Group: Documentation
92
93%description apidocs
94API documentation for %{name} library.
95
96%description apidocs -l pl.UTF-8
97Dokumentacja API biblioteki %{name}.
98
99%prep
100%setup -q
101
1676018f
AG
102cd locales
103%{__mv} bg{_BG,}.po
104%{__mv} ca{_ES,}@valencia.po
105%{__mv} cs{_CZ,}.po
106%{__mv} fa{_IR,}.po
107%{__mv} fi{_FI,}.po
108%{__mv} gl{_ES,}.po
109%{__mv} he{_IL,}.po
110%{__mv} hu{_HU,}.po
111%{__mv} id{_ID,}.po
112%{__mv} ja{_JP,}.po
113%{__mv} ko{_KR,}.po
114%{__mv} lo{_LA,}.po
115%{__mv} lt{_LT,}.po
116%{__mv} lv{_LV,}.po
117%{__mv} mk{_MK,}.po
118%{__mv} nb{_NO,}.po
119%{__mv} nn{_NO,}.po
120%{__mv} pl{_PL,}.po
121%{__mv} pt{_PT,}.po
122%{__mv} ro{_RO,}.po
123%{__mv} sk{_SK,}.po
124%{__mv} sl{_SI,}.po
125%{__mv} th{_TH,}.po
126%{__mv} uk{_UA,}.po
127%{__mv} vi{_VN,}.po
128
fdec25bb 129%build
02115c6c
WF
130%{__libtoolize}
131%{__aclocal} -I m4
132%{__autoconf}
133%{__autoheader}
134%{__automake}
fdec25bb
WF
135%configure \
136 %{!?with_static_libs:--disable-static}
137%{__make}
138
98d72535
JB
139%if %{with tests}
140# wide char conversion test fails with plain C locale
141LC_ALL=C.UTF-8 \
142%{__make} check
143%endif
144
145%if %{with apidocs}
146%{__make} -C doc html
147%endif
148
fdec25bb
WF
149%install
150rm -rf $RPM_BUILD_ROOT
151
152%{__make} install \
153 DESTDIR=$RPM_BUILD_ROOT
154
155%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
156
1676018f
AG
157# not supported by glibc (as of 2.25)
158%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
159
db09d1b5
AG
160%find_lang %{name}
161
fdec25bb
WF
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%post -p /sbin/ldconfig
166%postun -p /sbin/ldconfig
167
db09d1b5 168%files -f %{name}.lang
fdec25bb 169%defattr(644,root,root,755)
98d72535
JB
170%doc AUTHORS ChangeLog NEWS README
171%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
172%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
fdec25bb
WF
173
174%files devel
175%defattr(644,root,root,755)
98d72535
JB
176%attr(755,root,root) %{_libdir}/libfilezilla.so
177%{_includedir}/libfilezilla
178%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
179
180%if %{with static_libs}
181%files static
182%defattr(644,root,root,755)
98d72535 183%{_libdir}/libfilezilla.a
fdec25bb
WF
184%endif
185
98d72535 186%if %{with apidocs}
fdec25bb
WF
187%files apidocs
188%defattr(644,root,root,755)
98d72535 189%doc doc/doxygen-doc/html/*
fdec25bb 190%endif
This page took 0.115832 seconds and 4 git commands to generate.