]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- release 2, rebuild against libnettle.so.6 (nettle-3.5)
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
421864e8 10Version: 0.16.0
e818b46e 11Release: 2
fdec25bb
WF
12License: GPL v2
13Group: Libraries
35f64aba 14Source0: https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
421864e8 15# Source0-md5: 045c8358067e48d8a2584284e8676139
35f64aba 16URL: https://lib.filezilla-project.org/
9f68b570 17%{?with_tests:BuildRequires: cppunit-devel >= 1.13.0}
98d72535 18%{?with_apidocs:BuildRequires: doxygen}
9021009f 19%if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
98d72535
JB
20BuildRequires: glibc-localedb-all
21%endif
02115c6c
WF
22BuildRequires: autoconf >= 2.50
23BuildRequires: automake
24BuildRequires: libtool >= 2:2
9f68b570 25BuildRequires: nettle-devel >= 3.1
02115c6c 26BuildRequires: pkgconfig >= 1:0.7
98d72535
JB
27# -std=c++14
28BuildRequires: libstdc++-devel >= 6:5
fdec25bb
WF
29BuildRequires: rpmbuild(macros) >= 1.583
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33libfilezilla is a free, open source C++ library, offering some basic
34functionality to build high-performing, platform-independent programs.
35Some of the highlights include:
36
37- A typesafe, multi-threaded event system that's very simple to use
38 yet extremely efficient
39- Timers for periodic events
40- A datetime class that not only tracks timestamp but also their
41 accuracy, which simplifies dealing with timestamps originating from
42 different sources
43- Simple process handling for spawning child processes with redirected
44 I/O
45
98d72535
JB
46%description -l pl.UTF-8
47libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
48oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
49programów niezależnych od platformy. Uwzględnione funkcje obejmują:
50- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
51 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
52- zegary do zdarzeń regularnych
53- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
54 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
55 różnych źródeł
56- prostą obsługę procesów do tworzenia procesów potomnych z
57 przekierowanym wejściem/wyjściem
fdec25bb
WF
58
59%package devel
98d72535
JB
60Summary: Header files for libfilezilla library
61Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
98d72535 64Requires: libstdc++-devel >= 6:5
fdec25bb
WF
65
66%description devel
98d72535 67Header files for libfilezilla library.
fdec25bb
WF
68
69%description devel -l pl.UTF-8
98d72535 70Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
71
72%package static
98d72535
JB
73Summary: Static libfilezilla library
74Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77
78%description static
98d72535 79Static libfilezilla library.
fdec25bb
WF
80
81%description static -l pl.UTF-8
98d72535 82Statyczna biblioteka libfilezilla.
fdec25bb
WF
83
84%package apidocs
85Summary: %{name} API documentation
86Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
87Group: Documentation
88
89%description apidocs
90API documentation for %{name} library.
91
92%description apidocs -l pl.UTF-8
93Dokumentacja API biblioteki %{name}.
94
95%prep
96%setup -q
97
98%build
02115c6c
WF
99%{__libtoolize}
100%{__aclocal} -I m4
101%{__autoconf}
102%{__autoheader}
103%{__automake}
fdec25bb
WF
104%configure \
105 %{!?with_static_libs:--disable-static}
106%{__make}
107
98d72535
JB
108%if %{with tests}
109# wide char conversion test fails with plain C locale
110LC_ALL=C.UTF-8 \
111%{__make} check
112%endif
113
114%if %{with apidocs}
115%{__make} -C doc html
116%endif
117
fdec25bb
WF
118%install
119rm -rf $RPM_BUILD_ROOT
120
121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
123
124%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130%postun -p /sbin/ldconfig
131
132%files
133%defattr(644,root,root,755)
98d72535
JB
134%doc AUTHORS ChangeLog NEWS README
135%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
136%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
fdec25bb
WF
137
138%files devel
139%defattr(644,root,root,755)
98d72535
JB
140%attr(755,root,root) %{_libdir}/libfilezilla.so
141%{_includedir}/libfilezilla
142%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
143
144%if %{with static_libs}
145%files static
146%defattr(644,root,root,755)
98d72535 147%{_libdir}/libfilezilla.a
fdec25bb
WF
148%endif
149
98d72535 150%if %{with apidocs}
fdec25bb
WF
151%files apidocs
152%defattr(644,root,root,755)
98d72535 153%doc doc/doxygen-doc/html/*
fdec25bb 154%endif
This page took 0.063002 seconds and 4 git commands to generate.