]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- fixed macro in soname
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
3733d616
KM
7%define libver 22
8#
98d72535
JB
9Summary: Library for high-performing platform-independent programs
10Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 11Name: libfilezilla
3733d616 12Version: 0.34.2
fe7ec2b4 13Release: 1
2feaabb3 14License: GPL v2+
fdec25bb 15Group: Libraries
35f64aba 16Source0: https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
3733d616 17# Source0-md5: c5cbaafcbf0fb307e30a59cb38a4b98d
35f64aba 18URL: https://lib.filezilla-project.org/
02115c6c
WF
19BuildRequires: autoconf >= 2.50
20BuildRequires: automake
15f7a1c5
JB
21%{?with_tests:BuildRequires: cppunit-devel >= 1.13.0}
22%{?with_apidocs:BuildRequires: doxygen}
02f4ce22 23BuildRequires: gettext-tools >= 0.11.0
639cd55f
JB
24%if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
25BuildRequires: glibc-localedb-all
26%endif
27BuildRequires: gnutls-devel >= 3.5.8
15f7a1c5
JB
28# -std=c++17
29BuildRequires: libstdc++-devel >= 6:7
02115c6c 30BuildRequires: libtool >= 2:2
639cd55f 31BuildRequires: nettle-devel >= 3.3
02115c6c 32BuildRequires: pkgconfig >= 1:0.7
fdec25bb 33BuildRequires: rpmbuild(macros) >= 1.583
639cd55f
JB
34Requires: gnutls-libs >= 3.5.8
35Requires: nettle >= 3.3
fdec25bb
WF
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39libfilezilla is a free, open source C++ library, offering some basic
40functionality to build high-performing, platform-independent programs.
41Some of the highlights include:
42
43- A typesafe, multi-threaded event system that's very simple to use
44 yet extremely efficient
45- Timers for periodic events
46- A datetime class that not only tracks timestamp but also their
47 accuracy, which simplifies dealing with timestamps originating from
48 different sources
49- Simple process handling for spawning child processes with redirected
50 I/O
51
98d72535
JB
52%description -l pl.UTF-8
53libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
54oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
55programów niezależnych od platformy. Uwzględnione funkcje obejmują:
3733d616
KM
56- bezpieczny pod względem typów, wielowątkowy system zdarzeń - bardzo
57 prosty w użyciu, a jednocześnie bardzo wydajny
98d72535
JB
58- zegary do zdarzeń regularnych
59- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
60 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
61 różnych źródeł
62- prostą obsługę procesów do tworzenia procesów potomnych z
63 przekierowanym wejściem/wyjściem
fdec25bb
WF
64
65%package devel
98d72535
JB
66Summary: Header files for libfilezilla library
67Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
68Group: Development/Libraries
69Requires: %{name} = %{version}-%{release}
639cd55f 70Requires: gnutls-devel >= 3.5.8
3733d616 71Requires: libstdc++-devel >= 6:7
639cd55f 72Requires: nettle-devel >= 3.3
fdec25bb
WF
73
74%description devel
98d72535 75Header files for libfilezilla library.
fdec25bb
WF
76
77%description devel -l pl.UTF-8
98d72535 78Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
79
80%package static
98d72535
JB
81Summary: Static libfilezilla library
82Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
83Group: Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85
86%description static
98d72535 87Static libfilezilla library.
fdec25bb
WF
88
89%description static -l pl.UTF-8
98d72535 90Statyczna biblioteka libfilezilla.
fdec25bb
WF
91
92%package apidocs
93Summary: %{name} API documentation
94Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
95Group: Documentation
96
97%description apidocs
98API documentation for %{name} library.
99
100%description apidocs -l pl.UTF-8
101Dokumentacja API biblioteki %{name}.
102
103%prep
104%setup -q
105
1676018f
AG
106cd locales
107%{__mv} bg{_BG,}.po
108%{__mv} ca{_ES,}@valencia.po
109%{__mv} cs{_CZ,}.po
110%{__mv} fa{_IR,}.po
111%{__mv} fi{_FI,}.po
112%{__mv} gl{_ES,}.po
113%{__mv} he{_IL,}.po
114%{__mv} hu{_HU,}.po
115%{__mv} id{_ID,}.po
116%{__mv} ja{_JP,}.po
117%{__mv} ko{_KR,}.po
118%{__mv} lo{_LA,}.po
119%{__mv} lt{_LT,}.po
120%{__mv} lv{_LV,}.po
121%{__mv} mk{_MK,}.po
122%{__mv} nb{_NO,}.po
123%{__mv} nn{_NO,}.po
124%{__mv} pl{_PL,}.po
125%{__mv} pt{_PT,}.po
126%{__mv} ro{_RO,}.po
127%{__mv} sk{_SK,}.po
128%{__mv} sl{_SI,}.po
129%{__mv} th{_TH,}.po
130%{__mv} uk{_UA,}.po
131%{__mv} vi{_VN,}.po
132
fdec25bb 133%build
02115c6c
WF
134%{__libtoolize}
135%{__aclocal} -I m4
136%{__autoconf}
137%{__autoheader}
138%{__automake}
fdec25bb
WF
139%configure \
140 %{!?with_static_libs:--disable-static}
141%{__make}
142
98d72535
JB
143%if %{with tests}
144# wide char conversion test fails with plain C locale
145LC_ALL=C.UTF-8 \
146%{__make} check
147%endif
148
149%if %{with apidocs}
150%{__make} -C doc html
151%endif
152
fdec25bb
WF
153%install
154rm -rf $RPM_BUILD_ROOT
155
156%{__make} install \
157 DESTDIR=$RPM_BUILD_ROOT
158
159%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
160
1676018f
AG
161# not supported by glibc (as of 2.25)
162%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
163
db09d1b5
AG
164%find_lang %{name}
165
fdec25bb
WF
166%clean
167rm -rf $RPM_BUILD_ROOT
168
169%post -p /sbin/ldconfig
170%postun -p /sbin/ldconfig
171
db09d1b5 172%files -f %{name}.lang
fdec25bb 173%defattr(644,root,root,755)
98d72535
JB
174%doc AUTHORS ChangeLog NEWS README
175%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
5b44552d 176%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.%{libver}
fdec25bb
WF
177
178%files devel
179%defattr(644,root,root,755)
98d72535
JB
180%attr(755,root,root) %{_libdir}/libfilezilla.so
181%{_includedir}/libfilezilla
182%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
183
184%if %{with static_libs}
185%files static
186%defattr(644,root,root,755)
98d72535 187%{_libdir}/libfilezilla.a
fdec25bb
WF
188%endif
189
98d72535 190%if %{with apidocs}
fdec25bb
WF
191%files apidocs
192%defattr(644,root,root,755)
98d72535 193%doc doc/doxygen-doc/html/*
fdec25bb 194%endif
This page took 0.088933 seconds and 4 git commands to generate.