]> git.pld-linux.org Git - packages/perl-IO-AIO.git/commitdiff
- revert epoch, instead do what other distros do - package as version 4.40
authorMarcin Krol <hawk@tld-linux.org>
Thu, 8 Mar 2018 12:47:08 +0000 (12:47 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 8 Mar 2018 12:47:08 +0000 (12:47 +0000)
- fix perl path in treescan

IO-AIO-path.patch [new file with mode: 0644]
IO-AIO-version.patch [new file with mode: 0644]
perl-IO-AIO.spec

diff --git a/IO-AIO-path.patch b/IO-AIO-path.patch
new file mode 100644 (file)
index 0000000..dc8be08
--- /dev/null
@@ -0,0 +1,9 @@
+diff -ur IO-AIO-4.4.orig/bin/treescan IO-AIO-4.4/bin/treescan
+--- IO-AIO-4.4.orig/bin/treescan       2017-12-18 12:58:00.000000000 +0000
++++ IO-AIO-4.4/bin/treescan    2018-03-08 12:44:41.045764429 +0000
+@@ -1,4 +1,4 @@
+-#!/opt/bin/perl
++#!/usr/bin/perl
+ # inspired by treescan by Jamie Lokier <jamie@imbolc.ucc.ie>
+ # about 40% faster than the original version (on my fs and raid :)
diff --git a/IO-AIO-version.patch b/IO-AIO-version.patch
new file mode 100644 (file)
index 0000000..7aa86ff
--- /dev/null
@@ -0,0 +1,45 @@
+diff -ur IO-AIO-4.4.orig/AIO.pm IO-AIO-4.4/AIO.pm
+--- IO-AIO-4.4.orig/AIO.pm     2018-02-20 05:44:15.000000000 +0000
++++ IO-AIO-4.4/AIO.pm  2018-03-08 12:43:23.252765304 +0000
+@@ -173,7 +173,7 @@
+ use base 'Exporter';
+ BEGIN {
+-   our $VERSION = 4.4;
++   our $VERSION = 4.40;
+    our @AIO_REQ = qw(aio_sendfile aio_seek aio_read aio_write aio_open aio_close
+                      aio_stat aio_lstat aio_unlink aio_rmdir aio_readdir aio_readdirx
+diff -ur IO-AIO-4.4.orig/Changes IO-AIO-4.4/Changes
+--- IO-AIO-4.4.orig/Changes    2018-02-20 06:54:29.000000000 +0000
++++ IO-AIO-4.4/Changes 2018-03-08 12:43:12.604765424 +0000
+@@ -34,7 +34,7 @@
+ TODO: define useful rules for [[$wd, $path], $path] &c and implement them
+ TODO: https://github.com/coreutils/coreutils/blob/master/src/stat.c maybe IO::AIO::FSID
+-4.4   Tue Feb 20 07:54:12 CET 2018
++4.40  Tue Feb 20 07:54:12 CET 2018
+       - new aio_slurp request.
+         - add (experimental) IO::AIO::eventfd and timerfd* function.
+       - add (experimental) IO::AIO::get_fdlimit and IO::AIO::min_fdlimit.
+diff -ur IO-AIO-4.4.orig/META.json IO-AIO-4.4/META.json
+--- IO-AIO-4.4.orig/META.json  2018-02-20 06:54:40.000000000 +0000
++++ IO-AIO-4.4/META.json       2018-03-08 12:43:18.204765361 +0000
+@@ -38,6 +38,6 @@
+       }
+    },
+    "release_status" : "stable",
+-   "version" : 4.4,
++   "version" : 4.40,
+    "x_serialization_backend" : "JSON::PP version 2.27300"
+ }
+diff -ur IO-AIO-4.4.orig/META.yml IO-AIO-4.4/META.yml
+--- IO-AIO-4.4.orig/META.yml   2018-02-20 06:54:40.000000000 +0000
++++ IO-AIO-4.4/META.yml        2018-03-08 12:43:03.260765530 +0000
+@@ -20,5 +20,5 @@
+     - inc
+ requires:
+   common::sense: '0'
+-version: 4.4
++version: 4.40
+ x_serialization_backend: 'CPAN::Meta::YAML version 0.012'
index 0f111f58ead38770c9afdfcc2dbf16508f0c7c77..3af1fdbc3b762b698a7a1f509e1aff23f1bfb6a4 100644 (file)
@@ -5,16 +5,18 @@
 %include       /usr/lib/rpm/macros.perl
 %define                pdir    IO
 %define                pnam    AIO
+%define                dist_ver        4.4
 Summary:       IO::AIO - Perl Asynchronous Input/Output
 Summary(pl.UTF-8):     IO::AIO - asynchroniczne wejście/wyjście w Perlu
 Name:          perl-IO-AIO
-Version:       4.4
+Version:       4.40
 Release:       1
-Epoch:         1
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
+Source0:       http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{dist_ver}.tar.gz
 # Source0-md5: 74d97a2a5162bbac5af79fa33f88c9d1
+Patch0:                %{pdir}-%{pnam}-path.patch
+Patch1:                %{pdir}-%{pnam}-version.patch
 URL:           http://search.cpan.org/dist/IO-AIO/
 BuildRequires: perl-devel >= 1:5.8.2
 BuildRequires: rpm-perlprov >= 4.1-13
@@ -32,7 +34,9 @@ Ten moduł implementuje asynchroniczne we/wy przy użyciu dowolnych
 metod obsługiwanych przez system operacyjny.
 
 %prep
-%setup -q -n %{pdir}-%{pnam}-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{dist_ver}
+%patch0 -p1
+%patch1 -p1
 
 %build
 PERL_CANARY_STABILITY_NOPROMPT=1 \
This page took 0.152268 seconds and 4 git commands to generate.