]> git.pld-linux.org Git - packages/perl-IO-AIO.git/blob - perl-IO-AIO.spec
0f111f58ead38770c9afdfcc2dbf16508f0c7c77
[packages/perl-IO-AIO.git] / perl-IO-AIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    AIO
8 Summary:        IO::AIO - Perl Asynchronous Input/Output
9 Summary(pl.UTF-8):      IO::AIO - asynchroniczne wejście/wyjście w Perlu
10 Name:           perl-IO-AIO
11 Version:        4.4
12 Release:        1
13 Epoch:          1
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  74d97a2a5162bbac5af79fa33f88c9d1
18 URL:            http://search.cpan.org/dist/IO-AIO/
19 BuildRequires:  perl-devel >= 1:5.8.2
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-common-sense
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module implements asynchronous I/O using whatever means your
28 operating system supports.
29
30 %description -l pl.UTF-8
31 Ten moduł implementuje asynchroniczne we/wy przy użyciu dowolnych
32 metod obsługiwanych przez system operacyjny.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 PERL_CANARY_STABILITY_NOPROMPT=1 \
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %attr(755,root,root) %{_bindir}/treescan
61 %{perl_vendorarch}/IO/AIO.pm
62 %dir %{perl_vendorarch}/auto/IO/AIO
63 %attr(755,root,root) %{perl_vendorarch}/auto/IO/AIO/AIO.so
64 %{_mandir}/man3/IO::AIO.3pm*
65 %{_mandir}/man1/treescan.1p*
This page took 0.040172 seconds and 2 git commands to generate.