]> git.pld-linux.org Git - packages/perl-IO-AIO.git/blob - perl-IO-AIO.spec
- revert epoch, instead do what other distros do - package as version 4.40
[packages/perl-IO-AIO.git] / perl-IO-AIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    AIO
8 %define         dist_ver        4.4
9 Summary:        IO::AIO - Perl Asynchronous Input/Output
10 Summary(pl.UTF-8):      IO::AIO - asynchroniczne wejście/wyjście w Perlu
11 Name:           perl-IO-AIO
12 Version:        4.40
13 Release:        1
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{dist_ver}.tar.gz
17 # Source0-md5:  74d97a2a5162bbac5af79fa33f88c9d1
18 Patch0:         %{pdir}-%{pnam}-path.patch
19 Patch1:         %{pdir}-%{pnam}-version.patch
20 URL:            http://search.cpan.org/dist/IO-AIO/
21 BuildRequires:  perl-devel >= 1:5.8.2
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-common-sense
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module implements asynchronous I/O using whatever means your
30 operating system supports.
31
32 %description -l pl.UTF-8
33 Ten moduł implementuje asynchroniczne we/wy przy użyciu dowolnych
34 metod obsługiwanych przez system operacyjny.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{dist_ver}
38 %patch0 -p1
39 %patch1 -p1
40
41 %build
42 PERL_CANARY_STABILITY_NOPROMPT=1 \
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45
46 %{__make} \
47         CC="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %attr(755,root,root) %{_bindir}/treescan
65 %{perl_vendorarch}/IO/AIO.pm
66 %dir %{perl_vendorarch}/auto/IO/AIO
67 %attr(755,root,root) %{perl_vendorarch}/auto/IO/AIO/AIO.so
68 %{_mandir}/man3/IO::AIO.3pm*
69 %{_mandir}/man1/treescan.1p*
This page took 0.030948 seconds and 3 git commands to generate.