]> git.pld-linux.org Git - packages/wlroots.git/commitdiff
- make x32 patch rely on compiler, not rpm
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 5 Feb 2021 19:23:23 +0000 (20:23 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 5 Feb 2021 19:23:23 +0000 (20:23 +0100)
wlroots.spec
x32.patch

index 032b1b52911316d1a7f31fff65658ad3b775a899..b5078b40b0250068f21dd80abcf786313e5dd667 100644 (file)
@@ -85,9 +85,7 @@ Static wlroots library.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
-%ifarch x32
 %patch0 -p1
 %patch0 -p1
-%endif
 
 %build
 %meson build
 
 %build
 %meson build
index 35ac873bc856bbaa8ff225c053b152ee4489bf92..cdfc2c24bf7719d1a111faec73232afe2c93689a 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,11 +1,14 @@
 --- wlroots-0.12.0/util/log.c.orig     2020-11-08 15:01:44.000000000 +0100
 +++ wlroots-0.12.0/util/log.c  2021-02-03 10:32:04.394433021 +0100
 --- wlroots-0.12.0/util/log.c.orig     2020-11-08 15:01:44.000000000 +0100
 +++ wlroots-0.12.0/util/log.c  2021-02-03 10:32:04.394433021 +0100
-@@ -47,7 +47,7 @@
+@@ -47,7 +47,11 @@
        clock_gettime(CLOCK_MONOTONIC, &ts);
        timespec_sub(&ts, &ts, &start_time);
  
        clock_gettime(CLOCK_MONOTONIC, &ts);
        timespec_sub(&ts, &ts, &start_time);
  
--      fprintf(stderr, "%02d:%02d:%02d.%03ld ", (int)(ts.tv_sec / 60 / 60),
++#ifdef __ILP32__
 +      fprintf(stderr, "%02d:%02d:%02d.%03lld ", (int)(ts.tv_sec / 60 / 60),
 +      fprintf(stderr, "%02d:%02d:%02d.%03lld ", (int)(ts.tv_sec / 60 / 60),
++#else
+       fprintf(stderr, "%02d:%02d:%02d.%03ld ", (int)(ts.tv_sec / 60 / 60),
++#endif
                (int)(ts.tv_sec / 60 % 60), (int)(ts.tv_sec % 60),
                ts.tv_nsec / 1000000);
  
                (int)(ts.tv_sec / 60 % 60), (int)(ts.tv_sec % 60),
                ts.tv_nsec / 1000000);
  
This page took 0.269447 seconds and 4 git commands to generate.