]> git.pld-linux.org Git - packages/wlroots.git/blob - wlroots.spec
- make x32 patch rely on compiler, not rpm
[packages/wlroots.git] / wlroots.spec
1 Summary:        A modular Wayland compositor library
2 Name:           wlroots
3 Version:        0.12.0
4 Release:        1
5 License:        MIT
6 Group:          Libraries
7 Source0:        https://github.com/swaywm/wlroots/releases/download/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  bc9dbfef37385dbe0f4fe129d2329be5
9 Patch0:         x32.patch
10 URL:            https://github.com/swaywm/wlroots
11 BuildRequires:  EGL-devel
12 BuildRequires:  Mesa-libgbm-devel >= 17.1.0
13 BuildRequires:  OpenGLESv2-devel
14 BuildRequires:  libdrm-devel >= 2.4.95
15 BuildRequires:  libinput-devel >= 1.9.0
16 BuildRequires:  libxcb-devel
17 BuildRequires:  meson >= 0.54.0
18 BuildRequires:  ninja
19 BuildRequires:  pixman-devel
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.736
22 BuildRequires:  systemd-devel >= 237
23 BuildRequires:  udev-devel
24 BuildRequires:  wayland-devel >= 1.18
25 BuildRequires:  wayland-protocols >= 1.17
26 BuildRequires:  xcb-util-wm-devel
27 BuildRequires:  xorg-lib-libxkbcommon-devel
28 Requires:       Mesa-libgbm >= 17.1.0
29 Requires:       libdrm >= 2.4.95
30 Requires:       libinput >= 1.9.0
31 Requires:       wayland >= 1.18
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Pluggable, composable, unopinionated modules for building a Wayland
36 compositor; or about 50,000 lines of code you were going to write
37 anyway.
38 - wlroots provides backends that abstract the underlying display and
39   input hardware, including KMS/DRM, libinput, Wayland, X11, and
40   headless backends, plus any custom backends you choose to write, which
41   can all be created or destroyed at runtime and used in concert with
42   each other.
43 - wlroots provides unopinionated, mostly standalone implementations of
44   many Wayland interfaces, both from wayland.xml and various protocol
45   extensions. We also promote the standardization of portable extensions
46   across many compositors.
47 - wlroots provides several powerful, standalone, and optional tools
48   that implement components common to many compositors, such as the
49   arrangement of outputs in physical space.
50 - wlroots provides an Xwayland abstraction that allows you to have
51   excellent Xwayland support without worrying about writing your own X11
52   window manager on top of writing your compositor.
53 - wlroots provides a renderer abstraction that simple compositors can
54   use to avoid writing GL code directly, but which steps out of the way
55   when your needs demand custom rendering code.
56
57 %package devel
58 Summary:        Header files for wlroots library
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       EGL-devel
62 Requires:       Mesa-libgbm-devel >= 17.1.0
63 Requires:       OpenGLESv2-devel
64 Requires:       libdrm-devel >= 2.4.95
65 Requires:       libinput-devel >= 1.9.0
66 Requires:       libxcb-devel
67 Requires:       pixman-devel
68 Requires:       systemd-devel >= 237
69 Requires:       udev-devel
70 Requires:       wayland-devel >= 1.18
71 Requires:       wayland-protocols >= 1.17
72 Requires:       xcb-util-wm-devel
73 Requires:       xorg-lib-libxkbcommon-devel
74
75 %description devel
76 Header files for wlroots library.
77
78 %package static
79 Summary:        Static wlroots library
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static wlroots library.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 %meson build
92 %ninja_build -C build
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %ninja_install -C build
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc CONTRIBUTING.md README.md
107 %attr(755,root,root) %{_libdir}/libwlroots.so.7
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libwlroots.so
112 %{_includedir}/wlr
113 %{_pkgconfigdir}/wlroots.pc
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libwlroots.a
This page took 0.05948 seconds and 3 git commands to generate.