]> git.pld-linux.org Git - packages/wlroots.git/blame - wlroots.spec
- make x32 patch rely on compiler, not rpm
[packages/wlroots.git] / wlroots.spec
CommitLineData
ed3567b5
JP
1Summary: A modular Wayland compositor library
2Name: wlroots
3Version: 0.12.0
4Release: 1
5License: MIT
6Group: Libraries
7Source0: https://github.com/swaywm/wlroots/releases/download/%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: bc9dbfef37385dbe0f4fe129d2329be5
378d42d3 9Patch0: x32.patch
ed3567b5
JP
10URL: https://github.com/swaywm/wlroots
11BuildRequires: EGL-devel
12BuildRequires: Mesa-libgbm-devel >= 17.1.0
13BuildRequires: OpenGLESv2-devel
14BuildRequires: libdrm-devel >= 2.4.95
15BuildRequires: libinput-devel >= 1.9.0
16BuildRequires: libxcb-devel
17BuildRequires: meson >= 0.54.0
18BuildRequires: ninja
19BuildRequires: pixman-devel
20BuildRequires: pkgconfig
21BuildRequires: rpmbuild(macros) >= 1.736
22BuildRequires: systemd-devel >= 237
23BuildRequires: udev-devel
24BuildRequires: wayland-devel >= 1.18
25BuildRequires: wayland-protocols >= 1.17
26BuildRequires: xcb-util-wm-devel
27BuildRequires: xorg-lib-libxkbcommon-devel
28Requires: Mesa-libgbm >= 17.1.0
29Requires: libdrm >= 2.4.95
30Requires: libinput >= 1.9.0
31Requires: wayland >= 1.18
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Pluggable, composable, unopinionated modules for building a Wayland
36compositor; or about 50,000 lines of code you were going to write
37anyway.
38- wlroots provides backends that abstract the underlying display and
39 input hardware, including KMS/DRM, libinput, Wayland, X11, and
40 headless backends, plus any custom backends you choose to write, which
41 can all be created or destroyed at runtime and used in concert with
42 each other.
43- wlroots provides unopinionated, mostly standalone implementations of
44 many Wayland interfaces, both from wayland.xml and various protocol
45 extensions. We also promote the standardization of portable extensions
46 across many compositors.
47- wlroots provides several powerful, standalone, and optional tools
48 that implement components common to many compositors, such as the
49 arrangement of outputs in physical space.
50- wlroots provides an Xwayland abstraction that allows you to have
51 excellent Xwayland support without worrying about writing your own X11
52 window manager on top of writing your compositor.
53- wlroots provides a renderer abstraction that simple compositors can
54 use to avoid writing GL code directly, but which steps out of the way
55 when your needs demand custom rendering code.
56
57%package devel
58Summary: Header files for wlroots library
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: EGL-devel
62Requires: Mesa-libgbm-devel >= 17.1.0
63Requires: OpenGLESv2-devel
64Requires: libdrm-devel >= 2.4.95
65Requires: libinput-devel >= 1.9.0
66Requires: libxcb-devel
67Requires: pixman-devel
68Requires: systemd-devel >= 237
69Requires: udev-devel
70Requires: wayland-devel >= 1.18
71Requires: wayland-protocols >= 1.17
72Requires: xcb-util-wm-devel
73Requires: xorg-lib-libxkbcommon-devel
74
75%description devel
76Header files for wlroots library.
77
78%package static
79Summary: Static wlroots library
80Group: Development/Libraries
81Requires: %{name}-devel = %{version}-%{release}
82
83%description static
84Static wlroots library.
85
86%prep
87%setup -q
378d42d3 88%patch0 -p1
ed3567b5
JP
89
90%build
91%meson build
92%ninja_build -C build
93
94%install
95rm -rf $RPM_BUILD_ROOT
96%ninja_install -C build
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(644,root,root,755)
106%doc CONTRIBUTING.md README.md
107%attr(755,root,root) %{_libdir}/libwlroots.so.7
108
109%files devel
110%defattr(644,root,root,755)
111%attr(755,root,root) %{_libdir}/libwlroots.so
112%{_includedir}/wlr
113%{_pkgconfigdir}/wlroots.pc
114
115%files static
116%defattr(644,root,root,755)
117%{_libdir}/libwlroots.a
This page took 0.127277 seconds and 4 git commands to generate.