]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- fixed branding tarball (I hope)
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 # - about dialog broken:
6 #XML Parsing Error: undefined entity
7 #Location: chrome://messenger/content/aboutDialog.xul
8 #Line Number 27, Column 37:        <description id="copyright">&logoTrademark;</description>
9 #------------------------------------^
10 #
11 # Conditional builds
12 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
13 %bcond_without  gnomeui         # disable gnomeui support
14 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
15 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
16 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
17 %bcond_without  lightning       # disable sunbird calendar
18 %bcond_with             xulrunner       # build with xulrunner
19 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
20
21 %if %{without gnome}
22 %undefine       with_gnomeui
23 %undefine       with_gnomevfs
24 %endif
25
26 %if %{?_enable_debug_packages} != 1
27 %undefine       crashreporter
28 %endif
29
30 %define         enigmail_ver            1.1.2
31
32 %if %{without xulrunner}
33 # The actual sqlite version (see RHBZ#480989):
34 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
35 %endif
36
37 Summary:        Icedove - email client
38 Summary(pl.UTF-8):      Icedove - klient poczty
39 Name:           icedove
40 Version:        3.1.2
41 Release:        0.10
42 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
43 Group:          X11/Applications/Networking
44 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
45 # Source0-md5:  48e80576a7af70e64d30a5162364525a
46 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
47 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
48 Source2:        %{name}-branding.tar.bz2
49 # Source2-md5:  85fdf877e2f1bc41329d8086ef5cf0f1
50 Source3:        %{name}-rm_nonfree.sh
51 Source4:        %{name}.desktop
52 Source5:        %{name}.sh
53 Patch0:         %{name}-branding.patch
54 Patch1:         %{name}-enigmail-shared.patch
55 Patch2:         %{name}-gcc.patch
56 Patch3:         %{name}-fonts.patch
57 Patch4:         %{name}-install.patch
58 Patch5:         %{name}-hunspell.patch
59 Patch6:         %{name}-prefs.patch
60 Patch7:         system-mozldap.patch
61 Patch8:         %{name}-makefile.patch
62 Patch9:         %{name}-libpng.patch
63 Patch10:        %{name}-extensiondir.patch
64 Patch11:        crashreporter.patch
65 URL:            http://www.pld-linux.org/Packages/Icedove
66 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
67 BuildRequires:  automake
68 BuildRequires:  freetype-devel >= 1:2.1.8
69 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
70 BuildRequires:  gtk+2-devel >= 1:2.0.0
71 BuildRequires:  hunspell-devel
72 BuildRequires:  libIDL-devel >= 0.8.0
73 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
74 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
75 BuildRequires:  libjpeg-devel >= 6b
76 BuildRequires:  libpng-devel >= 1.2.0
77 BuildRequires:  libstdc++-devel
78 BuildRequires:  nspr-devel >= 1:4.8
79 BuildRequires:  nss-devel >= 1:3.12.0
80 BuildRequires:  pango-devel >= 1:1.1.0
81 BuildRequires:  pkgconfig
82 BuildRequires:  sed >= 4.0
83 BuildRequires:  sqlite3-devel >= 3.6.22
84 BuildRequires:  startup-notification-devel >= 0.8
85 BuildRequires:  xorg-lib-libXext-devel
86 BuildRequires:  xorg-lib-libXinerama-devel
87 BuildRequires:  xorg-lib-libXt-devel
88 BuildRequires:  zip
89 %if %{with xulrunner}
90 %else
91 Requires:       myspell-common
92 Requires:       nspr >= 1:4.6.1
93 Requires:       nss >= 1:3.11.3
94 Requires:       sqlite3 >= %{sqlite_build_version}
95 %endif
96 Obsoletes:      mozilla-thunderbird
97 Obsoletes:      mozilla-thunderbird-dictionary-en-US
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
101
102 # iceweasel/icedove/iceape provide their own versions
103 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
104 %define         _noautoprovfiles        %{_libdir}/%{name}/components
105 # we don't want these to satisfy xulrunner-devel
106 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
107 # and as we don't provide them, don't require either
108 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
109
110 %description
111 Icedove is an open-source,fast and portable email client.
112
113 %description -l pl.UTF-8
114 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
115
116 %package addon-lightning
117 Summary:        An integrated calendar for Icedove
118 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
119 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
120 Group:          Applications/Networking
121 Requires:       %{name} = %{version}-%{release}
122
123 %description addon-lightning
124 Lightning is an calendar extension to Icedove email client.
125
126 %description addon-lightning -l pl.UTF-8
127 Lightning to rozszerzenie do klienta poczty Icedove dodające
128 funkcjonalność kalendarza.
129
130 %package addon-enigmail
131 Summary:        Extension for the authentication and encryption features provided by GnuPG
132 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
133 License:        MPL/LGPL
134 Group:          Applications/Networking
135 URL:            http://enigmail.mozdev.org/
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       gnupg
138 Obsoletes:      mozilla-thunderbird-addon-enigmail
139
140 %description addon-enigmail
141 Enigmail is an extension to the Icedove mail client which allows users
142 to access the authentication and encryption features provided by
143 GnuPG.
144
145 Main Features:
146 - Encrypt/sign mail when sending, decrypt/authenticate received mail
147 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
148 - Per-Account based encryption and signing defaults
149 - Per-Recipient rules for automated key selection, and
150   enabling/disabling encryption and signing
151 - OpenPGP key management interface
152
153 %description addon-enigmail -l pl.UTF-8
154 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
155 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
156 przez GnuPG.
157
158 Główne możliwości:
159 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
160   odszyfrowywanie/uwierzytelnianie poczty odebranej
161 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
162 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
163 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
164   podpisywania dla każdego adresata
165 - interfejs do zarządzania kluczami OpenPGP
166
167 %prep
168 %setup -qc
169 mv -f comm-1.9.2 mozilla
170 %setup -q -T -D -a2
171 cd mozilla
172 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
173 /bin/sh %{SOURCE3}
174 %patch0 -p1
175 %{?with_enigmail:%patch1 -p1}
176 %patch2 -p1
177 %patch3 -p1
178 %patch4 -p1
179 %patch5 -p1
180 %patch6 -p1
181 %patch7 -p1
182 %patch8 -p0
183 %patch9 -p0
184 %patch10 -p2
185 %patch11 -p2
186
187 %build
188 cd mozilla
189 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
190 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
191 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
192
193 install -d libxul-sdk
194 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
195
196 cat << EOF > .mozconfig
197 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
198
199 export CFLAGS="%{rpmcflags}"
200 export CXXFLAGS="%{rpmcflags}"
201
202 %if %{with crashreporter}
203 export MOZ_DEBUG_SYMBOLS=1
204 %endif
205
206 # Options for 'configure' (same as command-line options).
207 ac_add_options --prefix=%{_prefix}
208 ac_add_options --exec-prefix=%{_exec_prefix}
209 ac_add_options --bindir=%{_bindir}
210 ac_add_options --sbindir=%{_sbindir}
211 ac_add_options --sysconfdir=%{_sysconfdir}
212 ac_add_options --datadir=%{_datadir}
213 ac_add_options --includedir=%{_includedir}
214 ac_add_options --libdir=%{_libdir}
215 ac_add_options --libexecdir=%{_libexecdir}
216 ac_add_options --localstatedir=%{_localstatedir}
217 ac_add_options --sharedstatedir=%{_sharedstatedir}
218 ac_add_options --mandir=%{_mandir}
219 ac_add_options --infodir=%{_infodir}
220 %if %{?debug:1}0
221 ac_add_options --disable-optimize
222 ac_add_options --enable-debug
223 ac_add_options --enable-debug-modules
224 ac_add_options --enable-debugger-info-modules
225 ac_add_options --enable-crash-on-assert
226 %else
227 ac_add_options --disable-debug
228 ac_add_options --disable-debug-modules
229 ac_add_options --disable-logging
230 ac_add_options --enable-optimize="%{rpmcflags} -Os"
231 %endif
232 ac_add_options --disable-strip
233 ac_add_options --disable-strip-libs
234 %if %{with tests}
235 ac_add_options --enable-tests
236 %else
237 ac_add_options --disable-tests
238 %endif
239 %if %{with gnomeui}
240 ac_add_options --enable-gnomeui
241 %else
242 ac_add_options --disable-gnomeui
243 %endif
244 %if %{with gnomevfs}
245 ac_add_options --enable-gnomevfs
246 %else
247 ac_add_options --disable-gnomevfs
248 %endif
249 %if %{with ldap}
250 ac_add_options --enable-ldap
251 ac_add_options --with-system-ldap
252 %else
253 ac_add_options --disable-ldap
254 %endif
255 %if %{with crashreporter}
256 ac_add_options --enable-crashreporter
257 %else
258 ac_add_options --disable-crashreporter
259 %endif
260 ac_add_options --disable-xterm-updates
261 ac_add_options --enable-postscript
262 %if %{with lightning}
263 ac_add_options --enable-calendar
264 %else
265 ac_add_options --disable-calendar
266 %endif
267 ac_add_options --disable-installer
268 ac_add_options --disable-jsd
269 ac_add_options --disable-updater
270 ac_add_options --disable-xprint
271 ac_add_options --disable-permissions
272 ac_add_options --disable-pref-extensions
273 ac_add_options --enable-canvas
274 ac_add_options --enable-crypto
275 ac_add_options --enable-mathml
276 ac_add_options --enable-pango
277 ac_add_options --enable-reorder
278 ac_add_options --enable-startup-notification
279 ac_add_options --enable-svg
280 ac_add_options --enable-system-cairo
281 ac_add_options --enable-system-hunspell
282 ac_add_options --enable-system-sqlite
283 ac_add_options --enable-xft
284 ac_add_options --enable-application=mail
285 ac_add_options --enable-default-toolkit=cairo-gtk2
286 ac_add_options --enable-xinerama
287 ac_add_options --with-distribution-id=org.pld-linux
288 ac_add_options --with-branding=icedove/branding
289 %if %{with xulrunner}
290 ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
291 ac_add_options --enable-shared
292 %else
293 ac_add_options --enable-static
294 %endif
295 ac_add_options --with-pthreads
296 ac_add_options --with-system-bz2
297 ac_add_options --with-system-jpeg
298 ac_add_options --with-system-nspr
299 ac_add_options --with-system-nss
300 ac_add_options --with-system-png
301 ac_add_options --with-system-zlib
302 ac_add_options --enable-single-profile
303 ac_add_options --disable-profilesharing
304 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
305 EOF
306
307 %{__make} -j1 -f client.mk build \
308         STRIP="/bin/true" \
309         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
310         CC="%{__cc}" \
311         CXX="%{__cxx}"
312
313 %if %{with crashreporter}
314 # create debuginfo for crash-stats.mozilla.com
315 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
316 %endif
317
318 %if %{with enigmail}
319 top=$(pwd)
320 cd mailnews/extensions/enigmail
321 ./makemake -r -o $top/obj-%{_target_cpu}
322 %{__make} -C $top/obj-%{_target_cpu}/mailnews/extensions/enigmail \
323         STRIP="/bin/true" \
324         CC="%{__cc}" \
325         CXX="%{__cxx}"
326 %endif
327
328 %install
329 rm -rf $RPM_BUILD_ROOT
330 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
331
332 cd mozilla/obj-%{_target_cpu}
333 %{__make} -C mail/installer stage-package \
334         DESTDIR=$RPM_BUILD_ROOT \
335         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
336         PKG_SKIP_STRIP=1
337
338 # Enable crash reporter for Firefox application
339 %if %{with crashreporter}
340 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
341
342 # Add debuginfo for crash-stats.mozilla.com
343 mkdir -p $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
344 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
345 %endif
346
347 # copy manually lightning files, somewhy they are not installed by make
348 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
349         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
350         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
351
352 # move arch independant ones to datadir
353 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
354 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
355 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
356 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
357 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
358 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
359 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
360 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
361 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
362 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
363 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
364 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
365
366 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
367 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
368
369 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
370 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
371 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
372
373 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
374 cp -a ../icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
375
376 # files created by regxpcom -register
377 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
378 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
379
380 %if %{with enigmail}
381 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
382 install -d $ext_dir/{chrome,components,defaults/preferences}
383 cd mozilla/dist/bin
384 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
385 cp -rfLp chrome/enigmime.jar $ext_dir/chrome
386 cp -rfLp components/enig* $ext_dir/components
387 cp -rfLp components/libenigmime.so $ext_dir/components
388 cp -rfLp components/libipc.so $ext_dir/components
389 cp -rfLp components/ipc.xpt $ext_dir/components
390 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
391 cd -
392 cp -a ../mailnews/extensions/enigmail/package/install.rdf $ext_dir
393 cp -a ../mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
394 %endif
395
396 # remove unecessary stuff
397 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
398 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
399 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
400
401 # never package these
402 # nss
403 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
404 # nspr
405 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
406 # mozldap
407 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %pretrans
413 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
414         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
415 fi
416 for d in chrome defaults greprefs icons isp modules res; do
417         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
418                 install -d %{_datadir}/%{name}
419                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
420         fi
421 done
422 exit 0
423
424 %files
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_bindir}/icedove
427 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
428 %attr(755,root,root) %{_bindir}/thunderbird
429 %dir %{_libdir}/%{name}
430 %{_libdir}/%{name}/application.ini
431 %{_libdir}/%{name}/platform.ini
432 %dir %{_libdir}/%{name}/components
433 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
434 %{_libdir}/%{name}/components/*.js
435 %{_libdir}/%{name}/components/*.xpt
436 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
437 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
438 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
439 %attr(755,root,root) %{_libdir}/%{name}/*.sh
440 %attr(755,root,root) %{_libdir}/%{name}/*-bin
441 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
442 %attr(755,root,root) %{_libdir}/%{name}/icedove
443
444 # symlinks
445 %{_libdir}/%{name}/chrome
446 %{_libdir}/%{name}/defaults
447 %{_libdir}/%{name}/dictionaries
448 %{_libdir}/%{name}/greprefs
449 %{_libdir}/%{name}/isp
450 %{_libdir}/%{name}/modules
451 %{_libdir}/%{name}/res
452
453 %{_pixmapsdir}/*.png
454 %{_desktopdir}/*.desktop
455
456 %dir %{_datadir}/%{name}
457 %{_datadir}/%{name}/chrome
458 %{_datadir}/%{name}/defaults
459 %{_datadir}/%{name}/greprefs
460 %{_datadir}/%{name}/isp
461 %{_datadir}/%{name}/modules
462 %{_datadir}/%{name}/res
463
464 %if %{with crashreporter}
465 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
466 %{_libdir}/%{name}/crashreporter.ini
467 %{_libdir}/%{name}/Throbber-small.gif
468 %endif
469
470 %dir %{_libdir}/%{name}/extensions
471 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
472
473 # files created by regxpcom -register
474 %ghost %{_libdir}/%{name}/components/compreg.dat
475 %ghost %{_libdir}/%{name}/components/xpti.dat
476
477 %if %{with lightning}
478 %files addon-lightning
479 %defattr(644,root,root,755)
480 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
481 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
482 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
483 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
484 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
485 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
486 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
487 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
488 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
489 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
490 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
491 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
492
493 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
494 %endif
495
496 %if %{with enigmail}
497 %files addon-enigmail
498 %defattr(644,root,root,755)
499 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
500 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
501 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
502 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
503 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
504 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
505 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
506 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
507 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
508 %endif
This page took 0.081248 seconds and 4 git commands to generate.