]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- create compreg.dat, xpti.dat on install
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - fix icedove (building) and installing nss/nspr libs!
283702b9 4# - build with system mozldap
c4ddd260 5#
44be9ed4 6# Conditional builds
7%bcond_without enigmail # don't build enigmail - GPG/PGP support
8%bcond_without gnomeui # disable gnomeui support
9%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
11%bcond_without ldap # disable e-mail address lookups in LDAP directories
6578c165 12%bcond_without lightning # disable sunbird calendar
765a3a27
ER
13%bcond_with xulrunner # build with xulrunner
14%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 15
44be9ed4 16%if %{without gnome}
17%undefine with_gnomeui
18%undefine with_gnomevfs
19%endif
88149483 20
765a3a27
ER
21%if %{?_enable_debug_packages} != 1
22%undefine crashreporter
23%endif
24
f4aadbdb 25%define enigmail_ver 1.1.2
44be9ed4 26
7d981f69
ER
27%if %{without xulrunner}
28# The actual sqlite version (see RHBZ#480989):
29%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
30%endif
31
44be9ed4 32Summary: Icedove - email client
33Summary(pl.UTF-8): Icedove - klient poczty
34Name: icedove
01af76c0 35Version: 3.1.3
e8f4ba81 36Release: 2
44be9ed4 37License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 38Group: X11/Applications/Networking
cadfb931 39Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
01af76c0 40# Source0-md5: 46332e1d9a658f6e31797035107b1a8d
44be9ed4 41Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
f4aadbdb 42# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
44be9ed4 43Source2: %{name}-branding.tar.bz2
fff49dda 44# Source2-md5: 85fdf877e2f1bc41329d8086ef5cf0f1
44be9ed4 45Source3: %{name}-rm_nonfree.sh
46Source4: %{name}.desktop
47Source5: %{name}.sh
44be9ed4 48Patch0: %{name}-branding.patch
faa5c89d
SP
49Patch1: %{name}-enigmail-shared.patch
50Patch2: %{name}-gcc.patch
51Patch3: %{name}-fonts.patch
52Patch4: %{name}-install.patch
5e9bb798 53Patch5: %{name}-hunspell.patch
faa5c89d 54Patch6: %{name}-prefs.patch
9a743685 55Patch7: system-mozldap.patch
a85e0ecb 56Patch8: %{name}-makefile.patch
ca336c77 57Patch9: %{name}-libpng.patch
ccc206fe 58Patch10: %{name}-extensiondir.patch
765a3a27 59Patch11: crashreporter.patch
268e7766 60Patch12: no-subshell.patch
4922c320 61URL: http://www.pld-linux.org/Packages/Icedove
44be9ed4 62%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
51a3b6db 63BuildRequires: alsa-lib-devel
44be9ed4 64BuildRequires: automake
51a3b6db 65BuildRequires: bzip2-devel
44be9ed4 66BuildRequires: freetype-devel >= 1:2.1.8
67%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
68BuildRequires: gtk+2-devel >= 1:2.0.0
5e9bb798 69BuildRequires: hunspell-devel
44be9ed4 70BuildRequires: libIDL-devel >= 0.8.0
71%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 72%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 73%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 74BuildRequires: libiw-devel
44be9ed4 75BuildRequires: libjpeg-devel >= 6b
51a3b6db 76BuildRequires: libnotify-devel >= 0.4
44be9ed4 77BuildRequires: libpng-devel >= 1.2.0
78BuildRequires: libstdc++-devel
cadfb931
SP
79BuildRequires: nspr-devel >= 1:4.8
80BuildRequires: nss-devel >= 1:3.12.0
44be9ed4 81BuildRequires: pango-devel >= 1:1.1.0
1c62cadb 82BuildRequires: pkgconfig
44be9ed4 83BuildRequires: sed >= 4.0
268e7766 84BuildRequires: sqlite3-devel >= 3.7.2-2
1c62cadb 85BuildRequires: startup-notification-devel >= 0.8
44be9ed4 86BuildRequires: xorg-lib-libXext-devel
44be9ed4 87BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 88BuildRequires: xorg-lib-libXt-devel
1c62cadb 89BuildRequires: zip
7d981f69
ER
90%if %{with xulrunner}
91%else
44be9ed4 92Requires: myspell-common
93Requires: nspr >= 1:4.6.1
94Requires: nss >= 1:3.11.3
4b6bc367 95Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 96%endif
44be9ed4 97Obsoletes: mozilla-thunderbird
98Obsoletes: mozilla-thunderbird-dictionary-en-US
99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
9e366f18
AM
101%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
102
44be9ed4 103# iceweasel/icedove/iceape provide their own versions
c072808a 104%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 105%define _noautoprovfiles %{_libdir}/%{name}/components
106# we don't want these to satisfy xulrunner-devel
c072808a 107%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 108# and as we don't provide them, don't require either
c072808a 109%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 110
9e7875fc
ER
111%define topdir %{_builddir}/%{name}-%{version}
112%define objdir %{topdir}/obj-%{_target_cpu}
113
44be9ed4 114%description
115Icedove is an open-source,fast and portable email client.
116
117%description -l pl.UTF-8
118Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
119
6578c165 120%package addon-lightning
121Summary: An integrated calendar for Icedove
122Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
123License: MPL 1.1 or GPL v2+ or LGPL v2.1+
124Group: Applications/Networking
125Requires: %{name} = %{version}-%{release}
126
127%description addon-lightning
128Lightning is an calendar extension to Icedove email client.
129
130%description addon-lightning -l pl.UTF-8
131Lightning to rozszerzenie do klienta poczty Icedove dodające
132funkcjonalność kalendarza.
133
44be9ed4 134%package addon-enigmail
135Summary: Extension for the authentication and encryption features provided by GnuPG
136Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
137License: MPL/LGPL
138Group: Applications/Networking
139URL: http://enigmail.mozdev.org/
cd056caa 140Requires: %{name} = %{version}-%{release}
d076d93e 141Requires: gnupg
75991bbb 142Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 143
144%description addon-enigmail
c5e06599 145Enigmail is an extension to the Icedove mail client which allows users
146to access the authentication and encryption features provided by
147GnuPG.
44be9ed4 148
149Main Features:
150- Encrypt/sign mail when sending, decrypt/authenticate received mail
151- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
152- Per-Account based encryption and signing defaults
153- Per-Recipient rules for automated key selection, and
154 enabling/disabling encryption and signing
155- OpenPGP key management interface
156
157%description addon-enigmail -l pl.UTF-8
c5e06599 158Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
159użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
160przez GnuPG.
44be9ed4 161
162Główne możliwości:
163- szyfrowanie/podpisywanie poczty przy wysyłaniu,
164 odszyfrowywanie/uwierzytelnianie poczty odebranej
165- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
166- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
167- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
168 podpisywania dla każdego adresata
169- interfejs do zarządzania kluczami OpenPGP
170
171%prep
983562b1 172%setup -qc
a85e0ecb 173mv -f comm-1.9.2 mozilla
983562b1 174%setup -q -T -D -a2
175cd mozilla
44be9ed4 176%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
177/bin/sh %{SOURCE3}
983562b1 178%patch0 -p1
faa5c89d
SP
179%{?with_enigmail:%patch1 -p1}
180%patch2 -p1
4ccc2157 181%patch3 -p1
faa5c89d 182%patch4 -p1
5e9bb798 183%patch5 -p1
983562b1 184%patch6 -p1
9a743685 185%patch7 -p1
a85e0ecb 186%patch8 -p0
ca336c77 187%patch9 -p0
ccc206fe 188%patch10 -p2
765a3a27 189%patch11 -p2
268e7766 190%patch12 -p1
44be9ed4 191
192%build
983562b1 193cd mozilla
cadfb931
SP
194cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
195cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
44be9ed4 196cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
197
9a743685
ER
198install -d libxul-sdk
199ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 200
fbac75ca 201cat << EOF > .mozconfig
9e7875fc 202mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 203
8c107b4e
ER
204export CFLAGS="%{rpmcflags}"
205export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
206
207%if %{with crashreporter}
208export MOZ_DEBUG_SYMBOLS=1
209%endif
210
59c5a0e8 211# Options for 'configure' (same as command-line options).
44be9ed4 212ac_add_options --prefix=%{_prefix}
213ac_add_options --exec-prefix=%{_exec_prefix}
214ac_add_options --bindir=%{_bindir}
215ac_add_options --sbindir=%{_sbindir}
216ac_add_options --sysconfdir=%{_sysconfdir}
217ac_add_options --datadir=%{_datadir}
218ac_add_options --includedir=%{_includedir}
219ac_add_options --libdir=%{_libdir}
220ac_add_options --libexecdir=%{_libexecdir}
221ac_add_options --localstatedir=%{_localstatedir}
222ac_add_options --sharedstatedir=%{_sharedstatedir}
223ac_add_options --mandir=%{_mandir}
224ac_add_options --infodir=%{_infodir}
225%if %{?debug:1}0
59c5a0e8 226ac_add_options --disable-optimize
44be9ed4 227ac_add_options --enable-debug
228ac_add_options --enable-debug-modules
59c5a0e8
SP
229ac_add_options --enable-debugger-info-modules
230ac_add_options --enable-crash-on-assert
44be9ed4 231%else
232ac_add_options --disable-debug
233ac_add_options --disable-debug-modules
59c5a0e8
SP
234ac_add_options --disable-logging
235ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 236%endif
88149483
ER
237ac_add_options --disable-strip
238ac_add_options --disable-strip-libs
44be9ed4 239%if %{with tests}
240ac_add_options --enable-tests
241%else
242ac_add_options --disable-tests
243%endif
244%if %{with gnomeui}
245ac_add_options --enable-gnomeui
246%else
247ac_add_options --disable-gnomeui
248%endif
249%if %{with gnomevfs}
250ac_add_options --enable-gnomevfs
251%else
252ac_add_options --disable-gnomevfs
253%endif
254%if %{with ldap}
255ac_add_options --enable-ldap
9a743685 256ac_add_options --with-system-ldap
44be9ed4 257%else
258ac_add_options --disable-ldap
259%endif
765a3a27
ER
260%if %{with crashreporter}
261ac_add_options --enable-crashreporter
262%else
59c5a0e8 263ac_add_options --disable-crashreporter
765a3a27 264%endif
59c5a0e8 265ac_add_options --disable-xterm-updates
59c5a0e8 266ac_add_options --enable-postscript
d076d93e 267%if %{with lightning}
cb0e4412 268ac_add_options --enable-calendar
d076d93e
SP
269%else
270ac_add_options --disable-calendar
271%endif
44be9ed4 272ac_add_options --disable-installer
273ac_add_options --disable-jsd
88149483 274ac_add_options --disable-updater
44be9ed4 275ac_add_options --disable-xprint
cadfb931
SP
276ac_add_options --disable-permissions
277ac_add_options --disable-pref-extensions
44be9ed4 278ac_add_options --enable-canvas
279ac_add_options --enable-crypto
44be9ed4 280ac_add_options --enable-mathml
44be9ed4 281ac_add_options --enable-pango
282ac_add_options --enable-reorder
88149483
ER
283ac_add_options --enable-startup-notification
284ac_add_options --enable-svg
44be9ed4 285ac_add_options --enable-system-cairo
5e9bb798 286ac_add_options --enable-system-hunspell
7d981f69 287ac_add_options --enable-system-sqlite
44be9ed4 288ac_add_options --enable-xft
cadfb931
SP
289ac_add_options --enable-application=mail
290ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 291ac_add_options --enable-xinerama
88149483
ER
292ac_add_options --with-distribution-id=org.pld-linux
293ac_add_options --with-branding=icedove/branding
294%if %{with xulrunner}
fbac75ca
ER
295ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
296ac_add_options --enable-shared
297%else
298ac_add_options --enable-static
88149483
ER
299%endif
300ac_add_options --with-pthreads
301ac_add_options --with-system-bz2
44be9ed4 302ac_add_options --with-system-jpeg
303ac_add_options --with-system-nspr
304ac_add_options --with-system-nss
305ac_add_options --with-system-png
306ac_add_options --with-system-zlib
44be9ed4 307ac_add_options --enable-single-profile
308ac_add_options --disable-profilesharing
44be9ed4 309ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
310EOF
311
90e998ba 312%{__make} -j1 -f client.mk build \
d076d93e 313 STRIP="/bin/true" \
765a3a27 314 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 315 CC="%{__cc}" \
44be9ed4 316 CXX="%{__cxx}"
317
765a3a27
ER
318%if %{with crashreporter}
319# create debuginfo for crash-stats.mozilla.com
320%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
321%endif
322
44be9ed4 323%if %{with enigmail}
59c5a0e8 324cd mailnews/extensions/enigmail
9e7875fc
ER
325./makemake -r -o %{objdir}
326%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
327 STRIP="/bin/true" \
328 CC="%{__cc}" \
329 CXX="%{__cxx}"
44be9ed4 330%endif
331
332%install
333rm -rf $RPM_BUILD_ROOT
765a3a27 334install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 335
9e7875fc 336cd %{objdir}
ecf04393 337%{__make} -C mail/installer stage-package \
44be9ed4 338 DESTDIR=$RPM_BUILD_ROOT \
339 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
340 PKG_SKIP_STRIP=1
341
765a3a27
ER
342# Enable crash reporter for Firefox application
343%if %{with crashreporter}
344%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
345
346# Add debuginfo for crash-stats.mozilla.com
51a3b6db 347install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
348cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
349%endif
350
ecf04393
ER
351# copy manually lightning files, somewhy they are not installed by make
352cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
353 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
354 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
355
44be9ed4 356# move arch independant ones to datadir
357mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
358mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
359mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
44be9ed4 360mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 361mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 362mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
363ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
364ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
365ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
44be9ed4 366ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 367ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 368ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
369
370rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
371ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
372
373%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
374ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
375ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
376
293928f3 377cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
9e7875fc 378cp -a %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 379
e8f4ba81 380# files created by regxpcom -register in post
52fc61e6
ER
381touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
382touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
383cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
384#!/bin/sh
385umask 022
386# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
387# dangerous if you run this with sudo with keep_env += HOME
388# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
389t=$(mktemp -d)
390rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
391TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
392rm -rf $t
393EOF
394chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 395
44be9ed4 396%if %{with enigmail}
283702b9
ER
397ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
398install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6
ER
399cd mozilla/dist/bin
400cp -rfLp chrome/enigmail.jar $ext_dir/chrome
401cp -rfLp chrome/enigmime.jar $ext_dir/chrome
402cp -rfLp components/enig* $ext_dir/components
403cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 404cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
405cp -rfLp components/ipc.xpt $ext_dir/components
406cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
407cd -
9e7875fc
ER
408cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
409cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 410%endif
411
9a743685
ER
412# remove unecessary stuff
413rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
293928f3 414rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
f3b6d696 415rm $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 416
9a743685 417# never package these
283702b9
ER
418# nss
419rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
420# nspr
421rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9
ER
422# mozldap
423rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
424
44be9ed4 425%clean
426rm -rf $RPM_BUILD_ROOT
427
428%pretrans
429if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
430 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
431fi
9e097178 432for d in chrome defaults greprefs icons isp modules res; do
44be9ed4 433 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
434 install -d %{_datadir}/%{name}
435 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
436 fi
437done
438exit 0
439
e8f4ba81
ER
440%post
441%{_libdir}/%{name}/register || :
442
44be9ed4 443%files
444%defattr(644,root,root,755)
445%attr(755,root,root) %{_bindir}/icedove
446%attr(755,root,root) %{_bindir}/mozilla-thunderbird
447%attr(755,root,root) %{_bindir}/thunderbird
448%dir %{_libdir}/%{name}
765a3a27
ER
449%{_libdir}/%{name}/application.ini
450%{_libdir}/%{name}/platform.ini
44be9ed4 451%dir %{_libdir}/%{name}/components
452%attr(755,root,root) %{_libdir}/%{name}/components/*.so
453%{_libdir}/%{name}/components/*.js
454%{_libdir}/%{name}/components/*.xpt
283702b9
ER
455%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
456%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
457%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
44be9ed4 458%attr(755,root,root) %{_libdir}/%{name}/*.sh
459%attr(755,root,root) %{_libdir}/%{name}/*-bin
460%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 461%attr(755,root,root) %{_libdir}/%{name}/icedove
e8f4ba81 462%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 463
464# symlinks
465%{_libdir}/%{name}/chrome
466%{_libdir}/%{name}/defaults
467%{_libdir}/%{name}/dictionaries
468%{_libdir}/%{name}/greprefs
44be9ed4 469%{_libdir}/%{name}/isp
9e097178 470%{_libdir}/%{name}/modules
44be9ed4 471%{_libdir}/%{name}/res
472
293928f3 473%{_pixmapsdir}/*.png
44be9ed4 474%{_desktopdir}/*.desktop
475
476%dir %{_datadir}/%{name}
477%{_datadir}/%{name}/chrome
478%{_datadir}/%{name}/defaults
479%{_datadir}/%{name}/greprefs
44be9ed4 480%{_datadir}/%{name}/isp
9e097178 481%{_datadir}/%{name}/modules
44be9ed4 482%{_datadir}/%{name}/res
483
765a3a27
ER
484%if %{with crashreporter}
485%attr(755,root,root) %{_libdir}/%{name}/crashreporter
486%{_libdir}/%{name}/crashreporter.ini
487%{_libdir}/%{name}/Throbber-small.gif
488%endif
489
44be9ed4 490%dir %{_libdir}/%{name}/extensions
491%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 492
52fc61e6
ER
493# files created by regxpcom -register
494%ghost %{_libdir}/%{name}/components/compreg.dat
495%ghost %{_libdir}/%{name}/components/xpti.dat
496
6578c165 497%if %{with lightning}
498%files addon-lightning
499%defattr(644,root,root,755)
f3b6d696
ER
500%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
501%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
502%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
503%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
504%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
505%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
506%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
507%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
508%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
509%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
510%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
511%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
512
6578c165 513%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
514%endif
44be9ed4 515
516%if %{with enigmail}
517%files addon-enigmail
518%defattr(644,root,root,755)
f6a43e2f
ER
519%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
520%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
521%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
522%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
523%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
524%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
525%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
526%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
527%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 528%endif
This page took 0.112685 seconds and 4 git commands to generate.