]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- i'm not sure, but shouldn't we skip providing/requiring libxpcom_core.so as well...
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - fix icedove (building) and installing nss/nspr libs!
283702b9 4# - build with system mozldap
c4ddd260 5#
44be9ed4 6# Conditional builds
7%bcond_without enigmail # don't build enigmail - GPG/PGP support
8%bcond_without gnomeui # disable gnomeui support
9%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
11%bcond_without ldap # disable e-mail address lookups in LDAP directories
6578c165 12%bcond_without lightning # disable sunbird calendar
765a3a27
ER
13%bcond_with xulrunner # build with xulrunner
14%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 15
44be9ed4 16%if %{without gnome}
17%undefine with_gnomeui
18%undefine with_gnomevfs
19%endif
88149483 20
765a3a27
ER
21%if %{?_enable_debug_packages} != 1
22%undefine crashreporter
23%endif
24
f4aadbdb 25%define enigmail_ver 1.1.2
44be9ed4 26
7d981f69
ER
27%if %{without xulrunner}
28# The actual sqlite version (see RHBZ#480989):
29%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
30%endif
31
44be9ed4 32Summary: Icedove - email client
33Summary(pl.UTF-8): Icedove - klient poczty
34Name: icedove
ecf04393 35Version: 3.1.2
c072808a 36Release: 2
44be9ed4 37License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 38Group: X11/Applications/Networking
cadfb931 39Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
ecf04393 40# Source0-md5: 48e80576a7af70e64d30a5162364525a
44be9ed4 41Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
f4aadbdb 42# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
44be9ed4 43Source2: %{name}-branding.tar.bz2
fff49dda 44# Source2-md5: 85fdf877e2f1bc41329d8086ef5cf0f1
44be9ed4 45Source3: %{name}-rm_nonfree.sh
46Source4: %{name}.desktop
47Source5: %{name}.sh
44be9ed4 48Patch0: %{name}-branding.patch
faa5c89d
SP
49Patch1: %{name}-enigmail-shared.patch
50Patch2: %{name}-gcc.patch
51Patch3: %{name}-fonts.patch
52Patch4: %{name}-install.patch
5e9bb798 53Patch5: %{name}-hunspell.patch
faa5c89d 54Patch6: %{name}-prefs.patch
9a743685 55Patch7: system-mozldap.patch
a85e0ecb 56Patch8: %{name}-makefile.patch
ca336c77 57Patch9: %{name}-libpng.patch
ccc206fe 58Patch10: %{name}-extensiondir.patch
765a3a27 59Patch11: crashreporter.patch
4922c320 60URL: http://www.pld-linux.org/Packages/Icedove
44be9ed4 61%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
51a3b6db 62BuildRequires: alsa-lib-devel
44be9ed4 63BuildRequires: automake
51a3b6db 64BuildRequires: bzip2-devel
44be9ed4 65BuildRequires: freetype-devel >= 1:2.1.8
66%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
67BuildRequires: gtk+2-devel >= 1:2.0.0
5e9bb798 68BuildRequires: hunspell-devel
44be9ed4 69BuildRequires: libIDL-devel >= 0.8.0
70%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 71%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 72%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 73BuildRequires: libiw-devel
44be9ed4 74BuildRequires: libjpeg-devel >= 6b
51a3b6db 75BuildRequires: libnotify-devel >= 0.4
44be9ed4 76BuildRequires: libpng-devel >= 1.2.0
77BuildRequires: libstdc++-devel
cadfb931
SP
78BuildRequires: nspr-devel >= 1:4.8
79BuildRequires: nss-devel >= 1:3.12.0
44be9ed4 80BuildRequires: pango-devel >= 1:1.1.0
1c62cadb 81BuildRequires: pkgconfig
44be9ed4 82BuildRequires: sed >= 4.0
4b6bc367 83BuildRequires: sqlite3-devel >= 3.6.22
1c62cadb 84BuildRequires: startup-notification-devel >= 0.8
44be9ed4 85BuildRequires: xorg-lib-libXext-devel
44be9ed4 86BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 87BuildRequires: xorg-lib-libXt-devel
1c62cadb 88BuildRequires: zip
7d981f69
ER
89%if %{with xulrunner}
90%else
44be9ed4 91Requires: myspell-common
92Requires: nspr >= 1:4.6.1
93Requires: nss >= 1:3.11.3
4b6bc367 94Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 95%endif
44be9ed4 96Obsoletes: mozilla-thunderbird
97Obsoletes: mozilla-thunderbird-dictionary-en-US
98BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
9e366f18
AM
100%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
101
44be9ed4 102# iceweasel/icedove/iceape provide their own versions
c072808a 103%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 104%define _noautoprovfiles %{_libdir}/%{name}/components
105# we don't want these to satisfy xulrunner-devel
c072808a 106%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 107# and as we don't provide them, don't require either
c072808a 108%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 109
9e7875fc
ER
110%define topdir %{_builddir}/%{name}-%{version}
111%define objdir %{topdir}/obj-%{_target_cpu}
112
44be9ed4 113%description
114Icedove is an open-source,fast and portable email client.
115
116%description -l pl.UTF-8
117Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
118
6578c165 119%package addon-lightning
120Summary: An integrated calendar for Icedove
121Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
122License: MPL 1.1 or GPL v2+ or LGPL v2.1+
123Group: Applications/Networking
124Requires: %{name} = %{version}-%{release}
125
126%description addon-lightning
127Lightning is an calendar extension to Icedove email client.
128
129%description addon-lightning -l pl.UTF-8
130Lightning to rozszerzenie do klienta poczty Icedove dodające
131funkcjonalność kalendarza.
132
44be9ed4 133%package addon-enigmail
134Summary: Extension for the authentication and encryption features provided by GnuPG
135Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
136License: MPL/LGPL
137Group: Applications/Networking
138URL: http://enigmail.mozdev.org/
cd056caa 139Requires: %{name} = %{version}-%{release}
d076d93e 140Requires: gnupg
75991bbb 141Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 142
143%description addon-enigmail
c5e06599 144Enigmail is an extension to the Icedove mail client which allows users
145to access the authentication and encryption features provided by
146GnuPG.
44be9ed4 147
148Main Features:
149- Encrypt/sign mail when sending, decrypt/authenticate received mail
150- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
151- Per-Account based encryption and signing defaults
152- Per-Recipient rules for automated key selection, and
153 enabling/disabling encryption and signing
154- OpenPGP key management interface
155
156%description addon-enigmail -l pl.UTF-8
c5e06599 157Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
158użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
159przez GnuPG.
44be9ed4 160
161Główne możliwości:
162- szyfrowanie/podpisywanie poczty przy wysyłaniu,
163 odszyfrowywanie/uwierzytelnianie poczty odebranej
164- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
165- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
166- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
167 podpisywania dla każdego adresata
168- interfejs do zarządzania kluczami OpenPGP
169
170%prep
983562b1 171%setup -qc
a85e0ecb 172mv -f comm-1.9.2 mozilla
983562b1 173%setup -q -T -D -a2
174cd mozilla
44be9ed4 175%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
176/bin/sh %{SOURCE3}
983562b1 177%patch0 -p1
faa5c89d
SP
178%{?with_enigmail:%patch1 -p1}
179%patch2 -p1
4ccc2157 180%patch3 -p1
faa5c89d 181%patch4 -p1
5e9bb798 182%patch5 -p1
983562b1 183%patch6 -p1
9a743685 184%patch7 -p1
a85e0ecb 185%patch8 -p0
ca336c77 186%patch9 -p0
ccc206fe 187%patch10 -p2
765a3a27 188%patch11 -p2
44be9ed4 189
190%build
983562b1 191cd mozilla
cadfb931
SP
192cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
193cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
44be9ed4 194cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
195
9a743685
ER
196install -d libxul-sdk
197ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 198
fbac75ca 199cat << EOF > .mozconfig
9e7875fc 200mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 201
8c107b4e
ER
202export CFLAGS="%{rpmcflags}"
203export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
204
205%if %{with crashreporter}
206export MOZ_DEBUG_SYMBOLS=1
207%endif
208
59c5a0e8 209# Options for 'configure' (same as command-line options).
44be9ed4 210ac_add_options --prefix=%{_prefix}
211ac_add_options --exec-prefix=%{_exec_prefix}
212ac_add_options --bindir=%{_bindir}
213ac_add_options --sbindir=%{_sbindir}
214ac_add_options --sysconfdir=%{_sysconfdir}
215ac_add_options --datadir=%{_datadir}
216ac_add_options --includedir=%{_includedir}
217ac_add_options --libdir=%{_libdir}
218ac_add_options --libexecdir=%{_libexecdir}
219ac_add_options --localstatedir=%{_localstatedir}
220ac_add_options --sharedstatedir=%{_sharedstatedir}
221ac_add_options --mandir=%{_mandir}
222ac_add_options --infodir=%{_infodir}
223%if %{?debug:1}0
59c5a0e8 224ac_add_options --disable-optimize
44be9ed4 225ac_add_options --enable-debug
226ac_add_options --enable-debug-modules
59c5a0e8
SP
227ac_add_options --enable-debugger-info-modules
228ac_add_options --enable-crash-on-assert
44be9ed4 229%else
230ac_add_options --disable-debug
231ac_add_options --disable-debug-modules
59c5a0e8
SP
232ac_add_options --disable-logging
233ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 234%endif
88149483
ER
235ac_add_options --disable-strip
236ac_add_options --disable-strip-libs
44be9ed4 237%if %{with tests}
238ac_add_options --enable-tests
239%else
240ac_add_options --disable-tests
241%endif
242%if %{with gnomeui}
243ac_add_options --enable-gnomeui
244%else
245ac_add_options --disable-gnomeui
246%endif
247%if %{with gnomevfs}
248ac_add_options --enable-gnomevfs
249%else
250ac_add_options --disable-gnomevfs
251%endif
252%if %{with ldap}
253ac_add_options --enable-ldap
9a743685 254ac_add_options --with-system-ldap
44be9ed4 255%else
256ac_add_options --disable-ldap
257%endif
765a3a27
ER
258%if %{with crashreporter}
259ac_add_options --enable-crashreporter
260%else
59c5a0e8 261ac_add_options --disable-crashreporter
765a3a27 262%endif
59c5a0e8 263ac_add_options --disable-xterm-updates
59c5a0e8 264ac_add_options --enable-postscript
d076d93e 265%if %{with lightning}
cb0e4412 266ac_add_options --enable-calendar
d076d93e
SP
267%else
268ac_add_options --disable-calendar
269%endif
44be9ed4 270ac_add_options --disable-installer
271ac_add_options --disable-jsd
88149483 272ac_add_options --disable-updater
44be9ed4 273ac_add_options --disable-xprint
cadfb931
SP
274ac_add_options --disable-permissions
275ac_add_options --disable-pref-extensions
44be9ed4 276ac_add_options --enable-canvas
277ac_add_options --enable-crypto
44be9ed4 278ac_add_options --enable-mathml
44be9ed4 279ac_add_options --enable-pango
280ac_add_options --enable-reorder
88149483
ER
281ac_add_options --enable-startup-notification
282ac_add_options --enable-svg
44be9ed4 283ac_add_options --enable-system-cairo
5e9bb798 284ac_add_options --enable-system-hunspell
7d981f69 285ac_add_options --enable-system-sqlite
44be9ed4 286ac_add_options --enable-xft
cadfb931
SP
287ac_add_options --enable-application=mail
288ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 289ac_add_options --enable-xinerama
88149483
ER
290ac_add_options --with-distribution-id=org.pld-linux
291ac_add_options --with-branding=icedove/branding
292%if %{with xulrunner}
fbac75ca
ER
293ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
294ac_add_options --enable-shared
295%else
296ac_add_options --enable-static
88149483
ER
297%endif
298ac_add_options --with-pthreads
299ac_add_options --with-system-bz2
44be9ed4 300ac_add_options --with-system-jpeg
301ac_add_options --with-system-nspr
302ac_add_options --with-system-nss
303ac_add_options --with-system-png
304ac_add_options --with-system-zlib
44be9ed4 305ac_add_options --enable-single-profile
306ac_add_options --disable-profilesharing
44be9ed4 307ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
308EOF
309
90e998ba 310%{__make} -j1 -f client.mk build \
d076d93e 311 STRIP="/bin/true" \
765a3a27 312 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 313 CC="%{__cc}" \
44be9ed4 314 CXX="%{__cxx}"
315
765a3a27
ER
316%if %{with crashreporter}
317# create debuginfo for crash-stats.mozilla.com
318%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
319%endif
320
44be9ed4 321%if %{with enigmail}
59c5a0e8 322cd mailnews/extensions/enigmail
9e7875fc
ER
323./makemake -r -o %{objdir}
324%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
325 STRIP="/bin/true" \
326 CC="%{__cc}" \
327 CXX="%{__cxx}"
44be9ed4 328%endif
329
330%install
331rm -rf $RPM_BUILD_ROOT
765a3a27 332install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 333
9e7875fc 334cd %{objdir}
ecf04393 335%{__make} -C mail/installer stage-package \
44be9ed4 336 DESTDIR=$RPM_BUILD_ROOT \
337 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
338 PKG_SKIP_STRIP=1
339
765a3a27
ER
340# Enable crash reporter for Firefox application
341%if %{with crashreporter}
342%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
343
344# Add debuginfo for crash-stats.mozilla.com
51a3b6db 345install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
346cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
347%endif
348
ecf04393
ER
349# copy manually lightning files, somewhy they are not installed by make
350cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
351 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
352 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
353
44be9ed4 354# move arch independant ones to datadir
355mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
356mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
357mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
44be9ed4 358mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 359mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 360mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
361ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
362ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
363ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
44be9ed4 364ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 365ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 366ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
367
368rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
369ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
370
371%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
372ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
373ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
374
293928f3 375cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
9e7875fc 376cp -a %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 377
52fc61e6
ER
378# files created by regxpcom -register
379touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
380touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
381
44be9ed4 382%if %{with enigmail}
283702b9
ER
383ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
384install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6
ER
385cd mozilla/dist/bin
386cp -rfLp chrome/enigmail.jar $ext_dir/chrome
387cp -rfLp chrome/enigmime.jar $ext_dir/chrome
388cp -rfLp components/enig* $ext_dir/components
389cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 390cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
391cp -rfLp components/ipc.xpt $ext_dir/components
392cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
393cd -
9e7875fc
ER
394cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
395cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 396%endif
397
9a743685
ER
398# remove unecessary stuff
399rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
293928f3 400rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
f3b6d696 401rm $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 402
9a743685 403# never package these
283702b9
ER
404# nss
405rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
406# nspr
407rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9
ER
408# mozldap
409rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
410
44be9ed4 411%clean
412rm -rf $RPM_BUILD_ROOT
413
414%pretrans
415if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
416 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
417fi
9e097178 418for d in chrome defaults greprefs icons isp modules res; do
44be9ed4 419 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
420 install -d %{_datadir}/%{name}
421 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
422 fi
423done
424exit 0
425
426%files
427%defattr(644,root,root,755)
428%attr(755,root,root) %{_bindir}/icedove
429%attr(755,root,root) %{_bindir}/mozilla-thunderbird
430%attr(755,root,root) %{_bindir}/thunderbird
431%dir %{_libdir}/%{name}
765a3a27
ER
432%{_libdir}/%{name}/application.ini
433%{_libdir}/%{name}/platform.ini
44be9ed4 434%dir %{_libdir}/%{name}/components
435%attr(755,root,root) %{_libdir}/%{name}/components/*.so
436%{_libdir}/%{name}/components/*.js
437%{_libdir}/%{name}/components/*.xpt
283702b9
ER
438%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
439%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
440%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
44be9ed4 441%attr(755,root,root) %{_libdir}/%{name}/*.sh
442%attr(755,root,root) %{_libdir}/%{name}/*-bin
443%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 444%attr(755,root,root) %{_libdir}/%{name}/icedove
44be9ed4 445
446# symlinks
447%{_libdir}/%{name}/chrome
448%{_libdir}/%{name}/defaults
449%{_libdir}/%{name}/dictionaries
450%{_libdir}/%{name}/greprefs
44be9ed4 451%{_libdir}/%{name}/isp
9e097178 452%{_libdir}/%{name}/modules
44be9ed4 453%{_libdir}/%{name}/res
454
293928f3 455%{_pixmapsdir}/*.png
44be9ed4 456%{_desktopdir}/*.desktop
457
458%dir %{_datadir}/%{name}
459%{_datadir}/%{name}/chrome
460%{_datadir}/%{name}/defaults
461%{_datadir}/%{name}/greprefs
44be9ed4 462%{_datadir}/%{name}/isp
9e097178 463%{_datadir}/%{name}/modules
44be9ed4 464%{_datadir}/%{name}/res
465
765a3a27
ER
466%if %{with crashreporter}
467%attr(755,root,root) %{_libdir}/%{name}/crashreporter
468%{_libdir}/%{name}/crashreporter.ini
469%{_libdir}/%{name}/Throbber-small.gif
470%endif
471
44be9ed4 472%dir %{_libdir}/%{name}/extensions
473%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 474
52fc61e6
ER
475# files created by regxpcom -register
476%ghost %{_libdir}/%{name}/components/compreg.dat
477%ghost %{_libdir}/%{name}/components/xpti.dat
478
6578c165 479%if %{with lightning}
480%files addon-lightning
481%defattr(644,root,root,755)
f3b6d696
ER
482%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
483%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
484%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
485%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
486%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
487%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
488%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
489%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
490%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
491%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
492%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
493%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
494
6578c165 495%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
496%endif
44be9ed4 497
498%if %{with enigmail}
499%files addon-enigmail
500%defattr(644,root,root,755)
f6a43e2f
ER
501%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
502%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
503%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
504%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
505%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
506%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
507%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
508%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
509%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 510%endif
This page took 0.123093 seconds and 4 git commands to generate.