]> git.pld-linux.org Git - packages/systemd.git/blame - systemd.spec
- R: libutempter for utmp group
[packages/systemd.git] / systemd.spec
CommitLineData
5d32f234 1#
d374e721
JR
2# TODO:
3# - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4# after enough packages provide their own tmpfiles.d configs for
5# /var/run directories
6#
c3037397 7# Conditional build:
6c89bbd4
ER
8%bcond_without audit # without audit support
9%bcond_without cryptsetup # without cryptsetup support
23107006
TP
10%bcond_without gtk # build gtk tools
11%bcond_without pam # PAM authentication support
4389e6f9 12%bcond_with plymouth # plymouth support
23107006
TP
13%bcond_without selinux # without SELinux support
14%bcond_without tcpd # libwrap (tcp_wrappers) support
9c0b975d 15
c3037397 16Summary: A System and Service Manager
ede8d3e5 17Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
18Name: systemd
2be4e142 19Version: 44
b7203b85 20Release: 2
ede8d3e5 21License: GPL v2+
22Group: Base
440d1d13 23Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
2be4e142 24# Source0-md5: 11f44ff74c87850064e4351518bcff17
4f25b6ac 25Source1: %{name}-sysv-convert
b0980573 26Source2: %{name}_booted.c
a3a953ae
JR
27Source3: network.service
28Source4: compat-pld-media.tmpfiles
29Source5: compat-pld-var-run.tmpfiles
44410185
JR
30Source10: pld-storage-init-late.service
31Source11: pld-storage-init.service
32Source12: pld-wait-storage.service
33Source13: pld-storage-init.sh
7619c097 34Patch0: target-pld.patch
252e1bad 35Patch1: config-pld.patch
8e088cd5 36Patch2: shut-sysv-up.patch
2e1f31c8 37Patch3: pld-sysv-network.patch
d374e721 38Patch4: tmpfiles-not-fatal.patch
2be4e142 39Patch5: CVE-2012-1174.patch
ede8d3e5 40URL: http://www.freedesktop.org/wiki/Software/systemd
5b9bde26 41BuildRequires: acl-devel
6c89bbd4 42%{?with_audit:BuildRequires: audit-libs-devel}
6e34428f
MB
43BuildRequires: autoconf >= 2.63
44BuildRequires: automake >= 1:1.11
e4c66821 45BuildRequires: binutils >= 3:2.22.52.0.1-2
6e34428f 46%{?with_cryptsetup:BuildRequires: cryptsetup-luks-devel}
23107006 47BuildRequires: dbus-devel >= 1.3.2
c3037397 48BuildRequires: docbook-style-xsl
3fc7a1cc 49BuildRequires: gperf
5b9bde26 50BuildRequires: intltool >= 0.40.0
4389e6f9 51BuildRequires: kmod-devel >= 5
b82d0bf2 52BuildRequires: libcap-devel
def6d132 53%{?with_selinux:BuildRequires: libselinux-devel >= 2.1.0}
6c89bbd4
ER
54BuildRequires: libtool >= 2:2.2
55%{?with_tcpd:BuildRequires: libwrap-devel}
6e34428f 56BuildRequires: libxslt-progs
961baf80 57BuildRequires: m4
6c89bbd4 58%{?with_pam:BuildRequires: pam-devel}
23107006 59BuildRequires: pkgconfig >= 0.9.0
4cc1cb1d 60BuildRequires: rpmbuild(macros) >= 1.627
58fd72e9 61BuildRequires: udev-devel >= 1:172
5b9bde26
JB
62# not required for building from release (which contains *.c for *.vala)
63#BuildRequires: vala >= 0.10.0
58fd72e9 64BuildRequires: xz-devel
e4c66821
JB
65%if %{with gtk}
66BuildRequires: glib2-devel >= 1:2.26.1
67BuildRequires: gtk+2-devel >= 2:2.24.0
68BuildRequires: libgee-devel
69BuildRequires: libnotify-devel >= 0.7.0
70%endif
011bccb6 71Requires: %{name}-libs = %{version}-%{release}
c3037397 72Requires: %{name}-units = %{version}-%{release}
58d6217a 73Requires: /etc/os-release
2ff27c26 74Requires: SysVinit-tools
37b8df82 75Requires: agetty
b0980573 76Requires: dbus >= 1.4.16-6
7cb5cfc8 77Requires: filesystem >= 4.0-2
ed5c41d4 78Requires: libutempter
851fb4d8 79Requires: rc-scripts >= 0.4.5.1-7
56701781 80Requires: setup >= 2.8.0-2
b0980573 81Requires: udev-core >= 1:175-5
fe6ae5ab 82Requires: udev-libs >= 1:172
e3134fe0 83Requires: virtual(module-tools)
b0980573 84Suggests: ConsoleKit
2a61be78 85Suggests: fsck >= 2.20
e3134fe0 86Suggests: kmod >= 5
4b15486a 87Suggests: nss_myhostname
2a61be78 88# python modules required by systemd-analyze
b0980573 89Suggests: %{name}-no-compat-tmpfiles
2a61be78
TP
90Suggests: python-dbus
91Suggests: python-modules
c35aa49c 92Suggests: service(klogd)
1cdd35cf 93Suggests: service(syslog)
fda563d5 94Provides: udev-acl
3baeefca
PG
95# systemd takes care of that and causes problems
96Conflicts: binfmt-detector
a6203073 97# sytemd wants pam with pam_systemd.so in system-auth...
3b292a99 98Conflicts: pam < 1:1.1.5-5
a6203073
JR
99# ...and sudo hates it
100Conflicts: sudo < 1:1.7.8p2-4
06d34666
JR
101# for prefdm script
102Conflicts: xinitrc-ng < 1.0
ede8d3e5 103BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
85879912
ER
105%define _libexecdir %{_prefix}/lib
106
ede8d3e5 107%description
1c239f8b 108systemd is a system and service manager for Linux, compatible with
ede8d3e5 109SysV and LSB init scripts. systemd provides aggressive parallelization
110capabilities, uses socket and D-Bus activation for starting services,
111offers on-demand starting of daemons, keeps track of processes using
112Linux cgroups, supports snapshotting and restoring of the system
113state, maintains mount and automount points and implements an
114elaborate transactional dependency-based service control logic. It can
1c239f8b 115work as a drop-in replacement for sysvinit.
ede8d3e5 116
117%description -l pl.UTF-8
118systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
119skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
120paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
121oferuje uruchamianie usług na życzenie, monitoruje procesy używając
122linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
123(restore) stanu systemu, zarządza (auto)mount pointami oraz
124implementuje starannie opracowaną transakcjonalną, bazującą na
d45dfc3a 125zależnościach logikę kontroli usług. Może pracować jako zastępca dla
ede8d3e5 126sysvinit.
127
c97dacdd
TP
128%package init
129Summary: systemd /sbin/init and LSB/SysV compatibility symlinks
5b9bde26 130Summary(pl.UTF-8): /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
c97dacdd 131Group: Base
d6829efa 132Requires: systemd
c97dacdd
TP
133Provides: readahead = 1:1.5.7-3
134Provides: virtual(init-daemon)
135Obsoletes: SysVinit
136Obsoletes: readahead < 1:1.5.7-3
137Obsoletes: virtual(init-daemon)
4e1559fc 138Conflicts: upstart
c97dacdd
TP
139
140%description init
141Install this package when you are ready to final switch to systemd.
142
5b9bde26
JB
143%description init -l pl.UTF-8
144Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
145przejścia na systemd.
146
c3037397
ER
147%package units
148Summary: Configuration files, directories and installation tool for systemd
5b9bde26 149Summary(pl.UTF-8): Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
c3037397 150Group: Base
c3037397 151Requires(post): coreutils
a8d86f01 152Requires(post): /bin/awk
c3037397
ER
153
154%description units
155Basic configuration files, directories and installation tool for the
156systemd system and service manager.
157
f341cd9b 158This is common config, use %{_sysconfdir}/systemd/system to override.
10ffdcd2 159
5b9bde26
JB
160%description units -l pl.UTF-8
161Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
162zarządcy systemu i usług systemd.
163
164Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
165poprzez katalog %{_sysconfdir}/systemd/system.
166
e4c66821
JB
167%package plymouth
168Summary: Plymouth support units for systemd
169Summary(pl.UTF-8): Jednostki wspierające Plymouth dla systemd
170Group: Base
171Requires: %{name}-units = %{version}-%{release}
172
173%description plymouth
174Plymouth (graphical boot) support units for systemd.
175
176%description plymouth -l pl.UTF-8
177Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
178
c3037397
ER
179%package gtk
180Summary: Graphical frontend for systemd
5b9bde26 181Summary(pl.UTF-8): Graficzny interfejs do systemd
c3037397
ER
182Group: Base
183Requires: %{name} = %{version}-%{release}
184Requires: polkit
185
186%description gtk
187Graphical front-end for systemd.
188
5b9bde26
JB
189%description gtk -l pl.UTF-8
190Graficzny interfejs do systemd.
6c89bbd4 191
011bccb6 192%package libs
5b9bde26
JB
193Summary: Shared systemd libraries
194Summary(pl.UTF-8): Biblioteki współdzielone systemd
011bccb6
BZ
195Group: Libraries
196
197%description libs
5b9bde26
JB
198Shared systemd libraries.
199
200%description libs -l pl.UTF-8
201Biblioteki współdzielone systemd.
011bccb6 202
961baf80
AF
203%package devel
204Summary: Header files for systemd libraries
205Summary(pl.UTF-8): Pliki nagłówkowe bibliotek systemd
206Group: Development/Libraries
011bccb6 207Requires: %{name}-libs = %{version}-%{release}
961baf80
AF
208
209%description devel
210Header files for systemd libraries.
211
212%description devel -l pl.UTF-8
213Pliki nagłówkowe bibliotek systemd.
214
5b9bde26
JB
215%package -n bash-completion-systemd
216Summary: bash-completion for systemd
217Summary(pl.UTF-8): Bashowe dopełnianie składni dla systemd
218Group: Applications/Shells
219Requires: %{name}
220Requires: bash-completion
221
222%description -n bash-completion-systemd
223bash-completion for systemd.
224
225%description -n bash-completion-systemd -l pl.UTF-8
226Bashowe dopełnianie składni dla systemd
227
ae4d0acb
JR
228%package no-compat-tmpfiles
229Summary: Force update of packages that provide tmpfiles.d configuration
230Group: Base
231Requires(post): sed > 4.0
232Conflicts: ConsoleKit-dirs < 0.4.5-7
233Conflicts: NetworkManager < 2:0.9.2.0-3
234Conflicts: Zope < 2.11.8-2
235Conflicts: amavisd-new < 1:2.7.0-1
ae4d0acb
JR
236Conflicts: apache-base < 2.2.21-4
237Conflicts: apache-mod_bw < 0.92-3
238Conflicts: apache-mod_fastcgi < 2.4.6-6
b0980573
ŁK
239Conflicts: apache1-base < 1.3.42-5
240Conflicts: apache1-mod_fastcgi < 2.4.6-2
ae4d0acb
JR
241Conflicts: asterisk < 10.0.1-2
242Conflicts: autossh-init < 1.4b-3
243Conflicts: balance < 3.54-2
244Conflicts: bind < 7:9.8.1.P1-4
245Conflicts: bopm < 3.1.3-4
246Conflicts: callweaver < 1.2.1-9
247Conflicts: cassandra-bin < 0.8.9-2
248Conflicts: clamav < 0.97.3-3
249Conflicts: cups < 1:1.5.0-10
250Conflicts: dbus < 1.4.16-4
251Conflicts: dovecot < 1:2.0.16-3
252Conflicts: dspam < 3.9.0-6
253Conflicts: fail2ban < 0.8.4-4
254Conflicts: filesystem < 4.0-3
255Conflicts: gammu-smsd < 1:1.31.0-3
a6203073
JR
256# Break gdm2.20 installs
257#Conflicts: gdm < 2:3.2.1.1-9
ae4d0acb
JR
258Conflicts: greylistd < 0.8.8-2
259Conflicts: inn < 2.4.6-7
260Conflicts: ipsec-tools < 0.8.0-3
261Conflicts: jabber-common < 0-9
262Conflicts: laptop-mode-tools < 1.58-2
263Conflicts: libgpod < 0.8.0-6
264Conflicts: libvirt-utils < 0.9.9-4
265Conflicts: lighttpd < 1.4.30-5
266Conflicts: lirc < 0.9.0-20
267Conflicts: mailman < 5:2.1.14-4
268Conflicts: memcached < 1.4.11-2
269Conflicts: mpd < 0.16.5-4
270Conflicts: mrtg < 2.17.0-3
271Conflicts: munin-common < 1.4.5-5
272Conflicts: nagios-nrpe < 2.13-2
273Conflicts: ndisc6-rdnssd < 1.0.1-3
274Conflicts: nscd < 6:2.14.1-5
275Conflicts: nss_ldapd-nslcd < 0.8.4-2
276Conflicts: openct < 0.6.20-3
277Conflicts: openl2tp < 1.8-3
278Conflicts: openldap-overlay-nssov < 2.4.28-4
279Conflicts: openldap-servers < 2.4.28-4
280Conflicts: openvpn < 2.2.2-2
ae4d0acb
JR
281Conflicts: pam-pam_mount < 2.12-3
282Conflicts: pam-pam_ssh < 1.97-2
283Conflicts: pcsc-lite < 1.8.1-2
284Conflicts: php-dirs < 1.2-3
285Conflicts: policyd < 2.0.10-3
286Conflicts: pound < 2.6-2
287Conflicts: pptp < 1.7.2-3
288Conflicts: proftpd-common < 2:1.3.4a-2
289Conflicts: pulseaudio-server < 1.1-2
290Conflicts: quagga < 0.99.20-3
291Conflicts: radvd < 1.8.5-2
292Conflicts: rc-scripts < 0.4.5.2-3
293Conflicts: red5 < 0.9.0-2
294Conflicts: redis-server < 2.4.2-4
295Conflicts: smokeping < 2.4.2-10
296Conflicts: smtp-gated < 1.4.17-2
297Conflicts: socat < 1.7.2.0-2
298Conflicts: speech-dispatcher < 0.7.1-2
299Conflicts: sphinx < 2.0.3-4
300Conflicts: splashutils < 1.5.4.3-3
301Conflicts: stunnel < 4.50-2
ae4d0acb
JR
302Conflicts: tenshi < 0.12-2
303Conflicts: tor < 0.2.2.35-2
304Conflicts: ucarp < 1.5.2-3
305Conflicts: udisks < 1.0.4-3
306Conflicts: util-vserver < 0.30.216-1.pre3002.3
307Conflicts: vpnc < 0.5.3-2
308Conflicts: web2ldap < 1.1.0rc1-2
309Conflicts: wesnoth-server < 1:1.10-2
310Conflicts: wpa_supplicant < 0.7.3-10
311Conflicts: xl2tpd < 1.3.0-2
312
313%description no-compat-tmpfiles
314Force update of packages that provide tmpfiles.d configuration
315
ede8d3e5 316%prep
317%setup -q
4c5b5ab6 318%patch0 -p1
252e1bad 319%patch1 -p1
a6203073 320%patch2 -p1
942c9075 321%patch3 -p1
d374e721 322%patch4 -p1
2be4e142 323%patch5 -p1
b77423ae 324cp -p %{SOURCE2} src/systemd_booted.c
ede8d3e5 325
326%build
4c5b5ab6 327%{__aclocal} -I m4
ede8d3e5 328%{__autoconf}
6e34428f 329%{__autoheader}
ede8d3e5 330%{__automake}
9c0b975d 331%configure \
6c89bbd4
ER
332 %{__enable_disable audit} \
333 %{__enable_disable cryptsetup libcryptsetup} \
334 %{__enable_disable gtk} \
335 %{__enable_disable pam} \
4389e6f9 336 %{__enable_disable plymouth} \
6c89bbd4
ER
337 %{__enable_disable selinux} \
338 %{__enable_disable tcpd tcpwrap} \
339 --disable-silent-rules \
961baf80 340 --disable-static \
5b9bde26 341 --with-distro=pld \
391eea76 342 --with-rootprefix= \
4389e6f9
JR
343 --with-rootlibdir=/%{_lib} \
344 --enable-split-usr
e1d9cc15 345
ede8d3e5 346%{__make}
b77423ae 347./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
ede8d3e5 348
349%install
350rm -rf $RPM_BUILD_ROOT
23107006 351
ede8d3e5 352%{__make} install \
353 DESTDIR=$RPM_BUILD_ROOT
354
b77423ae
AF
355./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
356
4389e6f9
JR
357# Main binary has been moved, but we don't want to break existing installs
358ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
359
1dcb74bb 360# Create SysV compatibility symlinks. systemctl/systemd are smart
2a61be78 361# enough to detect the way they were called
c28b0c1c 362install -d $RPM_BUILD_ROOT/sbin
4389e6f9 363ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
1dcb74bb 364ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
365ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
23107006
TP
366ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
367ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
1dcb74bb 368ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
369ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
1dcb74bb 370
5d32f234 371ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
44410185
JR
372
373# disable redundant SYSV services
374ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
4cc1cb1d 375ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
44410185
JR
376ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
377ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
378ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
379ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
5d32f234 380
f1586299 381# add static (non-NetworkManager) networking
a3a953ae 382install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
f1586299 383
5c8fe698 384# install compatibility tmpfiles configs
a3a953ae
JR
385install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
386install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
5c8fe698 387
44410185
JR
388# Install and enable storage subsystems support services (RAID, LVM, etc.)
389install %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
390install %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
391install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
392install %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
393
394ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
395ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
c3037397 396
2a61be78
TP
397# Make sure these directories are properly owned:
398# - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
399# - syslog _might_ be used by some syslog implementation (none for now),
400# - isn't dbus populated by dbus-systemd only (so to be moved there)?
4cc1cb1d 401install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
961baf80
AF
402
403# Create new-style configuration files so that we can ghost-own them
70047b34 404touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
4bbef33c 405
9d8b5dfe 406# Install SysV conversion tool for systemd
4f25b6ac 407install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
9d8b5dfe
BZ
408
409install -d $RPM_BUILD_ROOT/var/log
5a65c84e
TP
410:> $RPM_BUILD_ROOT/var/log/btmp
411:> $RPM_BUILD_ROOT/var/log/wtmp
a761f93e 412
5d32f234 413%if %{without gtk}
5d32f234
TP
414%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
415%endif
416
417%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
a86320a6 418%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
5d32f234
TP
419%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
420
ede8d3e5 421%clean
422rm -rf $RPM_BUILD_ROOT
423
9638c72f 424%post
4bbef33c 425/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
9638c72f 426/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
c3037397 427
961baf80 428%postun
85879912 429if [ $1 -ge 1 ]; then
961baf80 430 /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
9638c72f 431fi
432
3edd52a6
TP
433%post libs -p /sbin/ldconfig
434%postun libs -p /sbin/ldconfig
011bccb6 435
961baf80 436%post units
85879912 437if [ $1 -eq 1 ]; then
961baf80
AF
438 # Try to read default runlevel from the old inittab if it exists
439 runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
440 if [ -z "$runlevel" ] ; then
4cc1cb1d 441 target="%{systemdunitdir}/graphical.target"
961baf80 442 else
4cc1cb1d 443 target="%{systemdunitdir}/runlevel$runlevel.target"
961baf80
AF
444 fi
445
446 # And symlink what we found to the new-style default.target
f341cd9b 447 ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
cf819365
JR
448
449 # Setup hostname
450 [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
451 if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
452 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
453 echo $HOSTNAME > /etc/hostname
454 chmod 644 /etc/hostname
455 fi
44410185
JR
456
457 # Enable the services we install by default.
458 /bin/systemctl enable \
459 getty@.service \
460 network.service \
461 remote-fs.target \
462 systemd-readahead-replay.service \
463 systemd-readahead-collect.service >/dev/null 2>&1 || :
9638c72f 464fi
c3037397
ER
465
466%preun units
961baf80
AF
467if [ $1 -eq 0 ] ; then
468 /bin/systemctl disable \
469 getty@.service \
f1586299 470 network.service \
961baf80
AF
471 remote-fs.target \
472 systemd-readahead-replay.service \
473 systemd-readahead-collect.service >/dev/null 2>&1 || :
474
f341cd9b 475 %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
c3037397 476fi
9638c72f 477
961baf80 478%postun units
85879912 479if [ $1 -ge 1 ]; then
9638c72f 480 /bin/systemctl daemon-reload > /dev/null 2>&1 || :
481fi
482
f2a385f3 483%triggerpostun units -- %{name}-units < 43-7
44410185 484# Remove design fialures
44410185
JR
485rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
486rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
f3877668
JR
487rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
488/bin/systemctl reenable network.service >/dev/null 2>&1 || :
44410185 489
ae4d0acb 490%post no-compat-tmpfiles
a6203073 491%{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
ae4d0acb 492
ede8d3e5 493%files
494%defattr(644,root,root,755)
1c239f8b 495%doc DISTRO_PORTING README TODO
6e34428f 496/etc/dbus-1/system.d/org.freedesktop.hostname1.conf
961baf80
AF
497/etc/dbus-1/system.d/org.freedesktop.locale1.conf
498/etc/dbus-1/system.d/org.freedesktop.login1.conf
c3037397 499/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
961baf80 500/etc/dbus-1/system.d/org.freedesktop.timedate1.conf
3edd52a6 501%ghost %config(noreplace) %{_sysconfdir}/machine-id
b77423ae
AF
502%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
503%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
504%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
b77423ae
AF
505%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
506%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
5d32f234 507%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
2a61be78 508%dir %{_sysconfdir}/systemd/user
44410185
JR
509%dir %{_sysconfdir}/systemd/system/*.target.wants
510%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
511%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
abd479ee 512/etc/xdg/systemd
1dcb74bb 513%attr(755,root,root) /bin/systemd
514%attr(755,root,root) /bin/systemd-ask-password
c76a8951 515%attr(755,root,root) /bin/systemd-journalctl
961baf80 516%attr(755,root,root) /bin/systemd-loginctl
7a76bc86 517%attr(755,root,root) /bin/systemd-machine-id-setup
1dcb74bb 518%attr(755,root,root) /bin/systemd-notify
519%attr(755,root,root) /bin/systemd-tty-ask-password-agent
57cd0d13 520%attr(755,root,root) %{_bindir}/systemd-analyze
d374e721
JR
521%attr(755,root,root) %{_bindir}/systemd-cat
522%attr(755,root,root) %{_bindir}/systemd-cgtop
23107006 523%attr(755,root,root) %{_bindir}/systemd-cgls
57cd0d13
ZU
524%attr(755,root,root) %{_bindir}/systemd-nspawn
525%attr(755,root,root) %{_bindir}/systemd-stdio-bridge
2a61be78 526%attr(755,root,root) %{_bindir}/systemd-sysv-convert
44410185 527%attr(755,root,root) /lib/systemd/pld-storage-init
abd479ee 528%attr(755,root,root) /lib/systemd/systemd-*
c3037397 529%dir /lib/systemd/system-generators
4389e6f9 530%attr(755,root,root) /lib/systemd/systemd
5d32f234 531%attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
abd479ee 532%dir /lib/systemd/system-shutdown
1c239f8b 533/lib/udev/rules.d/99-systemd.rules
961baf80
AF
534/lib/udev/rules.d/70-uaccess.rules
535/lib/udev/rules.d/71-seat.rules
536/lib/udev/rules.d/73-seat-late.rules
3edd52a6
TP
537%dir %{_libexecdir}/systemd
538%{_libexecdir}/systemd/user
2a61be78 539%dir %{_libexecdir}/systemd/user-generators
89d58574 540%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
961baf80
AF
541%{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
542%{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
c3037397 543%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
961baf80 544%{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
1c239f8b 545%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
6e34428f 546%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
961baf80
AF
547%{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
548%{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
1c239f8b 549%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
961baf80 550%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
6e34428f 551%{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
961baf80
AF
552%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
553%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
554%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
555%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
556%dir %{_datadir}/systemd
557%{_datadir}/systemd/kbd-model-map
7a76bc86 558%{_mandir}/man1/systemd.1*
2a61be78 559%{_mandir}/man1/systemd-*.1*
6e34428f 560%{_mandir}/man5/binfmt.d.5*
1c239f8b 561%{_mandir}/man5/hostname.5*
562%{_mandir}/man5/locale.conf.5*
7a76bc86 563%{_mandir}/man5/machine-id.5*
6e34428f 564%{_mandir}/man5/machine-info.5*
1c239f8b 565%{_mandir}/man5/modules-load.d.5*
566%{_mandir}/man5/os-release.5*
6e34428f 567%{_mandir}/man5/sysctl.d.5*
89d58574 568%{_mandir}/man5/systemd.*.5*
2be4e142 569%{_mandir}/man5/systemd-journald.conf.5*
961baf80
AF
570%{_mandir}/man5/systemd-logind.conf.5*
571%{_mandir}/man5/timezone.5*
23107006 572%{_mandir}/man5/vconsole.conf.5*
1c239f8b 573%{_mandir}/man7/daemon.7*
574%{_mandir}/man7/sd-daemon.7*
c76a8951 575%{_mandir}/man7/sd-login.7*
1c239f8b 576%{_mandir}/man7/sd-readahead.7*
577%{_mandir}/man7/systemd.special.7*
a761f93e
TP
578%attr(640,root,root) %ghost /var/log/btmp
579%attr(664,root,utmp) %ghost /var/log/wtmp
c3037397 580
6c89bbd4 581%if %{with pam}
a86320a6 582%attr(755,root,root) /%{_lib}/security/pam_systemd.so
6c89bbd4
ER
583%{_mandir}/man8/pam_systemd.8*
584%endif
585
c97dacdd 586%files init
5b9bde26 587%defattr(644,root,root,755)
c97dacdd
TP
588%attr(755,root,root) /sbin/halt
589%attr(755,root,root) /sbin/init
590%attr(755,root,root) /sbin/poweroff
591%attr(755,root,root) /sbin/reboot
592%attr(755,root,root) /sbin/runlevel
593%attr(755,root,root) /sbin/shutdown
594%attr(755,root,root) /sbin/telinit
595%{_mandir}/man1/init.1
596%{_mandir}/man8/halt.8*
597%{_mandir}/man8/poweroff.8
598%{_mandir}/man8/reboot.8
599%{_mandir}/man8/runlevel.8*
600%{_mandir}/man8/shutdown.8*
601%{_mandir}/man8/telinit.8*
602
c3037397
ER
603%files units
604%defattr(644,root,root,755)
abd479ee
MB
605%dir %{_sysconfdir}/binfmt.d
606%dir %{_sysconfdir}/modules-load.d
5d32f234 607%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
abd479ee 608%dir %{_sysconfdir}/sysctl.d
c3037397
ER
609%dir %{_sysconfdir}/systemd
610%dir %{_sysconfdir}/systemd/system
611%dir %{_sysconfdir}/tmpfiles.d
7cb5cfc8 612%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
85879912
ER
613%dir %{_libexecdir}/binfmt.d
614%dir %{_libexecdir}/modules-load.d
615%dir %{_libexecdir}/sysctl.d
d374e721 616%{_libexecdir}/sysctl.d/coredump.conf
c3037397
ER
617%attr(755,root,root) /bin/systemctl
618%attr(755,root,root) /bin/systemd-tmpfiles
b77423ae 619%attr(755,root,root) /bin/systemd_booted
c3037397 620%{_mandir}/man1/systemctl.1*
89d58574 621%{_mandir}/man5/tmpfiles.d.5*
c3037397 622%{_mandir}/man8/systemd-tmpfiles.8*
961baf80 623%{_npkgconfigdir}/systemd.pc
c3037397 624
4cc1cb1d
ER
625%{systemdunitdir}/*.automount
626%{systemdunitdir}/*.mount
627%{systemdunitdir}/*.path
628%{systemdunitdir}/*.service
629%{systemdunitdir}/*.socket
630%{systemdunitdir}/*.target
631%{systemdunitdir}/*.timer
e4c66821
JB
632%if %{with plymouth}
633%exclude %{systemdunitdir}/plymouth*.service
634%exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
635%endif
636%dir %{systemdunitdir}/basic.target.wants
637%dir %{systemdunitdir}/dbus.target.wants
638%dir %{systemdunitdir}/final.target.wants
639%dir %{systemdunitdir}/graphical.target.wants
640%dir %{systemdunitdir}/halt.target.wants
641%dir %{systemdunitdir}/kexec.target.wants
642%dir %{systemdunitdir}/local-fs.target.wants
643%dir %{systemdunitdir}/multi-user.target.wants
644%dir %{systemdunitdir}/poweroff.target.wants
645%dir %{systemdunitdir}/reboot.target.wants
646%dir %{systemdunitdir}/runlevel[12345].target.wants
647%dir %{systemdunitdir}/shutdown.target.wants
648%dir %{systemdunitdir}/sockets.target.wants
649%dir %{systemdunitdir}/sysinit.target.wants
650%dir %{systemdunitdir}/syslog.target.wants
651%config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
652%config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
653%config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
654%config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
655%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
656%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
657%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
658%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
659%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
660%config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
661%config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
662%config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
663%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
664%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
665%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
666%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
667%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
668%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
669
670%if %{with plymouth}
671%files plymouth
672%defattr(644,root,root,755)
673%{systemdunitdir}/plymouth-halt.service
674%{systemdunitdir}/plymouth-kexec.service
675%{systemdunitdir}/plymouth-poweroff.service
676%{systemdunitdir}/plymouth-quit-wait.service
677%{systemdunitdir}/plymouth-quit.service
678%{systemdunitdir}/plymouth-read-write.service
679%{systemdunitdir}/plymouth-reboot.service
680%{systemdunitdir}/plymouth-start.service
681%{systemdunitdir}/systemd-ask-password-plymouth.path
682%{systemdunitdir}/systemd-ask-password-plymouth.service
683%config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
684%config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
685%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
686%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
687%config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
688%config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
689%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
690%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
691%endif
10ffdcd2 692
c3037397
ER
693%if %{with gtk}
694%files gtk
695%defattr(644,root,root,755)
696%attr(755,root,root) %{_bindir}/systemadm
697%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
c3037397
ER
698%{_mandir}/man1/systemadm.1*
699%endif
6c89bbd4 700
5b9bde26 701%files libs
6c89bbd4 702%defattr(644,root,root,755)
6ba1f779
MB
703%attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
704%attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
705%attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
706%attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
707%attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
708%attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
709%attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
710%attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
961baf80
AF
711
712%files devel
713%defattr(644,root,root,755)
89d58574 714%attr(755,root,root) %{_libdir}/libsystemd-daemon.so
c76a8951
BZ
715%attr(755,root,root) %{_libdir}/libsystemd-id128.so
716%attr(755,root,root) %{_libdir}/libsystemd-journal.so
89d58574 717%attr(755,root,root) %{_libdir}/libsystemd-login.so
5b9bde26 718%{_includedir}/%{name}
961baf80 719%{_pkgconfigdir}/libsystemd-daemon.pc
c76a8951
BZ
720%{_pkgconfigdir}/libsystemd-id128.pc
721%{_pkgconfigdir}/libsystemd-journal.pc
961baf80 722%{_pkgconfigdir}/libsystemd-login.pc
2be4e142 723%{_mandir}/man3/sd_booted.3*
c76a8951
BZ
724%{_mandir}/man3/sd_get_seats.3*
725%{_mandir}/man3/sd_get_sessions.3*
726%{_mandir}/man3/sd_get_uids.3*
2be4e142 727%{_mandir}/man3/sd_is_fifo.3*
c76a8951 728%{_mandir}/man3/sd_is_mq.3*
2be4e142
JR
729%{_mandir}/man3/sd_is_socket.3
730%{_mandir}/man3/sd_is_socket_inet.3
731%{_mandir}/man3/sd_is_socket_unix.3
732%{_mandir}/man3/sd_listen_fds.3*
c76a8951
BZ
733%{_mandir}/man3/sd_login_monitor_flush.3*
734%{_mandir}/man3/sd_login_monitor_get_fd.3*
735%{_mandir}/man3/sd_login_monitor_new.3*
736%{_mandir}/man3/sd_login_monitor_unref.3*
2be4e142
JR
737%{_mandir}/man3/sd_notify.3*
738%{_mandir}/man3/sd_notifyf.3
c76a8951
BZ
739%{_mandir}/man3/sd_pid_get_owner_uid.3*
740%{_mandir}/man3/sd_pid_get_session.3*
741%{_mandir}/man3/sd_pid_get_unit.3*
2be4e142 742%{_mandir}/man3/sd_readahead.3*
c76a8951
BZ
743%{_mandir}/man3/sd_seat_can_multi_session.3*
744%{_mandir}/man3/sd_seat_get_active.3*
745%{_mandir}/man3/sd_seat_get_sessions.3*
2be4e142
JR
746%{_mandir}/man3/sd_session_get_class.3*
747%{_mandir}/man3/sd_session_get_display.3*
c76a8951 748%{_mandir}/man3/sd_session_get_seat.3*
2be4e142
JR
749%{_mandir}/man3/sd_session_get_service.3*
750%{_mandir}/man3/sd_session_get_type.3*
c76a8951
BZ
751%{_mandir}/man3/sd_session_get_uid.3*
752%{_mandir}/man3/sd_session_is_active.3*
753%{_mandir}/man3/sd_uid_get_seats.3*
754%{_mandir}/man3/sd_uid_get_sessions.3*
755%{_mandir}/man3/sd_uid_get_state.3*
756%{_mandir}/man3/sd_uid_is_on_seat.3*
5b9bde26
JB
757
758%files -n bash-completion-systemd
759%defattr(644,root,root,755)
391eea76 760/etc/bash_completion.d/systemd-bash-completion.sh
ae4d0acb
JR
761
762%files no-compat-tmpfiles
763%defattr(644,root,root,755)
764# empty package
This page took 0.211984 seconds and 4 git commands to generate.