]> git.pld-linux.org Git - packages/systemd.git/blame - systemd.spec
- it seemed like a good idea :(
[packages/systemd.git] / systemd.spec
CommitLineData
5d32f234 1#
d374e721
JR
2# TODO:
3# - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4# after enough packages provide their own tmpfiles.d configs for
5# /var/run directories
6#
c3037397 7# Conditional build:
6c89bbd4
ER
8%bcond_without audit # without audit support
9%bcond_without cryptsetup # without cryptsetup support
23107006
TP
10%bcond_without gtk # build gtk tools
11%bcond_without pam # PAM authentication support
4389e6f9 12%bcond_with plymouth # plymouth support
23107006
TP
13%bcond_without selinux # without SELinux support
14%bcond_without tcpd # libwrap (tcp_wrappers) support
9c0b975d 15
c3037397 16Summary: A System and Service Manager
ede8d3e5 17Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
18Name: systemd
c3d5cf4e 19Version: 43
44410185 20Release: 4
ede8d3e5 21License: GPL v2+
22Group: Base
440d1d13 23Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
c3d5cf4e 24# Source0-md5: 446cc6db7625617af67e2d8e5f503a49
4f25b6ac 25Source1: %{name}-sysv-convert
b0980573 26Source2: %{name}_booted.c
f1586299 27Source5: network.service
5c8fe698
JR
28Source6: compat-pld-media.tmpfiles
29Source7: compat-pld-var-run.tmpfiles
44410185
JR
30Source10: pld-storage-init-late.service
31Source11: pld-storage-init.service
32Source12: pld-wait-storage.service
33Source13: pld-storage-init.sh
7619c097 34Patch0: target-pld.patch
252e1bad 35Patch1: config-pld.patch
8e088cd5 36Patch2: shut-sysv-up.patch
2e1f31c8 37Patch3: pld-sysv-network.patch
d374e721 38Patch4: tmpfiles-not-fatal.patch
ede8d3e5 39URL: http://www.freedesktop.org/wiki/Software/systemd
5b9bde26 40BuildRequires: acl-devel
6c89bbd4 41%{?with_audit:BuildRequires: audit-libs-devel}
6e34428f
MB
42BuildRequires: autoconf >= 2.63
43BuildRequires: automake >= 1:1.11
e4c66821 44BuildRequires: binutils >= 3:2.22.52.0.1-2
6e34428f 45%{?with_cryptsetup:BuildRequires: cryptsetup-luks-devel}
23107006 46BuildRequires: dbus-devel >= 1.3.2
c3037397 47BuildRequires: docbook-style-xsl
3fc7a1cc 48BuildRequires: gperf
5b9bde26 49BuildRequires: intltool >= 0.40.0
4389e6f9 50BuildRequires: kmod-devel >= 5
b82d0bf2 51BuildRequires: libcap-devel
def6d132 52%{?with_selinux:BuildRequires: libselinux-devel >= 2.1.0}
6c89bbd4
ER
53BuildRequires: libtool >= 2:2.2
54%{?with_tcpd:BuildRequires: libwrap-devel}
6e34428f 55BuildRequires: libxslt-progs
961baf80 56BuildRequires: m4
6c89bbd4 57%{?with_pam:BuildRequires: pam-devel}
23107006 58BuildRequires: pkgconfig >= 0.9.0
4cc1cb1d 59BuildRequires: rpmbuild(macros) >= 1.627
58fd72e9 60BuildRequires: udev-devel >= 1:172
5b9bde26
JB
61# not required for building from release (which contains *.c for *.vala)
62#BuildRequires: vala >= 0.10.0
58fd72e9 63BuildRequires: xz-devel
e4c66821
JB
64%if %{with gtk}
65BuildRequires: glib2-devel >= 1:2.26.1
66BuildRequires: gtk+2-devel >= 2:2.24.0
67BuildRequires: libgee-devel
68BuildRequires: libnotify-devel >= 0.7.0
69%endif
011bccb6 70Requires: %{name}-libs = %{version}-%{release}
c3037397 71Requires: %{name}-units = %{version}-%{release}
58d6217a 72Requires: /etc/os-release
2ff27c26 73Requires: SysVinit-tools
37b8df82 74Requires: agetty
b0980573 75Requires: dbus >= 1.4.16-6
7cb5cfc8 76Requires: filesystem >= 4.0-2
851fb4d8 77Requires: rc-scripts >= 0.4.5.1-7
56701781 78Requires: setup >= 2.8.0-2
b0980573 79Requires: udev-core >= 1:175-5
fe6ae5ab 80Requires: udev-libs >= 1:172
e3134fe0 81Requires: virtual(module-tools)
b0980573 82Suggests: ConsoleKit
2a61be78 83Suggests: fsck >= 2.20
e3134fe0 84Suggests: kmod >= 5
4b15486a 85Suggests: nss_myhostname
2a61be78 86# python modules required by systemd-analyze
b0980573 87Suggests: %{name}-no-compat-tmpfiles
2a61be78
TP
88Suggests: python-dbus
89Suggests: python-modules
c35aa49c 90Suggests: service(klogd)
1cdd35cf 91Suggests: service(syslog)
fda563d5 92Provides: udev-acl
3baeefca
PG
93# systemd takes care of that and causes problems
94Conflicts: binfmt-detector
a6203073 95# sytemd wants pam with pam_systemd.so in system-auth...
3b292a99 96Conflicts: pam < 1:1.1.5-5
a6203073
JR
97# ...and sudo hates it
98Conflicts: sudo < 1:1.7.8p2-4
ede8d3e5 99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
85879912
ER
101%define _libexecdir %{_prefix}/lib
102
ede8d3e5 103%description
1c239f8b 104systemd is a system and service manager for Linux, compatible with
ede8d3e5 105SysV and LSB init scripts. systemd provides aggressive parallelization
106capabilities, uses socket and D-Bus activation for starting services,
107offers on-demand starting of daemons, keeps track of processes using
108Linux cgroups, supports snapshotting and restoring of the system
109state, maintains mount and automount points and implements an
110elaborate transactional dependency-based service control logic. It can
1c239f8b 111work as a drop-in replacement for sysvinit.
ede8d3e5 112
113%description -l pl.UTF-8
114systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
115skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
116paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
117oferuje uruchamianie usług na życzenie, monitoruje procesy używając
118linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
119(restore) stanu systemu, zarządza (auto)mount pointami oraz
120implementuje starannie opracowaną transakcjonalną, bazującą na
d45dfc3a 121zależnościach logikę kontroli usług. Może pracować jako zastępca dla
ede8d3e5 122sysvinit.
123
c97dacdd
TP
124%package init
125Summary: systemd /sbin/init and LSB/SysV compatibility symlinks
5b9bde26 126Summary(pl.UTF-8): /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
c97dacdd 127Group: Base
d6829efa 128Requires: systemd
c97dacdd
TP
129Provides: readahead = 1:1.5.7-3
130Provides: virtual(init-daemon)
131Obsoletes: SysVinit
132Obsoletes: readahead < 1:1.5.7-3
133Obsoletes: virtual(init-daemon)
4e1559fc 134Conflicts: upstart
c97dacdd
TP
135
136%description init
137Install this package when you are ready to final switch to systemd.
138
5b9bde26
JB
139%description init -l pl.UTF-8
140Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
141przejścia na systemd.
142
c3037397
ER
143%package units
144Summary: Configuration files, directories and installation tool for systemd
5b9bde26 145Summary(pl.UTF-8): Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
c3037397 146Group: Base
c3037397 147Requires(post): coreutils
a8d86f01 148Requires(post): /bin/awk
c3037397
ER
149
150%description units
151Basic configuration files, directories and installation tool for the
152systemd system and service manager.
153
f341cd9b 154This is common config, use %{_sysconfdir}/systemd/system to override.
10ffdcd2 155
5b9bde26
JB
156%description units -l pl.UTF-8
157Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
158zarządcy systemu i usług systemd.
159
160Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
161poprzez katalog %{_sysconfdir}/systemd/system.
162
e4c66821
JB
163%package plymouth
164Summary: Plymouth support units for systemd
165Summary(pl.UTF-8): Jednostki wspierające Plymouth dla systemd
166Group: Base
167Requires: %{name}-units = %{version}-%{release}
168
169%description plymouth
170Plymouth (graphical boot) support units for systemd.
171
172%description plymouth -l pl.UTF-8
173Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
174
c3037397
ER
175%package gtk
176Summary: Graphical frontend for systemd
5b9bde26 177Summary(pl.UTF-8): Graficzny interfejs do systemd
c3037397
ER
178Group: Base
179Requires: %{name} = %{version}-%{release}
180Requires: polkit
181
182%description gtk
183Graphical front-end for systemd.
184
5b9bde26
JB
185%description gtk -l pl.UTF-8
186Graficzny interfejs do systemd.
6c89bbd4 187
011bccb6 188%package libs
5b9bde26
JB
189Summary: Shared systemd libraries
190Summary(pl.UTF-8): Biblioteki współdzielone systemd
011bccb6
BZ
191Group: Libraries
192
193%description libs
5b9bde26
JB
194Shared systemd libraries.
195
196%description libs -l pl.UTF-8
197Biblioteki współdzielone systemd.
011bccb6 198
961baf80
AF
199%package devel
200Summary: Header files for systemd libraries
201Summary(pl.UTF-8): Pliki nagłówkowe bibliotek systemd
202Group: Development/Libraries
011bccb6 203Requires: %{name}-libs = %{version}-%{release}
961baf80
AF
204
205%description devel
206Header files for systemd libraries.
207
208%description devel -l pl.UTF-8
209Pliki nagłówkowe bibliotek systemd.
210
5b9bde26
JB
211%package -n bash-completion-systemd
212Summary: bash-completion for systemd
213Summary(pl.UTF-8): Bashowe dopełnianie składni dla systemd
214Group: Applications/Shells
215Requires: %{name}
216Requires: bash-completion
217
218%description -n bash-completion-systemd
219bash-completion for systemd.
220
221%description -n bash-completion-systemd -l pl.UTF-8
222Bashowe dopełnianie składni dla systemd
223
ae4d0acb
JR
224%package no-compat-tmpfiles
225Summary: Force update of packages that provide tmpfiles.d configuration
226Group: Base
227Requires(post): sed > 4.0
228Conflicts: ConsoleKit-dirs < 0.4.5-7
229Conflicts: NetworkManager < 2:0.9.2.0-3
230Conflicts: Zope < 2.11.8-2
231Conflicts: amavisd-new < 1:2.7.0-1
ae4d0acb
JR
232Conflicts: apache-base < 2.2.21-4
233Conflicts: apache-mod_bw < 0.92-3
234Conflicts: apache-mod_fastcgi < 2.4.6-6
b0980573
ŁK
235Conflicts: apache1-base < 1.3.42-5
236Conflicts: apache1-mod_fastcgi < 2.4.6-2
ae4d0acb
JR
237Conflicts: asterisk < 10.0.1-2
238Conflicts: autossh-init < 1.4b-3
239Conflicts: balance < 3.54-2
240Conflicts: bind < 7:9.8.1.P1-4
241Conflicts: bopm < 3.1.3-4
242Conflicts: callweaver < 1.2.1-9
243Conflicts: cassandra-bin < 0.8.9-2
244Conflicts: clamav < 0.97.3-3
245Conflicts: cups < 1:1.5.0-10
246Conflicts: dbus < 1.4.16-4
247Conflicts: dovecot < 1:2.0.16-3
248Conflicts: dspam < 3.9.0-6
249Conflicts: fail2ban < 0.8.4-4
250Conflicts: filesystem < 4.0-3
251Conflicts: gammu-smsd < 1:1.31.0-3
a6203073
JR
252# Break gdm2.20 installs
253#Conflicts: gdm < 2:3.2.1.1-9
ae4d0acb
JR
254Conflicts: greylistd < 0.8.8-2
255Conflicts: inn < 2.4.6-7
256Conflicts: ipsec-tools < 0.8.0-3
257Conflicts: jabber-common < 0-9
258Conflicts: laptop-mode-tools < 1.58-2
259Conflicts: libgpod < 0.8.0-6
260Conflicts: libvirt-utils < 0.9.9-4
261Conflicts: lighttpd < 1.4.30-5
262Conflicts: lirc < 0.9.0-20
263Conflicts: mailman < 5:2.1.14-4
264Conflicts: memcached < 1.4.11-2
265Conflicts: mpd < 0.16.5-4
266Conflicts: mrtg < 2.17.0-3
267Conflicts: munin-common < 1.4.5-5
268Conflicts: nagios-nrpe < 2.13-2
269Conflicts: ndisc6-rdnssd < 1.0.1-3
270Conflicts: nscd < 6:2.14.1-5
271Conflicts: nss_ldapd-nslcd < 0.8.4-2
272Conflicts: openct < 0.6.20-3
273Conflicts: openl2tp < 1.8-3
274Conflicts: openldap-overlay-nssov < 2.4.28-4
275Conflicts: openldap-servers < 2.4.28-4
276Conflicts: openvpn < 2.2.2-2
ae4d0acb
JR
277Conflicts: pam-pam_mount < 2.12-3
278Conflicts: pam-pam_ssh < 1.97-2
279Conflicts: pcsc-lite < 1.8.1-2
280Conflicts: php-dirs < 1.2-3
281Conflicts: policyd < 2.0.10-3
282Conflicts: pound < 2.6-2
283Conflicts: pptp < 1.7.2-3
284Conflicts: proftpd-common < 2:1.3.4a-2
285Conflicts: pulseaudio-server < 1.1-2
286Conflicts: quagga < 0.99.20-3
287Conflicts: radvd < 1.8.5-2
288Conflicts: rc-scripts < 0.4.5.2-3
289Conflicts: red5 < 0.9.0-2
290Conflicts: redis-server < 2.4.2-4
291Conflicts: smokeping < 2.4.2-10
292Conflicts: smtp-gated < 1.4.17-2
293Conflicts: socat < 1.7.2.0-2
294Conflicts: speech-dispatcher < 0.7.1-2
295Conflicts: sphinx < 2.0.3-4
296Conflicts: splashutils < 1.5.4.3-3
297Conflicts: stunnel < 4.50-2
ae4d0acb
JR
298Conflicts: tenshi < 0.12-2
299Conflicts: tor < 0.2.2.35-2
300Conflicts: ucarp < 1.5.2-3
301Conflicts: udisks < 1.0.4-3
302Conflicts: util-vserver < 0.30.216-1.pre3002.3
303Conflicts: vpnc < 0.5.3-2
304Conflicts: web2ldap < 1.1.0rc1-2
305Conflicts: wesnoth-server < 1:1.10-2
306Conflicts: wpa_supplicant < 0.7.3-10
307Conflicts: xl2tpd < 1.3.0-2
308
309%description no-compat-tmpfiles
310Force update of packages that provide tmpfiles.d configuration
311
ede8d3e5 312%prep
313%setup -q
4c5b5ab6 314%patch0 -p1
252e1bad 315%patch1 -p1
a6203073 316%patch2 -p1
942c9075 317%patch3 -p1
d374e721 318%patch4 -p1
b77423ae 319cp -p %{SOURCE2} src/systemd_booted.c
ede8d3e5 320
321%build
4c5b5ab6 322%{__aclocal} -I m4
ede8d3e5 323%{__autoconf}
6e34428f 324%{__autoheader}
ede8d3e5 325%{__automake}
9c0b975d 326%configure \
6c89bbd4
ER
327 %{__enable_disable audit} \
328 %{__enable_disable cryptsetup libcryptsetup} \
329 %{__enable_disable gtk} \
330 %{__enable_disable pam} \
4389e6f9 331 %{__enable_disable plymouth} \
6c89bbd4
ER
332 %{__enable_disable selinux} \
333 %{__enable_disable tcpd tcpwrap} \
334 --disable-silent-rules \
961baf80 335 --disable-static \
5b9bde26 336 --with-distro=pld \
391eea76 337 --with-rootprefix= \
4389e6f9
JR
338 --with-rootlibdir=/%{_lib} \
339 --enable-split-usr
e1d9cc15 340
ede8d3e5 341%{__make}
b77423ae 342./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
ede8d3e5 343
344%install
345rm -rf $RPM_BUILD_ROOT
23107006 346
ede8d3e5 347%{__make} install \
348 DESTDIR=$RPM_BUILD_ROOT
349
b77423ae
AF
350./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
351
4389e6f9
JR
352# Main binary has been moved, but we don't want to break existing installs
353ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
354
1dcb74bb 355# Create SysV compatibility symlinks. systemctl/systemd are smart
2a61be78 356# enough to detect the way they were called
c28b0c1c 357install -d $RPM_BUILD_ROOT/sbin
4389e6f9 358ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
1dcb74bb 359ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
360ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
23107006
TP
361ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
362ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
1dcb74bb 363ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
364ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
1dcb74bb 365
5d32f234 366ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
44410185
JR
367
368# disable redundant SYSV services
369ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
4cc1cb1d 370ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
44410185
JR
371ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
372ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
373ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
374ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
5d32f234 375
f1586299 376# add static (non-NetworkManager) networking
4cc1cb1d 377install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
f1586299 378
5c8fe698
JR
379# install compatibility tmpfiles configs
380install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
d374e721 381install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
5c8fe698 382
44410185
JR
383# Install and enable storage subsystems support services (RAID, LVM, etc.)
384install %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
385install %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
386install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
387install %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
388
389ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
390ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
c3037397 391
e64703a8 392# it is in rc-scripts pkg
4cc1cb1d 393%{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
e64703a8 394
2a61be78
TP
395# Make sure these directories are properly owned:
396# - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
397# - syslog _might_ be used by some syslog implementation (none for now),
398# - isn't dbus populated by dbus-systemd only (so to be moved there)?
4cc1cb1d 399install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
961baf80
AF
400
401# Create new-style configuration files so that we can ghost-own them
70047b34 402touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
4bbef33c 403
9d8b5dfe 404# Install SysV conversion tool for systemd
4f25b6ac 405install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
9d8b5dfe
BZ
406
407install -d $RPM_BUILD_ROOT/var/log
5a65c84e
TP
408:> $RPM_BUILD_ROOT/var/log/btmp
409:> $RPM_BUILD_ROOT/var/log/wtmp
a761f93e 410
5d32f234 411%if %{without gtk}
5d32f234
TP
412%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
413%endif
414
415%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
a86320a6 416%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
5d32f234
TP
417%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
418
ede8d3e5 419%clean
420rm -rf $RPM_BUILD_ROOT
421
9638c72f 422%post
4bbef33c 423/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
9638c72f 424/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
c3037397 425
961baf80 426%postun
85879912 427if [ $1 -ge 1 ]; then
961baf80 428 /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
9638c72f 429fi
430
3edd52a6
TP
431%post libs -p /sbin/ldconfig
432%postun libs -p /sbin/ldconfig
011bccb6 433
961baf80 434%post units
85879912 435if [ $1 -eq 1 ]; then
961baf80
AF
436 # Try to read default runlevel from the old inittab if it exists
437 runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
438 if [ -z "$runlevel" ] ; then
4cc1cb1d 439 target="%{systemdunitdir}/graphical.target"
961baf80 440 else
4cc1cb1d 441 target="%{systemdunitdir}/runlevel$runlevel.target"
961baf80
AF
442 fi
443
444 # And symlink what we found to the new-style default.target
f341cd9b 445 ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
cf819365
JR
446
447 # Setup hostname
448 [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
449 if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
450 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
451 echo $HOSTNAME > /etc/hostname
452 chmod 644 /etc/hostname
453 fi
44410185
JR
454
455 # Enable the services we install by default.
456 /bin/systemctl enable \
457 getty@.service \
458 network.service \
459 remote-fs.target \
460 systemd-readahead-replay.service \
461 systemd-readahead-collect.service >/dev/null 2>&1 || :
9638c72f 462fi
c3037397
ER
463
464%preun units
961baf80
AF
465if [ $1 -eq 0 ] ; then
466 /bin/systemctl disable \
467 getty@.service \
f1586299 468 network.service \
961baf80
AF
469 remote-fs.target \
470 systemd-readahead-replay.service \
471 systemd-readahead-collect.service >/dev/null 2>&1 || :
472
f341cd9b 473 %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
c3037397 474fi
9638c72f 475
961baf80 476%postun units
85879912 477if [ $1 -ge 1 ]; then
9638c72f 478 /bin/systemctl daemon-reload > /dev/null 2>&1 || :
479fi
480
44410185
JR
481%triggerpostun units -- %{name}-units < 43-4
482# Remove design fialures
483/bin/systemctl disable network-post.service >/dev/null 2>&1 || :
484rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
485rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
486
ae4d0acb 487%post no-compat-tmpfiles
a6203073 488%{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
ae4d0acb 489
ede8d3e5 490%files
491%defattr(644,root,root,755)
1c239f8b 492%doc DISTRO_PORTING README TODO
6e34428f 493/etc/dbus-1/system.d/org.freedesktop.hostname1.conf
961baf80
AF
494/etc/dbus-1/system.d/org.freedesktop.locale1.conf
495/etc/dbus-1/system.d/org.freedesktop.login1.conf
c3037397 496/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
961baf80 497/etc/dbus-1/system.d/org.freedesktop.timedate1.conf
3edd52a6 498%ghost %config(noreplace) %{_sysconfdir}/machine-id
b77423ae
AF
499%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
500%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
501%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
b77423ae
AF
502%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
503%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
5d32f234 504%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
2a61be78 505%dir %{_sysconfdir}/systemd/user
44410185
JR
506%dir %{_sysconfdir}/systemd/system/*.target.wants
507%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
508%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
abd479ee 509/etc/xdg/systemd
1dcb74bb 510%attr(755,root,root) /bin/systemd
511%attr(755,root,root) /bin/systemd-ask-password
c76a8951 512%attr(755,root,root) /bin/systemd-journalctl
961baf80 513%attr(755,root,root) /bin/systemd-loginctl
7a76bc86 514%attr(755,root,root) /bin/systemd-machine-id-setup
1dcb74bb 515%attr(755,root,root) /bin/systemd-notify
516%attr(755,root,root) /bin/systemd-tty-ask-password-agent
57cd0d13 517%attr(755,root,root) %{_bindir}/systemd-analyze
d374e721
JR
518%attr(755,root,root) %{_bindir}/systemd-cat
519%attr(755,root,root) %{_bindir}/systemd-cgtop
23107006 520%attr(755,root,root) %{_bindir}/systemd-cgls
57cd0d13
ZU
521%attr(755,root,root) %{_bindir}/systemd-nspawn
522%attr(755,root,root) %{_bindir}/systemd-stdio-bridge
2a61be78 523%attr(755,root,root) %{_bindir}/systemd-sysv-convert
44410185 524%attr(755,root,root) /lib/systemd/pld-storage-init
abd479ee 525%attr(755,root,root) /lib/systemd/systemd-*
c3037397 526%dir /lib/systemd/system-generators
4389e6f9 527%attr(755,root,root) /lib/systemd/systemd
5d32f234 528%attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
abd479ee 529%dir /lib/systemd/system-shutdown
1c239f8b 530/lib/udev/rules.d/99-systemd.rules
961baf80
AF
531/lib/udev/rules.d/70-uaccess.rules
532/lib/udev/rules.d/71-seat.rules
533/lib/udev/rules.d/73-seat-late.rules
3edd52a6
TP
534%dir %{_libexecdir}/systemd
535%{_libexecdir}/systemd/user
2a61be78 536%dir %{_libexecdir}/systemd/user-generators
89d58574 537%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
961baf80
AF
538%{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
539%{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
c3037397 540%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
961baf80 541%{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
1c239f8b 542%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
6e34428f 543%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
961baf80
AF
544%{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
545%{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
1c239f8b 546%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
961baf80 547%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
6e34428f 548%{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
961baf80
AF
549%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
550%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
551%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
552%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
553%dir %{_datadir}/systemd
554%{_datadir}/systemd/kbd-model-map
7a76bc86 555%{_mandir}/man1/systemd.1*
2a61be78 556%{_mandir}/man1/systemd-*.1*
1c239f8b 557%{_mandir}/man3/sd_booted.3*
558%{_mandir}/man3/sd_is_fifo.3*
559%{_mandir}/man3/sd_is_socket.3
560%{_mandir}/man3/sd_is_socket_inet.3
561%{_mandir}/man3/sd_is_socket_unix.3
562%{_mandir}/man3/sd_listen_fds.3*
563%{_mandir}/man3/sd_notify.3*
564%{_mandir}/man3/sd_notifyf.3
565%{_mandir}/man3/sd_readahead.3*
6e34428f 566%{_mandir}/man5/binfmt.d.5*
1c239f8b 567%{_mandir}/man5/hostname.5*
568%{_mandir}/man5/locale.conf.5*
7a76bc86 569%{_mandir}/man5/machine-id.5*
6e34428f 570%{_mandir}/man5/machine-info.5*
1c239f8b 571%{_mandir}/man5/modules-load.d.5*
572%{_mandir}/man5/os-release.5*
6e34428f 573%{_mandir}/man5/sysctl.d.5*
89d58574 574%{_mandir}/man5/systemd.*.5*
961baf80
AF
575%{_mandir}/man5/systemd-logind.conf.5*
576%{_mandir}/man5/timezone.5*
23107006 577%{_mandir}/man5/vconsole.conf.5*
1c239f8b 578%{_mandir}/man7/daemon.7*
579%{_mandir}/man7/sd-daemon.7*
c76a8951 580%{_mandir}/man7/sd-login.7*
1c239f8b 581%{_mandir}/man7/sd-readahead.7*
582%{_mandir}/man7/systemd.special.7*
a761f93e
TP
583%attr(640,root,root) %ghost /var/log/btmp
584%attr(664,root,utmp) %ghost /var/log/wtmp
c3037397 585
6c89bbd4 586%if %{with pam}
a86320a6 587%attr(755,root,root) /%{_lib}/security/pam_systemd.so
6c89bbd4
ER
588%{_mandir}/man8/pam_systemd.8*
589%endif
590
c97dacdd 591%files init
5b9bde26 592%defattr(644,root,root,755)
c97dacdd
TP
593%attr(755,root,root) /sbin/halt
594%attr(755,root,root) /sbin/init
595%attr(755,root,root) /sbin/poweroff
596%attr(755,root,root) /sbin/reboot
597%attr(755,root,root) /sbin/runlevel
598%attr(755,root,root) /sbin/shutdown
599%attr(755,root,root) /sbin/telinit
600%{_mandir}/man1/init.1
601%{_mandir}/man8/halt.8*
602%{_mandir}/man8/poweroff.8
603%{_mandir}/man8/reboot.8
604%{_mandir}/man8/runlevel.8*
605%{_mandir}/man8/shutdown.8*
606%{_mandir}/man8/telinit.8*
607
c3037397
ER
608%files units
609%defattr(644,root,root,755)
abd479ee
MB
610%dir %{_sysconfdir}/binfmt.d
611%dir %{_sysconfdir}/modules-load.d
5d32f234 612%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
abd479ee 613%dir %{_sysconfdir}/sysctl.d
c3037397
ER
614%dir %{_sysconfdir}/systemd
615%dir %{_sysconfdir}/systemd/system
616%dir %{_sysconfdir}/tmpfiles.d
7cb5cfc8 617%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
85879912
ER
618%dir %{_libexecdir}/binfmt.d
619%dir %{_libexecdir}/modules-load.d
620%dir %{_libexecdir}/sysctl.d
d374e721 621%{_libexecdir}/sysctl.d/coredump.conf
c3037397
ER
622%attr(755,root,root) /bin/systemctl
623%attr(755,root,root) /bin/systemd-tmpfiles
b77423ae 624%attr(755,root,root) /bin/systemd_booted
c3037397 625%{_mandir}/man1/systemctl.1*
89d58574 626%{_mandir}/man5/tmpfiles.d.5*
c3037397 627%{_mandir}/man8/systemd-tmpfiles.8*
961baf80 628%{_npkgconfigdir}/systemd.pc
c3037397 629
4cc1cb1d
ER
630%{systemdunitdir}/*.automount
631%{systemdunitdir}/*.mount
632%{systemdunitdir}/*.path
633%{systemdunitdir}/*.service
634%{systemdunitdir}/*.socket
635%{systemdunitdir}/*.target
636%{systemdunitdir}/*.timer
e4c66821
JB
637%if %{with plymouth}
638%exclude %{systemdunitdir}/plymouth*.service
639%exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
640%endif
641%dir %{systemdunitdir}/basic.target.wants
642%dir %{systemdunitdir}/dbus.target.wants
643%dir %{systemdunitdir}/final.target.wants
644%dir %{systemdunitdir}/graphical.target.wants
645%dir %{systemdunitdir}/halt.target.wants
646%dir %{systemdunitdir}/kexec.target.wants
647%dir %{systemdunitdir}/local-fs.target.wants
648%dir %{systemdunitdir}/multi-user.target.wants
649%dir %{systemdunitdir}/poweroff.target.wants
650%dir %{systemdunitdir}/reboot.target.wants
651%dir %{systemdunitdir}/runlevel[12345].target.wants
652%dir %{systemdunitdir}/shutdown.target.wants
653%dir %{systemdunitdir}/sockets.target.wants
654%dir %{systemdunitdir}/sysinit.target.wants
655%dir %{systemdunitdir}/syslog.target.wants
656%config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
657%config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
658%config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
659%config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
660%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
661%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
662%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
663%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
664%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
665%config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
666%config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
667%config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
668%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
669%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
670%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
671%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
672%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
673%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
674
675%if %{with plymouth}
676%files plymouth
677%defattr(644,root,root,755)
678%{systemdunitdir}/plymouth-halt.service
679%{systemdunitdir}/plymouth-kexec.service
680%{systemdunitdir}/plymouth-poweroff.service
681%{systemdunitdir}/plymouth-quit-wait.service
682%{systemdunitdir}/plymouth-quit.service
683%{systemdunitdir}/plymouth-read-write.service
684%{systemdunitdir}/plymouth-reboot.service
685%{systemdunitdir}/plymouth-start.service
686%{systemdunitdir}/systemd-ask-password-plymouth.path
687%{systemdunitdir}/systemd-ask-password-plymouth.service
688%config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
689%config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
690%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
691%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
692%config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
693%config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
694%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
695%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
696%endif
10ffdcd2 697
c3037397
ER
698%if %{with gtk}
699%files gtk
700%defattr(644,root,root,755)
701%attr(755,root,root) %{_bindir}/systemadm
702%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
c3037397
ER
703%{_mandir}/man1/systemadm.1*
704%endif
6c89bbd4 705
5b9bde26 706%files libs
6c89bbd4 707%defattr(644,root,root,755)
6ba1f779
MB
708%attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
709%attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
710%attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
711%attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
712%attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
713%attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
714%attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
715%attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
961baf80
AF
716
717%files devel
718%defattr(644,root,root,755)
89d58574 719%attr(755,root,root) %{_libdir}/libsystemd-daemon.so
c76a8951
BZ
720%attr(755,root,root) %{_libdir}/libsystemd-id128.so
721%attr(755,root,root) %{_libdir}/libsystemd-journal.so
89d58574 722%attr(755,root,root) %{_libdir}/libsystemd-login.so
5b9bde26 723%{_includedir}/%{name}
961baf80 724%{_pkgconfigdir}/libsystemd-daemon.pc
c76a8951
BZ
725%{_pkgconfigdir}/libsystemd-id128.pc
726%{_pkgconfigdir}/libsystemd-journal.pc
961baf80 727%{_pkgconfigdir}/libsystemd-login.pc
c76a8951
BZ
728%{_mandir}/man3/sd_get_seats.3*
729%{_mandir}/man3/sd_get_sessions.3*
730%{_mandir}/man3/sd_get_uids.3*
731%{_mandir}/man3/sd_is_mq.3*
732%{_mandir}/man3/sd_login_monitor_flush.3*
733%{_mandir}/man3/sd_login_monitor_get_fd.3*
734%{_mandir}/man3/sd_login_monitor_new.3*
735%{_mandir}/man3/sd_login_monitor_unref.3*
736%{_mandir}/man3/sd_pid_get_owner_uid.3*
737%{_mandir}/man3/sd_pid_get_session.3*
738%{_mandir}/man3/sd_pid_get_unit.3*
739%{_mandir}/man3/sd_seat_can_multi_session.3*
740%{_mandir}/man3/sd_seat_get_active.3*
741%{_mandir}/man3/sd_seat_get_sessions.3*
742%{_mandir}/man3/sd_session_get_seat.3*
743%{_mandir}/man3/sd_session_get_uid.3*
744%{_mandir}/man3/sd_session_is_active.3*
745%{_mandir}/man3/sd_uid_get_seats.3*
746%{_mandir}/man3/sd_uid_get_sessions.3*
747%{_mandir}/man3/sd_uid_get_state.3*
748%{_mandir}/man3/sd_uid_is_on_seat.3*
5b9bde26
JB
749
750%files -n bash-completion-systemd
751%defattr(644,root,root,755)
391eea76 752/etc/bash_completion.d/systemd-bash-completion.sh
ae4d0acb
JR
753
754%files no-compat-tmpfiles
755%defattr(644,root,root,755)
756# empty package
This page took 0.235148 seconds and 4 git commands to generate.