]> git.pld-linux.org Git - packages/systemd.git/blame - systemd.spec
- S: fsck >= 2.20 (2.18 doesn't work for sure), s/R/S python modules for
[packages/systemd.git] / systemd.spec
CommitLineData
5d32f234 1# TODO: - move %_libexecdir/tmpfiles.d/* to /etc/tmpfiles.d?
c28b0c1c 2# - shouldn't ../bin/systemctl symlinks be absolute? -no they shouldn't (think browsing mounted as chroot and seeing all blink due invalid link targets when doing ls)
0669f0db
TP
3# - separate init subpackage (with symlink), one can switch to
4# systemd using init=/bin/systemd with other one installed
5d32f234 5# - verify %_sysconfdir usage vs literal '/etc'
2a61be78 6# - %post systemd-sysv-convert
5d32f234 7#
c3037397 8# Conditional build:
6c89bbd4
ER
9%bcond_without audit # without audit support
10%bcond_without cryptsetup # without cryptsetup support
23107006
TP
11%bcond_without gtk # build gtk tools
12%bcond_without pam # PAM authentication support
13%bcond_without selinux # without SELinux support
14%bcond_without tcpd # libwrap (tcp_wrappers) support
9c0b975d 15
c3037397 16Summary: A System and Service Manager
ede8d3e5 17Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
18Name: systemd
961baf80 19Version: 37
da83fdda 20Release: 2
ede8d3e5 21License: GPL v2+
22Group: Base
23Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
961baf80 24# Source0-md5: 1435f23be79c8c38d1121c6b150510f3
4f25b6ac 25Source1: %{name}-sysv-convert
b77423ae 26Source2: systemd_booted.c
7619c097 27Patch0: target-pld.patch
252e1bad 28Patch1: config-pld.patch
ede8d3e5 29URL: http://www.freedesktop.org/wiki/Software/systemd
6c89bbd4 30%{?with_audit:BuildRequires: audit-libs-devel}
6e34428f
MB
31BuildRequires: autoconf >= 2.63
32BuildRequires: automake >= 1:1.11
33%{?with_cryptsetup:BuildRequires: cryptsetup-luks-devel}
23107006 34BuildRequires: dbus-devel >= 1.3.2
c3037397 35BuildRequires: docbook-style-xsl
23107006
TP
36%if %{with gtk}
37BuildRequires: glib2-devel >= 1:2.26.1
38BuildRequires: gtk+2-devel >= 2:2.24.0
39BuildRequires: libnotify-devel >= 0.7.0
40%endif
3fc7a1cc 41BuildRequires: gperf
b82d0bf2 42BuildRequires: libcap-devel
6c89bbd4
ER
43%{?with_selinux:BuildRequires: libselinux-devel}
44BuildRequires: libtool >= 2:2.2
45%{?with_tcpd:BuildRequires: libwrap-devel}
6e34428f 46BuildRequires: libxslt-progs
961baf80 47BuildRequires: m4
6c89bbd4 48%{?with_pam:BuildRequires: pam-devel}
23107006 49BuildRequires: pkgconfig >= 0.9.0
6c89bbd4 50BuildRequires: rpmbuild(macros) >= 1.527
de86bd7f 51BuildRequires: udev-devel >= 172
6e34428f 52BuildRequires: vala >= 0.10.0
011bccb6 53Requires: %{name}-libs = %{version}-%{release}
c3037397 54Requires: %{name}-units = %{version}-%{release}
2ff27c26 55Requires: SysVinit-tools
37b8df82 56Requires: agetty
c3037397 57Requires: dbus >= 1.3.2
2ff27c26 58Requires: dbus-systemd
ea96631d 59Requires: filesystem >= 4.0
c3037397 60Requires: rc-scripts
56701781 61Requires: setup >= 2.8.0-2
fe6ae5ab
AF
62Requires: udev-core >= 1:172
63Requires: udev-systemd >= 1:172
64Requires: udev-libs >= 1:172
c28b0c1c 65Suggests: ConsoleKit-systemd
2a61be78
TP
66Suggests: fsck >= 2.20
67# python modules required by systemd-analyze
68Suggests: python-dbus
69Suggests: python-modules
c28b0c1c 70Suggests: rsyslog-systemd
c3037397 71Provides: readahead = 1:1.5.7-3
fda563d5 72Provides: udev-acl
2a61be78 73Provides: virtual(init-daemon)
da83fdda 74Obsoletes: SysVinit
c3037397 75Obsoletes: readahead < 1:1.5.7-3
1dcb74bb 76Obsoletes: virtual(init-daemon)
ede8d3e5 77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
85879912
ER
79%define _libexecdir %{_prefix}/lib
80
ede8d3e5 81%description
1c239f8b 82systemd is a system and service manager for Linux, compatible with
ede8d3e5 83SysV and LSB init scripts. systemd provides aggressive parallelization
84capabilities, uses socket and D-Bus activation for starting services,
85offers on-demand starting of daemons, keeps track of processes using
86Linux cgroups, supports snapshotting and restoring of the system
87state, maintains mount and automount points and implements an
88elaborate transactional dependency-based service control logic. It can
1c239f8b 89work as a drop-in replacement for sysvinit.
ede8d3e5 90
91%description -l pl.UTF-8
92systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
93skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
94paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
95oferuje uruchamianie usług na życzenie, monitoruje procesy używając
96linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
97(restore) stanu systemu, zarządza (auto)mount pointami oraz
98implementuje starannie opracowaną transakcjonalną, bazującą na
d45dfc3a 99zależnościach logikę kontroli usług. Może pracować jako zastępca dla
ede8d3e5 100sysvinit.
101
c3037397
ER
102%package units
103Summary: Configuration files, directories and installation tool for systemd
104Group: Base
c3037397
ER
105Requires(post): coreutils
106Requires(post): gawk
961baf80 107Requires: pkgconfig
c3037397
ER
108
109%description units
110Basic configuration files, directories and installation tool for the
111systemd system and service manager.
112
2a61be78 113This is common config, use /etc/systemd/system to override.
10ffdcd2 114
c3037397
ER
115%package gtk
116Summary: Graphical frontend for systemd
117Group: Base
118Requires: %{name} = %{version}-%{release}
119Requires: polkit
120
121%description gtk
122Graphical front-end for systemd.
123
6c89bbd4
ER
124%package -n bash-completion-systemd
125Summary: bash-completion for systemd
126Group: Applications/Shells
127Requires: %{name}
128Requires: bash-completion
129
130%description -n bash-completion-systemd
131bash-completion for systemd.
132
011bccb6
BZ
133%package libs
134Summary: Shared systemd library
135Group: Libraries
136
137%description libs
138Shared systemd library.
139
961baf80
AF
140%package devel
141Summary: Header files for systemd libraries
142Summary(pl.UTF-8): Pliki nagłówkowe bibliotek systemd
143Group: Development/Libraries
011bccb6 144Requires: %{name}-libs = %{version}-%{release}
961baf80
AF
145
146%description devel
147Header files for systemd libraries.
148
149%description devel -l pl.UTF-8
150Pliki nagłówkowe bibliotek systemd.
151
ede8d3e5 152%prep
153%setup -q
4c5b5ab6 154%patch0 -p1
252e1bad 155%patch1 -p1
b77423ae 156cp -p %{SOURCE2} src/systemd_booted.c
ede8d3e5 157
158%build
4c5b5ab6 159%{__aclocal} -I m4
ede8d3e5 160%{__autoconf}
6e34428f 161%{__autoheader}
ede8d3e5 162%{__automake}
9c0b975d 163%configure \
6c89bbd4
ER
164 %{__enable_disable audit} \
165 %{__enable_disable cryptsetup libcryptsetup} \
166 %{__enable_disable gtk} \
167 %{__enable_disable pam} \
168 %{__enable_disable selinux} \
169 %{__enable_disable tcpd tcpwrap} \
170 --disable-silent-rules \
961baf80 171 --disable-static \
1dcb74bb 172 --with-rootdir=
e1d9cc15 173
ede8d3e5 174%{__make}
b77423ae 175./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
ede8d3e5 176
177%install
178rm -rf $RPM_BUILD_ROOT
23107006 179
ede8d3e5 180%{__make} install \
181 DESTDIR=$RPM_BUILD_ROOT
182
b77423ae
AF
183./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
184
8a981770
ER
185for lib in libsystemd-daemon libsystemd-login; do
186 %{__mv} $RPM_BUILD_ROOT{%{_libdir}/$lib.so.*,/%{_lib}}
89d58574 187 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/$lib.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/$lib.so
8a981770 188done
23107006 189
1dcb74bb 190# Create SysV compatibility symlinks. systemctl/systemd are smart
2a61be78 191# enough to detect the way they were called
c28b0c1c 192install -d $RPM_BUILD_ROOT/sbin
1dcb74bb 193ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
1dcb74bb 194ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
195ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
23107006
TP
196ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
197ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
1dcb74bb 198ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
199ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
1dcb74bb 200
5d32f234
TP
201ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
202
2a61be78
TP
203# All wants links are created at %post to make sure they are not owned
204# and hence overriden by rpm if the user deletes them (missingok?)
23107006 205%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
c3037397 206
89d58574
TP
207# do not cover /media (system-specific removable mountpoints) for now
208# needs %post code to convert existing /media structure to tmpfiles
78af65f9 209%{__rm} -f $RPM_BUILD_ROOT/lib/systemd/local-fs.target.wants/media.mount
89d58574 210# do not cover /var/run until packages need rpm-provided-only subdirectories
78af65f9 211%{__rm} -f $RPM_BUILD_ROOT/lib/systemd/local-fs.target.wants/var-run.mount
3edd52a6 212
2a61be78
TP
213# Make sure these directories are properly owned:
214# - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
215# - syslog _might_ be used by some syslog implementation (none for now),
216# - isn't dbus populated by dbus-systemd only (so to be moved there)?
217# - default should be left intact by distro packages, shouldn't it?
218install -d $RPM_BUILD_ROOT/lib/systemd/system/{dbus,default,halt,kexec,poweroff,reboot,syslog}.target.wants
961baf80
AF
219
220# Create new-style configuration files so that we can ghost-own them
23107006 221touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
4bbef33c 222
9d8b5dfe 223# Install SysV conversion tool for systemd
4f25b6ac 224install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
9d8b5dfe
BZ
225
226install -d $RPM_BUILD_ROOT/var/log
a761f93e
TP
227> $RPM_BUILD_ROOT/var/log/btmp
228> $RPM_BUILD_ROOT/var/log/wtmp
229
5d32f234
TP
230%if %{without gtk}
231# to shut up check-files
2a61be78
TP
232rm -f $RPM_BUILD_ROOT%{_bindir}/systemadm
233rm -f $RPM_BUILD_ROOT%{_bindir}/systemd-gnome-ask-password-agent
5d32f234
TP
234%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
235%endif
236
237%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
238%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
239%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
240
ede8d3e5 241%clean
242rm -rf $RPM_BUILD_ROOT
243
9638c72f 244%post
4bbef33c 245/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
9638c72f 246/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
c3037397 247
961baf80 248%postun
85879912 249if [ $1 -ge 1 ]; then
961baf80 250 /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
9638c72f 251fi
252
3edd52a6
TP
253%post libs -p /sbin/ldconfig
254%postun libs -p /sbin/ldconfig
011bccb6 255
961baf80 256%post units
85879912 257if [ $1 -eq 1 ]; then
961baf80
AF
258 # Try to read default runlevel from the old inittab if it exists
259 runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
260 if [ -z "$runlevel" ] ; then
261 target="/lib/systemd/system/graphical.target"
262 else
263 target="/lib/systemd/system/runlevel$runlevel.target"
264 fi
265
266 # And symlink what we found to the new-style default.target
85879912
ER
267 ln -sf "$target" /etc/systemd/system/default.target >/dev/null 2>&1 || :
268
961baf80
AF
269 # Enable the services we install by default.
270 /bin/systemctl enable \
271 getty@.service \
272 remote-fs.target \
273 systemd-readahead-replay.service \
274 systemd-readahead-collect.service >/dev/null 2>&1 || :
9638c72f 275fi
c3037397
ER
276
277%preun units
961baf80
AF
278if [ $1 -eq 0 ] ; then
279 /bin/systemctl disable \
280 getty@.service \
281 remote-fs.target \
282 systemd-readahead-replay.service \
283 systemd-readahead-collect.service >/dev/null 2>&1 || :
284
85879912 285 %{__rm} -f /etc/systemd/system/default.target >/dev/null 2>&1 || :
c3037397 286fi
9638c72f 287
961baf80 288%postun units
85879912 289if [ $1 -ge 1 ]; then
9638c72f 290 /bin/systemctl daemon-reload > /dev/null 2>&1 || :
291fi
292
ede8d3e5 293%files
294%defattr(644,root,root,755)
1c239f8b 295%doc DISTRO_PORTING README TODO
6e34428f 296/etc/dbus-1/system.d/org.freedesktop.hostname1.conf
961baf80
AF
297/etc/dbus-1/system.d/org.freedesktop.locale1.conf
298/etc/dbus-1/system.d/org.freedesktop.login1.conf
c3037397 299/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
961baf80 300/etc/dbus-1/system.d/org.freedesktop.timedate1.conf
3edd52a6 301%ghost %config(noreplace) %{_sysconfdir}/machine-id
b77423ae
AF
302%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
303%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
304%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
305%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
306%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
307%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
5d32f234 308%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
2a61be78 309%dir %{_sysconfdir}/systemd/user
abd479ee 310/etc/xdg/systemd
1dcb74bb 311%attr(755,root,root) /bin/systemd
312%attr(755,root,root) /bin/systemd-ask-password
961baf80 313%attr(755,root,root) /bin/systemd-loginctl
7a76bc86 314%attr(755,root,root) /bin/systemd-machine-id-setup
1dcb74bb 315%attr(755,root,root) /bin/systemd-notify
316%attr(755,root,root) /bin/systemd-tty-ask-password-agent
57cd0d13 317%attr(755,root,root) %{_bindir}/systemd-analyze
23107006 318%attr(755,root,root) %{_bindir}/systemd-cgls
57cd0d13
ZU
319%attr(755,root,root) %{_bindir}/systemd-nspawn
320%attr(755,root,root) %{_bindir}/systemd-stdio-bridge
2a61be78 321%attr(755,root,root) %{_bindir}/systemd-sysv-convert
c3037397
ER
322%attr(755,root,root) /sbin/halt
323%attr(755,root,root) /sbin/init
324%attr(755,root,root) /sbin/poweroff
325%attr(755,root,root) /sbin/reboot
326%attr(755,root,root) /sbin/runlevel
327%attr(755,root,root) /sbin/shutdown
328%attr(755,root,root) /sbin/telinit
abd479ee 329%attr(755,root,root) /lib/systemd/systemd-*
c3037397 330%dir /lib/systemd/system-generators
5d32f234 331%attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
abd479ee 332%dir /lib/systemd/system-shutdown
1c239f8b 333/lib/udev/rules.d/99-systemd.rules
961baf80
AF
334/lib/udev/rules.d/70-uaccess.rules
335/lib/udev/rules.d/71-seat.rules
336/lib/udev/rules.d/73-seat-late.rules
3edd52a6
TP
337%dir %{_libexecdir}/systemd
338%{_libexecdir}/systemd/user
2a61be78 339%dir %{_libexecdir}/systemd/user-generators
89d58574 340%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
961baf80
AF
341%{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
342%{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
c3037397 343%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
961baf80 344%{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
1c239f8b 345%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
6e34428f 346%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
961baf80
AF
347%{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
348%{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
1c239f8b 349%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
961baf80 350%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
6e34428f 351%{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
961baf80
AF
352%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
353%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
354%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
355%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
356%dir %{_datadir}/systemd
357%{_datadir}/systemd/kbd-model-map
1c239f8b 358%{_mandir}/man1/init.1
7a76bc86 359%{_mandir}/man1/systemd.1*
2a61be78 360%{_mandir}/man1/systemd-*.1*
1c239f8b 361%{_mandir}/man3/sd_booted.3*
362%{_mandir}/man3/sd_is_fifo.3*
363%{_mandir}/man3/sd_is_socket.3
364%{_mandir}/man3/sd_is_socket_inet.3
365%{_mandir}/man3/sd_is_socket_unix.3
366%{_mandir}/man3/sd_listen_fds.3*
367%{_mandir}/man3/sd_notify.3*
368%{_mandir}/man3/sd_notifyf.3
369%{_mandir}/man3/sd_readahead.3*
6e34428f 370%{_mandir}/man5/binfmt.d.5*
1c239f8b 371%{_mandir}/man5/hostname.5*
372%{_mandir}/man5/locale.conf.5*
7a76bc86 373%{_mandir}/man5/machine-id.5*
6e34428f 374%{_mandir}/man5/machine-info.5*
1c239f8b 375%{_mandir}/man5/modules-load.d.5*
376%{_mandir}/man5/os-release.5*
6e34428f 377%{_mandir}/man5/sysctl.d.5*
89d58574 378%{_mandir}/man5/systemd.*.5*
961baf80
AF
379%{_mandir}/man5/systemd-logind.conf.5*
380%{_mandir}/man5/timezone.5*
23107006 381%{_mandir}/man5/vconsole.conf.5*
1c239f8b 382%{_mandir}/man7/daemon.7*
383%{_mandir}/man7/sd-daemon.7*
384%{_mandir}/man7/sd-readahead.7*
385%{_mandir}/man7/systemd.special.7*
386%{_mandir}/man8/halt.8*
1c239f8b 387%{_mandir}/man8/poweroff.8
388%{_mandir}/man8/reboot.8
389%{_mandir}/man8/runlevel.8*
390%{_mandir}/man8/shutdown.8*
391%{_mandir}/man8/telinit.8*
a761f93e
TP
392%attr(640,root,root) %ghost /var/log/btmp
393%attr(664,root,utmp) %ghost /var/log/wtmp
c3037397 394
6c89bbd4
ER
395%if %{with pam}
396%attr(755,root,root) /%{_lib}/security/pam_systemd.so
397%{_mandir}/man8/pam_systemd.8*
398%endif
399
011bccb6
BZ
400%files libs
401%defattr(644,root,root,755)
402%attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
403%attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
404%attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
405%attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
406
c3037397
ER
407%files units
408%defattr(644,root,root,755)
abd479ee
MB
409%dir %{_sysconfdir}/binfmt.d
410%dir %{_sysconfdir}/modules-load.d
5d32f234 411%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
abd479ee 412%dir %{_sysconfdir}/sysctl.d
c3037397
ER
413%dir %{_sysconfdir}/systemd
414%dir %{_sysconfdir}/systemd/system
415%dir %{_sysconfdir}/tmpfiles.d
85879912
ER
416%dir %{_libexecdir}/binfmt.d
417%dir %{_libexecdir}/modules-load.d
418%dir %{_libexecdir}/sysctl.d
c3037397
ER
419%attr(755,root,root) /bin/systemctl
420%attr(755,root,root) /bin/systemd-tmpfiles
b77423ae 421%attr(755,root,root) /bin/systemd_booted
c3037397 422%{_mandir}/man1/systemctl.1*
89d58574 423%{_mandir}/man5/tmpfiles.d.5*
c3037397 424%{_mandir}/man8/systemd-tmpfiles.8*
961baf80 425%{_npkgconfigdir}/systemd.pc
c3037397 426
10ffdcd2
BZ
427/lib/systemd/system/*.automount
428/lib/systemd/system/*.mount
429/lib/systemd/system/*.path
430/lib/systemd/system/*.service
431/lib/systemd/system/*.socket
432/lib/systemd/system/*.target
433/lib/systemd/system/*.timer
2a61be78 434%config(noreplace,missingok) /lib/systemd/system/*.wants
10ffdcd2 435
c3037397
ER
436%if %{with gtk}
437%files gtk
438%defattr(644,root,root,755)
439%attr(755,root,root) %{_bindir}/systemadm
440%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
c3037397
ER
441%{_mandir}/man1/systemadm.1*
442%endif
6c89bbd4
ER
443
444%files -n bash-completion-systemd
445%defattr(644,root,root,755)
446/etc/bash_completion.d/systemctl-bash-completion.sh
961baf80
AF
447
448%files devel
449%defattr(644,root,root,755)
2a61be78 450%{_includedir}/%{name}
89d58574
TP
451%attr(755,root,root) %{_libdir}/libsystemd-daemon.so
452%attr(755,root,root) %{_libdir}/libsystemd-login.so
961baf80
AF
453%{_pkgconfigdir}/libsystemd-daemon.pc
454%{_pkgconfigdir}/libsystemd-login.pc
This page took 0.088766 seconds and 4 git commands to generate.