]> git.pld-linux.org Git - packages/systemd.git/blame - systemd.spec
- better file location
[packages/systemd.git] / systemd.spec
CommitLineData
ede8d3e5 1#
9c4bd736 2# TODO:
3# - gtk BRs: libnotify 0.7 and gtk+3
4# - subpackages: bash-autocompletion, dbus(?), gtk, others?
5# - more BRs
6#
ede8d3e5 7
9c0b975d 8%bcond_with gtk # build gtk tools
9
ede8d3e5 10Summary: systemd - a system and service manager for Linux
11Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
12Name: systemd
13Version: 15
14Release: 0.1
15License: GPL v2+
16Group: Base
17Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
18# Source0-md5: 36011aa8593862ca78e3e909f6143570
19URL: http://www.freedesktop.org/wiki/Software/systemd
ede8d3e5 20BuildRequires: autoconf
21BuildRequires: automake
9c0b975d 22BuildRequires: dbus-devel
9c0b975d 23%if %{with gtk}
24BuildRequires: libnotify-devel >= 0.7.0
25%endif
ede8d3e5 26BuildRequires: libtool
27BuildRequires: udev-devel >= 160
eb2fda66 28BuildRequires: vala >= 0.11
b8651d75 29Provides: SysVinit = 2.86-23
1dcb74bb 30Provides: virtual(init-daemon)
0de25f0e 31Obsoletes: SysVinit
1dcb74bb 32Obsoletes: virtual(init-daemon)
0de25f0e 33Obsoletes: vserver-SysVinit
ede8d3e5 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
1c239f8b 37systemd is a system and service manager for Linux, compatible with
ede8d3e5 38SysV and LSB init scripts. systemd provides aggressive parallelization
39capabilities, uses socket and D-Bus activation for starting services,
40offers on-demand starting of daemons, keeps track of processes using
41Linux cgroups, supports snapshotting and restoring of the system
42state, maintains mount and automount points and implements an
43elaborate transactional dependency-based service control logic. It can
1c239f8b 44work as a drop-in replacement for sysvinit.
ede8d3e5 45
46%description -l pl.UTF-8
47systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
48skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
49paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
50oferuje uruchamianie usług na życzenie, monitoruje procesy używając
51linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
52(restore) stanu systemu, zarządza (auto)mount pointami oraz
53implementuje starannie opracowaną transakcjonalną, bazującą na
54zależnościach logikę kontroli usług. Może pracować jako zastepca dla
55sysvinit.
56
57%prep
58%setup -q
59
60%build
ede8d3e5 61%{__autoconf}
62%{__automake}
9c0b975d 63%configure \
e1d9cc15 64 --with-distro=other \
65 --%{?with_gtk:en}%{!?with_gtk:dis}able-gtk \
66 --with-syslog-service=syslog-ng \
67 --with-sysvinit-path=/etc/rc.d/init.d \
1c239f8b 68 --with-sysvrcd-path=/etc/rc.d \
1dcb74bb 69 --with-rootdir=
e1d9cc15 70
ede8d3e5 71%{__make}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76%{__make} install \
77 DESTDIR=$RPM_BUILD_ROOT
78
1dcb74bb 79# Create SysV compatibility symlinks. systemctl/systemd are smart
80# enough to detect in which way they are called.
81install -d $RPM_BUILD_ROOT/sbin
82ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
83ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
84ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
85ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
86ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
87ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
88ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
89
ede8d3e5 90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(644,root,root,755)
1c239f8b 95%doc DISTRO_PORTING README TODO
1dcb74bb 96%attr(755,root,root) /bin/systemctl
97%attr(755,root,root) /bin/systemd
98%attr(755,root,root) /bin/systemd-ask-password
1c239f8b 99%attr(755,root,root) %{_bindir}/systemd-cgls
1dcb74bb 100%attr(755,root,root) /bin/systemd-notify
101%attr(755,root,root) /bin/systemd-tty-ask-password-agent
102/sbin/halt
103/sbin/init
104/sbin/poweroff
105/sbin/reboot
106/sbin/runlevel
107/sbin/shutdown
108/sbin/telinit
109/lib/systemd/
1c239f8b 110/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
58f74834 111%{_sysconfdir}/systemd
112%{_sysconfdir}/tmpfiles.d
113%{_sysconfdir}/xdg/systemd
1c239f8b 114/lib/udev/rules.d/99-systemd.rules
a2d47a49 115/%{_lib}/security/pam_systemd.la
116%attr(755,root,root) /%{_lib}/security/pam_systemd.so
1c239f8b 117%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Automount.xml
118%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Device.xml
119%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Job.xml
120%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Manager.xml
121%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Mount.xml
122%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Path.xml
123%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Service.xml
124%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Snapshot.xml
125%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Socket.xml
126%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Swap.xml
127%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Target.xml
128%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Timer.xml
129%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Unit.xml
130%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
131%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
132%{_mandir}/man1/init.1
133%{_mandir}/man1/systemadm.1*
134%{_mandir}/man1/systemctl.1*
135%{_mandir}/man1/systemd-cgls.1*
136%{_mandir}/man1/systemd-notify.1*
137%{_mandir}/man1/systemd.1*
138%{_mandir}/man3/sd_booted.3*
139%{_mandir}/man3/sd_is_fifo.3*
140%{_mandir}/man3/sd_is_socket.3
141%{_mandir}/man3/sd_is_socket_inet.3
142%{_mandir}/man3/sd_is_socket_unix.3
143%{_mandir}/man3/sd_listen_fds.3*
144%{_mandir}/man3/sd_notify.3*
145%{_mandir}/man3/sd_notifyf.3
146%{_mandir}/man3/sd_readahead.3*
147%{_mandir}/man5/hostname.5*
148%{_mandir}/man5/locale.conf.5*
149%{_mandir}/man5/modules-load.d.5*
150%{_mandir}/man5/os-release.5*
151%{_mandir}/man5/systemd.automount.5*
152%{_mandir}/man5/systemd.conf.5*
153%{_mandir}/man5/systemd.device.5*
154%{_mandir}/man5/systemd.exec.5*
155%{_mandir}/man5/systemd.mount.5*
156%{_mandir}/man5/systemd.path.5*
157%{_mandir}/man5/systemd.service.5*
158%{_mandir}/man5/systemd.snapshot.5*
159%{_mandir}/man5/systemd.socket.5*
160%{_mandir}/man5/systemd.swap.5*
161%{_mandir}/man5/systemd.target.5*
162%{_mandir}/man5/systemd.timer.5*
163%{_mandir}/man5/systemd.unit.5*
164%{_mandir}/man5/tmpfiles.d.5*
165%{_mandir}/man5/vconsole.conf.5*
166%{_mandir}/man7/daemon.7*
167%{_mandir}/man7/sd-daemon.7*
168%{_mandir}/man7/sd-readahead.7*
169%{_mandir}/man7/systemd.special.7*
170%{_mandir}/man8/halt.8*
171%{_mandir}/man8/pam_systemd.8*
172%{_mandir}/man8/poweroff.8
173%{_mandir}/man8/reboot.8
174%{_mandir}/man8/runlevel.8*
175%{_mandir}/man8/shutdown.8*
176%{_mandir}/man8/telinit.8*
177%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
178%{_datadir}/systemd
This page took 0.067502 seconds and 4 git commands to generate.