]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
up to 1.65.0
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
fc3be51a 21# To bootstrap from scratch, set the channel and date from src/stage0.json
e361528e
ER
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
4079dca2 24%define bootstrap_rust 1.64.0
aea1d260 25%define bootstrap_cargo %{bootstrap_rust}
4079dca2 26%define bootstrap_date 2022-09-22
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
4079dca2
JP
39Version: 1.65.0
40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
4079dca2 45# Source0-md5: e8588b74b238f0f2f2701217cfd449e1
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
4079dca2 47# Source1-md5: 2c4c8116a0121d260591c4f4e9a9e1a8
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
4079dca2 49# Source2-md5: 810702367f20ea89a62096df07d8e88d
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
4079dca2 51# Source3-md5: c335b36395834b5e532a8d3247cc3cd4
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
4079dca2 53# Source4-md5: 1e2a697052328304af093875255f2591
ad044650 54Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
4079dca2 55# Source5-md5: 25b5bb6f3b2db5b876bd379bf3d79867
e361528e 56URL: https://www.rust-lang.org/
e8f16183
JB
57# for src/compiler-rt
58BuildRequires: cmake >= 3.4.3
e361528e 59BuildRequires: curl
2eb30149
JB
60# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61BuildRequires: procps
e65d284f
JP
62BuildRequires: python3
63BuildRequires: python3-modules
fc3be51a 64BuildRequires: rpm-build >= 4.6
2eb30149
JB
65BuildRequires: rpmbuild(macros) >= 1.752
66%if %{without cross}
8f176645 67BuildRequires: curl-devel
8745efaa 68BuildRequires: libgit2-devel >= 1.4.0
d1b96fd8 69BuildRequires: libstdc++-devel
2cec66d3 70%if %{with system_llvm}
4079dca2
JP
71BuildRequires: llvm >= 13.0
72BuildRequires: llvm-devel >= 13.0
2cec66d3 73%endif
7da6653d 74BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
75BuildRequires: tar >= 1:1.22
76BuildRequires: xz
79a067de 77BuildRequires: xz-devel
e361528e 78BuildRequires: zlib-devel
2eb30149 79%endif
e361528e 80%if %{without bootstrap}
d6d4cb2b 81BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 82BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 83BuildConflicts: %{name} > %{version}
e361528e 84%endif
2eb30149 85%ifarch x32
cd0c1484
JR
86BuildRequires: glibc-devel(x86-64)
87BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
88%if "%{_host_cpu}" == "x86_64"
89# building on x86_64 host with --target x32-pld-linux
8f176645 90BuildRequires: curl-devel
2eb30149 91BuildRequires: gcc-multilib-x32
8745efaa 92BuildRequires: libgit2-devel >= 1.4.0
2eb30149 93BuildRequires: libstdc++-devel
4079dca2 94%{?with_system_llvm:BuildRequires: llvm-devel >= 13.0}
2eb30149 95BuildRequires: openssl-devel >= 1.0.1
79a067de 96BuildRequires: xz-devel
2eb30149
JB
97BuildRequires: zlib-devel
98%else
99# building x86_64-hosted crosscompiler on x32 host
56b25e8b 100BuildRequires: curl-devel(x86-64)
cd0c1484 101BuildRequires: curl-devel(x86-x32)
2eb30149 102BuildRequires: gcc-multilib-64
8745efaa
JP
103BuildRequires: libgit2-devel(x86-64) >= 1.4.0
104BuildRequires: libgit2-devel(x86-x32) >= 1.4.0
2eb30149 105BuildRequires: libstdc++-multilib-64-devel
cd0c1484 106%if %{with system_llvm}
4079dca2
JP
107BuildRequires: llvm-devel(x86-64) >= 13.0
108BuildRequires: llvm-devel(x86-x32) >= 13.0
cd0c1484 109%endif
56b25e8b 110BuildRequires: openssl-devel(x86-64)
cd0c1484 111BuildRequires: openssl-devel(x86-x32)
79a067de
JP
112BuildRequires: xz-devel(x86-64)
113BuildRequires: xz-devel(x86-x32)
56b25e8b 114BuildRequires: zlib-devel(x86-64)
cd0c1484 115BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
116%endif
117%endif
e361528e
ER
118# The C compiler is needed at runtime just for linking. Someday rustc might
119# invoke the linker directly, and then we'll only need binutils.
120# https://github.com/rust-lang/rust/issues/11937
121Requires: gcc
cd0c1484
JR
122Requires: %{name}-std%{?_isa} = %{version}-%{release}
123%ifarch x32
124Requires: %{name}-std(x86-64) = %{version}-%{release}
417178e1 125Requires: gcc-multilib-64
cd0c1484 126%endif
e361528e 127# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 128# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 129# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 130ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 131BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 132
e064fbd0 133%ifarch x32
badbe44d 134%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 135%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 136%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
137# libs in _libdir are x86_64 64bit
138%define _lib lib64
139%define _libdir %{_prefix}/lib64
e064fbd0 140%else
ad044650 141%ifarch armv6hl
1fe729c8
JP
142%define rust_triple arm-unknown-linux-gnueabihf
143%define rust_host_triple %{rust_triple}
144%define rust_bootstrap_triple %{rust_triple}
145%else
ad044650
JP
146%ifarch armv7hl armv7hnl
147%define rust_triple armv7-unknown-linux-gnueabihf
148%define rust_host_triple %{rust_triple}
149%define rust_bootstrap_triple %{rust_triple}
6c4856ce 150%define rust_suppl_targets thumbv7neon-unknown-linux-gnueabihf
ad044650 151%else
badbe44d 152%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
153%define rust_host_triple %{rust_triple}
154%define rust_bootstrap_triple %{rust_triple}
e064fbd0 155%endif
1fe729c8 156%endif
ad044650 157%endif
e361528e 158
62473c95
JP
159%define rust_targets %rust_triple %{?rust_suppl_targets}
160
e361528e 161%if %{without bootstrap}
8a073211 162%define local_rust_root %{_prefix}
e361528e 163%else
badbe44d 164%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 165%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
166%endif
167
18a1004b
JR
168# We're going to override --libdir when configuring to get rustlib into a
169# common path, but we'll fix the shared libraries during install.
5b9d67b0 170# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
171# for non-bootstrap build, lib64 is just too complicated for it.
172%define common_libdir %{_prefix}/lib
173%define rustlibdir %{common_libdir}/rustlib
174
19f98749 175# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 176%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 177
e361528e 178# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
179%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
180%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 181
37765656
JP
182%define x_py { \
183 x_py() { \
184 local cmd="$1"; \
185 shift; \
e65d284f 186 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
37765656
JP
187 }; x_py }
188
189
e361528e
ER
190%description
191Rust is a systems programming language that runs blazingly fast,
192prevents segfaults, and guarantees thread safety.
193
194This package includes the Rust compiler, standard library, and
195documentation generator.
196
e8f16183
JB
197%description -l pl.UTF-8
198Rust to systemowy język programowania działający bardzo szybko,
199zapobiegający naruszeniom ochrony pamięci i gwarantujący
200bezpieczną wielowątkowość.
201
cd0c1484
JR
202%package analysis
203Summary: Metadata about the standard library
204Summary(pl.UTF-8): Metadane o standardowej bibliotece
205Group: Development/Tools
89a1e043 206Requires: %{name} = %{version}-%{release}
cd0c1484
JR
207
208%description analysis
209Metadata about the standard library.
210
211%description analysis -l pl.UTF-8
212Metadane o standardowej bibliotece.
213
214%package std
215Summary: Standard library for Rust
216Summary(pl.UTF-8): Standardowa biblioteka Rusta
217Group: Development/Tools
89a1e043 218Requires: %{name} = %{version}-%{release}
cd0c1484
JR
219
220%description std
221Standard library for Rust.
222
223%description std -l pl.UTF-8
224Standardowa biblioteka Rusta.
225
f397d93b 226%package analyzer
4079dca2
JP
227Summary: Implementation of Language Server Protocol for Rust
228Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
229Group: Development/Tools
230Requires: %{name} = %{version}-%{release}
231Obsoletes: rust-rls < 1.65.0
f397d93b
JP
232
233%description analyzer
234Implementation of Language Server Protocol for Rust.
235
236%description analyzer -l pl.UTF-8
237Implementacja Language Server Protocol dla Rusta.
238
d1b96fd8
JR
239%package debugger-common
240Summary: Common debugger pretty printers for Rust
e8f16183 241Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 242Group: Development/Debuggers
e67020b3 243BuildArch: noarch
d1b96fd8
JR
244
245%description debugger-common
e8f16183
JB
246This package includes the common functionality for rust-gdb and
247rust-lldb.
248
249%description debugger-common -l pl.UTF-8
250Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 251
e361528e
ER
252%package gdb
253Summary: GDB pretty printers for Rust
e8f16183 254Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
255Group: Development/Debuggers
256Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 257Requires: gdb
e67020b3 258BuildArch: noarch
e361528e
ER
259
260%description gdb
261This package includes the rust-gdb script, which allows easier
262debugging of Rust programs.
263
e8f16183
JB
264%description gdb -l pl.UTF-8
265Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
266odpluskwianie programów w języku Rust.
267
d1b96fd8
JR
268%package lldb
269Summary: LLDB pretty printers for Rust
e8f16183 270Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
271Group: Development/Debuggers
272Requires: %{name}-debugger-common = %{version}-%{release}
273Requires: lldb
e67020b3 274BuildArch: noarch
d1b96fd8
JR
275
276%description lldb
277This package includes the rust-lldb script, which allows easier
278debugging of Rust programs.
279
e8f16183
JB
280%description lldb -l pl.UTF-8
281Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
282odpluskwianie programów w języku Rust.
283
e361528e
ER
284%package doc
285Summary: Documentation for Rust
e8f16183 286Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 287Group: Documentation
e67020b3 288BuildArch: noarch
e361528e
ER
289
290%description doc
291This package includes HTML documentation for the Rust programming
292language and its standard library.
293
e8f16183
JB
294%description doc -l pl.UTF-8
295Ten pakiet zawiera dokumentację w formacie HTML do języka
296programowania Rust i jego biblioteki standardowej.
297
8a758d34
JP
298%package -n cargo
299Summary: Rust's package manager and build tool
300Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
301Group: Development/Tools
cd0c1484 302Requires: %{name}%{?_isa}
8a758d34
JP
303
304%description -n cargo
305Cargo is a tool that allows Rust projects to declare their various
306dependencies and ensure that you'll always get a repeatable build.
307
308%description -n cargo -l pl.UTF-8
309Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
310zależności i zapewniające powtarzalność procesu budowania.
311
6ed79af8
JB
312%package -n bash-completion-cargo
313Summary: Bash completion for cargo command
314Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
315Group: Applications/Shells
316Requires: %{name} = %{version}-%{release}
317Requires: bash-completion
318
319%description -n bash-completion-cargo
320Bash completion for cargo command.
321
322%description -n bash-completion-cargo -l pl.UTF-8
323Bashowe dopełnianie parametrów polecenia cargo.
324
8a758d34
JP
325%package -n zsh-completion-cargo
326Summary: Zsh completion for cargo command
327Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
328Group: Applications/Shells
329Requires: %{name} = %{version}-%{release}
6ed79af8 330Requires: zsh
8a758d34
JP
331
332%description -n zsh-completion-cargo
333Zsh completion for cargo command.
334
335%description -n zsh-completion-cargo -l pl.UTF-8
336Dopełnianie parametrów polecenia cargo w powłoce Zsh.
337
e361528e
ER
338%prep
339%setup -q -n %{rustc_package}
b5eceb5e 340
e361528e 341%if %{with bootstrap}
a1735efb 342%ifarch %{x8664} x32
e361528e
ER
343tar xf %{SOURCE1}
344%endif
345%ifarch %{ix86}
346tar xf %{SOURCE2}
347%endif
c160f211 348%ifarch aarch64
9eb0511e 349tar xf %{SOURCE3}
c160f211 350%endif
ad044650 351%ifarch armv6hl
1fe729c8
JP
352tar xf %{SOURCE4}
353%endif
ad044650
JP
354%ifarch armv7hl armv7hnl
355tar xf %{SOURCE5}
356%endif
d6d4cb2b
JR
357%{__mv} %{bootstrap_root} %{bootstrap_root}-root
358%{bootstrap_root}-root/install.sh \
badbe44d 359 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
360 --prefix=%{local_rust_root} \
361 --disable-ldconfig
362test -f %{local_rust_root}/bin/cargo
e361528e
ER
363test -f %{local_rust_root}/bin/rustc
364%endif
365
366# unbundle
d4b51567 367# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 368#%{__rm} -r src/jemalloc
9e7854c5
JP
369%if %{with system_llvm}
370%{__rm} -r src/llvm-project
371mkdir -p src/llvm-project/libunwind
372%endif
e361528e 373
e361528e
ER
374# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
375sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
376 src/etc/rust-gdb
377
4b354bd7
JB
378# cargo has hardcoded libexec path - honour rpm _libexecdir
379%if "%{_libexecdir}" != "%{_prefix}/libexec"
380suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
381%{__sed} -i -e 's,"libexec","'${suffix}'",' \
382 src/bootstrap/dist.rs \
383 src/tools/cargo/src/cargo/ops/registry/auth.rs
384%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
385%endif
386
5ee06aa0
JR
387# The configure macro will modify some autoconf-related files, which upsets
388# cargo when it tries to verify checksums in those files. If we just truncate
389# that file list, cargo won't have anything to complain about.
fe49e3fc 390find vendor -name .cargo-checksum.json \
5ee06aa0 391 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 392
e361528e 393%build
863a59ff
JP
394export CC="%{__cc}"
395export CXX="%{__cxx}"
396export AR="%{__ar}"
e361528e 397%configure \
2eb30149
JB
398 --build=%{rust_bootstrap_triple} \
399 --host=%{rust_host_triple} \
62473c95 400 --target="%(echo %rust_targets | tr ' ' ,)" \
18a1004b 401 --libdir=%{common_libdir} \
e8f16183 402 --disable-codegen-tests \
5ee06aa0 403 --disable-debuginfo-lines \
5b9d67b0 404%if %{with full_debuginfo}
5ee06aa0 405 --disable-debuginfo-only-std \
e361528e 406 --enable-debuginfo \
5b9d67b0
JB
407%else
408 --enable-debuginfo-only-std \
409 --disable-debuginfo \
410%endif
6ed79af8
JB
411 --disable-jemalloc \
412 --disable-option-checking \
413 --disable-rpath \
8a758d34 414 --enable-extended \
e8f16183 415 --enable-llvm-link-shared \
d6d4cb2b 416 --enable-vendor \
6ed79af8 417 --local-rust-root=%{local_rust_root} \
e8f16183 418 --llvm-root=%{_prefix} \
595dfba2
JP
419 --release-channel=%{channel} \
420 --set=llvm.static-libstdcpp=false
e361528e 421
37765656
JP
422export RUST_BACKTRACE=full
423%x_py dist --verbose
e361528e 424
37765656 425%{?with_tests:%x_py test}
8a073211 426
e361528e
ER
427%install
428rm -rf $RPM_BUILD_ROOT
e361528e 429
13ab0532
JP
430export CC="%{__cc}"
431export CXX="%{__cxx}"
432export AR="%{__ar}"
37765656
JP
433export DESTDIR=$RPM_BUILD_ROOT
434%x_py install
e361528e 435
18a1004b
JR
436# Make sure the shared libraries are in the proper libdir
437%if "%{_libdir}" != "%{common_libdir}"
438mkdir -p %{buildroot}%{_libdir}
439find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
440 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
441%endif
442
d1b96fd8 443# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
444find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
445
d1b96fd8
JR
446# The libdir libraries are identical to those under rustlib/. It's easier on
447# library loading if we keep them in libdir, but we do need them in rustlib/
448# to support dynamic linking for compiler plugins, so we'll symlink.
62473c95
JP
449for rust_target in %rust_targets; do
450 for l in libstd libtest ; do
451 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
452 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
453 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
454 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
455 fi
456 done
a973dc7e 457done
d1b96fd8
JR
458
459# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 460find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
461
462# FIXME: __os_install_post will strip the rlibs
463# -- should we find a way to preserve debuginfo?
464
465# Remove unwanted documentation files (we already package them)
e8f16183
JB
466%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
467%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
468%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
469%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
470
471# Sanitize the HTML documentation
472find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
473find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
474
475# Move rust-gdb's python scripts so they're noarch
476install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 477%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 478
4f353dba
JR
479# We don't need stdlib source
480%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
481
1dd26160
JP
482# Create the path for crate-devel packages
483install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
484
e361528e
ER
485%clean
486rm -rf $RPM_BUILD_ROOT
487
488%post -p /sbin/ldconfig
489%postun -p /sbin/ldconfig
490
491%files
492%defattr(644,root,root,755)
16ea23d8 493%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
1736a047 494%attr(755,root,root) %{_bindir}/rust-demangler
e361528e
ER
495%attr(755,root,root) %{_bindir}/rustc
496%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 497%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 498%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 499%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 500%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
501%{_mandir}/man1/rustc.1*
502%{_mandir}/man1/rustdoc.1*
18a1004b 503%dir %{rustlibdir}
cd0c1484
JR
504
505%files analysis
506%defattr(644,root,root,755)
62473c95
JP
507%(for rust_target in %rust_targets; do
508echo "%{rustlibdir}/$rust_target/analysis"
509done
510)
cd0c1484
JR
511
512%files std
513%defattr(644,root,root,755)
62473c95
JP
514%(for rust_target in %rust_targets; do
515cat <<EOF
516%dir %{rustlibdir}/$rust_target
517%dir %{rustlibdir}/$rust_target/lib
518%attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
519%{rustlibdir}/$rust_target/lib/*.rlib
520EOF
521done
522)
e361528e 523
f397d93b
JP
524%files analyzer
525%defattr(644,root,root,755)
526%attr(755,root,root) %{_bindir}/rust-analyzer
527%attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
528
d1b96fd8
JR
529%files debugger-common
530%defattr(644,root,root,755)
531%dir %{_datadir}/%{name}
532%dir %{_datadir}/%{name}/etc
5aae056c
JP
533%{_datadir}/%{name}/etc/lldb_commands
534%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
535
536%files lldb
537%defattr(644,root,root,755)
538%attr(755,root,root) %{_bindir}/rust-lldb
539%{_datadir}/%{name}/etc/lldb_*.py*
540
e361528e
ER
541%files gdb
542%defattr(644,root,root,755)
543%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 544%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 545%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
546
547%files doc
548%defattr(644,root,root,755)
549%dir %{_docdir}/%{name}
d1b96fd8 550%doc %{_docdir}/%{name}/html
8a758d34
JP
551
552%files -n cargo
553%defattr(644,root,root,755)
554%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
555%attr(755,root,root) %{_bindir}/cargo-clippy
556%attr(755,root,root) %{_bindir}/cargo-fmt
557%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 558%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
559%{_mandir}/man1/cargo*.1*
560%dir %{_datadir}/cargo
561%dir %{_datadir}/cargo/registry
562
563%files -n bash-completion-cargo
564%defattr(644,root,root,755)
565%{_sysconfdir}/bash_completion.d/cargo
566
567%files -n zsh-completion-cargo
568%defattr(644,root,root,755)
569%{zsh_compdir}/_cargo
This page took 1.291954 seconds and 4 git commands to generate.