]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
- fix non-bootstrap prep
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
e361528e
ER
4#
5# Conditional build:
8a073211 6%bcond_with bootstrap
cace5bf9 7%bcond_with tests # build without tests
e361528e 8
8a073211
JR
9# The channel can be stable, beta, or nightly
10%define channel stable
11
e361528e 12%if "%{channel}" == "stable"
8a073211 13%define rustc_package rustc-%{version}-src
e361528e 14%else
8a073211 15%define rustc_package rustc-%{channel}-src
e361528e
ER
16%endif
17
18# To bootstrap from scratch, set the channel and date from src/stage0.txt
19# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
20# or nightly wants some beta-YYYY-MM-DD
8a073211
JR
21%define bootstrap_rust 1.17.0
22%define bootstrap_cargo 0.18.0
23%define bootstrap_date 2017-04-27
e361528e
ER
24
25Summary: The Rust Programming Language
26Name: rust
d6d4cb2b 27Version: 1.18.0
cace5bf9 28Release: 0.2
d1b96fd8 29# Licenses: (rust itself) and (bundled libraries)
e361528e 30License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
e361528e 31Group: Development/Languages
d6d4cb2b
JR
32Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
33# Source0-md5: c37c0cd9d500f6a9d1f2f44401351f88
8a073211 34Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.gz
d6d4cb2b 35# Source1-md5: 98e8f479515969123b4c203191104a54
8a073211 36Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.gz
d6d4cb2b 37# Source2-md5: 2d5de850c32aa8d40c8c21abacf749f8
e361528e
ER
38URL: https://www.rust-lang.org/
39BuildRequires: cmake
40BuildRequires: curl
41BuildRequires: gcc
42BuildRequires: libstdc++-devel
d1b96fd8 43BuildRequires: libstdc++-devel
e361528e 44BuildRequires: llvm-devel
d1b96fd8 45BuildRequires: ncurses-devel
e361528e
ER
46BuildRequires: python
47BuildRequires: zlib-devel
48%if %{without bootstrap}
49BuildRequires: %{name} < %{version}-%{release}
d6d4cb2b 50BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 51BuildRequires: cargo >= %{bootstrap_cargo}
e361528e
ER
52%endif
53# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
54BuildRequires: procps
e361528e
ER
55# The C compiler is needed at runtime just for linking. Someday rustc might
56# invoke the linker directly, and then we'll only need binutils.
57# https://github.com/rust-lang/rust/issues/11937
58Requires: gcc
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60# Only x86_64 and i686 are Tier 1 platforms at this time.
61# https://doc.rust-lang.org/stable/book/getting-started.html#tier-1
d36946a0 62ExclusiveArch: %{x8664} %{ix86}
e361528e 63
8a073211 64%define rust_triple %{_target_cpu}-unknown-linux-gnu
e361528e
ER
65
66%if %{without bootstrap}
8a073211 67%define local_rust_root %{_prefix}
e361528e 68%else
8a073211
JR
69%define bootstrap_root rust-%{bootstrap_rust}-%{rust_triple}
70%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
71%endif
72
19f98749 73# once_call/once_callable non-function libstdc++ symbols
8a073211 74%define skip_post_check_so 'librustc_llvm-.*\.so.*'
19f98749 75
e361528e 76# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
77%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
78%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e
ER
79
80%description
81Rust is a systems programming language that runs blazingly fast,
82prevents segfaults, and guarantees thread safety.
83
84This package includes the Rust compiler, standard library, and
85documentation generator.
86
d1b96fd8
JR
87%package debugger-common
88Summary: Common debugger pretty printers for Rust
89Group: Development/Debuggers
90BuildArch: noarch
91
92%description debugger-common
93This package includes the common functionality for %{name}-gdb and
94%{name}-lldb.
95
e361528e
ER
96%package gdb
97Summary: GDB pretty printers for Rust
d1b96fd8
JR
98Group: Development/Debuggers
99Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 100Requires: gdb
e361528e 101BuildArch: noarch
e361528e
ER
102
103%description gdb
104This package includes the rust-gdb script, which allows easier
105debugging of Rust programs.
106
d1b96fd8
JR
107%package lldb
108Summary: LLDB pretty printers for Rust
109Group: Development/Debuggers
110Requires: %{name}-debugger-common = %{version}-%{release}
111Requires: lldb
112Requires: python-lldb
113BuildArch: noarch
114
115%description lldb
116This package includes the rust-lldb script, which allows easier
117debugging of Rust programs.
118
e361528e
ER
119%package doc
120Summary: Documentation for Rust
d1b96fd8
JR
121Group: Documentation
122BuildArch: noarch
e361528e
ER
123
124%description doc
125This package includes HTML documentation for the Rust programming
126language and its standard library.
127
128%prep
129%setup -q -n %{rustc_package}
130%if %{with bootstrap}
131%ifarch %{x8664}
132tar xf %{SOURCE1}
133%endif
134%ifarch %{ix86}
135tar xf %{SOURCE2}
136%endif
d6d4cb2b
JR
137%{__mv} %{bootstrap_root} %{bootstrap_root}-root
138%{bootstrap_root}-root/install.sh \
139 --components=cargo,rustc,rust-std-%{rust_triple} \
140 --prefix=%{local_rust_root} \
141 --disable-ldconfig
142test -f %{local_rust_root}/bin/cargo
e361528e
ER
143test -f %{local_rust_root}/bin/rustc
144%endif
145
146# unbundle
147rm -r src/jemalloc/
148rm -r src/llvm/
149
150# extract bundled licenses for packaging
151cp -p src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
152sed -e '/*\//q' src/libbacktrace/backtrace.h \
153 >src/libbacktrace/LICENSE-libbacktrace
154
155# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
156sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
157 src/etc/rust-gdb
158
159# These tests assume that alloc_jemalloc is present
160sed -i -e '1i // ignore-test jemalloc is disabled' \
161 src/test/compile-fail/allocator-dylib-is-system.rs \
162 src/test/compile-fail/allocator-rust-dylib-is-jemalloc.rs \
163 src/test/run-pass/allocator-default.rs
164
165# Fedora's LLVM doesn't support any mips targets -- see "llc -version".
166# Fixed properly by Rust PR36344, which should be released in 1.13.
167sed -i -e '/target=mips/,+1s/^/# unsupported /' \
168 src/test/run-make/atomic-lock-free/Makefile
169
e361528e
ER
170%build
171%configure \
172 --disable-option-checking \
173 --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
174 --enable-local-rust --local-rust-root=%{local_rust_root} \
175 --llvm-root=%{_prefix} --disable-codegen-tests \
176 --disable-jemalloc \
177 --disable-rpath \
178 --enable-debuginfo \
d6d4cb2b 179 --enable-vendor \
e361528e
ER
180 --release-channel=%{channel}
181
d6d4cb2b 182./x.py dist
e361528e 183
8a073211
JR
184%{?with_tests:./x.py test}
185
e361528e
ER
186%install
187rm -rf $RPM_BUILD_ROOT
e361528e 188
d1b96fd8 189DESTDIR=$RPM_BUILD_ROOT ./x.py dist --install
e361528e 190
d1b96fd8 191# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
192find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
193
d1b96fd8
JR
194# The libdir libraries are identical to those under rustlib/. It's easier on
195# library loading if we keep them in libdir, but we do need them in rustlib/
196# to support dynamic linking for compiler plugins, so we'll symlink.
197(cd "$RPM_BUILD_ROOT%{_libdir}/rustlib/%{rust_triple}/lib" &&
198 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
199 -exec ln -v -f -s -t . '{}' '+')
200
201# Remove installer artifacts (manifests, uninstall scripts, etc.)
202find $RPM_BUILD_ROOT%{_libdir}/rustlib/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
203
204# FIXME: __os_install_post will strip the rlibs
205# -- should we find a way to preserve debuginfo?
206
207# Remove unwanted documentation files (we already package them)
208rm $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
209rm $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
210rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
211rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
212
213# Sanitize the HTML documentation
214find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
215find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
216
217# Move rust-gdb's python scripts so they're noarch
218install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
219mv -v $RPM_BUILD_ROOT%{_libdir}/rustlib%{_sysconfdir} $RPM_BUILD_ROOT%{_datadir}/%{name}/
220
221%clean
222rm -rf $RPM_BUILD_ROOT
223
224%post -p /sbin/ldconfig
225%postun -p /sbin/ldconfig
226
227%files
228%defattr(644,root,root,755)
229%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT
230%doc src/libbacktrace/LICENSE-libbacktrace
231%doc src/rt/hoedown/LICENSE-hoedown
232%doc README.md
233%attr(755,root,root) %{_bindir}/rustc
234%attr(755,root,root) %{_bindir}/rustdoc
235%{_mandir}/man1/rustc.1*
236%{_mandir}/man1/rustdoc.1*
237%{_libdir}/lib*
238%dir %{_libdir}/rustlib
239%{_libdir}/rustlib/%{rust_triple}
240
d1b96fd8
JR
241%files debugger-common
242%defattr(644,root,root,755)
243%dir %{_datadir}/%{name}
244%dir %{_datadir}/%{name}/etc
245%{_datadir}/%{name}/etc/debugger_*.py*
246
247%files lldb
248%defattr(644,root,root,755)
249%attr(755,root,root) %{_bindir}/rust-lldb
250%{_datadir}/%{name}/etc/lldb_*.py*
251
e361528e
ER
252%files gdb
253%defattr(644,root,root,755)
254%attr(755,root,root) %{_bindir}/rust-gdb
d1b96fd8 255%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
256
257%files doc
258%defattr(644,root,root,755)
259%dir %{_docdir}/%{name}
d1b96fd8 260%doc %{_docdir}/%{name}/html
This page took 1.020414 seconds and 4 git commands to generate.