]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
up to 1.54.0
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
5a053d91
JP
24%define bootstrap_rust 1.53.0
25%define bootstrap_cargo 1.53.0
26%define bootstrap_date 2021-06-17
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
5a053d91
JP
39Version: 1.54.0
40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
5a053d91 45# Source0-md5: f1fc7b0f0c7aff2b8d61e58b510a6f66
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
5a053d91 47# Source1-md5: 3f2ea3d908dac317d6006a117463f18e
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
5a053d91 49# Source2-md5: 2ea9461d6c06c38ad85cc6037d70b9d7
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
5a053d91 51# Source3-md5: 0772ec454b29685a4d79ead06c5cdd23
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
5a053d91 53# Source4-md5: 7ecbfb7344a3dbafcaddffb898afbfa9
ad044650 54Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
5a053d91 55# Source5-md5: 3650d93b062c6605e3aa96ce4d63335c
e361528e 56URL: https://www.rust-lang.org/
e8f16183
JB
57# for src/compiler-rt
58BuildRequires: cmake >= 3.4.3
e361528e 59BuildRequires: curl
2eb30149
JB
60# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61BuildRequires: procps
62BuildRequires: python >= 1:2.7
63BuildRequires: rpmbuild(macros) >= 1.752
64%if %{without cross}
8f176645 65BuildRequires: curl-devel
1f9b8560 66BuildRequires: libgit2-devel >= 1.1.0
d1b96fd8 67BuildRequires: libstdc++-devel
cdc531fa 68%{?with_system_llvm:BuildRequires: llvm-devel >= 10.0}
7da6653d 69BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
70BuildRequires: tar >= 1:1.22
71BuildRequires: xz
e361528e 72BuildRequires: zlib-devel
2eb30149 73%endif
e361528e 74%if %{without bootstrap}
d6d4cb2b 75BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 76BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 77BuildConflicts: %{name} > %{version}
e361528e 78%endif
2eb30149 79%ifarch x32
cd0c1484
JR
80BuildRequires: glibc-devel(x86-64)
81BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
82%if "%{_host_cpu}" == "x86_64"
83# building on x86_64 host with --target x32-pld-linux
8f176645 84BuildRequires: curl-devel
2eb30149 85BuildRequires: gcc-multilib-x32
1f9b8560 86BuildRequires: libgit2-devel >= 1.1.0
2eb30149 87BuildRequires: libstdc++-devel
cdc531fa 88%{?with_system_llvm:BuildRequires: llvm-devel >= 10.0}
2eb30149
JB
89BuildRequires: openssl-devel >= 1.0.1
90BuildRequires: zlib-devel
91%else
92# building x86_64-hosted crosscompiler on x32 host
56b25e8b 93BuildRequires: curl-devel(x86-64)
cd0c1484 94BuildRequires: curl-devel(x86-x32)
2eb30149 95BuildRequires: gcc-multilib-64
1f9b8560 96BuildRequires: libgit2-devel(x86-64) >= 1.1.0
cd0c1484 97BuildRequires: libgit2-devel(x86-x32) >= 1.1.0
2eb30149 98BuildRequires: libstdc++-multilib-64-devel
cd0c1484 99%if %{with system_llvm}
cdc531fa
JP
100BuildRequires: llvm-devel(x86-64) >= 10.0
101BuildRequires: llvm-devel(x86-x32) >= 10.0
cd0c1484 102%endif
56b25e8b 103BuildRequires: openssl-devel(x86-64)
cd0c1484 104BuildRequires: openssl-devel(x86-x32)
56b25e8b 105BuildRequires: zlib-devel(x86-64)
cd0c1484 106BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
107%endif
108%endif
e361528e
ER
109# The C compiler is needed at runtime just for linking. Someday rustc might
110# invoke the linker directly, and then we'll only need binutils.
111# https://github.com/rust-lang/rust/issues/11937
112Requires: gcc
cd0c1484
JR
113Requires: %{name}-std%{?_isa} = %{version}-%{release}
114%ifarch x32
115Requires: %{name}-std(x86-64) = %{version}-%{release}
116%endif
b8711561 117Obsoletes: rust-analyzer < 1.53.0
e361528e 118# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 119# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 120# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 121ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 122BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 123
e064fbd0 124%ifarch x32
badbe44d 125%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 126%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 127%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
128# libs in _libdir are x86_64 64bit
129%define _lib lib64
130%define _libdir %{_prefix}/lib64
e064fbd0 131%else
ad044650 132%ifarch armv6hl
1fe729c8
JP
133%define rust_triple arm-unknown-linux-gnueabihf
134%define rust_host_triple %{rust_triple}
135%define rust_bootstrap_triple %{rust_triple}
136%else
ad044650
JP
137%ifarch armv7hl armv7hnl
138%define rust_triple armv7-unknown-linux-gnueabihf
139%define rust_host_triple %{rust_triple}
140%define rust_bootstrap_triple %{rust_triple}
141%else
badbe44d 142%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
143%define rust_host_triple %{rust_triple}
144%define rust_bootstrap_triple %{rust_triple}
e064fbd0 145%endif
1fe729c8 146%endif
ad044650 147%endif
e361528e
ER
148
149%if %{without bootstrap}
8a073211 150%define local_rust_root %{_prefix}
e361528e 151%else
badbe44d 152%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 153%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
154%endif
155
18a1004b
JR
156# We're going to override --libdir when configuring to get rustlib into a
157# common path, but we'll fix the shared libraries during install.
5b9d67b0 158# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
159# for non-bootstrap build, lib64 is just too complicated for it.
160%define common_libdir %{_prefix}/lib
161%define rustlibdir %{common_libdir}/rustlib
162
19f98749 163# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 164%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 165
e361528e 166# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
167%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
168%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 169
37765656
JP
170%define x_py { \
171 x_py() { \
172 local cmd="$1"; \
173 shift; \
174 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
175 }; x_py }
176
177
e361528e
ER
178%description
179Rust is a systems programming language that runs blazingly fast,
180prevents segfaults, and guarantees thread safety.
181
182This package includes the Rust compiler, standard library, and
183documentation generator.
184
e8f16183
JB
185%description -l pl.UTF-8
186Rust to systemowy język programowania działający bardzo szybko,
187zapobiegający naruszeniom ochrony pamięci i gwarantujący
188bezpieczną wielowątkowość.
189
cd0c1484
JR
190%package analysis
191Summary: Metadata about the standard library
192Summary(pl.UTF-8): Metadane o standardowej bibliotece
193Group: Development/Tools
89a1e043 194Requires: %{name} = %{version}-%{release}
cd0c1484
JR
195
196%description analysis
197Metadata about the standard library.
198
199%description analysis -l pl.UTF-8
200Metadane o standardowej bibliotece.
201
202%package std
203Summary: Standard library for Rust
204Summary(pl.UTF-8): Standardowa biblioteka Rusta
205Group: Development/Tools
89a1e043 206Requires: %{name} = %{version}-%{release}
cd0c1484
JR
207
208%description std
209Standard library for Rust.
210
211%description std -l pl.UTF-8
212Standardowa biblioteka Rusta.
213
d1b96fd8
JR
214%package debugger-common
215Summary: Common debugger pretty printers for Rust
e8f16183 216Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 217Group: Development/Debuggers
e67020b3 218BuildArch: noarch
d1b96fd8
JR
219
220%description debugger-common
e8f16183
JB
221This package includes the common functionality for rust-gdb and
222rust-lldb.
223
224%description debugger-common -l pl.UTF-8
225Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 226
e361528e
ER
227%package gdb
228Summary: GDB pretty printers for Rust
e8f16183 229Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
230Group: Development/Debuggers
231Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 232Requires: gdb
e67020b3 233BuildArch: noarch
e361528e
ER
234
235%description gdb
236This package includes the rust-gdb script, which allows easier
237debugging of Rust programs.
238
e8f16183
JB
239%description gdb -l pl.UTF-8
240Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
241odpluskwianie programów w języku Rust.
242
d1b96fd8
JR
243%package lldb
244Summary: LLDB pretty printers for Rust
e8f16183 245Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
246Group: Development/Debuggers
247Requires: %{name}-debugger-common = %{version}-%{release}
248Requires: lldb
e67020b3 249BuildArch: noarch
d1b96fd8
JR
250
251%description lldb
252This package includes the rust-lldb script, which allows easier
253debugging of Rust programs.
254
e8f16183
JB
255%description lldb -l pl.UTF-8
256Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
257odpluskwianie programów w języku Rust.
258
a7fda0f8
JP
259%package rls
260Summary: Rust Language Server for IDE integration
261Summary(pl.UTF-8): Rust Language Server do integracji z IDE
262Group: Development/Tools
89a1e043
JR
263Requires: %{name} = %{version}-%{release}
264Requires: %{name}-analysis = %{version}-%{release}
a7fda0f8
JP
265
266%description rls
267Rust Language Server for IDE integration.
268
269%description rls -l pl.UTF-8
270Rust Language Server do integracji z IDE.
271
e361528e
ER
272%package doc
273Summary: Documentation for Rust
e8f16183 274Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 275Group: Documentation
e67020b3 276BuildArch: noarch
e361528e
ER
277
278%description doc
279This package includes HTML documentation for the Rust programming
280language and its standard library.
281
e8f16183
JB
282%description doc -l pl.UTF-8
283Ten pakiet zawiera dokumentację w formacie HTML do języka
284programowania Rust i jego biblioteki standardowej.
285
8a758d34
JP
286%package -n cargo
287Summary: Rust's package manager and build tool
288Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
289Group: Development/Tools
cd0c1484 290Requires: %{name}%{?_isa}
8a758d34
JP
291
292%description -n cargo
293Cargo is a tool that allows Rust projects to declare their various
294dependencies and ensure that you'll always get a repeatable build.
295
296%description -n cargo -l pl.UTF-8
297Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
298zależności i zapewniające powtarzalność procesu budowania.
299
6ed79af8
JB
300%package -n bash-completion-cargo
301Summary: Bash completion for cargo command
302Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
303Group: Applications/Shells
304Requires: %{name} = %{version}-%{release}
305Requires: bash-completion
306
307%description -n bash-completion-cargo
308Bash completion for cargo command.
309
310%description -n bash-completion-cargo -l pl.UTF-8
311Bashowe dopełnianie parametrów polecenia cargo.
312
8a758d34
JP
313%package -n zsh-completion-cargo
314Summary: Zsh completion for cargo command
315Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
316Group: Applications/Shells
317Requires: %{name} = %{version}-%{release}
6ed79af8 318Requires: zsh
8a758d34
JP
319
320%description -n zsh-completion-cargo
321Zsh completion for cargo command.
322
323%description -n zsh-completion-cargo -l pl.UTF-8
324Dopełnianie parametrów polecenia cargo w powłoce Zsh.
325
e361528e
ER
326%prep
327%setup -q -n %{rustc_package}
b5eceb5e 328
e361528e 329%if %{with bootstrap}
a1735efb 330%ifarch %{x8664} x32
e361528e
ER
331tar xf %{SOURCE1}
332%endif
333%ifarch %{ix86}
334tar xf %{SOURCE2}
335%endif
c160f211 336%ifarch aarch64
9eb0511e 337tar xf %{SOURCE3}
c160f211 338%endif
ad044650 339%ifarch armv6hl
1fe729c8
JP
340tar xf %{SOURCE4}
341%endif
ad044650
JP
342%ifarch armv7hl armv7hnl
343tar xf %{SOURCE5}
344%endif
d6d4cb2b
JR
345%{__mv} %{bootstrap_root} %{bootstrap_root}-root
346%{bootstrap_root}-root/install.sh \
badbe44d 347 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
348 --prefix=%{local_rust_root} \
349 --disable-ldconfig
350test -f %{local_rust_root}/bin/cargo
e361528e
ER
351test -f %{local_rust_root}/bin/rustc
352%endif
353
354# unbundle
d4b51567 355# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 356#%{__rm} -r src/jemalloc
9e7854c5
JP
357%if %{with system_llvm}
358%{__rm} -r src/llvm-project
359mkdir -p src/llvm-project/libunwind
360%endif
e361528e
ER
361
362# extract bundled licenses for packaging
5aae056c
JP
363sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
364 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
365
366# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
367sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
368 src/etc/rust-gdb
369
5ee06aa0
JR
370# The configure macro will modify some autoconf-related files, which upsets
371# cargo when it tries to verify checksums in those files. If we just truncate
372# that file list, cargo won't have anything to complain about.
fe49e3fc 373find vendor -name .cargo-checksum.json \
5ee06aa0 374 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 375
e361528e
ER
376%build
377%configure \
2eb30149
JB
378 --build=%{rust_bootstrap_triple} \
379 --host=%{rust_host_triple} \
e8f16183 380 --target=%{rust_triple} \
18a1004b 381 --libdir=%{common_libdir} \
e8f16183 382 --disable-codegen-tests \
5ee06aa0 383 --disable-debuginfo-lines \
5b9d67b0 384%if %{with full_debuginfo}
5ee06aa0 385 --disable-debuginfo-only-std \
e361528e 386 --enable-debuginfo \
5b9d67b0
JB
387%else
388 --enable-debuginfo-only-std \
389 --disable-debuginfo \
390%endif
6ed79af8
JB
391 --disable-jemalloc \
392 --disable-option-checking \
393 --disable-rpath \
8a758d34 394 --enable-extended \
e8f16183 395 --enable-llvm-link-shared \
d6d4cb2b 396 --enable-vendor \
6ed79af8 397 --local-rust-root=%{local_rust_root} \
e8f16183 398 --llvm-root=%{_prefix} \
e361528e
ER
399 --release-channel=%{channel}
400
37765656
JP
401export RUST_BACKTRACE=full
402%x_py dist --verbose
e361528e 403
37765656 404%{?with_tests:%x_py test}
8a073211 405
e361528e
ER
406%install
407rm -rf $RPM_BUILD_ROOT
e361528e 408
37765656
JP
409export DESTDIR=$RPM_BUILD_ROOT
410%x_py install
e361528e 411
18a1004b
JR
412# Make sure the shared libraries are in the proper libdir
413%if "%{_libdir}" != "%{common_libdir}"
414mkdir -p %{buildroot}%{_libdir}
415find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
416 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
417%endif
418
d1b96fd8 419# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
420find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
421
d1b96fd8
JR
422# The libdir libraries are identical to those under rustlib/. It's easier on
423# library loading if we keep them in libdir, but we do need them in rustlib/
424# to support dynamic linking for compiler plugins, so we'll symlink.
a973dc7e
JR
425for l in libstd libtest ; do
426 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
427 libstd=$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib/${l}-*.so
428 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
429 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
430 fi
431done
d1b96fd8
JR
432
433# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 434find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
435
436# FIXME: __os_install_post will strip the rlibs
437# -- should we find a way to preserve debuginfo?
438
439# Remove unwanted documentation files (we already package them)
e8f16183
JB
440%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
441%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
442%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
443%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
444
445# Sanitize the HTML documentation
446find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
447find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
448
449# Move rust-gdb's python scripts so they're noarch
450install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 451%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 452
4f353dba
JR
453# We don't need stdlib source
454%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
455
1dd26160
JP
456# Create the path for crate-devel packages
457install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
458
e361528e
ER
459%clean
460rm -rf $RPM_BUILD_ROOT
461
462%post -p /sbin/ldconfig
463%postun -p /sbin/ldconfig
464
465%files
466%defattr(644,root,root,755)
5aae056c 467%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
468%attr(755,root,root) %{_bindir}/rustc
469%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 470%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 471%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 472%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 473%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
474%{_mandir}/man1/rustc.1*
475%{_mandir}/man1/rustdoc.1*
18a1004b 476%dir %{rustlibdir}
cd0c1484
JR
477
478%files analysis
479%defattr(644,root,root,755)
6ed79af8 480%{rustlibdir}/%{rust_triple}/analysis
cd0c1484
JR
481
482%files std
483%defattr(644,root,root,755)
484%dir %{rustlibdir}/%{rust_triple}
18a1004b
JR
485%dir %{rustlibdir}/%{rust_triple}/lib
486%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
487%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 488
d1b96fd8
JR
489%files debugger-common
490%defattr(644,root,root,755)
491%dir %{_datadir}/%{name}
492%dir %{_datadir}/%{name}/etc
5aae056c
JP
493%{_datadir}/%{name}/etc/lldb_commands
494%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
495
496%files lldb
497%defattr(644,root,root,755)
498%attr(755,root,root) %{_bindir}/rust-lldb
499%{_datadir}/%{name}/etc/lldb_*.py*
500
e361528e
ER
501%files gdb
502%defattr(644,root,root,755)
503%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 504%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 505%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 506
a7fda0f8
JP
507%files rls
508%defattr(644,root,root,755)
509%attr(755,root,root) %{_bindir}/rls
510
e361528e
ER
511%files doc
512%defattr(644,root,root,755)
513%dir %{_docdir}/%{name}
d1b96fd8 514%doc %{_docdir}/%{name}/html
8a758d34
JP
515
516%files -n cargo
517%defattr(644,root,root,755)
518%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
519%attr(755,root,root) %{_bindir}/cargo-clippy
520%attr(755,root,root) %{_bindir}/cargo-fmt
521%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 522%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
523%{_mandir}/man1/cargo*.1*
524%dir %{_datadir}/cargo
525%dir %{_datadir}/cargo/registry
526
527%files -n bash-completion-cargo
528%defattr(644,root,root,755)
529%{_sysconfdir}/bash_completion.d/cargo
530
531%files -n zsh-completion-cargo
532%defattr(644,root,root,755)
533%{zsh_compdir}/_cargo
This page took 0.6876 seconds and 4 git commands to generate.