]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
up to 1.65.0
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.64.0
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2022-09-22
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.65.0
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  e8588b74b238f0f2f2701217cfd449e1
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  2c4c8116a0121d260591c4f4e9a9e1a8
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  810702367f20ea89a62096df07d8e88d
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  c335b36395834b5e532a8d3247cc3cd4
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  1e2a697052328304af093875255f2591
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  25b5bb6f3b2db5b876bd379bf3d79867
56 URL:            https://www.rust-lang.org/
57 # for src/compiler-rt
58 BuildRequires:  cmake >= 3.4.3
59 BuildRequires:  curl
60 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61 BuildRequires:  procps
62 BuildRequires:  python3
63 BuildRequires:  python3-modules
64 BuildRequires:  rpm-build >= 4.6
65 BuildRequires:  rpmbuild(macros) >= 1.752
66 %if %{without cross}
67 BuildRequires:  curl-devel
68 BuildRequires:  libgit2-devel >= 1.4.0
69 BuildRequires:  libstdc++-devel
70 %if %{with system_llvm}
71 BuildRequires:  llvm >= 13.0
72 BuildRequires:  llvm-devel >= 13.0
73 %endif
74 BuildRequires:  openssl-devel >= 1.0.1
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  xz
77 BuildRequires:  xz-devel
78 BuildRequires:  zlib-devel
79 %endif
80 %if %{without bootstrap}
81 BuildRequires:  %{name} >= %{bootstrap_rust}
82 BuildRequires:  cargo >= %{bootstrap_cargo}
83 BuildConflicts: %{name} > %{version}
84 %endif
85 %ifarch x32
86 BuildRequires:  glibc-devel(x86-64)
87 BuildRequires:  glibc-devel(x86-x32)
88 %if "%{_host_cpu}" == "x86_64"
89 # building on x86_64 host with --target x32-pld-linux
90 BuildRequires:  curl-devel
91 BuildRequires:  gcc-multilib-x32
92 BuildRequires:  libgit2-devel >= 1.4.0
93 BuildRequires:  libstdc++-devel
94 %{?with_system_llvm:BuildRequires:      llvm-devel >= 13.0}
95 BuildRequires:  openssl-devel >= 1.0.1
96 BuildRequires:  xz-devel
97 BuildRequires:  zlib-devel
98 %else
99 # building x86_64-hosted crosscompiler on x32 host
100 BuildRequires:  curl-devel(x86-64)
101 BuildRequires:  curl-devel(x86-x32)
102 BuildRequires:  gcc-multilib-64
103 BuildRequires:  libgit2-devel(x86-64) >= 1.4.0
104 BuildRequires:  libgit2-devel(x86-x32) >= 1.4.0
105 BuildRequires:  libstdc++-multilib-64-devel
106 %if %{with system_llvm}
107 BuildRequires:  llvm-devel(x86-64) >= 13.0
108 BuildRequires:  llvm-devel(x86-x32) >= 13.0
109 %endif
110 BuildRequires:  openssl-devel(x86-64)
111 BuildRequires:  openssl-devel(x86-x32)
112 BuildRequires:  xz-devel(x86-64)
113 BuildRequires:  xz-devel(x86-x32)
114 BuildRequires:  zlib-devel(x86-64)
115 BuildRequires:  zlib-devel(x86-x32)
116 %endif
117 %endif
118 # The C compiler is needed at runtime just for linking.  Someday rustc might
119 # invoke the linker directly, and then we'll only need binutils.
120 # https://github.com/rust-lang/rust/issues/11937
121 Requires:       gcc
122 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
123 %ifarch x32
124 Requires:       %{name}-std(x86-64) = %{version}-%{release}
125 Requires:       gcc-multilib-64
126 %endif
127 # Only x86_64 and i686 are Tier 1 platforms at this time.
128 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
129 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
130 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
131 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
132
133 %ifarch x32
134 %define         rust_triple             x86_64-unknown-linux-gnux32
135 %define         rust_host_triple        x86_64-unknown-linux-gnu
136 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
137 # libs in _libdir are x86_64 64bit
138 %define         _lib                    lib64
139 %define         _libdir                 %{_prefix}/lib64
140 %else
141 %ifarch armv6hl
142 %define         rust_triple             arm-unknown-linux-gnueabihf
143 %define         rust_host_triple        %{rust_triple}
144 %define         rust_bootstrap_triple   %{rust_triple}
145 %else
146 %ifarch armv7hl armv7hnl
147 %define         rust_triple             armv7-unknown-linux-gnueabihf
148 %define         rust_host_triple        %{rust_triple}
149 %define         rust_bootstrap_triple   %{rust_triple}
150 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
151 %else
152 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
153 %define         rust_host_triple        %{rust_triple}
154 %define         rust_bootstrap_triple   %{rust_triple}
155 %endif
156 %endif
157 %endif
158
159 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
160
161 %if %{without bootstrap}
162 %define         local_rust_root %{_prefix}
163 %else
164 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
165 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
166 %endif
167
168 # We're going to override --libdir when configuring to get rustlib into a
169 # common path, but we'll fix the shared libraries during install.
170 # Without this ugly hack, rust would not be able to build itself
171 # for non-bootstrap build, lib64 is just too complicated for it.
172 %define         common_libdir   %{_prefix}/lib
173 %define         rustlibdir      %{common_libdir}/rustlib
174
175 # once_call/once_callable non-function libstdc++ symbols
176 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
177
178 # ALL Rust libraries are private, because they don't keep an ABI.
179 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
180 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
181
182 %define         x_py { \
183         x_py() { \
184                 local cmd="$1"; \
185                 shift; \
186                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
187         }; x_py }
188
189
190 %description
191 Rust is a systems programming language that runs blazingly fast,
192 prevents segfaults, and guarantees thread safety.
193
194 This package includes the Rust compiler, standard library, and
195 documentation generator.
196
197 %description -l pl.UTF-8
198 Rust to systemowy język programowania działający bardzo szybko,
199 zapobiegający naruszeniom ochrony pamięci i gwarantujący
200 bezpieczną wielowątkowość.
201
202 %package analysis
203 Summary:        Metadata about the standard library
204 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
205 Group:          Development/Tools
206 Requires:       %{name} = %{version}-%{release}
207
208 %description analysis
209 Metadata about the standard library.
210
211 %description analysis -l pl.UTF-8
212 Metadane o standardowej bibliotece.
213
214 %package std
215 Summary:        Standard library for Rust
216 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
217 Group:          Development/Tools
218 Requires:       %{name} = %{version}-%{release}
219
220 %description std
221 Standard library for Rust.
222
223 %description std -l pl.UTF-8
224 Standardowa biblioteka Rusta.
225
226 %package analyzer
227 Summary:        Implementation of Language Server Protocol for Rust
228 Summary(pl.UTF-8):      Implementacja Language Server Protocol dla Rusta
229 Group:          Development/Tools
230 Requires:       %{name} = %{version}-%{release}
231 Obsoletes:      rust-rls < 1.65.0
232
233 %description analyzer
234 Implementation of Language Server Protocol for Rust.
235
236 %description analyzer -l pl.UTF-8
237 Implementacja Language Server Protocol dla Rusta.
238
239 %package debugger-common
240 Summary:        Common debugger pretty printers for Rust
241 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
242 Group:          Development/Debuggers
243 BuildArch:      noarch
244
245 %description debugger-common
246 This package includes the common functionality for rust-gdb and
247 rust-lldb.
248
249 %description debugger-common -l pl.UTF-8
250 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
251
252 %package gdb
253 Summary:        GDB pretty printers for Rust
254 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
255 Group:          Development/Debuggers
256 Requires:       %{name}-debugger-common = %{version}-%{release}
257 Requires:       gdb
258 BuildArch:      noarch
259
260 %description gdb
261 This package includes the rust-gdb script, which allows easier
262 debugging of Rust programs.
263
264 %description gdb -l pl.UTF-8
265 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
266 odpluskwianie programów w języku Rust.
267
268 %package lldb
269 Summary:        LLDB pretty printers for Rust
270 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
271 Group:          Development/Debuggers
272 Requires:       %{name}-debugger-common = %{version}-%{release}
273 Requires:       lldb
274 BuildArch:      noarch
275
276 %description lldb
277 This package includes the rust-lldb script, which allows easier
278 debugging of Rust programs.
279
280 %description lldb -l pl.UTF-8
281 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
282 odpluskwianie programów w języku Rust.
283
284 %package doc
285 Summary:        Documentation for Rust
286 Summary(pl.UTF-8):      Dokumentacja do Rusta
287 Group:          Documentation
288 BuildArch:      noarch
289
290 %description doc
291 This package includes HTML documentation for the Rust programming
292 language and its standard library.
293
294 %description doc -l pl.UTF-8
295 Ten pakiet zawiera dokumentację w formacie HTML do języka
296 programowania Rust i jego biblioteki standardowej.
297
298 %package -n cargo
299 Summary:        Rust's package manager and build tool
300 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
301 Group:          Development/Tools
302 Requires:       %{name}%{?_isa}
303
304 %description -n cargo
305 Cargo is a tool that allows Rust projects to declare their various
306 dependencies and ensure that you'll always get a repeatable build.
307
308 %description -n cargo -l pl.UTF-8
309 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
310 zależności i zapewniające powtarzalność procesu budowania.
311
312 %package -n bash-completion-cargo
313 Summary:        Bash completion for cargo command
314 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
315 Group:          Applications/Shells
316 Requires:       %{name} = %{version}-%{release}
317 Requires:       bash-completion
318
319 %description -n bash-completion-cargo
320 Bash completion for cargo command.
321
322 %description -n bash-completion-cargo -l pl.UTF-8
323 Bashowe dopełnianie parametrów polecenia cargo.
324
325 %package -n zsh-completion-cargo
326 Summary:        Zsh completion for cargo command
327 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
328 Group:          Applications/Shells
329 Requires:       %{name} = %{version}-%{release}
330 Requires:       zsh
331
332 %description -n zsh-completion-cargo
333 Zsh completion for cargo command.
334
335 %description -n zsh-completion-cargo -l pl.UTF-8
336 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
337
338 %prep
339 %setup -q -n %{rustc_package}
340
341 %if %{with bootstrap}
342 %ifarch %{x8664} x32
343 tar xf %{SOURCE1}
344 %endif
345 %ifarch %{ix86}
346 tar xf %{SOURCE2}
347 %endif
348 %ifarch aarch64
349 tar xf %{SOURCE3}
350 %endif
351 %ifarch armv6hl
352 tar xf %{SOURCE4}
353 %endif
354 %ifarch armv7hl armv7hnl
355 tar xf %{SOURCE5}
356 %endif
357 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
358 %{bootstrap_root}-root/install.sh \
359         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
360         --prefix=%{local_rust_root} \
361         --disable-ldconfig
362 test -f %{local_rust_root}/bin/cargo
363 test -f %{local_rust_root}/bin/rustc
364 %endif
365
366 # unbundle
367 # We're disabling jemalloc, but rust-src still wants it.
368 #%{__rm} -r src/jemalloc
369 %if %{with system_llvm}
370 %{__rm} -r src/llvm-project
371 mkdir -p src/llvm-project/libunwind
372 %endif
373
374 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
375 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
376         src/etc/rust-gdb
377
378 # cargo has hardcoded libexec path - honour rpm _libexecdir
379 %if "%{_libexecdir}" != "%{_prefix}/libexec"
380 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
381 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
382         src/bootstrap/dist.rs \
383         src/tools/cargo/src/cargo/ops/registry/auth.rs
384 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
385 %endif
386
387 # The configure macro will modify some autoconf-related files, which upsets
388 # cargo when it tries to verify checksums in those files.  If we just truncate
389 # that file list, cargo won't have anything to complain about.
390 find vendor -name .cargo-checksum.json \
391         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
392
393 %build
394 export CC="%{__cc}"
395 export CXX="%{__cxx}"
396 export AR="%{__ar}"
397 %configure \
398         --build=%{rust_bootstrap_triple} \
399         --host=%{rust_host_triple} \
400         --target="%(echo %rust_targets | tr ' ' ,)" \
401         --libdir=%{common_libdir} \
402         --disable-codegen-tests \
403         --disable-debuginfo-lines \
404 %if %{with full_debuginfo}
405         --disable-debuginfo-only-std \
406         --enable-debuginfo \
407 %else
408         --enable-debuginfo-only-std \
409         --disable-debuginfo \
410 %endif
411         --disable-jemalloc \
412         --disable-option-checking \
413         --disable-rpath \
414         --enable-extended \
415         --enable-llvm-link-shared \
416         --enable-vendor \
417         --local-rust-root=%{local_rust_root} \
418         --llvm-root=%{_prefix} \
419         --release-channel=%{channel} \
420         --set=llvm.static-libstdcpp=false
421
422 export RUST_BACKTRACE=full
423 %x_py dist --verbose
424
425 %{?with_tests:%x_py test}
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429
430 export CC="%{__cc}"
431 export CXX="%{__cxx}"
432 export AR="%{__ar}"
433 export DESTDIR=$RPM_BUILD_ROOT
434 %x_py install
435
436 # Make sure the shared libraries are in the proper libdir
437 %if "%{_libdir}" != "%{common_libdir}"
438 mkdir -p %{buildroot}%{_libdir}
439 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
440         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
441 %endif
442
443 # The shared libraries should be executable for debuginfo extraction.
444 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
445
446 # The libdir libraries are identical to those under rustlib/.  It's easier on
447 # library loading if we keep them in libdir, but we do need them in rustlib/
448 # to support dynamic linking for compiler plugins, so we'll symlink.
449 for rust_target in %rust_targets; do
450         for l in libstd libtest ; do
451                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
452                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
453                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
454                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
455                 fi
456         done
457 done
458
459 # Remove installer artifacts (manifests, uninstall scripts, etc.)
460 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
461
462 # FIXME: __os_install_post will strip the rlibs
463 # -- should we find a way to preserve debuginfo?
464
465 # Remove unwanted documentation files (we already package them)
466 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
467 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
468 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
469 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
470
471 # Sanitize the HTML documentation
472 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
473 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
474
475 # Move rust-gdb's python scripts so they're noarch
476 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
477 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
478
479 # We don't need stdlib source
480 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
481
482 # Create the path for crate-devel packages
483 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 %post   -p /sbin/ldconfig
489 %postun -p /sbin/ldconfig
490
491 %files
492 %defattr(644,root,root,755)
493 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
494 %attr(755,root,root) %{_bindir}/rust-demangler
495 %attr(755,root,root) %{_bindir}/rustc
496 %attr(755,root,root) %{_bindir}/rustdoc
497 %attr(755,root,root) %{_bindir}/rustfmt
498 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
499 %attr(755,root,root) %{_libdir}/libstd-*.so
500 %attr(755,root,root) %{_libdir}/libtest-*.so
501 %{_mandir}/man1/rustc.1*
502 %{_mandir}/man1/rustdoc.1*
503 %dir %{rustlibdir}
504
505 %files analysis
506 %defattr(644,root,root,755)
507 %(for rust_target in %rust_targets; do
508 echo "%{rustlibdir}/$rust_target/analysis"
509 done
510 )
511
512 %files std
513 %defattr(644,root,root,755)
514 %(for rust_target in %rust_targets; do
515 cat <<EOF
516 %dir %{rustlibdir}/$rust_target
517 %dir %{rustlibdir}/$rust_target/lib
518 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
519 %{rustlibdir}/$rust_target/lib/*.rlib
520 EOF
521 done
522 )
523
524 %files analyzer
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_bindir}/rust-analyzer
527 %attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
528
529 %files debugger-common
530 %defattr(644,root,root,755)
531 %dir %{_datadir}/%{name}
532 %dir %{_datadir}/%{name}/etc
533 %{_datadir}/%{name}/etc/lldb_commands
534 %{_datadir}/%{name}/etc/rust_types.py
535
536 %files lldb
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_bindir}/rust-lldb
539 %{_datadir}/%{name}/etc/lldb_*.py*
540
541 %files gdb
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_bindir}/rust-gdb
544 %attr(755,root,root) %{_bindir}/rust-gdbgui
545 %{_datadir}/%{name}/etc/gdb_*.py*
546
547 %files doc
548 %defattr(644,root,root,755)
549 %dir %{_docdir}/%{name}
550 %doc %{_docdir}/%{name}/html
551
552 %files -n cargo
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_bindir}/cargo
555 %attr(755,root,root) %{_bindir}/cargo-clippy
556 %attr(755,root,root) %{_bindir}/cargo-fmt
557 %attr(755,root,root) %{_bindir}/clippy-driver
558 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
559 %{_mandir}/man1/cargo*.1*
560 %dir %{_datadir}/cargo
561 %dir %{_datadir}/cargo/registry
562
563 %files -n bash-completion-cargo
564 %defattr(644,root,root,755)
565 %{_sysconfdir}/bash_completion.d/cargo
566
567 %files -n zsh-completion-cargo
568 %defattr(644,root,root,755)
569 %{zsh_compdir}/_cargo
This page took 0.092754 seconds and 3 git commands to generate.