]> git.pld-linux.org Git - packages/qemu.git/commitdiff
- enabled GlusterFS backend and RDMA migration support auto/ti/qemu-1.6.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 19 Aug 2013 19:47:22 +0000 (21:47 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 19 Aug 2013 19:47:22 +0000 (21:47 +0200)
qemu.spec

index 50eb13b292fd87f874a09e7feb96953f8725c87c..a0aad107ca646b1b0fd8099579e65b7676b0201d 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,6 +1,5 @@
 # TODO:
 # - merge missing bits from qemu-kvm
-# - --enable-glusterfs when glusterfs 3.4 is out
 # - qemu-system-ppc -hda ac-ppc.img says:
 #   qemu: could not open disk image ac-ppc.img: error "Success"
 #   qemu-0.12.2-2.x86_64.rpm - broken
@@ -12,7 +11,8 @@
 %bcond_without sdl             # SDL UI and audio support
 %bcond_without glx             # OpenGL/GLX support
 %bcond_without ceph            # Ceph/RBD support
-%bcond_with    glusterfs       # GlusterFS backend
+%bcond_without glusterfs       # GlusterFS backend
+%bcond_without rdma            # RDMA-based migration support
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
@@ -54,9 +54,11 @@ BuildRequires:       libcacard-devel
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
 BuildRequires: libfdt-devel
+%{?with_rdma:BuildRequires:    libibverbs-devel}
 BuildRequires: libiscsi-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
+%{?with_rdma:BuildRequires:    librdmacm-devel}
 BuildRequires: libseccomp-devel
 BuildRequires: libssh2-devel >= 1.2.8
 # for usb passthrough, when available
@@ -550,6 +552,7 @@ ln -s ../error.h qapi/error.h
        --enable-mixemu \
        %{__enable_disable glx} \
        %{__enable_disable ceph rbd} \
+       %{__enable_disable rdma} \
        %{__enable_disable sdl} \
        --enable-seccomp \
        %{__enable_disable spice} \
This page took 0.088322 seconds and 4 git commands to generate.