]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
50eb13b292fd87f874a09e7feb96953f8725c87c
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 # - --enable-glusterfs when glusterfs 3.4 is out
4 # - qemu-system-ppc -hda ac-ppc.img says:
5 #   qemu: could not open disk image ac-ppc.img: error "Success"
6 #   qemu-0.12.2-2.x86_64.rpm - broken
7 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
8 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
9 #   qemu-0.11.1-*.x86_64.rpm - OK
10 #
11 # Conditional build:
12 %bcond_without  sdl             # SDL UI and audio support
13 %bcond_without  glx             # OpenGL/GLX support
14 %bcond_without  ceph            # Ceph/RBD support
15 %bcond_with     glusterfs       # GlusterFS backend
16 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
17 %bcond_without  spice           # SPICE support
18 %bcond_with     esd             # EsounD audio support
19 %bcond_without  oss             # OSS audio support
20 %bcond_without  pulseaudio      # PulseAudio audio support
21 %bcond_without  xen             # Xen backend driver support
22
23 Summary:        QEMU CPU Emulator
24 Summary(pl.UTF-8):      QEMU - emulator procesora
25 Name:           qemu
26 Version:        1.6.0
27 Release:        1
28 License:        GPL v2+
29 Group:          Applications/Emulators
30 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
31 # Source0-md5:  f3f39308472d629aca57a255a0c91ba9
32 Patch0:         %{name}-cflags.patch
33 Patch1:         vgabios-widescreens.patch
34 Patch2:         %{name}-whitelist.patch
35 Patch3:         %{name}-system-libcacard.patch
36 # Proof of concept, for reference, do not remove
37 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
38 URL:            http://www.qemu-project.org/
39 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
40 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
41 BuildRequires:  alsa-lib-devel
42 BuildRequires:  bcc
43 BuildRequires:  bluez-libs-devel
44 BuildRequires:  brlapi-devel
45 %{?with_ceph:BuildRequires:     ceph-devel}
46 BuildRequires:  curl-devel
47 BuildRequires:  cyrus-sasl-devel >= 2
48 %{?with_esd:BuildRequires:      esound-devel}
49 BuildRequires:  glib2-devel >= 1:2.12
50 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
51 BuildRequires:  gnutls-devel
52 BuildRequires:  libaio-devel
53 BuildRequires:  libcacard-devel
54 BuildRequires:  libcap-devel
55 BuildRequires:  libcap-ng-devel
56 BuildRequires:  libfdt-devel
57 BuildRequires:  libiscsi-devel
58 BuildRequires:  libjpeg-devel
59 BuildRequires:  libpng-devel
60 BuildRequires:  libseccomp-devel
61 BuildRequires:  libssh2-devel >= 1.2.8
62 # for usb passthrough, when available
63 #BuildRequires: libusb-devel >= 1.0.13
64 BuildRequires:  libuuid-devel
65 BuildRequires:  ncurses-devel
66 BuildRequires:  nss-devel >= 3.12.8
67 BuildRequires:  perl-Encode
68 BuildRequires:  perl-tools-pod
69 BuildRequires:  pkgconfig
70 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
71 BuildRequires:  rpmbuild(macros) >= 1.202
72 BuildRequires:  sed >= 4.0
73 %if %{with spice}
74 BuildRequires:  spice-protocol >= 0.12.0
75 BuildRequires:  spice-server-devel >= 0.12.0
76 %endif
77 BuildRequires:  texi2html
78 BuildRequires:  texinfo
79 BuildRequires:  usbredir-devel >= 0.6
80 BuildRequires:  vde2-devel
81 BuildRequires:  which
82 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
83 BuildRequires:  xfsprogs-devel
84 BuildRequires:  xorg-lib-libX11-devel
85 BuildRequires:  zlib-devel
86 %if %{with gtk2}
87 BuildRequires:  gtk+2-devel >= 2:2.18.0
88 BuildRequires:  vte0-devel >= 0.24.0
89 %else
90 BuildRequires:  gtk+3-devel >= 3.0.0
91 BuildRequires:  vte-devel >= 0.32.0
92 %endif
93 Requires:       %{name}-img = %{version}-%{release}
94 Requires:       %{name}-system-alpha = %{version}-%{release}
95 Requires:       %{name}-system-arm = %{version}-%{release}
96 Requires:       %{name}-system-cris = %{version}-%{release}
97 Requires:       %{name}-system-lm32 = %{version}-%{release}
98 Requires:       %{name}-system-m68k = %{version}-%{release}
99 Requires:       %{name}-system-microblaze = %{version}-%{release}
100 Requires:       %{name}-system-mips = %{version}-%{release}
101 Requires:       %{name}-system-moxie = %{version}-%{release}
102 Requires:       %{name}-system-or32 = %{version}-%{release}
103 Requires:       %{name}-system-ppc = %{version}-%{release}
104 Requires:       %{name}-system-s390x = %{version}-%{release}
105 Requires:       %{name}-system-sh4 = %{version}-%{release}
106 Requires:       %{name}-system-sparc = %{version}-%{release}
107 Requires:       %{name}-system-unicore32 = %{version}-%{release}
108 Requires:       %{name}-system-x86 = %{version}-%{release}
109 Requires:       %{name}-system-xtensa = %{version}-%{release}
110 Requires:       %{name}-user = %{version}-%{release}
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define systempkg_req \
114 Requires:       SDL >= 1.2.1 \
115 Requires:       usbredir >= 0.6 \
116 %if %{with gtk2} \
117 Requires:       gtk+2 >= 2:2.18.0 \
118 Requires:       vte0 >= 0.24.0 \
119 %else \
120 Requires:       gtk+3 >= 3.0.0 \
121 Requires:       vte >= 0.32.0 \
122 %endif
123
124 # some PPC/SPARC boot image in ELF format
125 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
126
127 %description
128 QEMU is a FAST! processor emulator. By using dynamic translation it
129 achieves a reasonnable speed while being easy to port on new host
130 CPUs. QEMU has two operating modes:
131
132 - User mode emulation. In this mode, QEMU can launch Linux processes
133   compiled for one CPU on another CPU. Linux system calls are converted
134   because of endianness and 32/64 bit mismatches. Wine (Windows
135   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
136
137 - Full system emulation. In this mode, QEMU emulates a full system,
138   including a processor and various peripherials. It can also be used to
139   provide virtual hosting of several virtual PC on a single server.
140
141 %description -l pl.UTF-8
142 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
143 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
144 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
145
146 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
147   procesy linuksowe skompilowane dla jednego procesora na innym
148   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
149   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
150   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
151   cele QEMU.
152
153 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
154   włączając w to procesor i różne urządzenia peryferyjne. Może być także
155   używane do wirtualnego hostowania kilku wirtualnych pecetów na
156   pojedynczym serwerze.
157
158 %package common
159 Summary:        QEMU common files needed by all QEMU targets
160 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
161 Group:          Development/Tools
162 Requires(postun):       /usr/sbin/groupdel
163 Requires(postun):       /usr/sbin/userdel
164 Requires(pre):  /bin/id
165 Requires(pre):  /usr/bin/getgid
166 Requires(pre):  /usr/sbin/groupadd
167 Requires(pre):  /usr/sbin/useradd
168 Requires:       glib2 >= 1:2.12
169 Requires:       libssh2 >= 1.2.8
170 Provides:       group(qemu)
171 Provides:       user(qemu)
172 Conflicts:      qemu < 1.0-2
173
174 %description common
175 QEMU is a generic and open source processor emulator which achieves a
176 good emulation speed by using dynamic translation.
177
178 This package provides the common files needed by all QEMU targets.
179
180 %description common -l pl.UTF-8
181 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
182 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
183
184 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
185 środowiska QEMU.
186
187 %package img
188 Summary:        QEMU command line tool for manipulating disk images
189 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
190 Group:          Development/Tools
191 Conflicts:      qemu < 1.0-2
192
193 %description img
194 This package provides a command line tool for manipulating disk
195 images.
196
197 %description img -l pl.UTF-8
198 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
199 na obrazach dysków.
200
201 %package user
202 Summary:        QEMU user mode emulation of qemu targets
203 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
204 Group:          Development/Tools
205 Requires:       %{name}-common = %{version}-%{release}
206
207 %description user
208 QEMU is a generic and open source processor emulator which achieves a
209 good emulation speed by using dynamic translation.
210
211 This package provides the user mode emulation of QEMU targets.
212
213 %description user -l pl.UTF-8
214 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
215 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
216
217 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
218
219 %package system-alpha
220 Summary:        QEMU system emulator for Alpha
221 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
222 Group:          Development/Tools
223 Requires:       %{name}-common = %{version}-%{release}
224 %systempkg_req
225
226 %description system-alpha
227 QEMU is a generic and open source processor emulator which achieves a
228 good emulation speed by using dynamic translation.
229
230 This package provides the system emulator with Alpha CPU.
231
232 %description system-alpha -l pl.UTF-8
233 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
234 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
235
236 Ten pakiet zawiera emulator systemu z procesorem Alpha.
237
238 %package system-arm
239 Summary:        QEMU system emulator for ARM
240 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
241 Group:          Development/Tools
242 Requires:       %{name}-common = %{version}-%{release}
243 %systempkg_req
244
245 %description system-arm
246 QEMU is a generic and open source processor emulator which achieves a
247 good emulation speed by using dynamic translation.
248
249 This package provides the system emulator for ARM.
250
251 %description system-arm -l pl.UTF-8
252 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
253 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
254
255 Ten pakiet zawiera emulator systemu z procesorem ARM.
256
257 %package system-cris
258 Summary:        QEMU system emulator for CRIS
259 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
260 Group:          Development/Tools
261 Requires:       %{name}-common = %{version}-%{release}
262 %systempkg_req
263
264 %description system-cris
265 QEMU is a generic and open source processor emulator which achieves a
266 good emulation speed by using dynamic translation.
267
268 This package provides the system emulator with CRIS CPU.
269
270 %description system-cris -l pl.UTF-8
271 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
272 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
273
274 Ten pakiet zawiera emulator systemu z procesorem CRIS.
275
276 %package system-lm32
277 Summary:        QEMU system emulator for LM32
278 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
279 Group:          Development/Tools
280 Requires:       %{name}-common = %{version}-%{release}
281 %systempkg_req
282
283 %description system-lm32
284 QEMU is a generic and open source processor emulator which achieves a
285 good emulation speed by using dynamic translation.
286
287 This package provides the system emulator with LM32 CPU.
288
289 %description system-lm32 -l pl.UTF-8
290 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
291 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
292
293 Ten pakiet zawiera emulator systemu z procesorem LM32.
294
295 %package system-m68k
296 Summary:        QEMU system emulator for m68k
297 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
298 Group:          Development/Tools
299 Requires:       %{name}-common = %{version}-%{release}
300 %systempkg_req
301
302 %description system-m68k
303 QEMU is a generic and open source processor emulator which achieves a
304 good emulation speed by using dynamic translation.
305
306 This package provides the system emulator with m68k CPU.
307
308 %description system-m68k -l pl.UTF-8
309 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
310 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
311
312 Ten pakiet zawiera emulator systemu z procesorem m68k.
313
314 %package system-microblaze
315 Summary:        QEMU system emulator for MicroBlaze
316 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
317 Group:          Development/Tools
318 Requires:       %{name}-common = %{version}-%{release}
319 %systempkg_req
320
321 %description system-microblaze
322 QEMU is a generic and open source processor emulator which achieves a
323 good emulation speed by using dynamic translation.
324
325 This package provides the system emulator with MicroBlaze CPU.
326
327 %description system-microblaze -l pl.UTF-8
328 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
329 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
330
331 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
332
333 %package system-mips
334 Summary:        QEMU system emulator for MIPS
335 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
336 Group:          Development/Tools
337 Requires:       %{name}-common = %{version}-%{release}
338 %systempkg_req
339
340 %description system-mips
341 QEMU is a generic and open source processor emulator which achieves a
342 good emulation speed by using dynamic translation.
343
344 This package provides the system emulator with MIPS CPU.
345
346 %description system-mips -l pl.UTF-8
347 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
348 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
349
350 Ten pakiet zawiera emulator systemu z procesorem MIPS.
351
352 %package system-moxie
353 Summary:        QEMU system emulator for Moxie
354 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
355 Group:          Development/Tools
356 Requires:       %{name}-common = %{version}-%{release}
357 %systempkg_req
358
359 %description system-moxie
360 QEMU is a generic and open source processor emulator which achieves a
361 good emulation speed by using dynamic translation.
362
363 This package provides the system emulator with Moxie CPU.
364
365 %description system-moxie -l pl.UTF-8
366 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
367 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
368
369 Ten pakiet zawiera emulator systemu z procesorem Moxie.
370
371 %package system-or32
372 Summary:        QEMU system emulator for OpenRISC
373 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
374 Group:          Development/Tools
375 Requires:       %{name}-common = %{version}-%{release}
376 %systempkg_req
377
378 %description system-or32
379 QEMU is a generic and open source processor emulator which achieves a
380 good emulation speed by using dynamic translation.
381
382 This package provides the system emulator with OpenRISC CPU.
383
384 %description system-or32 -l pl.UTF-8
385 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
386 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
387
388 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
389
390 %package system-ppc
391 Summary:        QEMU system emulator for PowerPC
392 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
393 Group:          Development/Tools
394 Requires:       %{name}-common = %{version}-%{release}
395 %systempkg_req
396
397 %description system-ppc
398 QEMU is a generic and open source processor emulator which achieves a
399 good emulation speed by using dynamic translation.
400
401 This package provides the system emulator with PowerPC CPU.
402
403 %description system-ppc -l pl.UTF-8
404 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
405 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
406
407 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
408
409 %package system-s390x
410 Summary:        QEMU system emulator for S390
411 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
412 Group:          Development/Tools
413 Requires:       %{name}-common = %{version}-%{release}
414 %systempkg_req
415
416 %description system-s390x
417 QEMU is a generic and open source processor emulator which achieves a
418 good emulation speed by using dynamic translation.
419
420 This package provides the system emulator with S390 CPU.
421
422 %description system-s390x -l pl.UTF-8
423 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
424 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
425
426 Ten pakiet zawiera emulator systemu z procesorem S390.
427
428 %package system-sh4
429 Summary:        QEMU system emulator for SH4
430 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
431 Group:          Development/Tools
432 Requires:       %{name}-common = %{version}-%{release}
433 %systempkg_req
434
435 %description system-sh4
436 QEMU is a generic and open source processor emulator which achieves a
437 good emulation speed by using dynamic translation.
438
439 This package provides the system emulator with SH4 CPU.
440
441 %description system-sh4 -l pl.UTF-8
442 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
443 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
444
445 Ten pakiet zawiera emulator systemu z procesorem SH4.
446
447 %package system-sparc
448 Summary:        QEMU system emulator for SPARC
449 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
450 Group:          Development/Tools
451 Requires:       %{name}-common = %{version}-%{release}
452 %systempkg_req
453
454 %description system-sparc
455 QEMU is a generic and open source processor emulator which achieves a
456 good emulation speed by using dynamic translation.
457
458 This package provides the system emulator with SPARC/SPARC64 CPU.
459
460 %description system-sparc -l pl.UTF-8
461 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
462 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
463
464 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
465
466 %package system-unicore32
467 Summary:        QEMU system emulator for UniCore32
468 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
469 Group:          Development/Tools
470 Requires:       %{name}-common = %{version}-%{release}
471 %systempkg_req
472
473 %description system-unicore32
474 QEMU is a generic and open source processor emulator which achieves a
475 good emulation speed by using dynamic translation.
476
477 This package provides the system emulator with UniCore32 CPU.
478
479 %description system-unicore32 -l pl.UTF-8
480 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
481 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
482
483 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
484
485 %package system-x86
486 Summary:        QEMU system emulator for x86
487 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
488 Group:          Development/Tools
489 Requires:       %{name}-common = %{version}-%{release}
490 %systempkg_req
491
492 %description system-x86
493 QEMU is a generic and open source processor emulator which achieves a
494 good emulation speed by using dynamic translation.
495
496 %description system-x86 -l pl.UTF-8
497 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
498 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
499
500 %package system-xtensa
501 Summary:        QEMU system emulator for Xtensa
502 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
503 Group:          Development/Tools
504 Requires:       %{name}-common = %{version}-%{release}
505 %systempkg_req
506
507 %description system-xtensa
508 QEMU is a generic and open source processor emulator which achieves a
509 good emulation speed by using dynamic translation.
510
511 This package provides the system emulator with Xtensa CPU.
512
513 %description system-xtensa -l pl.UTF-8
514 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
515 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
516
517 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
518
519 %prep
520 %setup -q
521 %patch0 -p1
522 %patch1 -p1
523 %patch2 -p0
524 %patch3 -p1
525
526 %{__mv} libcacard libcacard-use-system-lib
527
528 # workaround for conflict with alsa/error.h
529 ln -s ../error.h qapi/error.h
530
531 %build
532 ./configure \
533         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
534         --extra-ldflags="%{rpmldflags}" \
535         --prefix=%{_prefix} \
536         --sysconfdir=%{_sysconfdir} \
537         --cc="%{__cc}" \
538         --host-cc="%{__cc}" \
539         --disable-strip \
540         --enable-attr \
541         --enable-bluez \
542         --enable-brlapi \
543         --enable-cap-ng \
544         --enable-curl \
545         --enable-curses \
546         --enable-docs \
547         --enable-fdt \
548         %{__enable_disable glusterfs} \
549         --enable-libiscsi \
550         --enable-mixemu \
551         %{__enable_disable glx} \
552         %{__enable_disable ceph rbd} \
553         %{__enable_disable sdl} \
554         --enable-seccomp \
555         %{__enable_disable spice} \
556         --enable-smartcard-nss \
557         --enable-tpm \
558         --enable-usb-redir \
559         --enable-uuid \
560         --enable-vde \
561         --enable-virtfs \
562         --enable-vnc-jpeg \
563         --enable-vnc-png \
564         --enable-vnc-sasl \
565         --enable-vnc-tls \
566         %{__enable_disable xen} \
567         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
568         --interp-prefix=%{_libdir}/qemu/lib-%%M \
569         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
570
571 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
572 # --libexecdir in configure is nop
573 %{__make} \
574         V=1 \
575         CONFIG_QEMU_HELPERDIR="%{_libdir}"
576
577 # rebuild patched vesa tables with additional widescreen modes.
578 %{__make} -C roms/vgabios stdvga-bios
579
580 %install
581 rm -rf $RPM_BUILD_ROOT
582
583 %{__make} install \
584         DESTDIR=$RPM_BUILD_ROOT \
585         libexecdir=%{_libdir}
586
587 install -d $RPM_BUILD_ROOT%{_sysconfdir}
588 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
589 #!/bin/sh
590
591 EOF
592
593 # already packaged
594 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
595 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
596
597 # install patched vesa tables with additional widescreen modes.
598 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
599
600 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
601 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
602 %find_lang %{name}
603
604 %clean
605 rm -rf $RPM_BUILD_ROOT
606
607 %pre common
608 %groupadd -g 276 qemu
609 %useradd -u 276 -g qemu -c "QEMU User" qemu
610
611 %postun common
612 if [ "$1" = "0" ]; then
613         %userremove qemu
614         %groupremove qemu
615 fi
616
617 %files
618 %defattr(644,root,root,755)
619
620 %files common -f %{name}.lang
621 %defattr(644,root,root,755)
622 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
623 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
624 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
625 %dir %{_sysconfdir}/qemu
626 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
627 %attr(755,root,root) %{_bindir}/qemu-nbd
628 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
629 %{_mandir}/man1/qemu.1*
630 %{_mandir}/man1/virtfs-proxy-helper.1*
631 %{_mandir}/man8/qemu-nbd.8*
632
633 %dir %{_datadir}/qemu
634 %{_datadir}/%{name}/keymaps
635 %{_datadir}/%{name}/qemu-icon.bmp
636 # various bios images
637 %{_datadir}/%{name}/*.aml
638 %{_datadir}/%{name}/*.bin
639 %{_datadir}/%{name}/*.rom
640 %{_datadir}/%{name}/*.dtb
641 %{_datadir}/%{name}/qemu_logo_no_text.svg
642 %{_datadir}/%{name}/openbios-ppc
643 %{_datadir}/%{name}/openbios-sparc*
644 %{_datadir}/%{name}/palcode-clipper
645 %{_datadir}/%{name}/s390-ccw.img
646
647 %files img
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_bindir}/qemu-img
650 %{_mandir}/man1/qemu-img.1*
651
652 %files user
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_bindir}/qemu-alpha
655 %attr(755,root,root) %{_bindir}/qemu-arm
656 %attr(755,root,root) %{_bindir}/qemu-armeb
657 %attr(755,root,root) %{_bindir}/qemu-cris
658 %attr(755,root,root) %{_bindir}/qemu-ga
659 %attr(755,root,root) %{_bindir}/qemu-i386
660 %attr(755,root,root) %{_bindir}/qemu-io
661 %attr(755,root,root) %{_bindir}/qemu-m68k
662 %attr(755,root,root) %{_bindir}/qemu-microblaze
663 %attr(755,root,root) %{_bindir}/qemu-microblazeel
664 %attr(755,root,root) %{_bindir}/qemu-mips
665 %attr(755,root,root) %{_bindir}/qemu-mipsel
666 %attr(755,root,root) %{_bindir}/qemu-mips64
667 %attr(755,root,root) %{_bindir}/qemu-mips64el
668 %attr(755,root,root) %{_bindir}/qemu-mipsn32
669 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
670 %attr(755,root,root) %{_bindir}/qemu-or32
671 %attr(755,root,root) %{_bindir}/qemu-ppc
672 %attr(755,root,root) %{_bindir}/qemu-ppc64
673 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
674 %attr(755,root,root) %{_bindir}/qemu-s390x
675 %attr(755,root,root) %{_bindir}/qemu-sh4
676 %attr(755,root,root) %{_bindir}/qemu-sh4eb
677 %attr(755,root,root) %{_bindir}/qemu-sparc
678 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
679 %attr(755,root,root) %{_bindir}/qemu-sparc64
680 %attr(755,root,root) %{_bindir}/qemu-unicore32
681 %attr(755,root,root) %{_bindir}/qemu-x86_64
682
683 %files system-alpha
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_bindir}/qemu-system-alpha
686
687 %files system-arm
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_bindir}/qemu-system-arm
690
691 %files system-cris
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_bindir}/qemu-system-cris
694
695 %files system-lm32
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_bindir}/qemu-system-lm32
698
699 %files system-m68k
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_bindir}/qemu-system-m68k
702
703 %files system-microblaze
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
706 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
707
708 %files system-mips
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/qemu-system-mips
711 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
712 %attr(755,root,root) %{_bindir}/qemu-system-mips64
713 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
714
715 %files system-moxie
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_bindir}/qemu-system-moxie
718
719 %files system-or32
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_bindir}/qemu-system-or32
722
723 %files system-ppc
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_bindir}/qemu-system-ppc
726 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
727 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
728
729 %files system-s390x
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_bindir}/qemu-system-s390x
732
733 %files system-sh4
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_bindir}/qemu-system-sh4
736 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
737
738 %files system-sparc
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_bindir}/qemu-system-sparc
741 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
742
743 %files system-unicore32
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
746
747 %files system-x86
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_bindir}/qemu-system-i386
750 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
751
752 %files system-xtensa
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
755 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.0976590000000001 seconds and 2 git commands to generate.