]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- enabled GlusterFS backend and RDMA migration support
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: error "Success"
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8 #   qemu-0.11.1-*.x86_64.rpm - OK
9 #
10 # Conditional build:
11 %bcond_without  sdl             # SDL UI and audio support
12 %bcond_without  glx             # OpenGL/GLX support
13 %bcond_without  ceph            # Ceph/RBD support
14 %bcond_without  glusterfs       # GlusterFS backend
15 %bcond_without  rdma            # RDMA-based migration support
16 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
17 %bcond_without  spice           # SPICE support
18 %bcond_with     esd             # EsounD audio support
19 %bcond_without  oss             # OSS audio support
20 %bcond_without  pulseaudio      # PulseAudio audio support
21 %bcond_without  xen             # Xen backend driver support
22
23 Summary:        QEMU CPU Emulator
24 Summary(pl.UTF-8):      QEMU - emulator procesora
25 Name:           qemu
26 Version:        1.6.0
27 Release:        1
28 License:        GPL v2+
29 Group:          Applications/Emulators
30 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
31 # Source0-md5:  f3f39308472d629aca57a255a0c91ba9
32 Patch0:         %{name}-cflags.patch
33 Patch1:         vgabios-widescreens.patch
34 Patch2:         %{name}-whitelist.patch
35 Patch3:         %{name}-system-libcacard.patch
36 # Proof of concept, for reference, do not remove
37 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
38 URL:            http://www.qemu-project.org/
39 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
40 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
41 BuildRequires:  alsa-lib-devel
42 BuildRequires:  bcc
43 BuildRequires:  bluez-libs-devel
44 BuildRequires:  brlapi-devel
45 %{?with_ceph:BuildRequires:     ceph-devel}
46 BuildRequires:  curl-devel
47 BuildRequires:  cyrus-sasl-devel >= 2
48 %{?with_esd:BuildRequires:      esound-devel}
49 BuildRequires:  glib2-devel >= 1:2.12
50 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
51 BuildRequires:  gnutls-devel
52 BuildRequires:  libaio-devel
53 BuildRequires:  libcacard-devel
54 BuildRequires:  libcap-devel
55 BuildRequires:  libcap-ng-devel
56 BuildRequires:  libfdt-devel
57 %{?with_rdma:BuildRequires:     libibverbs-devel}
58 BuildRequires:  libiscsi-devel
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libpng-devel
61 %{?with_rdma:BuildRequires:     librdmacm-devel}
62 BuildRequires:  libseccomp-devel
63 BuildRequires:  libssh2-devel >= 1.2.8
64 # for usb passthrough, when available
65 #BuildRequires: libusb-devel >= 1.0.13
66 BuildRequires:  libuuid-devel
67 BuildRequires:  ncurses-devel
68 BuildRequires:  nss-devel >= 3.12.8
69 BuildRequires:  perl-Encode
70 BuildRequires:  perl-tools-pod
71 BuildRequires:  pkgconfig
72 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
73 BuildRequires:  rpmbuild(macros) >= 1.202
74 BuildRequires:  sed >= 4.0
75 %if %{with spice}
76 BuildRequires:  spice-protocol >= 0.12.0
77 BuildRequires:  spice-server-devel >= 0.12.0
78 %endif
79 BuildRequires:  texi2html
80 BuildRequires:  texinfo
81 BuildRequires:  usbredir-devel >= 0.6
82 BuildRequires:  vde2-devel
83 BuildRequires:  which
84 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
85 BuildRequires:  xfsprogs-devel
86 BuildRequires:  xorg-lib-libX11-devel
87 BuildRequires:  zlib-devel
88 %if %{with gtk2}
89 BuildRequires:  gtk+2-devel >= 2:2.18.0
90 BuildRequires:  vte0-devel >= 0.24.0
91 %else
92 BuildRequires:  gtk+3-devel >= 3.0.0
93 BuildRequires:  vte-devel >= 0.32.0
94 %endif
95 Requires:       %{name}-img = %{version}-%{release}
96 Requires:       %{name}-system-alpha = %{version}-%{release}
97 Requires:       %{name}-system-arm = %{version}-%{release}
98 Requires:       %{name}-system-cris = %{version}-%{release}
99 Requires:       %{name}-system-lm32 = %{version}-%{release}
100 Requires:       %{name}-system-m68k = %{version}-%{release}
101 Requires:       %{name}-system-microblaze = %{version}-%{release}
102 Requires:       %{name}-system-mips = %{version}-%{release}
103 Requires:       %{name}-system-moxie = %{version}-%{release}
104 Requires:       %{name}-system-or32 = %{version}-%{release}
105 Requires:       %{name}-system-ppc = %{version}-%{release}
106 Requires:       %{name}-system-s390x = %{version}-%{release}
107 Requires:       %{name}-system-sh4 = %{version}-%{release}
108 Requires:       %{name}-system-sparc = %{version}-%{release}
109 Requires:       %{name}-system-unicore32 = %{version}-%{release}
110 Requires:       %{name}-system-x86 = %{version}-%{release}
111 Requires:       %{name}-system-xtensa = %{version}-%{release}
112 Requires:       %{name}-user = %{version}-%{release}
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define systempkg_req \
116 Requires:       SDL >= 1.2.1 \
117 Requires:       usbredir >= 0.6 \
118 %if %{with gtk2} \
119 Requires:       gtk+2 >= 2:2.18.0 \
120 Requires:       vte0 >= 0.24.0 \
121 %else \
122 Requires:       gtk+3 >= 3.0.0 \
123 Requires:       vte >= 0.32.0 \
124 %endif
125
126 # some PPC/SPARC boot image in ELF format
127 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
128
129 %description
130 QEMU is a FAST! processor emulator. By using dynamic translation it
131 achieves a reasonnable speed while being easy to port on new host
132 CPUs. QEMU has two operating modes:
133
134 - User mode emulation. In this mode, QEMU can launch Linux processes
135   compiled for one CPU on another CPU. Linux system calls are converted
136   because of endianness and 32/64 bit mismatches. Wine (Windows
137   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
138
139 - Full system emulation. In this mode, QEMU emulates a full system,
140   including a processor and various peripherials. It can also be used to
141   provide virtual hosting of several virtual PC on a single server.
142
143 %description -l pl.UTF-8
144 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
145 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
146 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
147
148 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
149   procesy linuksowe skompilowane dla jednego procesora na innym
150   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
151   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
152   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
153   cele QEMU.
154
155 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
156   włączając w to procesor i różne urządzenia peryferyjne. Może być także
157   używane do wirtualnego hostowania kilku wirtualnych pecetów na
158   pojedynczym serwerze.
159
160 %package common
161 Summary:        QEMU common files needed by all QEMU targets
162 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
163 Group:          Development/Tools
164 Requires(postun):       /usr/sbin/groupdel
165 Requires(postun):       /usr/sbin/userdel
166 Requires(pre):  /bin/id
167 Requires(pre):  /usr/bin/getgid
168 Requires(pre):  /usr/sbin/groupadd
169 Requires(pre):  /usr/sbin/useradd
170 Requires:       glib2 >= 1:2.12
171 Requires:       libssh2 >= 1.2.8
172 Provides:       group(qemu)
173 Provides:       user(qemu)
174 Conflicts:      qemu < 1.0-2
175
176 %description common
177 QEMU is a generic and open source processor emulator which achieves a
178 good emulation speed by using dynamic translation.
179
180 This package provides the common files needed by all QEMU targets.
181
182 %description common -l pl.UTF-8
183 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
184 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
185
186 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
187 środowiska QEMU.
188
189 %package img
190 Summary:        QEMU command line tool for manipulating disk images
191 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
192 Group:          Development/Tools
193 Conflicts:      qemu < 1.0-2
194
195 %description img
196 This package provides a command line tool for manipulating disk
197 images.
198
199 %description img -l pl.UTF-8
200 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
201 na obrazach dysków.
202
203 %package user
204 Summary:        QEMU user mode emulation of qemu targets
205 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
206 Group:          Development/Tools
207 Requires:       %{name}-common = %{version}-%{release}
208
209 %description user
210 QEMU is a generic and open source processor emulator which achieves a
211 good emulation speed by using dynamic translation.
212
213 This package provides the user mode emulation of QEMU targets.
214
215 %description user -l pl.UTF-8
216 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
217 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
218
219 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
220
221 %package system-alpha
222 Summary:        QEMU system emulator for Alpha
223 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
224 Group:          Development/Tools
225 Requires:       %{name}-common = %{version}-%{release}
226 %systempkg_req
227
228 %description system-alpha
229 QEMU is a generic and open source processor emulator which achieves a
230 good emulation speed by using dynamic translation.
231
232 This package provides the system emulator with Alpha CPU.
233
234 %description system-alpha -l pl.UTF-8
235 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
236 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
237
238 Ten pakiet zawiera emulator systemu z procesorem Alpha.
239
240 %package system-arm
241 Summary:        QEMU system emulator for ARM
242 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
243 Group:          Development/Tools
244 Requires:       %{name}-common = %{version}-%{release}
245 %systempkg_req
246
247 %description system-arm
248 QEMU is a generic and open source processor emulator which achieves a
249 good emulation speed by using dynamic translation.
250
251 This package provides the system emulator for ARM.
252
253 %description system-arm -l pl.UTF-8
254 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
255 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
256
257 Ten pakiet zawiera emulator systemu z procesorem ARM.
258
259 %package system-cris
260 Summary:        QEMU system emulator for CRIS
261 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
262 Group:          Development/Tools
263 Requires:       %{name}-common = %{version}-%{release}
264 %systempkg_req
265
266 %description system-cris
267 QEMU is a generic and open source processor emulator which achieves a
268 good emulation speed by using dynamic translation.
269
270 This package provides the system emulator with CRIS CPU.
271
272 %description system-cris -l pl.UTF-8
273 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
274 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
275
276 Ten pakiet zawiera emulator systemu z procesorem CRIS.
277
278 %package system-lm32
279 Summary:        QEMU system emulator for LM32
280 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
281 Group:          Development/Tools
282 Requires:       %{name}-common = %{version}-%{release}
283 %systempkg_req
284
285 %description system-lm32
286 QEMU is a generic and open source processor emulator which achieves a
287 good emulation speed by using dynamic translation.
288
289 This package provides the system emulator with LM32 CPU.
290
291 %description system-lm32 -l pl.UTF-8
292 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
293 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
294
295 Ten pakiet zawiera emulator systemu z procesorem LM32.
296
297 %package system-m68k
298 Summary:        QEMU system emulator for m68k
299 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
300 Group:          Development/Tools
301 Requires:       %{name}-common = %{version}-%{release}
302 %systempkg_req
303
304 %description system-m68k
305 QEMU is a generic and open source processor emulator which achieves a
306 good emulation speed by using dynamic translation.
307
308 This package provides the system emulator with m68k CPU.
309
310 %description system-m68k -l pl.UTF-8
311 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
312 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
313
314 Ten pakiet zawiera emulator systemu z procesorem m68k.
315
316 %package system-microblaze
317 Summary:        QEMU system emulator for MicroBlaze
318 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
319 Group:          Development/Tools
320 Requires:       %{name}-common = %{version}-%{release}
321 %systempkg_req
322
323 %description system-microblaze
324 QEMU is a generic and open source processor emulator which achieves a
325 good emulation speed by using dynamic translation.
326
327 This package provides the system emulator with MicroBlaze CPU.
328
329 %description system-microblaze -l pl.UTF-8
330 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
331 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
332
333 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
334
335 %package system-mips
336 Summary:        QEMU system emulator for MIPS
337 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
338 Group:          Development/Tools
339 Requires:       %{name}-common = %{version}-%{release}
340 %systempkg_req
341
342 %description system-mips
343 QEMU is a generic and open source processor emulator which achieves a
344 good emulation speed by using dynamic translation.
345
346 This package provides the system emulator with MIPS CPU.
347
348 %description system-mips -l pl.UTF-8
349 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
350 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
351
352 Ten pakiet zawiera emulator systemu z procesorem MIPS.
353
354 %package system-moxie
355 Summary:        QEMU system emulator for Moxie
356 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
357 Group:          Development/Tools
358 Requires:       %{name}-common = %{version}-%{release}
359 %systempkg_req
360
361 %description system-moxie
362 QEMU is a generic and open source processor emulator which achieves a
363 good emulation speed by using dynamic translation.
364
365 This package provides the system emulator with Moxie CPU.
366
367 %description system-moxie -l pl.UTF-8
368 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
369 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
370
371 Ten pakiet zawiera emulator systemu z procesorem Moxie.
372
373 %package system-or32
374 Summary:        QEMU system emulator for OpenRISC
375 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
376 Group:          Development/Tools
377 Requires:       %{name}-common = %{version}-%{release}
378 %systempkg_req
379
380 %description system-or32
381 QEMU is a generic and open source processor emulator which achieves a
382 good emulation speed by using dynamic translation.
383
384 This package provides the system emulator with OpenRISC CPU.
385
386 %description system-or32 -l pl.UTF-8
387 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
388 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
389
390 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
391
392 %package system-ppc
393 Summary:        QEMU system emulator for PowerPC
394 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
395 Group:          Development/Tools
396 Requires:       %{name}-common = %{version}-%{release}
397 %systempkg_req
398
399 %description system-ppc
400 QEMU is a generic and open source processor emulator which achieves a
401 good emulation speed by using dynamic translation.
402
403 This package provides the system emulator with PowerPC CPU.
404
405 %description system-ppc -l pl.UTF-8
406 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
407 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
408
409 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
410
411 %package system-s390x
412 Summary:        QEMU system emulator for S390
413 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
414 Group:          Development/Tools
415 Requires:       %{name}-common = %{version}-%{release}
416 %systempkg_req
417
418 %description system-s390x
419 QEMU is a generic and open source processor emulator which achieves a
420 good emulation speed by using dynamic translation.
421
422 This package provides the system emulator with S390 CPU.
423
424 %description system-s390x -l pl.UTF-8
425 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
426 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
427
428 Ten pakiet zawiera emulator systemu z procesorem S390.
429
430 %package system-sh4
431 Summary:        QEMU system emulator for SH4
432 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
433 Group:          Development/Tools
434 Requires:       %{name}-common = %{version}-%{release}
435 %systempkg_req
436
437 %description system-sh4
438 QEMU is a generic and open source processor emulator which achieves a
439 good emulation speed by using dynamic translation.
440
441 This package provides the system emulator with SH4 CPU.
442
443 %description system-sh4 -l pl.UTF-8
444 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
445 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
446
447 Ten pakiet zawiera emulator systemu z procesorem SH4.
448
449 %package system-sparc
450 Summary:        QEMU system emulator for SPARC
451 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
452 Group:          Development/Tools
453 Requires:       %{name}-common = %{version}-%{release}
454 %systempkg_req
455
456 %description system-sparc
457 QEMU is a generic and open source processor emulator which achieves a
458 good emulation speed by using dynamic translation.
459
460 This package provides the system emulator with SPARC/SPARC64 CPU.
461
462 %description system-sparc -l pl.UTF-8
463 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
464 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
465
466 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
467
468 %package system-unicore32
469 Summary:        QEMU system emulator for UniCore32
470 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
471 Group:          Development/Tools
472 Requires:       %{name}-common = %{version}-%{release}
473 %systempkg_req
474
475 %description system-unicore32
476 QEMU is a generic and open source processor emulator which achieves a
477 good emulation speed by using dynamic translation.
478
479 This package provides the system emulator with UniCore32 CPU.
480
481 %description system-unicore32 -l pl.UTF-8
482 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
483 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
484
485 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
486
487 %package system-x86
488 Summary:        QEMU system emulator for x86
489 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
490 Group:          Development/Tools
491 Requires:       %{name}-common = %{version}-%{release}
492 %systempkg_req
493
494 %description system-x86
495 QEMU is a generic and open source processor emulator which achieves a
496 good emulation speed by using dynamic translation.
497
498 %description system-x86 -l pl.UTF-8
499 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
500 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
501
502 %package system-xtensa
503 Summary:        QEMU system emulator for Xtensa
504 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
505 Group:          Development/Tools
506 Requires:       %{name}-common = %{version}-%{release}
507 %systempkg_req
508
509 %description system-xtensa
510 QEMU is a generic and open source processor emulator which achieves a
511 good emulation speed by using dynamic translation.
512
513 This package provides the system emulator with Xtensa CPU.
514
515 %description system-xtensa -l pl.UTF-8
516 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
517 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
518
519 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
520
521 %prep
522 %setup -q
523 %patch0 -p1
524 %patch1 -p1
525 %patch2 -p0
526 %patch3 -p1
527
528 %{__mv} libcacard libcacard-use-system-lib
529
530 # workaround for conflict with alsa/error.h
531 ln -s ../error.h qapi/error.h
532
533 %build
534 ./configure \
535         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
536         --extra-ldflags="%{rpmldflags}" \
537         --prefix=%{_prefix} \
538         --sysconfdir=%{_sysconfdir} \
539         --cc="%{__cc}" \
540         --host-cc="%{__cc}" \
541         --disable-strip \
542         --enable-attr \
543         --enable-bluez \
544         --enable-brlapi \
545         --enable-cap-ng \
546         --enable-curl \
547         --enable-curses \
548         --enable-docs \
549         --enable-fdt \
550         %{__enable_disable glusterfs} \
551         --enable-libiscsi \
552         --enable-mixemu \
553         %{__enable_disable glx} \
554         %{__enable_disable ceph rbd} \
555         %{__enable_disable rdma} \
556         %{__enable_disable sdl} \
557         --enable-seccomp \
558         %{__enable_disable spice} \
559         --enable-smartcard-nss \
560         --enable-tpm \
561         --enable-usb-redir \
562         --enable-uuid \
563         --enable-vde \
564         --enable-virtfs \
565         --enable-vnc-jpeg \
566         --enable-vnc-png \
567         --enable-vnc-sasl \
568         --enable-vnc-tls \
569         %{__enable_disable xen} \
570         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
571         --interp-prefix=%{_libdir}/qemu/lib-%%M \
572         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
573
574 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
575 # --libexecdir in configure is nop
576 %{__make} \
577         V=1 \
578         CONFIG_QEMU_HELPERDIR="%{_libdir}"
579
580 # rebuild patched vesa tables with additional widescreen modes.
581 %{__make} -C roms/vgabios stdvga-bios
582
583 %install
584 rm -rf $RPM_BUILD_ROOT
585
586 %{__make} install \
587         DESTDIR=$RPM_BUILD_ROOT \
588         libexecdir=%{_libdir}
589
590 install -d $RPM_BUILD_ROOT%{_sysconfdir}
591 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
592 #!/bin/sh
593
594 EOF
595
596 # already packaged
597 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
598 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
599
600 # install patched vesa tables with additional widescreen modes.
601 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
602
603 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
604 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
605 %find_lang %{name}
606
607 %clean
608 rm -rf $RPM_BUILD_ROOT
609
610 %pre common
611 %groupadd -g 276 qemu
612 %useradd -u 276 -g qemu -c "QEMU User" qemu
613
614 %postun common
615 if [ "$1" = "0" ]; then
616         %userremove qemu
617         %groupremove qemu
618 fi
619
620 %files
621 %defattr(644,root,root,755)
622
623 %files common -f %{name}.lang
624 %defattr(644,root,root,755)
625 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
626 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
627 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
628 %dir %{_sysconfdir}/qemu
629 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
630 %attr(755,root,root) %{_bindir}/qemu-nbd
631 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
632 %{_mandir}/man1/qemu.1*
633 %{_mandir}/man1/virtfs-proxy-helper.1*
634 %{_mandir}/man8/qemu-nbd.8*
635
636 %dir %{_datadir}/qemu
637 %{_datadir}/%{name}/keymaps
638 %{_datadir}/%{name}/qemu-icon.bmp
639 # various bios images
640 %{_datadir}/%{name}/*.aml
641 %{_datadir}/%{name}/*.bin
642 %{_datadir}/%{name}/*.rom
643 %{_datadir}/%{name}/*.dtb
644 %{_datadir}/%{name}/qemu_logo_no_text.svg
645 %{_datadir}/%{name}/openbios-ppc
646 %{_datadir}/%{name}/openbios-sparc*
647 %{_datadir}/%{name}/palcode-clipper
648 %{_datadir}/%{name}/s390-ccw.img
649
650 %files img
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_bindir}/qemu-img
653 %{_mandir}/man1/qemu-img.1*
654
655 %files user
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/qemu-alpha
658 %attr(755,root,root) %{_bindir}/qemu-arm
659 %attr(755,root,root) %{_bindir}/qemu-armeb
660 %attr(755,root,root) %{_bindir}/qemu-cris
661 %attr(755,root,root) %{_bindir}/qemu-ga
662 %attr(755,root,root) %{_bindir}/qemu-i386
663 %attr(755,root,root) %{_bindir}/qemu-io
664 %attr(755,root,root) %{_bindir}/qemu-m68k
665 %attr(755,root,root) %{_bindir}/qemu-microblaze
666 %attr(755,root,root) %{_bindir}/qemu-microblazeel
667 %attr(755,root,root) %{_bindir}/qemu-mips
668 %attr(755,root,root) %{_bindir}/qemu-mipsel
669 %attr(755,root,root) %{_bindir}/qemu-mips64
670 %attr(755,root,root) %{_bindir}/qemu-mips64el
671 %attr(755,root,root) %{_bindir}/qemu-mipsn32
672 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
673 %attr(755,root,root) %{_bindir}/qemu-or32
674 %attr(755,root,root) %{_bindir}/qemu-ppc
675 %attr(755,root,root) %{_bindir}/qemu-ppc64
676 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
677 %attr(755,root,root) %{_bindir}/qemu-s390x
678 %attr(755,root,root) %{_bindir}/qemu-sh4
679 %attr(755,root,root) %{_bindir}/qemu-sh4eb
680 %attr(755,root,root) %{_bindir}/qemu-sparc
681 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
682 %attr(755,root,root) %{_bindir}/qemu-sparc64
683 %attr(755,root,root) %{_bindir}/qemu-unicore32
684 %attr(755,root,root) %{_bindir}/qemu-x86_64
685
686 %files system-alpha
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_bindir}/qemu-system-alpha
689
690 %files system-arm
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_bindir}/qemu-system-arm
693
694 %files system-cris
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_bindir}/qemu-system-cris
697
698 %files system-lm32
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_bindir}/qemu-system-lm32
701
702 %files system-m68k
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_bindir}/qemu-system-m68k
705
706 %files system-microblaze
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
709 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
710
711 %files system-mips
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_bindir}/qemu-system-mips
714 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
715 %attr(755,root,root) %{_bindir}/qemu-system-mips64
716 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
717
718 %files system-moxie
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_bindir}/qemu-system-moxie
721
722 %files system-or32
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_bindir}/qemu-system-or32
725
726 %files system-ppc
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_bindir}/qemu-system-ppc
729 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
730 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
731
732 %files system-s390x
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_bindir}/qemu-system-s390x
735
736 %files system-sh4
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_bindir}/qemu-system-sh4
739 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
740
741 %files system-sparc
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_bindir}/qemu-system-sparc
744 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
745
746 %files system-unicore32
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
749
750 %files system-x86
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_bindir}/qemu-system-i386
753 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
754
755 %files system-xtensa
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
758 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.100386 seconds and 3 git commands to generate.