]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python-cryptography.spec
- require fixed rpm-pythonprov instead
[packages/python3-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
049a803f
JB
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5%bcond_with tests # test target [not all dependencies are currently available in PLD]
06232684
JB
6
7Summary: Crypthography library for Python 2
8Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
9Name: python-cryptography
6b2525da 10Version: 2.3.1
14238969 11Release: 2
d6e7edf5 12License: Apache v2.0 or BSD
06232684 13Group: Libraries/Python
049a803f 14#Source0Download: https://pypi.python.org/simple/cryptography/
7df50b22 15Source0: https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
6b2525da 16# Source0-md5: 2b5e8269c43c9b9ab54fc8c75ba3c7ac
06232684 17URL: https://cryptography.io/
7df50b22 18BuildRequires: openssl-devel >= 1.0.1
d331861d 19BuildRequires: rpm-pythonprov >= 5.4.15-48
049a803f 20BuildRequires: rpmbuild(macros) >= 1.714
06232684 21%if %{with python2}
6c9680f2 22BuildRequires: python-cffi >= 1.4.1
226a2f8d 23BuildRequires: python-devel >= 1:2.6
b2fc4ef3 24BuildRequires: python-enum34
c30df12e 25BuildRequires: python-pyasn1 >= 0.1.8
049a803f 26BuildRequires: python-setuptools >= 11.3
06232684 27BuildRequires: python-six >= 1.4.1
049a803f
JB
28%if %{with tests}
29BuildRequires: python-cryptography_vectors
30%if "%{py_ver}" >= "2.7"
31BuildRequires: python-hypothesis >= 1.11.4
32%endif
33BuildRequires: python-idna >= 2.0
34BuildRequires: python-ipaddress
35BuildRequires: python-iso8601
36BuildRequires: python-pretend
37BuildRequires: python-pyasn1_modules
38BuildRequires: python-pytest
39%endif
06232684
JB
40%endif
41%if %{with python3}
6c9680f2 42BuildRequires: python3-cffi >= 1.4.1
d331861d 43BuildRequires: python3-devel >= 1:3.4
c30df12e 44BuildRequires: python3-pyasn1 >= 0.1.8
049a803f 45BuildRequires: python3-setuptools >= 11.3
06232684 46BuildRequires: python3-six >= 1.4.1
049a803f
JB
47%if %{with tests}
48BuildRequires: python3-cryptography_vectors
49BuildRequires: python3-hypothesis >= 1.11.4
50BuildRequires: python3-idna >= 2.0
51BuildRequires: python3-iso8601
52BuildRequires: python3-pretend
53BuildRequires: python3-pyasn1_modules
54BuildRequires: python3-pytest
55%endif
06232684 56%endif
7df50b22 57Requires: openssl >= 1.0.1
6c9680f2 58Requires: python-cffi >= 1.4.1
06232684
JB
59Requires: python-six >= 1.4.1
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62%description
63cryptography is a package designed to expose cryptographic recipes and
64primitives to Python developers. Our goal is for it to be your
65"cryptographic standard library". It supports Python 2.6-2.7, Python
663.2+, and PyPy.
67
68cryptography includes both high level recipes, and low level
69interfaces to common cryptographic algorithms such as symmetric
70ciphers, message digests and key derivation functions.
71
72This package contains Python 2 modules.
73
74%description -l pl.UTF-8
75cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
76obiektów kryptograficznych programistom Pythona. Celem jest
77dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
78Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
79
80cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
81niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 82takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
83wyprowadzające klucze.
84
85Ten pakiet zawiera moduły Pythona 2.
86
87%package -n python3-cryptography
88Summary: Crypthography library for Python 3
89Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
90Group: Libraries/Python
7df50b22 91Requires: openssl >= 1.0.1
6c9680f2 92Requires: python3-cffi >= 1.4.1
06232684
JB
93Requires: python3-six >= 1.4.1
94
95%description -n python3-cryptography
96cryptography is a package designed to expose cryptographic recipes and
97primitives to Python developers. Our goal is for it to be your
98"cryptographic standard library". It supports Python 2.6-2.7, Python
993.2+, and PyPy.
100
101cryptography includes both high level recipes, and low level
102interfaces to common cryptographic algorithms such as symmetric
103ciphers, message digests and key derivation functions.
104
105This package contains Python 3 modules.
106
107%description -n python3-cryptography -l pl.UTF-8
108cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
109obiektów kryptograficznych programistom Pythona. Celem jest
110dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
111Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
112
113cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
114niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 115takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
116wyprowadzające klucze.
117
118Ten pakiet zawiera moduły Pythona 3.
119
120%prep
121%setup -q -n cryptography-%{version}
122
123%build
124export CFLAGS="%{rpmcflags}"
125
126%if %{with python2}
049a803f 127%py_build %{?with_tests:test}
06232684
JB
128%endif
129
130%if %{with python2}
049a803f 131%py3_build %{?with_tests:test}
06232684
JB
132%endif
133
134%install
135rm -rf $RPM_BUILD_ROOT
136
137%if %{with python2}
6d1f8f74 138%py_install
06232684
JB
139
140%py_postclean
141%endif
142
143%if %{with python3}
6d1f8f74 144%py3_install
06232684
JB
145%endif
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%if %{with python2}
151%files
152%defattr(644,root,root,755)
049a803f 153%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 154%dir %{py_sitedir}/cryptography
06232684
JB
155%{py_sitedir}/cryptography/*.py[co]
156%dir %{py_sitedir}/cryptography/hazmat
157%{py_sitedir}/cryptography/hazmat/*.py[co]
158%dir %{py_sitedir}/cryptography/hazmat/backends
159%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
06232684
JB
160%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
161%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
162%dir %{py_sitedir}/cryptography/hazmat/bindings
163%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
d198b5a4 164%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
165%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
166%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
167%dir %{py_sitedir}/cryptography/hazmat/primitives
168%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
169%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
170%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
171%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
172%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
173%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
174%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f7d88309
AM
175%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
176%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
d198b5a4
AM
177%dir %{py_sitedir}/cryptography/x509
178%{py_sitedir}/cryptography/x509/*.py[co]
06232684
JB
179%{py_sitedir}/cryptography-%{version}-py*.egg-info
180%endif
181
182%if %{with python3}
183%files -n python3-cryptography
184%defattr(644,root,root,755)
049a803f 185%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 186%dir %{py3_sitedir}/cryptography
06232684
JB
187%{py3_sitedir}/cryptography/*.py
188%{py3_sitedir}/cryptography/__pycache__
189%dir %{py3_sitedir}/cryptography/hazmat
190%{py3_sitedir}/cryptography/hazmat/*.py
191%{py3_sitedir}/cryptography/hazmat/__pycache__
192%dir %{py3_sitedir}/cryptography/hazmat/backends
193%{py3_sitedir}/cryptography/hazmat/backends/*.py
194%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
06232684
JB
195%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
196%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
197%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
198%dir %{py3_sitedir}/cryptography/hazmat/bindings
199%{py3_sitedir}/cryptography/hazmat/bindings/*.py
200%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
d198b5a4 201%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
202%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
203%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
204%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
205%dir %{py3_sitedir}/cryptography/hazmat/primitives
206%{py3_sitedir}/cryptography/hazmat/primitives/*.py
207%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
208%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
209%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
210%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
211%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
212%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
213%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
214%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
215%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
216%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f7d88309
AM
217%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
218%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
219%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
d198b5a4
AM
220%dir %{py3_sitedir}/cryptography/x509
221%{py3_sitedir}/cryptography/x509/*.py
222%{py3_sitedir}/cryptography/x509/__pycache__
06232684
JB
223%{py3_sitedir}/cryptography-%{version}-py*.egg-info
224%endif
This page took 0.069715 seconds and 4 git commands to generate.