]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python-cryptography.spec
- python 3.6
[packages/python3-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
049a803f
JB
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5%bcond_with tests # test target [not all dependencies are currently available in PLD]
06232684
JB
6
7Summary: Crypthography library for Python 2
8Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
9Name: python-cryptography
049a803f 10Version: 1.3.1
8dd4e35f 11Release: 2
d6e7edf5 12License: Apache v2.0 or BSD
06232684 13Group: Libraries/Python
049a803f 14#Source0Download: https://pypi.python.org/simple/cryptography/
06232684 15Source0: https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
049a803f 16# Source0-md5: bc8148d2ff2d80fef8ef2d2e856b3a7f
06232684 17URL: https://cryptography.io/
cd19033e 18BuildRequires: openssl-devel >= 0.9.8
b2fc4ef3 19BuildRequires: rpm-pythonprov
049a803f 20BuildRequires: rpmbuild(macros) >= 1.714
06232684 21%if %{with python2}
6c9680f2 22BuildRequires: python-cffi >= 1.4.1
226a2f8d 23BuildRequires: python-devel >= 1:2.6
b2fc4ef3 24BuildRequires: python-enum34
c30df12e 25BuildRequires: python-pyasn1 >= 0.1.8
049a803f 26BuildRequires: python-setuptools >= 11.3
06232684 27BuildRequires: python-six >= 1.4.1
049a803f
JB
28%if %{with tests}
29BuildRequires: python-cryptography_vectors
30%if "%{py_ver}" >= "2.7"
31BuildRequires: python-hypothesis >= 1.11.4
32%endif
33BuildRequires: python-idna >= 2.0
34BuildRequires: python-ipaddress
35BuildRequires: python-iso8601
36BuildRequires: python-pretend
37BuildRequires: python-pyasn1_modules
38BuildRequires: python-pytest
39%endif
06232684
JB
40%endif
41%if %{with python3}
6c9680f2 42BuildRequires: python3-cffi >= 1.4.1
049a803f
JB
43BuildRequires: python3-devel >= 1:3.3
44%if "%{py3_ver}" < "3.4"
45BuildRequires: python3-enum34
46%endif
c30df12e 47BuildRequires: python3-pyasn1 >= 0.1.8
049a803f 48BuildRequires: python3-setuptools >= 11.3
06232684 49BuildRequires: python3-six >= 1.4.1
049a803f
JB
50%if %{with tests}
51BuildRequires: python3-cryptography_vectors
52BuildRequires: python3-hypothesis >= 1.11.4
53BuildRequires: python3-idna >= 2.0
54BuildRequires: python3-iso8601
55BuildRequires: python3-pretend
56BuildRequires: python3-pyasn1_modules
57BuildRequires: python3-pytest
58%endif
06232684 59%endif
6c9680f2 60Requires: python-cffi >= 1.4.1
06232684
JB
61Requires: python-six >= 1.4.1
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%description
65cryptography is a package designed to expose cryptographic recipes and
66primitives to Python developers. Our goal is for it to be your
67"cryptographic standard library". It supports Python 2.6-2.7, Python
683.2+, and PyPy.
69
70cryptography includes both high level recipes, and low level
71interfaces to common cryptographic algorithms such as symmetric
72ciphers, message digests and key derivation functions.
73
74This package contains Python 2 modules.
75
76%description -l pl.UTF-8
77cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
78obiektów kryptograficznych programistom Pythona. Celem jest
79dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
80Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
81
82cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
83niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 84takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
85wyprowadzające klucze.
86
87Ten pakiet zawiera moduły Pythona 2.
88
89%package -n python3-cryptography
90Summary: Crypthography library for Python 3
91Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
92Group: Libraries/Python
6c9680f2 93Requires: python3-cffi >= 1.4.1
049a803f
JB
94%if "%{py3_ver}" < "3.4"
95BuildRequires: python3-enum34
96%endif
06232684
JB
97Requires: python3-six >= 1.4.1
98
99%description -n python3-cryptography
100cryptography is a package designed to expose cryptographic recipes and
101primitives to Python developers. Our goal is for it to be your
102"cryptographic standard library". It supports Python 2.6-2.7, Python
1033.2+, and PyPy.
104
105cryptography includes both high level recipes, and low level
106interfaces to common cryptographic algorithms such as symmetric
107ciphers, message digests and key derivation functions.
108
109This package contains Python 3 modules.
110
111%description -n python3-cryptography -l pl.UTF-8
112cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
113obiektów kryptograficznych programistom Pythona. Celem jest
114dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
115Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
116
117cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
118niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 119takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
120wyprowadzające klucze.
121
122Ten pakiet zawiera moduły Pythona 3.
123
124%prep
125%setup -q -n cryptography-%{version}
126
127%build
128export CFLAGS="%{rpmcflags}"
129
130%if %{with python2}
049a803f 131%py_build %{?with_tests:test}
06232684
JB
132%endif
133
134%if %{with python2}
049a803f 135%py3_build %{?with_tests:test}
06232684
JB
136%endif
137
138%install
139rm -rf $RPM_BUILD_ROOT
140
141%if %{with python2}
6d1f8f74 142%py_install
06232684
JB
143
144%py_postclean
145%endif
146
147%if %{with python3}
6d1f8f74 148%py3_install
06232684
JB
149%endif
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%if %{with python2}
155%files
156%defattr(644,root,root,755)
049a803f 157%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 158%dir %{py_sitedir}/cryptography
06232684
JB
159%{py_sitedir}/cryptography/*.py[co]
160%dir %{py_sitedir}/cryptography/hazmat
161%{py_sitedir}/cryptography/hazmat/*.py[co]
162%dir %{py_sitedir}/cryptography/hazmat/backends
163%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
164%dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
165%{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
166%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
167%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
168%dir %{py_sitedir}/cryptography/hazmat/bindings
169%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
d198b5a4 170%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
171%dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
172%{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
173%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
174%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
70c7ac12
ER
175%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
176%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
06232684
JB
177%dir %{py_sitedir}/cryptography/hazmat/primitives
178%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
179%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
180%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
181%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
182%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
183%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
184%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f7d88309
AM
185%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
186%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
d198b5a4
AM
187%dir %{py_sitedir}/cryptography/x509
188%{py_sitedir}/cryptography/x509/*.py[co]
06232684
JB
189%{py_sitedir}/cryptography-%{version}-py*.egg-info
190%endif
191
192%if %{with python3}
193%files -n python3-cryptography
194%defattr(644,root,root,755)
049a803f 195%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 196%dir %{py3_sitedir}/cryptography
06232684
JB
197%{py3_sitedir}/cryptography/*.py
198%{py3_sitedir}/cryptography/__pycache__
199%dir %{py3_sitedir}/cryptography/hazmat
200%{py3_sitedir}/cryptography/hazmat/*.py
201%{py3_sitedir}/cryptography/hazmat/__pycache__
202%dir %{py3_sitedir}/cryptography/hazmat/backends
203%{py3_sitedir}/cryptography/hazmat/backends/*.py
204%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
205%dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
206%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
207%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
208%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
209%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
210%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
211%dir %{py3_sitedir}/cryptography/hazmat/bindings
212%{py3_sitedir}/cryptography/hazmat/bindings/*.py
213%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
d198b5a4 214%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
215%dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
216%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
217%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
218%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
219%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
220%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
70c7ac12
ER
221%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
222%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
223%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
06232684
JB
224%dir %{py3_sitedir}/cryptography/hazmat/primitives
225%{py3_sitedir}/cryptography/hazmat/primitives/*.py
226%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
227%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
228%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
229%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
230%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
231%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
232%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
233%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
234%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
235%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f7d88309
AM
236%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
237%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
238%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
d198b5a4
AM
239%dir %{py3_sitedir}/cryptography/x509
240%{py3_sitedir}/cryptography/x509/*.py
241%{py3_sitedir}/cryptography/x509/__pycache__
06232684
JB
242%{py3_sitedir}/cryptography-%{version}-py*.egg-info
243%endif
This page took 0.150802 seconds and 4 git commands to generate.