]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python-cryptography.spec
- up to 1.2.3
[packages/python3-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Crypthography library for Python 2
7Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
8Name: python-cryptography
d198b5a4
AM
9Version: 1.2.3
10Release: 1
d6e7edf5 11License: Apache v2.0 or BSD
06232684
JB
12Group: Libraries/Python
13Source0: https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
d198b5a4 14# Source0-md5: 5474d2b3e8c7555a60852e48d2743f85
06232684 15URL: https://cryptography.io/
cd19033e 16BuildRequires: openssl-devel >= 0.9.8
b2fc4ef3 17BuildRequires: rpm-pythonprov
762a0a78 18BuildRequires: rpmbuild(macros) >= 1.710
06232684 19%if %{with python2}
06232684 20BuildRequires: python-cffi >= 0.8
226a2f8d 21BuildRequires: python-devel >= 1:2.6
b2fc4ef3
ER
22BuildRequires: python-enum34
23BuildRequires: python-pyasn1
24BuildRequires: python-setuptools
06232684 25BuildRequires: python-six >= 1.4.1
06232684
JB
26%endif
27%if %{with python3}
06232684 28BuildRequires: python3-cffi >= 0.8
226a2f8d 29BuildRequires: python3-devel >= 1:3.2
b2fc4ef3
ER
30BuildRequires: python3-pyasn1
31BuildRequires: python3-setuptools
06232684
JB
32BuildRequires: python3-six >= 1.4.1
33%endif
06232684
JB
34Requires: python-cffi >= 0.8
35Requires: python-six >= 1.4.1
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39cryptography is a package designed to expose cryptographic recipes and
40primitives to Python developers. Our goal is for it to be your
41"cryptographic standard library". It supports Python 2.6-2.7, Python
423.2+, and PyPy.
43
44cryptography includes both high level recipes, and low level
45interfaces to common cryptographic algorithms such as symmetric
46ciphers, message digests and key derivation functions.
47
48This package contains Python 2 modules.
49
50%description -l pl.UTF-8
51cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
52obiektów kryptograficznych programistom Pythona. Celem jest
53dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
54Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
55
56cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
57niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 58takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
59wyprowadzające klucze.
60
61Ten pakiet zawiera moduły Pythona 2.
62
63%package -n python3-cryptography
64Summary: Crypthography library for Python 3
65Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
66Group: Libraries/Python
67Requires: python3-cffi >= 0.8
68Requires: python3-six >= 1.4.1
69
70%description -n python3-cryptography
71cryptography is a package designed to expose cryptographic recipes and
72primitives to Python developers. Our goal is for it to be your
73"cryptographic standard library". It supports Python 2.6-2.7, Python
743.2+, and PyPy.
75
76cryptography includes both high level recipes, and low level
77interfaces to common cryptographic algorithms such as symmetric
78ciphers, message digests and key derivation functions.
79
80This package contains Python 3 modules.
81
82%description -n python3-cryptography -l pl.UTF-8
83cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
84obiektów kryptograficznych programistom Pythona. Celem jest
85dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
86Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
87
88cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
89niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 90takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
91wyprowadzające klucze.
92
93Ten pakiet zawiera moduły Pythona 3.
94
95%prep
96%setup -q -n cryptography-%{version}
97
98%build
99export CFLAGS="%{rpmcflags}"
100
101%if %{with python2}
6d1f8f74 102%py_build \
06232684
JB
103 --build-base build-2
104%endif
105
106%if %{with python2}
6d1f8f74 107%py3_build \
06232684
JB
108 --build-base build-3
109%endif
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%if %{with python2}
6d1f8f74 115%py_install
06232684
JB
116
117%py_postclean
118%endif
119
120%if %{with python3}
6d1f8f74 121%py3_install
06232684
JB
122%endif
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%if %{with python2}
128%files
129%defattr(644,root,root,755)
d6e7edf5 130%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
06232684 131%dir %{py_sitedir}/cryptography
06232684
JB
132%{py_sitedir}/cryptography/*.py[co]
133%dir %{py_sitedir}/cryptography/hazmat
134%{py_sitedir}/cryptography/hazmat/*.py[co]
135%dir %{py_sitedir}/cryptography/hazmat/backends
136%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
137%dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
138%{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
139%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
140%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
141%dir %{py_sitedir}/cryptography/hazmat/bindings
142%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
d198b5a4 143%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
144%dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
145%{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
146%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
147%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
70c7ac12
ER
148%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
149%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
06232684
JB
150%dir %{py_sitedir}/cryptography/hazmat/primitives
151%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
152%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
153%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
154%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
155%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
156%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
157%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f7d88309
AM
158%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
159%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
d198b5a4
AM
160%dir %{py_sitedir}/cryptography/x509
161%{py_sitedir}/cryptography/x509/*.py[co]
06232684
JB
162%{py_sitedir}/cryptography-%{version}-py*.egg-info
163%endif
164
165%if %{with python3}
166%files -n python3-cryptography
167%defattr(644,root,root,755)
d6e7edf5 168%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
06232684 169%dir %{py3_sitedir}/cryptography
06232684
JB
170%{py3_sitedir}/cryptography/*.py
171%{py3_sitedir}/cryptography/__pycache__
172%dir %{py3_sitedir}/cryptography/hazmat
173%{py3_sitedir}/cryptography/hazmat/*.py
174%{py3_sitedir}/cryptography/hazmat/__pycache__
175%dir %{py3_sitedir}/cryptography/hazmat/backends
176%{py3_sitedir}/cryptography/hazmat/backends/*.py
177%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
178%dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
179%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
180%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
181%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
182%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
183%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
184%dir %{py3_sitedir}/cryptography/hazmat/bindings
185%{py3_sitedir}/cryptography/hazmat/bindings/*.py
186%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
d198b5a4 187%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
188%dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
189%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
190%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
191%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
192%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
193%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
70c7ac12
ER
194%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
195%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
196%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
06232684
JB
197%dir %{py3_sitedir}/cryptography/hazmat/primitives
198%{py3_sitedir}/cryptography/hazmat/primitives/*.py
199%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
200%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
201%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
202%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
203%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
204%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
205%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
206%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
207%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
208%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f7d88309
AM
209%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
210%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
211%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
d198b5a4
AM
212%dir %{py3_sitedir}/cryptography/x509
213%{py3_sitedir}/cryptography/x509/*.py
214%{py3_sitedir}/cryptography/x509/__pycache__
06232684
JB
215%{py3_sitedir}/cryptography-%{version}-py*.egg-info
216%endif
This page took 0.131223 seconds and 4 git commands to generate.