]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python-cryptography.spec
- python3.5 rebuild
[packages/python3-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Crypthography library for Python 2
7Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
8Name: python-cryptography
d6e7edf5 9Version: 0.8.2
ca38062e 10Release: 3
d6e7edf5 11License: Apache v2.0 or BSD
06232684
JB
12Group: Libraries/Python
13Source0: https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
d6e7edf5 14# Source0-md5: 7d33499e851300c194cbb0396de72462
06232684 15URL: https://cryptography.io/
cd19033e 16BuildRequires: openssl-devel >= 0.9.8
b2fc4ef3
ER
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.612
06232684 19%if %{with python2}
06232684 20BuildRequires: python-cffi >= 0.8
226a2f8d 21BuildRequires: python-devel >= 1:2.6
b2fc4ef3
ER
22BuildRequires: python-enum34
23BuildRequires: python-pyasn1
24BuildRequires: python-setuptools
06232684 25BuildRequires: python-six >= 1.4.1
06232684
JB
26%endif
27%if %{with python3}
06232684 28BuildRequires: python3-cffi >= 0.8
226a2f8d 29BuildRequires: python3-devel >= 1:3.2
b2fc4ef3
ER
30BuildRequires: python3-pyasn1
31BuildRequires: python3-setuptools
06232684
JB
32BuildRequires: python3-six >= 1.4.1
33%endif
06232684
JB
34Requires: python-cffi >= 0.8
35Requires: python-six >= 1.4.1
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39cryptography is a package designed to expose cryptographic recipes and
40primitives to Python developers. Our goal is for it to be your
41"cryptographic standard library". It supports Python 2.6-2.7, Python
423.2+, and PyPy.
43
44cryptography includes both high level recipes, and low level
45interfaces to common cryptographic algorithms such as symmetric
46ciphers, message digests and key derivation functions.
47
48This package contains Python 2 modules.
49
50%description -l pl.UTF-8
51cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
52obiektów kryptograficznych programistom Pythona. Celem jest
53dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
54Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
55
56cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
57niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 58takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
59wyprowadzające klucze.
60
61Ten pakiet zawiera moduły Pythona 2.
62
63%package -n python3-cryptography
64Summary: Crypthography library for Python 3
65Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
66Group: Libraries/Python
67Requires: python3-cffi >= 0.8
68Requires: python3-six >= 1.4.1
69
70%description -n python3-cryptography
71cryptography is a package designed to expose cryptographic recipes and
72primitives to Python developers. Our goal is for it to be your
73"cryptographic standard library". It supports Python 2.6-2.7, Python
743.2+, and PyPy.
75
76cryptography includes both high level recipes, and low level
77interfaces to common cryptographic algorithms such as symmetric
78ciphers, message digests and key derivation functions.
79
80This package contains Python 3 modules.
81
82%description -n python3-cryptography -l pl.UTF-8
83cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
84obiektów kryptograficznych programistom Pythona. Celem jest
85dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
86Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
87
88cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
89niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 90takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
91wyprowadzające klucze.
92
93Ten pakiet zawiera moduły Pythona 3.
94
95%prep
96%setup -q -n cryptography-%{version}
97
98%build
99export CFLAGS="%{rpmcflags}"
100
101%if %{with python2}
102%{__python} setup.py build \
103 --build-base build-2
104%endif
105
106%if %{with python2}
107%{__python3} setup.py build \
108 --build-base build-3
109%endif
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%if %{with python2}
115%{__python} setup.py \
f7d88309
AM
116 build --build-base build-2 \
117 install --skip-build \
06232684
JB
118 --optimize=2 \
119 --root=$RPM_BUILD_ROOT
120
121%py_postclean
226a2f8d
ER
122%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/bindings/__pycache__/*.c
123%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
06232684
JB
124%endif
125
126%if %{with python3}
127%{__python3} setup.py \
f7d88309
AM
128 build --build-base build-3 \
129 install --skip-build \
06232684
JB
130 --optimize=2 \
131 --root=$RPM_BUILD_ROOT
226a2f8d
ER
132
133%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
06232684
JB
134%endif
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%if %{with python2}
140%files
141%defattr(644,root,root,755)
d6e7edf5 142%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
06232684 143%dir %{py_sitedir}/cryptography
f7d88309 144%attr(755,root,root) %{py_sitedir}/cryptography/_*_cffi_*.so
06232684
JB
145%{py_sitedir}/cryptography/*.py[co]
146%dir %{py_sitedir}/cryptography/hazmat
147%{py_sitedir}/cryptography/hazmat/*.py[co]
148%dir %{py_sitedir}/cryptography/hazmat/backends
149%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
150%dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
151%{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
152%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
153%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
154%dir %{py_sitedir}/cryptography/hazmat/bindings
155%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
156%dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
157%{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
158%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
159%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
70c7ac12
ER
160%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
161%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
06232684
JB
162%dir %{py_sitedir}/cryptography/hazmat/primitives
163%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
164%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
165%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
166%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
167%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
168%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
169%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f7d88309
AM
170%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
171%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
06232684
JB
172%{py_sitedir}/cryptography-%{version}-py*.egg-info
173%endif
174
175%if %{with python3}
176%files -n python3-cryptography
177%defattr(644,root,root,755)
d6e7edf5 178%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
06232684 179%dir %{py3_sitedir}/cryptography
f7d88309 180%attr(755,root,root) %{py3_sitedir}/cryptography/_*_cffi_*.so
06232684
JB
181%{py3_sitedir}/cryptography/*.py
182%{py3_sitedir}/cryptography/__pycache__
183%dir %{py3_sitedir}/cryptography/hazmat
184%{py3_sitedir}/cryptography/hazmat/*.py
185%{py3_sitedir}/cryptography/hazmat/__pycache__
186%dir %{py3_sitedir}/cryptography/hazmat/backends
187%{py3_sitedir}/cryptography/hazmat/backends/*.py
188%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
189%dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
190%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
191%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
192%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
193%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
194%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
195%dir %{py3_sitedir}/cryptography/hazmat/bindings
196%{py3_sitedir}/cryptography/hazmat/bindings/*.py
197%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
198%dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
199%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
200%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
201%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
202%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
203%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
70c7ac12
ER
204%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
205%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
206%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
06232684
JB
207%dir %{py3_sitedir}/cryptography/hazmat/primitives
208%{py3_sitedir}/cryptography/hazmat/primitives/*.py
209%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
210%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
211%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
212%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
213%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
214%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
215%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
216%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
217%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
218%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f7d88309
AM
219%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
220%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
221%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
06232684
JB
222%{py3_sitedir}/cryptography-%{version}-py*.egg-info
223%endif
This page took 0.056693 seconds and 4 git commands to generate.