]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blame - php-pecl-memcache.spec
session requires spl (sometimes)
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
CommitLineData
8dfd8797
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
3917ea3d 5%define php_name php%{?php_suffix}
a9222c27 6%define modname memcache
afdaa3d2 7%define php_min_version 5.0.0
3917ea3d 8%include /usr/lib/rpm/macros.php
a9222c27
ER
9Summary: %{modname} - a memcached extension
10Summary(pl.UTF-8): %{modname} - rozszerzenie memcached
3917ea3d 11Name: %{php_name}-pecl-%{modname}
10d2ed2a
ER
12Version: 3.0.9
13Release: 1
d7d5fbe6 14License: PHP 3.01
15f9ce79 15Group: Development/Languages/PHP
10d2ed2a
ER
16#Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
17Source0: https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
18# Source0-md5: 7751d8191302a726449d7c6506b8783d
20995d54 19Source1: %{modname}.ini
afdaa3d2
ER
20Source2: %{modname}-apache.conf
21Source3: %{modname}-lighttpd.conf
22Source4: config.php
23Patch0: %{modname}-webapp.patch
016f4b1b 24URL: http://pecl.php.net/package/memcache/
3917ea3d 25BuildRequires: %{php_name}-devel >= 3:5.0.0
241a36be 26BuildRequires: %{php_name}-xml
fae887d4 27BuildRequires: php-packagexml2cl
afdaa3d2 28BuildRequires: rpm-php-pearprov >= 4.4.2-11
62a21c7f 29BuildRequires: rpmbuild(macros) >= 1.650
8dfd8797
ER
30%if %{with tests}
31BuildRequires: %{php_name}-cli
32BuildRequires: %{php_name}-session
ef0230c6 33BuildRequires: %{php_name}-spl
8dfd8797 34%endif
0bee29d4 35%{?requires_php_extension}
3917ea3d
ER
36Requires: %{php_name}-session
37Requires: %{php_name}-zlib
afdaa3d2 38Suggests: memcached
bd3aaaff 39Provides: php(memcache) = %{version}
41a892be 40Obsoletes: php-pecl-memcache < 3.0.8-5
15f9ce79
AG
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
afdaa3d2
ER
43%define _webapps /etc/webapps
44%define _webapp %{modname}
45%define _sysconfdir %{_webapps}/%{_webapp}
46%define _appdir %{_datadir}/%{_webapp}
47
48# bad depsolver
49%define _noautopear pear
50
51# put it together for rpmbuild
52%define _noautoreq %{?_noautophp} %{?_noautopear}
53
15f9ce79
AG
54%description
55Memcached is a caching daemon designed especially for dynamic web
56applications to decrease database load by storing objects in memory.
57
58This extension allows you to work with memcached through handy OO and
59procedural interfaces.
60
6dd6de29 61%description -l pl.UTF-8
15f9ce79 62Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
6dd6de29
JR
63daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
64przez przechowywanie w pamięci obiektów.
15f9ce79 65
6dd6de29 66To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
15f9ce79
AG
67zorientowanego obiektowo (oraz przez procedury) interfejsu.
68
afdaa3d2
ER
69%package web
70Summary: Web interface for memcache
71Group: Libraries
09120ee3 72# does not require extension itself
fae887d4 73Requires: php(core) >= %{php_min_version}
3917ea3d
ER
74Requires: php(date)
75Requires: php(gd)
76Requires: php(pcre)
afdaa3d2
ER
77Requires: webapps
78Requires: webserver(php) >= 5.0
3917ea3d
ER
79%if "%{_rpmversion}" >= "5"
80BuildArch: noarch
81%endif
afdaa3d2
ER
82
83%description web
84Via this web interface script you can manage and view statistics of
85memcache.
86
15f9ce79 87%prep
10d2ed2a
ER
88%setup -qc
89mv pecl-%{modname}-*/{.??*,*} .
afdaa3d2 90%patch0 -p1
15f9ce79
AG
91
92%build
6c6304c8 93packagexml2cl package.xml > ChangeLog
15f9ce79 94phpize
172c079e
AG
95%configure \
96 --with-zlib-dir=/usr
15f9ce79
AG
97%{__make}
98
8dfd8797
ER
99%if %{with tests}
100# simple module load test
101%{__php} -n -q \
102 -d extension_dir=modules \
ef0230c6 103 -d extension=%{php_extensiondir}/spl.so \
8dfd8797
ER
104 -d extension=%{php_extensiondir}/session.so \
105 -d extension=%{modname}.so \
106 -m > modules.log
107grep %{modname} modules.log
e7368be2
ER
108
109cat <<'EOF' > run-tests.sh
110#!/bin/sh
111export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
112exec %{__make} test \
113 PHP_EXECUTABLE=%{__php} \
ef0230c6 114 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl session" \
e7368be2
ER
115 RUN_TESTS_SETTINGS="-q $*"
116EOF
117chmod +x run-tests.sh
118
119./run-tests.sh
8dfd8797
ER
120%endif
121
15f9ce79
AG
122%install
123rm -rf $RPM_BUILD_ROOT
a9222c27 124install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
20995d54
ER
125install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
126# we use "session_" prefix in inifile to get loader *after* session extension
10d2ed2a
ER
127cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
128cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
129
130install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
10d2ed2a
ER
131cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
132cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
133cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
134cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
135cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
15f9ce79
AG
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post
86295f4f 141%php_webserver_restart
15f9ce79 142
0bee29d4
ER
143%postun
144if [ "$1" = 0 ]; then
86295f4f 145 %php_webserver_restart
15f9ce79
AG
146fi
147
c69936a3
ER
148%triggerpostun -- %{name} < 3.0.4-2
149if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
150 echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
151 cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
152 mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
153 %php_webserver_restart
154fi
155
afdaa3d2
ER
156%triggerin web -- apache1 < 1.3.37-3, apache1-base
157%webapp_register apache %{_webapp}
158
159%triggerun web -- apache1 < 1.3.37-3, apache1-base
160%webapp_unregister apache %{_webapp}
161
fbc0c377 162%triggerin web -- apache < 2.2.0, apache-base
afdaa3d2
ER
163%webapp_register httpd %{_webapp}
164
fbc0c377 165%triggerun web -- apache < 2.2.0, apache-base
afdaa3d2
ER
166%webapp_unregister httpd %{_webapp}
167
168%triggerin web -- lighttpd
169%webapp_register lighttpd %{_webapp}
170
171%triggerun web -- lighttpd
172%webapp_unregister lighttpd %{_webapp}
173
15f9ce79
AG
174%files
175%defattr(644,root,root,755)
6c6304c8 176%doc CREDITS README ChangeLog
c69936a3 177%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
a9222c27
ER
178%attr(755,root,root) %{php_extensiondir}/%{modname}.so
179%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
180
181%files web
182%defattr(644,root,root,755)
183%dir %attr(750,root,http) %{_sysconfdir}
184%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
185%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
186%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
1ec0934f 187%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
afdaa3d2 188%{_appdir}
This page took 0.273736 seconds and 4 git commands to generate.