]> git.pld-linux.org Git - packages/php-pecl-memcache.git/commitdiff
session requires spl (sometimes)
authorElan Ruusamäe <glen@delfi.ee>
Wed, 23 Nov 2016 01:54:58 +0000 (03:54 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 23 Nov 2016 01:54:58 +0000 (03:54 +0200)
php-pecl-memcache.spec

index 58a3a48348ddbb75e94ee46ceb825878b75e61b5..e2f6502f1c4188c2c87e4bd7349f1d4dfc2b7f9f 100644 (file)
@@ -30,6 +30,7 @@ BuildRequires:        rpmbuild(macros) >= 1.650
 %if %{with tests}
 BuildRequires: %{php_name}-cli
 BuildRequires: %{php_name}-session
+BuildRequires: %{php_name}-spl
 %endif
 %{?requires_php_extension}
 Requires:      %{php_name}-session
@@ -99,6 +100,7 @@ phpize
 # simple module load test
 %{__php} -n -q \
        -d extension_dir=modules \
+       -d extension=%{php_extensiondir}/spl.so \
        -d extension=%{php_extensiondir}/session.so \
        -d extension=%{modname}.so \
        -m > modules.log
@@ -109,7 +111,7 @@ cat <<'EOF' > run-tests.sh
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
 exec %{__make} test \
        PHP_EXECUTABLE=%{__php} \
-       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="session" \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl session" \
        RUN_TESTS_SETTINGS="-q $*"
 EOF
 chmod +x run-tests.sh
This page took 0.035627 seconds and 4 git commands to generate.