]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blame - php-pecl-memcache.spec
simple module load test
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
CommitLineData
8dfd8797
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
3917ea3d 5%define php_name php%{?php_suffix}
a9222c27 6%define modname memcache
afdaa3d2 7%define php_min_version 5.0.0
3917ea3d 8%include /usr/lib/rpm/macros.php
a9222c27
ER
9Summary: %{modname} - a memcached extension
10Summary(pl.UTF-8): %{modname} - rozszerzenie memcached
3917ea3d 11Name: %{php_name}-pecl-%{modname}
10d2ed2a
ER
12Version: 3.0.9
13Release: 1
d7d5fbe6 14License: PHP 3.01
15f9ce79 15Group: Development/Languages/PHP
10d2ed2a
ER
16#Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
17Source0: https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
18# Source0-md5: 7751d8191302a726449d7c6506b8783d
20995d54 19Source1: %{modname}.ini
afdaa3d2
ER
20Source2: %{modname}-apache.conf
21Source3: %{modname}-lighttpd.conf
22Source4: config.php
23Patch0: %{modname}-webapp.patch
016f4b1b 24URL: http://pecl.php.net/package/memcache/
3917ea3d 25BuildRequires: %{php_name}-devel >= 3:5.0.0
241a36be 26BuildRequires: %{php_name}-xml
fae887d4 27BuildRequires: php-packagexml2cl
afdaa3d2 28BuildRequires: rpm-php-pearprov >= 4.4.2-11
62a21c7f 29BuildRequires: rpmbuild(macros) >= 1.650
8dfd8797
ER
30%if %{with tests}
31BuildRequires: %{php_name}-cli
32BuildRequires: %{php_name}-session
33%endif
0bee29d4 34%{?requires_php_extension}
3917ea3d
ER
35Requires: %{php_name}-session
36Requires: %{php_name}-zlib
afdaa3d2 37Suggests: memcached
bd3aaaff 38Provides: php(memcache) = %{version}
41a892be 39Obsoletes: php-pecl-memcache < 3.0.8-5
15f9ce79
AG
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
afdaa3d2
ER
42%define _webapps /etc/webapps
43%define _webapp %{modname}
44%define _sysconfdir %{_webapps}/%{_webapp}
45%define _appdir %{_datadir}/%{_webapp}
46
47# bad depsolver
48%define _noautopear pear
49
50# put it together for rpmbuild
51%define _noautoreq %{?_noautophp} %{?_noautopear}
52
15f9ce79
AG
53%description
54Memcached is a caching daemon designed especially for dynamic web
55applications to decrease database load by storing objects in memory.
56
57This extension allows you to work with memcached through handy OO and
58procedural interfaces.
59
6dd6de29 60%description -l pl.UTF-8
15f9ce79 61Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
6dd6de29
JR
62daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
63przez przechowywanie w pamięci obiektów.
15f9ce79 64
6dd6de29 65To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
15f9ce79
AG
66zorientowanego obiektowo (oraz przez procedury) interfejsu.
67
afdaa3d2
ER
68%package web
69Summary: Web interface for memcache
70Group: Libraries
09120ee3 71# does not require extension itself
fae887d4 72Requires: php(core) >= %{php_min_version}
3917ea3d
ER
73Requires: php(date)
74Requires: php(gd)
75Requires: php(pcre)
afdaa3d2
ER
76Requires: webapps
77Requires: webserver(php) >= 5.0
3917ea3d
ER
78%if "%{_rpmversion}" >= "5"
79BuildArch: noarch
80%endif
afdaa3d2
ER
81
82%description web
83Via this web interface script you can manage and view statistics of
84memcache.
85
15f9ce79 86%prep
10d2ed2a
ER
87%setup -qc
88mv pecl-%{modname}-*/{.??*,*} .
afdaa3d2 89%patch0 -p1
15f9ce79
AG
90
91%build
6c6304c8 92packagexml2cl package.xml > ChangeLog
15f9ce79 93phpize
172c079e
AG
94%configure \
95 --with-zlib-dir=/usr
15f9ce79
AG
96%{__make}
97
8dfd8797
ER
98%if %{with tests}
99# simple module load test
100%{__php} -n -q \
101 -d extension_dir=modules \
102 -d extension=%{php_extensiondir}/session.so \
103 -d extension=%{modname}.so \
104 -m > modules.log
105grep %{modname} modules.log
106%endif
107
15f9ce79
AG
108%install
109rm -rf $RPM_BUILD_ROOT
a9222c27 110install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
20995d54
ER
111install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
112# we use "session_" prefix in inifile to get loader *after* session extension
10d2ed2a
ER
113cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
114cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
115
116install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
10d2ed2a
ER
117cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
118cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
119cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
120cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
121cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
15f9ce79
AG
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%post
86295f4f 127%php_webserver_restart
15f9ce79 128
0bee29d4
ER
129%postun
130if [ "$1" = 0 ]; then
86295f4f 131 %php_webserver_restart
15f9ce79
AG
132fi
133
c69936a3
ER
134%triggerpostun -- %{name} < 3.0.4-2
135if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
136 echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
137 cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
138 mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
139 %php_webserver_restart
140fi
141
afdaa3d2
ER
142%triggerin web -- apache1 < 1.3.37-3, apache1-base
143%webapp_register apache %{_webapp}
144
145%triggerun web -- apache1 < 1.3.37-3, apache1-base
146%webapp_unregister apache %{_webapp}
147
fbc0c377 148%triggerin web -- apache < 2.2.0, apache-base
afdaa3d2
ER
149%webapp_register httpd %{_webapp}
150
fbc0c377 151%triggerun web -- apache < 2.2.0, apache-base
afdaa3d2
ER
152%webapp_unregister httpd %{_webapp}
153
154%triggerin web -- lighttpd
155%webapp_register lighttpd %{_webapp}
156
157%triggerun web -- lighttpd
158%webapp_unregister lighttpd %{_webapp}
159
15f9ce79
AG
160%files
161%defattr(644,root,root,755)
6c6304c8 162%doc CREDITS README ChangeLog
c69936a3 163%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
a9222c27
ER
164%attr(755,root,root) %{php_extensiondir}/%{modname}.so
165%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
166
167%files web
168%defattr(644,root,root,755)
169%dir %attr(750,root,http) %{_sysconfdir}
170%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
171%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
172%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
1ec0934f 173%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
afdaa3d2 174%{_appdir}
This page took 0.067005 seconds and 4 git commands to generate.