]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blame - php-pecl-memcache.spec
up to 3.0.9 snap from NON_BLOCKING_IO_php7 branch (73623c3)
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
CommitLineData
3917ea3d 1%define php_name php%{?php_suffix}
a9222c27 2%define modname memcache
afdaa3d2 3%define php_min_version 5.0.0
3917ea3d 4%include /usr/lib/rpm/macros.php
a9222c27
ER
5Summary: %{modname} - a memcached extension
6Summary(pl.UTF-8): %{modname} - rozszerzenie memcached
3917ea3d 7Name: %{php_name}-pecl-%{modname}
10d2ed2a
ER
8Version: 3.0.9
9Release: 1
d7d5fbe6 10License: PHP 3.01
15f9ce79 11Group: Development/Languages/PHP
10d2ed2a
ER
12#Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
13Source0: https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
14# Source0-md5: 7751d8191302a726449d7c6506b8783d
20995d54 15Source1: %{modname}.ini
afdaa3d2
ER
16Source2: %{modname}-apache.conf
17Source3: %{modname}-lighttpd.conf
18Source4: config.php
19Patch0: %{modname}-webapp.patch
016f4b1b 20URL: http://pecl.php.net/package/memcache/
3917ea3d 21BuildRequires: %{php_name}-devel >= 3:5.0.0
241a36be 22BuildRequires: %{php_name}-xml
fae887d4 23BuildRequires: php-packagexml2cl
afdaa3d2 24BuildRequires: rpm-php-pearprov >= 4.4.2-11
62a21c7f 25BuildRequires: rpmbuild(macros) >= 1.650
0bee29d4 26%{?requires_php_extension}
3917ea3d
ER
27Requires: %{php_name}-session
28Requires: %{php_name}-zlib
afdaa3d2 29Suggests: memcached
bd3aaaff 30Provides: php(memcache) = %{version}
41a892be 31Obsoletes: php-pecl-memcache < 3.0.8-5
15f9ce79
AG
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
afdaa3d2
ER
34%define _webapps /etc/webapps
35%define _webapp %{modname}
36%define _sysconfdir %{_webapps}/%{_webapp}
37%define _appdir %{_datadir}/%{_webapp}
38
39# bad depsolver
40%define _noautopear pear
41
42# put it together for rpmbuild
43%define _noautoreq %{?_noautophp} %{?_noautopear}
44
15f9ce79
AG
45%description
46Memcached is a caching daemon designed especially for dynamic web
47applications to decrease database load by storing objects in memory.
48
49This extension allows you to work with memcached through handy OO and
50procedural interfaces.
51
6dd6de29 52%description -l pl.UTF-8
15f9ce79 53Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
6dd6de29
JR
54daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
55przez przechowywanie w pamięci obiektów.
15f9ce79 56
6dd6de29 57To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
15f9ce79
AG
58zorientowanego obiektowo (oraz przez procedury) interfejsu.
59
afdaa3d2
ER
60%package web
61Summary: Web interface for memcache
62Group: Libraries
09120ee3 63# does not require extension itself
fae887d4 64Requires: php(core) >= %{php_min_version}
3917ea3d
ER
65Requires: php(date)
66Requires: php(gd)
67Requires: php(pcre)
afdaa3d2
ER
68Requires: webapps
69Requires: webserver(php) >= 5.0
3917ea3d
ER
70%if "%{_rpmversion}" >= "5"
71BuildArch: noarch
72%endif
afdaa3d2
ER
73
74%description web
75Via this web interface script you can manage and view statistics of
76memcache.
77
15f9ce79 78%prep
10d2ed2a
ER
79%setup -qc
80mv pecl-%{modname}-*/{.??*,*} .
afdaa3d2 81%patch0 -p1
15f9ce79
AG
82
83%build
6c6304c8 84packagexml2cl package.xml > ChangeLog
15f9ce79 85phpize
172c079e
AG
86%configure \
87 --with-zlib-dir=/usr
15f9ce79
AG
88%{__make}
89
90%install
91rm -rf $RPM_BUILD_ROOT
a9222c27 92install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
20995d54
ER
93install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
94# we use "session_" prefix in inifile to get loader *after* session extension
10d2ed2a
ER
95cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
96cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
97
98install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
10d2ed2a
ER
99cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
100cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
101cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
102cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
103cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
15f9ce79
AG
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
86295f4f 109%php_webserver_restart
15f9ce79 110
0bee29d4
ER
111%postun
112if [ "$1" = 0 ]; then
86295f4f 113 %php_webserver_restart
15f9ce79
AG
114fi
115
c69936a3
ER
116%triggerpostun -- %{name} < 3.0.4-2
117if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
118 echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
119 cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
120 mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
121 %php_webserver_restart
122fi
123
afdaa3d2
ER
124%triggerin web -- apache1 < 1.3.37-3, apache1-base
125%webapp_register apache %{_webapp}
126
127%triggerun web -- apache1 < 1.3.37-3, apache1-base
128%webapp_unregister apache %{_webapp}
129
fbc0c377 130%triggerin web -- apache < 2.2.0, apache-base
afdaa3d2
ER
131%webapp_register httpd %{_webapp}
132
fbc0c377 133%triggerun web -- apache < 2.2.0, apache-base
afdaa3d2
ER
134%webapp_unregister httpd %{_webapp}
135
136%triggerin web -- lighttpd
137%webapp_register lighttpd %{_webapp}
138
139%triggerun web -- lighttpd
140%webapp_unregister lighttpd %{_webapp}
141
15f9ce79
AG
142%files
143%defattr(644,root,root,755)
6c6304c8 144%doc CREDITS README ChangeLog
c69936a3 145%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
a9222c27
ER
146%attr(755,root,root) %{php_extensiondir}/%{modname}.so
147%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
148
149%files web
150%defattr(644,root,root,755)
151%dir %attr(750,root,http) %{_sysconfdir}
152%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
153%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
154%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
1ec0934f 155%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
afdaa3d2 156%{_appdir}
This page took 0.087575 seconds and 4 git commands to generate.