]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
BR update
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname         imagick
7 %define         status          stable
8 Summary:        %{modname} - PHP wrapper to the Image Magick Library
9 Summary(pl.UTF-8):      %{modname} - PHP-owy wrapper do biblioteki Image Magick
10 Name:           %{php_name}-pecl-%{modname}
11 Version:        3.4.2
12 Release:        3
13 License:        PHP 3.01
14 Group:          Development/Languages/PHP
15 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
16 # Source0-md5:  3f80e35c2434636cdb5df01b221b3ffa
17 Patch0:         skip_version_check.patch
18 URL:            http://pecl.php.net/package/imagick/
19 BuildRequires:  %{php_name}-devel >= 4:5.3
20 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  re2c
23 BuildRequires:  rpmbuild(macros) >= 1.650
24 %if %{with tests}
25 BuildRequires:  %{php_name}-cli
26 BuildRequires:  %{php_name}-pcre
27 BuildRequires:  %{php_name}-spl
28 BuildRequires:  ImageMagick-coder-jpeg
29 BuildRequires:  ImageMagick-coder-png
30 BuildRequires:  ImageMagick-coder-tiff
31 %endif
32 %{?requires_php_extension}
33 Requires(triggerpostun):        sed >= 4.0
34 Requires:       %{php_name}-spl
35 Suggests:       ImageMagick-coder-jpeg
36 Suggests:       ImageMagick-coder-png
37 Suggests:       ImageMagick-coder-tiff
38 Provides:       php(imagick) = %{version}
39 Obsoletes:      php-pecl-imagick < 3.1.2-2
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 ImageMagick is a robust collection of tools and libraries to read,
44 write, and manipulate an image in many image formats (over 68 major
45 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
46 and GIF. With ImageMagick you can create images dynamically, making it
47 suitable for Web applications. You can also resize, rotate, sharpen,
48 color reduce, or add special effects to an image and save your
49 completed work in the same or differing image format.
50
51 In PECL status of this package is: %{status}.
52
53 %description -l pl.UTF-8
54 ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
55 modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
56 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
57 ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
58 aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
59 zmniejszać ilość kolorów - w tym samym lub innym formacie.
60
61 To rozszerzenie ma w PECL status: %{status}.
62
63 %prep
64 %setup -qc
65 mv %{modname}-%{version}/* .
66 %patch0 -p1
67
68 # skip failing tests
69 Test() {
70         nf=$(eval echo \$$#)
71         t=$nf; t=${t#\[}; t=${t%\]}
72         mv $t $t.skip
73 }
74 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
75 Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
76 Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
77 Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
78 Test ImagickDraw, setFontStretch [tests/208_ImagickDraw_setFontStretch_basic.phpt]
79 Test ImagickDraw, setFontWeight [tests/209_ImagickDraw_setFontWeight_basic.phpt]
80 Test ImagickDraw, setFontStyle [tests/210_ImagickDraw_setFontStyle_basic.phpt]
81 Test ImagickDraw, setGravity [tests/212_ImagickDraw_setGravity_basic.phpt]
82 Test ImagickDraw, setTextAlignment [tests/222_ImagickDraw_setTextAlignment_basic.phpt]
83 Test ImagickDraw, setTextAntialias [tests/223_ImagickDraw_setTextAntialias_basic.phpt]
84 Test ImagickDraw, setTextUnderColor [tests/224_ImagickDraw_setTextUnderColor_basic.phpt]
85 Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_basic.phpt]
86 Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
87 Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
88 Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
89
90 %build
91 phpize
92 %configure \
93         php_cv_cc_dashr=false
94
95 %{__make} \
96         CFLAGS_CLEAN="%{rpmcflags}"
97
98 %if %{with tests}
99 %{__php} -n -q \
100         -d extension_dir=modules \
101         -d extension=%{php_extensiondir}/pcre.so \
102         -d extension=%{php_extensiondir}/spl.so \
103         -d extension=%{modname}.so \
104         -m > modules.log
105 grep %{modname} modules.log
106
107 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
108 %{__make} test \
109         PHP_EXECUTABLE=%{__php} \
110         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
111 %endif
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
116 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
117 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
118 ; Enable %{modname} extension module
119 extension=%{modname}.so
120 EOF
121 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 %php_webserver_restart
128
129 %postun
130 if [ "$1" = 0 ]; then
131         %php_webserver_restart
132 fi
133
134 %triggerpostun -- %{name} < 0.9.11-2.1
135 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
136
137 %files
138 %defattr(644,root,root,755)
139 %doc CREDITS
140 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
141 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
142 %{_examplesdir}/%{name}-%{version}
This page took 0.346974 seconds and 4 git commands to generate.